Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171212 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171212

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
MozillaFirefox
MozillaThunderbird
aaa_base
bash
ceph (12.2.1+git.1510221942.af9ea5e715 -> 13.0.0)
dpdk (17.08_k4.14.4_1 -> 17.08.1_k4.14.4_1)
frei0r-plugins (1.4 -> 1.6.1)
glade (3.20.1 -> 3.20.2)
glib2
gstreamer-editing-services (1.12.3 -> 1.12.4)
gstreamer-rtsp-server (1.12.3 -> 1.12.4)
gstreamer-validate (1.12.3 -> 1.12.4)
gtk2
gzip
jing-trang (20091111 -> 20151127)
kde-l10n
kernel-firmware (20171125 -> 20171204)
libgit2-glib (0.26.0 -> 0.26.2)
libzypp (17.0.4 -> 17.0.5)
mozilla-nss
nano (2.9.0 -> 2.9.1)
openconnect
perl-Params-ValidationCompiler (0.24 -> 0.26)
python-gst (1.12.3 -> 1.12.4)
rubygem-fast_gettext (1.5.1 -> 1.6.0)
spamassassin
userspace-rcu
xen (4.10.0_03 -> 4.10.0_06)
xfce4-terminal
yast2-ruby-bindings (4.0.2 -> 4.0.3)
yum
zvbi

=== Details ===

==== MozillaFirefox ====
Subpackages: MozillaFirefox-translations-common

- Explicitly buildrequires python2-xml: The build system relies on
it. We wrongly relied on other packages pulling it in for us.
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.

==== MozillaThunderbird ====
Subpackages: MozillaThunderbird-translations-common

- Explicitly buildrequires python2-xml: The build system relies on
it. We wrongly relied on other packages pulling it in for us.
- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.

==== aaa_base ====
Subpackages: aaa_base-extras

- Cleanup PreReq and move some parts to Requires(post), so that
we can deinstall them if we no longer need them

==== bash ====
Subpackages: bash-doc bash-lang libreadline7 readline-devel readline-doc

- Enable multibyte characters by default

==== ceph ====
Version update (12.2.1+git.1510221942.af9ea5e715 -> 13.0.0)
Subpackages: librados2 librbd1

- Replace references to /var/adm/fillup-templates with new %_fillupdir macro
(boo#1069468)
- Update to version 13.0.0-3531.g3692e00bab:
+ rebase to latest upstream master
+ Add "checkin.sh" script to automate the checkin process, along
with a "README-checkin.txt" file containing basic information.
- Update to version 13.0.0-3512.gb018e431a6:
+ rebase to upstream "Mimic" (13.0.0) development snapshot
https://github.com/SUSE/ceph/tree/ses6
+ drop OBS source services in favor of generating the spec file
and tarball using the upstream "make-dist" script
+ new version number format, replacing timestamp with git tag
offset
+ reduce tarball size from 114 MB to 47 MB by omitting unused parts
of boost
- Update to version 12.2.1+git.1511279898.8aa892202e:
+ bsc#1060904
* rgw: keystone: bump up logging when error is received
+ bsc#1067705
* rgw: set sync_from_all as true when no value is seen
+ bsc#1066182
* rgw: data sync: set num_shards when building full maps
* dencoder/rgw: expose rgw sync status types
* rgw: set num_shards on 'radosgw-admin data sync init'

==== dpdk ====
Version update (17.08_k4.14.4_1 -> 17.08.1_k4.14.4_1)

- Upgraded to latest stable 17.08.1; some of the fixes include:
* net/qede: disable per-VF Tx switching feature
* revert "net/virtio: flush Rx queues on start"
* various fixes for mlx5 PMD drivers
* various fixes for bnxt PMD drivers
* various fixes for i40e PMD drivers
* various fixes for crypto PMD drivers
* testpmd: fix for non-consecutive ports
* ethdev: fix ABI version

==== frei0r-plugins ====
Version update (1.4 -> 1.6.1)

- Split off plugins built against OpenCV because they cause
multiprocessing issues in shotcut and kdenlive. See boo#1068792
and https://github.com/mltframework/mlt/issues/274.
- Reduce bit operations we do in the spec and convert to pkgconfig
dependencies
- Switch LICENSE to GPL-3.0+ even tho upstream says 2.0+ is enough
quite few filters and generators are 3.0+ only
- Update to version 1.6.1
- Rebase frei0r-plugins-1.4-missing_include.patch
- Rebase frei0r-plugins-openCV-3.0-compatibility.patch it is mostly
included upstream.
- Upstream changes:
* Minor fixes to the build system. Version correctly updated.
* This release contains new filters and some bugfixes to parameters
and building environment, documentation is updated accordingly.
* New filters (3): bgsubtract0r, glitch0r, rgbsplit0r
* Updated (2): Distort0r now mode and velocity, Curves has improved
precision.
* This release fixes several major bugs in existing plugins and adds
one new filter: NDVI (Normalized Difference Vegetation Index).

==== glade ====
Version update (3.20.1 -> 3.20.2)
Subpackages: glade-lang libgladeui-2-6

- Update to version 3.20.2:
+ Install appstream metadata to non-deprecated location.
+ Fix bugs:
- Glade interface designer eating ram & cpu (bgo#763624).
- Glade saves invalid GtkBuilder XML (bgo#790452).
- GtkLabel xalign and halign appeared in GTK+ 3.16 and are not
deprecated (bgo#782645).
- Add background class to GladeDesignLayout children
(bgo#773669).
+ Updated translations.
- Add gmodule-export-2.0 and gobject-2.0 pkgconfig BuildRequires:
they were being pulled and used since the package already had
another declared module dependencies upon glib2-devel, the same
provider. Note that gobject-2.0 is not mentioned in configure.ac
but it is checked by configure and the same goes for glib-2.0
module.
- Drop docbook-xsl-stylesheets BuildRequires and add gtk-doc:
that's what upstream uses and we don't want deviations to avoid
unexpected bugs.
- Pass enable-man-pages enable-gtk-doc and to ensure that manuals
and documentation will be built.
- Remove gnome-common BuildRequires and autogen.sh call, as we no
longer carry any patches.
- Adopt %make_build macro and drop raw commands following the best
practices.

==== glib2 ====
Subpackages: glib2-devel glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Add glib2-gtester-report-py3.patch: gtester-reporter fails to
run with python3 (bgo#791296, boo#1071378).

==== gstreamer-editing-services ====
Version update (1.12.3 -> 1.12.4)
Subpackages: libges-1_0-0 typelib-1_0-GES-1_0

- Update to version 1.12.4:
+ Misc fixes.

==== gstreamer-rtsp-server ====
Version update (1.12.3 -> 1.12.4)

- Update to version 1.12.4:
+ Bugs fixed: bgo#789646, bgo#769521.

==== gstreamer-validate ====
Version update (1.12.3 -> 1.12.4)
Subpackages: libgstvalidate-1_0-0 typelib-1_0-GstValidate-1_0

- Update to version 1.12.4:
+ No changes, stable version bump only.

==== gtk2 ====
Subpackages: gtk2-data gtk2-devel gtk2-immodule-amharic gtk2-immodule-inuktitut
gtk2-immodule-thai gtk2-immodule-vietnamese gtk2-immodule-xim gtk2-lang
gtk2-tools gtk2-tools-32bit libgtk-2_0-0 libgtk-2_0-0-32bit typelib-1_0-Gtk-2_0

- Switch to using python3:
+ Replace -devel's python2-xml Requires with python3-xml.
+ Add gtk2-converter-python3.patch: convert gtk-build-converter
to be a python3 script.

==== gzip ====

- add gzip-1.8-fix_unpack_EOB_check.patch to fix mishandling of
leading zeros in the end-of-block code [bsc#1067891]

==== jing-trang ====
Version update (20091111 -> 20151127)

- First attempt to combine jing and trang packages into a
single package on OBS
- Use patches and instructions from Fedora, but use %buildroot
instead of $RPM_BUILD_ROOT
- Install manpages for dtdinst, jing, and trang
- Use spec-cleaner
- Use saxon9 instead of saxon6 for jing script
- Apply spec-cleaner for spec file
- Fixed name of saxon jar [bsc#914681]
- Move from jpackage-utils to javapackage-tools
- used saxon9 for build and as a dependency (bnc#780666)
- Improved jing script: use now jpackage-utils, added
xml-commons-resolver to better support catalogs
- Adapted requires and buildrequires in spec file
- Updated documentation
* explained -C and -s options, removed obsolete -f
* updated version
- updated to 20091111
* add -C option to specify the catalog
* fix schematron test suite schema
* provide a resolver that implements OASIS XML catalogs
* take advantage of Java 5 features
- added documentation (manpage) by Thomas Schraitle
- updated to 20081028
- fixed build

==== kde-l10n ====
Subpackages: kde-l10n-cs kde-l10n-da kde-l10n-da-data kde-l10n-da-doc
kde-l10n-de kde-l10n-de-data kde-l10n-de-doc kde-l10n-el kde-l10n-en_GB
kde-l10n-en_GB-data kde-l10n-en_GB-doc kde-l10n-es kde-l10n-es-data
kde-l10n-es-doc kde-l10n-fr kde-l10n-fr-data kde-l10n-hu kde-l10n-it
kde-l10n-it-data kde-l10n-it-doc kde-l10n-ja kde-l10n-pl kde-l10n-pl-data
kde-l10n-pt kde-l10n-pt_BR kde-l10n-pt_BR-data kde-l10n-ru kde-l10n-ru-data
kde-l10n-zh_CN kde-l10n-zh_TW

- Remove kget.mo to prevent conflicts with the new kget tarball

==== kernel-firmware ====
Version update (20171125 -> 20171204)
Subpackages: ucode-amd

- Update to version 20171204:
* amdgpu: add firmware for Raven
* amdgpu: update vega10 vce firmware
* linux-firmware: DMC firmware for skylake v1.27

==== libgit2-glib ====
Version update (0.26.0 -> 0.26.2)

- Update to version 0.26.2:
+ Several fixes on the annotations.
+ Misc bug fixes.
- Update Url to https://wiki.gnome.org/Projects/Libgit2-glib:
current Libgit2-glib project's web page.
- Adopt the use of %make_build macro instead of raw make command,
following the best practices.
- Add missing gtk-doc BuildRequires and pass enable-gtk-doc to
configure once the API documentation is desired.
- Correct the library's name spelling in summaries and
descriptions.

==== libzypp ====
Version update (17.0.4 -> 17.0.5)

- Fix default for solver.allowNameChange (bsc#1071466)
- version 17.0.5 (0)

==== mozilla-nss ====
Subpackages: libfreebl3 libsoftokn3 mozilla-nss-certs mozilla-nss-tools

- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.

==== nano ====
Version update (2.9.0 -> 2.9.1)
Subpackages: nano-lang

- GNU nano 2.9.1:
* Fix a bug where, when the mark is on, ^S would overwrite the
file with just the marked region
* Clear the "Modified" flag when all edits are undone
* Add or updates some magic strings
* Remember when the cursor was last at line 1, column 1

==== openconnect ====
Subpackages: openconnect-devel openconnect-lang

- Add explicit python2-base and python2-xml BuildRequires: the
buildsystem checks for python2 and disables building the
documentation if not found. Buildinf the documentation in plus
depends on the xml modules.
So far we relied on other packages pulling in python2 for us.

==== perl-Params-ValidationCompiler ====
Version update (0.24 -> 0.26)

- updated to 0.26
see /usr/share/doc/packages/perl-Params-ValidationCompiler/Changes
0.26 2017-11-28
- The exceptions.t test would fail if Sub::Util was not installed. Reported by
Paul Howarth. GH #19.
- Fix test failures on Windows. GH #20.
- updated to 0.25
see /usr/share/doc/packages/perl-Params-ValidationCompiler/Changes
0.25 2017-11-23
- All exceptions now include a stack trace by default when treated as a
string. This makes finding where validation failed a lot easier. Fixes GH
[#18].
- The name for a subroutine is now used in some exception messages, even if
Sub::Util cannot be installed.

==== python-gst ====
Version update (1.12.3 -> 1.12.4)

- Update to version 1.12.4:
+ No changes, stable version bump only.

==== rubygem-fast_gettext ====
Version update (1.5.1 -> 1.6.0)

- updated to version 1.6.0
see installed CHANGELOG
1.6.0 -- Remove restrictions around yaml file names

==== spamassassin ====
Subpackages: perl-Mail-SpamAssassin

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== userspace-rcu ====

- Add baselibs.conf: create liburcu6-32bit package as a dependency
to liblttng-ust0-32bit.

==== xen ====
Version update (4.10.0_03 -> 4.10.0_06)
Subpackages: xen-doc-html xen-libs xen-tools xen-tools-domU

- Increase the value of LIBXL_DESTROY_TIMEOUT from 10 to 100 seconds
If many domUs shutdown in parallel the backends can not keep up
Add some debug output to track how long backend shutdown takes (bsc#1035442)
libxl.LIBXL_DESTROY_TIMEOUT.patch
libxl.LIBXL_DESTROY_TIMEOUT.debug.patch
- Adjust xenstore-run-in-studomain.patch to change the defaults
in the code instead of changing the sysconfig template, to also
cover the upgrade case

==== xfce4-terminal ====
Subpackages: xfce4-terminal-lang

- add 0001-Revert-Fix-handling-email-addresses.patch (boo#1071961,
bxo#14076) the "Fix handling email addresses" commit in 0.8.6
actually broke email address handling.

==== yast2-ruby-bindings ====
Version update (4.0.2 -> 4.0.3)

- Set proper title also for YaST2 Firstboot (bsc#1070583)
- 4.0.3

==== yum ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== zvbi ====

- Update RPM groups and descriptions.
- Cleanup spec file with spec-cleaner
- Add dropped dependency for libICE
- Add dependency for libpng support
- Split lang subpackage
- Split library subpackages
- Use patches from debian:
* 00_fix-configure.in.patch
* 01_Makefile.am.patch
* 03_fails-to-write.patch
* 05_MAXPATHLEN.patch
* 06_sizeof-FTBFS.patch
* 07_fix-spelling-in-binaries.patch
* 08_fix-manpage.patch
* 09_fix-FTBFS-GCC6.patch
- Drop zvbi-automake-1.13.patch
- Enable tests
- Use url for source
- BuildRequire pkgconfig(x11) instead of xorg-x11-devel


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages