Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] Lots of time spent on controlling conflicts between files
Since a few months now zypper takes a lot of timeĀ  controlling on conflicts between files. In this release it is more than 45 minutes, with one CPU constantly at 100%.
There is almost no disk activity durong the process.

Its not a big issue for me (zypper does its work happily in the background) , but I wonder if this is normal behavior?

Regards, Jogchum

Op 12-12-17 om 20:10 schreef Dominique Leuenberger:
Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171211

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
devhelp (3.26.0 -> 3.26.1)
gtksourceview (3.24.5 -> 3.24.6)
kdelibs4
libXcursor (1.1.14 -> 1.1.15)

=== Details ===

==== devhelp ====
Version update (3.26.0 -> 3.26.1)
Subpackages: devhelp-lang gedit-plugin-devhelp vim-plugin-devhelp

- Update to version 3.26.1:
+ Move New Tab button on the right side of the headerbar.
+ Updated translations.
- Drop obsolete post(un) handling of:
glib2_gsettings_schema_post(un), desktop_database_post(un) and
icon_theme_cache_post(un), file-triggers takes care of this now.

==== gtksourceview ====
Version update (3.24.5 -> 3.24.6)
Subpackages: gtksourceview-lang libgtksourceview-3_0-1 typelib-1_0-GtkSource-3_0

- Update to version 3.24.6:
+ New syntax highlighting definition file for: logcat.
+ Improvements to the syntax highlighting of: Python and
reStructuredText.
+ Improvements to the Visual Studio builds.
+ Updated translations.

==== kdelibs4 ====
Subpackages: kdelibs4-core libkde4 libkdecore4 libksuseinstall1

- Escape the usage of %{VERSION} when calling out to rpm.
RPM 4.14 has %{VERSION} defined as 'the main packages version'.

==== libXcursor ====
Version update (1.1.14 -> 1.1.15)
Subpackages: libXcursor1 libXcursor1-32bit

- Update to version 1.1.15:
* configure: Drop AM_MAINTAINER_MODE
* autogen.sh: Honor NOCONFIGURE=1
* Use strdup() instead of malloc(strlen())+strcpy()
* Fix some clang integer sign/size mismatch warnings
* autogen.sh: use quoted string variables
* autogen: add default patch prefix
* autogen.sh: use exec instead of waiting for configure to finish
* Fix heap overflows when parsing malicious files. (CVE-2017-16612)
* Insufficient memory for terminating null of string in _XcursorThemeInherits
- Drop U_Avoid-heap-overflows-due-to-integer-overflow-signedn.patch



--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >