Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171204 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171204

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager
adwaita-icon-theme (3.26.0 -> 3.26.1)
empathy
fcitx (4.2.9.1 -> 4.2.9.5)
flatpak (0.10.0 -> 0.10.1)
flatpak-builder (0.10.4 -> 0.10.5)
glib2
graphene
gstreamer
gstreamer-plugins-bad
gstreamer-plugins-base
gstreamer-plugins-good
gstreamer-plugins-ugly
kdebindings-smokeqt
lensfun
libQtWebKit4
libvirt (3.9.0 -> 3.10.0)
perl-CGI (4.37 -> 4.38)
ppp
sbl
speech-dispatcher
virtualbox

=== Details ===

==== NetworkManager ====
Subpackages: NetworkManager-devel NetworkManager-lang libnm-glib-vpn1
libnm-glib4 libnm-util2 libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Switch to python3:
+ Replace BuildRequires python-gobject, python2-dbus-python with
python3-gobject, python3-dbus-python.
+ Explictly set environment variable PYTHON as python3 in
build time.

==== adwaita-icon-theme ====
Version update (3.26.0 -> 3.26.1)

- Update to version 3.26.1:
+ Fix scalability issues with 256/512 size (bgo#785574).
+ Audio-volume-* pixel alignment.
- Point fdupes to the data directory instead of the build root,
which is a practice that must be avoided.
- Drop adwaita-symbolic-audio-volume-fix.patch: fixed upstream.
- Drop intltool BuildRequires once there is no translations to deal
with in the package.

==== empathy ====
Subpackages: telepathy-mission-control-plugin-goa

- Export LANG=C.UTF-8 before building: in case we use python3 to
build (we rely on what we get into the build system), an UTF-8
setting is required or pyhon won't be able to parse all files.
- Only call the post/postun scriptlets conditional on suse_version
< 1330. Newer systems use file triggers.
- Switch to using python3 to build:
+ Add python3-base and python3-xml BuildRequires.
+ Export PYTHON=/usr/bin/python3 before running configure: use
python3 for the build process.

==== fcitx ====
Version update (4.2.9.1 -> 4.2.9.5)
Subpackages: fcitx-branding-openSUSE fcitx-gtk2 fcitx-gtk3 fcitx-pinyin
fcitx-qt4 fcitx-table fcitx-table-cn-wubi fcitx-table-cn-wubi-pinyin
libfcitx-4_2_9

- update 4.2.9.5
* [qt] remove quickphrase editor, moved to qt5
* [misc] forget to remove the add_directory for quickphrase editor
* fcitx-configtool.desktop: Remove MimeType entry
* [frontend] add a compatibility layer for ofd.portal.Fcitx
* [gtk] run clang-format on gtk libraries
* [gclinet] remove a undefined function
* set display for fcitx and harden dbus frontend with sender verification
* extend dbus module to be able to accept external dbus connection
* [ipcportal] fix signal sending in portal
* [qt] delay the recheck on availability, but does do the recheck
* [portal] put ipc portal in queue
* [qt] do the real unwatch
* [misc] make more optional disabled option for easier flatpak
* [table] make sure we don't download table data if we disable table
- changes in 4.2.9.4
* [gtk, kimpanel] add relative coordinate support
* [kimpanel] check null before use ic
* [kimpanel] correctly reset relative spot state
* [notificationitem] Reply event method call
- changes in 4.2.9.3
* [core] Make sure when RealEnd is called, instance->destroy == true
- changes in 4.2.9.2
* [notificationitem] avoid unnecessary xembed tray icon fallback
* [classicui] give tray icon a default size
* [qt] fix inconsistency when handling qstring and ucs4 string
* [classicui] Watch for dockWindow visual property change
* [qt] fromUcs4 expect a nul terminated string by default, give it a size
* [core] Expose internal show input speed function
* logging should not include the build path(boo#951602)
* autostart desktop file should not be shown(boo#968486)
* [qt] replace QPointer with raw pointer in icdata
* [notificationitem] display layout under unity
* [diagnose] Print info about dbus name owner
* Include emoji short codes ("emoji alpha codes")
* [notificationitem] Fix a bug in plugin entry
* [core] Add a new hook to watch ui status changed
* [xim] handle reset ic
* [utils] Improve process name detection on *BSD
* [quickphrase] use some different character, original one looks bad under
noto
* [misc] use RTLD_NODELETE for all dlopen
* Call sem_post() only on valid semaphore
* [unicode] Update Unicode 9.0 descriptions
* [classicui] Check XShape version before using it
* [remote] exit the loop after trying 20 times
* Require bash in fcitx-cmake-helper.sh
* [xim] fix a memset
* [pinyin] fix missing files
* [dbus] fix a wrong dbus destruct order that my cause deadlock on exit
* [xkb] handle some corner case for any evil third party that override layout
* [xkb, xkbdbus] add support for our gnome-shell kimpanel dbus helper
* [xkb] fix circular deps between xkb and xkbdbus
* [gclient] try to eliminate a warning for configtool
* [misc] enforce c99 for compiler
* [core] call backtrace() ahead to let it finish init()
* [misc] remove a dup define
* [unicode] enable prev/next key and enter to choose for unicode
* [gtk] fix wrong gobject add weak pointer
* [misc] use unsigned int instead for portability
* Remove deprecated api in enchant so we can also support 2.1.0.
* Fix bashism/use correct shebang
- drop fcitx-autostart-desktop-no-display.patch, upstreamed
- drop fcitx-use-basename-for-log.patch, upstreamed
- drop boo954623.patch, upstreamed

==== flatpak ====
Version update (0.10.0 -> 0.10.1)

- Update to version 0.10.1:
+ New command "flatpak remote-info" shows information about
applications in a remote. In particular the --log operation
shows the history and can be used in combination with flatpak
update --commit=XYZ to roll back to a previous version.
+ New command "flatpak search" which allows you to search the
appstream data from the commandline.
+ flatpak update now updates appstream data for all configured
remotes, which is important for search to work.
+ Allow automatic installation of gtk themes matching the active
theme.
+ Handle the case when /etc/resolv.conf is a symlink.
+ /usr an /etc are now expose in /run/host in the app if the app
has full filesystem access.
+ flatpak remote-add now works as a user when /var/lib/flatpak is
empty, allowing flatpak to work on stateless systems.
+ Add support for flatpak build --log-session/system-bus, similar
to what flatpak run already does.
+ flatpak build --readonly runs with the target directory
(normally /app) mounted read-only.
+ Fall back to LD_LIBRARY_PATH if a runtime doesn't have
/usr/bin/ldconfig.
+ Updated the support for OCI remotes. This is work in progress
and still disabled by default though.
+ Updated translations.
- Add pkgconfig(appstream-glib) BuildRequires: New dependency.

==== flatpak-builder ====
Version update (0.10.4 -> 0.10.5)

- Update to version 0.10.5:
+ Add support for running tests during the build (disable with
- -disable-tests).
+ New build-option append-pkg-config to append to
PKG_CONFIG_PATH.
+ --state-dir option lets you reuse a single directory instead of
scattered .flatpak-builder dirs for builds, downloads and cache
data.
+ git: Allow updates with non-fastforwarded branched.
+ Don't fail if app ships both appdata and metainfo file.
+ Support --log-system/session-bus in --run.
- Adjust RPM groups.

==== glib2 ====
Subpackages: glib2-devel glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Switch to python3:
+ Pass --with-python=/usr/bin/python3 to configure.
+ Replace python-base and python-xml BuildRequires with their
python3 equivalents python3-base and python3-xml.
+ Replace the -devel package's python-xml requires with
python3-xml.

==== graphene ====

- Switch to python3:
+ Update the shebang in src/identfilter.py using sed.
+ Replace --identifier-filter-cmd=python in src/meson.build with
- -identifier-filter-cmd=python3 (using sed).
+ Add python3-base BuildRequires: needed to have the python3
interpreter present.
- on i586, disable sse2 for the moment, otherwise the package
fails in the testsuite on the "box" test
- Update to version 1.6.0:
+ The Meson dependency has been bumped to 0.37.0.
+ Added graphene_frustum_equal() method.
+ Dropped the -Denable-debug option for the Meson build;
debugging levels are handled through the --buildtype Meson
option; you can use release to disable all debugging code paths
when building Graphene.
+ Graphene now automatically builds binaries for Windows (i686
and x86_64) using Appveyor; you can find the builds attached to
the release notes.
- Add baselibs.conf: produce libgraphene-1_0-0-32bit, required by
gtk4.
- Update to version 1.5.4:
+ For the time being and after requests from distributors, the
autotools build environment has been reinstated in Git, though
Meson is still the preferred build environment; I still expect
to drop the autotools build in the near future.
+ Graphene now correctly identifies whether the platform has an
aligned memory allocator.
+ Compatibility fixes for printing int64_t to terminal.
+ Fixed the cross-references to GLib types in the API reference
build.
+ Improve the builtin detection in the Meson build and the build
of Graphene under MingW.
- Switch to github url, gnome url is currently broken.
- Pass export LANG=C.UTF-8, workaround meson issue.
- Drop sed call to workaround Mesa issue.
- Use meson provided macros to build instead of carrying the long
meson command lines.
- Trim description outside the main subpackage of interest;
reflow summaries.
- Initial package, version 1.5.2.

==== gstreamer ====
Subpackages: gstreamer-devel gstreamer-lang gstreamer-utils libgstreamer-1_0-0
typelib-1_0-Gst-1_0

- Add explicit python3-xml BuildRequires: fix build on older
versions of openSUSE.
- Switch to python3:
+ Replace python BuildRequires with python3-base.
+ Export PYTHON=/usr/bin/python3 before calling configure.

==== gstreamer-plugins-bad ====
Subpackages: gstreamer-plugins-bad-lang libgstadaptivedemux-1_0-0
libgstbadaudio-1_0-0 libgstbadbase-1_0-0 libgstbadvideo-1_0-0
libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstgl-1_0-0
libgstmpegts-1_0-0 libgstphotography-1_0-0 libgsturidownloader-1_0-0
libgstwayland-1_0-0

- Switch to python3:
+ Replace python-base BuildRequires with python3-base.
+ Export PYTHON=/usr/bin/python3 before calling configure.
- Add pkgconfig(libde265) BuildRequires in orig-addon subpackage,
build h.265 (HVEC) decode support.

==== gstreamer-plugins-base ====
Subpackages: gstreamer-plugins-base-lang libgstallocators-1_0-0 libgstapp-1_0-0
libgstaudio-1_0-0 libgstfft-1_0-0 libgstpbutils-1_0-0 libgstriff-1_0-0
libgstrtp-1_0-0 libgstrtsp-1_0-0 libgstsdp-1_0-0 libgsttag-1_0-0
libgstvideo-1_0-0 typelib-1_0-GstAudio-1_0 typelib-1_0-GstPbutils-1_0
typelib-1_0-GstTag-1_0 typelib-1_0-GstVideo-1_0

- Add explicit python3-xml BuildRequires: fix build on older
versions of openSUSE.
- Switch to python3:
+ Replace python-base BuildRequires with python3-base.
+ Export PYTHON=/usr/bin/python3 before calling configure.

==== gstreamer-plugins-good ====
Subpackages: gstreamer-plugins-good-extra gstreamer-plugins-good-lang

- Add python3-xml BuildRequires as it is needed for xml support.
- Switch to python3:
+ Replace python-base BuildRequires with python3-base.
+ Export PYTHON=/usr/bin/python3 before calling configure.

==== gstreamer-plugins-ugly ====
Subpackages: gstreamer-plugins-ugly-lang

- Add python3-xml BuildRequires as it is needed for xml support.
- Switch to python3:
+ Replace python-base BuildRequires with python3-base.
+ Export PYTHON=/usr/bin/python3 before calling configure.

==== kdebindings-smokeqt ====
Subpackages: libsmokeqt libsmokeqt-devel

- Don't build with Qt4 WebKit

==== lensfun ====
Subpackages: lensfun-data lensfun-devel liblensfun1

- Pass -DPYTHON_EXECUTABLE=%{_bindir}/python3 to cmake: ensure the
entire build uses python3.

==== libQtWebKit4 ====

- Unconditionally buildrequire python-xml: our build script makes
use of it and we just can't rely on 3rd party packages to bring
our dependencies (in the past, glib2-devel brought python-xml,
but that package changed to python3 code).

==== libvirt ====
Version update (3.9.0 -> 3.10.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- Update to libvirt 3.10.0 RC2
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
8056721c-qemu-null-storage-source.patch,
74a13be4-xdr-flags.patch,
apparmor-rules-for-new-mediation-features.patch,
apparmor-fine-grained-mount-rules.patch
- bsc#1070285, bsc#1070478, FATE#323473, FATE#324479
- spec: remove use of 'systemctl enable'
bsc#1038401
- spec: enable firewalld support for SLE15, Leap15, and Tumbleweed
FATE#320794

==== perl-CGI ====
Version update (4.37 -> 4.38)

- updated to 4.38
see /usr/share/doc/packages/perl-CGI/Changes
4.38 2017-12-01
[ TESTING ]
- command_line.t: Avoid -I for libs (GH #224, thanks to cpansprout)

==== ppp ====

- Refresh spec-file via spec-cleaner.
- Add ppp-modem package for automatic redial to mobile provider.

==== sbl ====

- Migrate orca plugin to python3: orca has been a python3
application since version 3.7, released in 2013:
+ Add python3-base BuildRequires.
+ Add sbl-orca-python3.patch: convert brlapi.py and
python/Makefile to python3.

==== speech-dispatcher ====
Subpackages: libspeechd-devel libspeechd2 python3-speechd
speech-dispatcher-configure speech-dispatcher-module-espeak

- Drop py_requires: this is a static python2-dependency on a
python3 package.

==== virtualbox ====
Subpackages: virtualbox-host-kmp-default virtualbox-qt

- Update "fixes_for_4.15.patch" for further API changes in kernel 4.15.


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages