Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openSSL 1.1 is now the default SSL implementation
On Mon, Dec 04, 2017 at 11:54:33AM +0100, Bjoern Voigt wrote:
Jan Engelhardt schrieb:
I recompiled my own local RPM packages after upgrading TW to the latest
snapshot. But some packages are broken.

It may be my fault or a general problem.

One example: MythTV frontend does not start anymore. The segmentation
fault is caused by LibreSSL in MySQL driver in Qt5
The fault is caused because openssl tries to use libressl functions:
Ok, thanks. Probably if libopenssl-devel and libressl-devel were both
installed, MythTV's configure script choose libopenssl-devel. But I
uninstalled libopenssl-devel during the last snapshot upgrade and so
MythTV choose libressl-devel.

I try again with libopenssl-devel-1.1.0g-1.1.noarch and without
libressl-devel.

The backtrace looked like the usual mix between two different openssl libraries.

only openssl 1.0 and 1.1 can be used in parallel due to use of symbol versions.

From my point of view, please do not try to use libressl unless it gets symbol
versions in SUSE.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >