Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
On Sat, 2017-12-02 at 12:52 +0000, pit wrote:
Bernhard M. Wiedemann wrote:
On 2017-12-01 11:17, H.Merijn Brand wrote:
Solution 2: deinstallation of libqt4-devel-4.8.7-9.1.x86_64

seems to be the best choice there
and maybe also a good hint on why no automatic solution could be
found.

That would effectively mean QT4 is no longer supported in TW, yes?
Bad choice, IMHO...

Qt4 apps can still be used and can still be built for Tumbleweed. To
run them you don't need openssl-1_0_0-devel and libqt4-devel on your
machine though.

If you need to compile qt4 stuff locally, you will have to remove
openssl 1.1 devel packages. Possibly you even need to swich between
them if you target different SSL versions.

But claiming Qt4 is 'no longer supported in Tumbleweed' is not accurate
(even though finally moving off to Qt5 is definitively a good thing to
happen)

cheers
Dominique
< Previous Next >
Follow Ups