Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
On Fri, 2017-12-01 at 10:12 +0100, H.Merijn Brand wrote:
2 Problems:
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Problem: openssl-1.1.0g-1.1.noarch requires openssl-1_1_0 =
1.1.0g,
but this requirement cannot be provided
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-
1.1.x86_64
Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):

Seems we missed an obsoletes for the -devel package. The best
answer
depends on why you even have libopenssl-devel installed on your
system.
The 'Tumbleweed default' should be to 'deinstall libopenssl-1_0_0-
devel', which would then pull in libopenssl-1_1_0-devel instead.

Packages that depend on 1.0.2m:

# zypper rm libopenssl-devel-1.0.2m-1.1.noarch
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Not sure why you decided to remove libopenssl-devel and not libopenssl-
1_0_0-devel as recommended by me earlier.

There are some more changes piled up for openssl 1.0/1.1 to be a bit
less aggressive on each other. But I can't yet estimate when those will
reach Tumbleweed.

Cheers
Dominique
< Previous Next >
Follow Ups