Mailinglist Archive: opensuse-factory (454 mails)

< Previous Next >
Re: [opensuse-factory] openssl dependency problems with snapshot 20171129
Hi all,

On Thu, 2017-11-30 at 22:33 +0200, Stratos Zolotas wrote:
Hello,

I'm getting the following result with the latest snapshot and I can't
find an obvious solution. Any possible solution results on
deinstallation of multiple packages and multiple dependency
problems..

sudo zypper dup --no-allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Problem: openssl-1.1.0g-1.1.noarch requires openssl-1_1_0 = 1.1.0g,
but this requirement cannot be provided

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-
1.1.x86_64
Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):

Seems we missed an obsoletes for the -devel package. The best answer
depends on why you even have libopenssl-devel installed on your system.
The 'Tumbleweed default' should be to 'deinstall libopenssl-1_0_0-
devel', which would then pull in libopenssl-1_1_0-devel instead.

Depending of what kind of software you're building locally, you might
want to switch between the provided openssl-1_x_0-devel packages.

Cheers,
Dominique
< Previous Next >
Follow Ups