Mailinglist Archive: opensuse-factory (765 mails)

< Previous Next >
[opensuse-factory] openssl dependency problems with snapshot 20171129
Hello,

I'm getting the following result with the latest snapshot and I can't
find an obvious solution. Any possible solution results on
deinstallation of multiple packages and multiple dependency problems..

sudo zypper dup --no-allow-vendor-change
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
2 Problems:
Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Problem: openssl-1.1.0g-1.1.noarch requires openssl-1_1_0 = 1.1.0g,
but this requirement cannot be provided

Problem: libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64 conflicts with
libopenssl-devel > 1.0.2m provided by
libopenssl-devel-1.1.0g-1.1.noarch
Solution 1: deinstallation of libopenssl-1_0_0-devel-1.0.2m-1.1.x86_64
Solution 2: deinstallation of libopenssl-devel-1.0.2m-1.1.noarch
Solution 3: keep obsolete libopenssl-devel-1.0.2m-1.1.noarch

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups