Mailinglist Archive: opensuse-factory (765 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171129 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171129

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
amarok
at
atftp
clamav
claws-mail
create-resources
cronie
goffice (0.10.35 -> 0.10.36)
gthumb (3.5.3 -> 3.6.0)
hddtemp
icecream
icinga
kernel-source (4.14.1 -> 4.14.2)
ldns (1.6.17 -> 1.7.0)
libchewing (0.4.0+git20150820.285b47d -> 0.5.1+git20171114.3df07c9)
lomoco
mailman
mcelog
openssl (1.0.2m -> 1.1.0g)
osc (0.161.1 -> 0.162.0)
postgresql (9.6 -> 10)
postgresql10 (9.6.4 -> 10.1)
ppp
radvd
rpcbind
rsync
scons (3.0.0 -> 3.0.1)
sensors
smartmontools
susepaste
syslogd
tftp
tlp
wondershaper
words

=== Details ===

==== amarok ====
Subpackages: amarok-lang

- Fix build with libmariadb by disabling using
mysql_config/mariadb_config (DMYSQLCONFIG_EXECUTABLE:BOOL=OFF)
and let find_library() find respective libraries in predefined
paths [bsc#1067898]
- Add amarok-2.8.0-find_mysql.patch to fix obvious typo in paths
definition in find_library()
- BuildIgnore openssl 1.0 headers to not conflict with 1.1 headers
required by some deps

==== at ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== atftp ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== clamav ====
Subpackages: libclamav7

- clamav-0.99.2-openssl-1.1.patch: fixed build against openssl 1.1

==== claws-mail ====
Subpackages: claws-mail-lang

- Disable fancy (HTML messages) plugin and drop build requires on
libwebkit, this can be re-enabled when code is updated to later
releases of libwebkit, see claws#3763.

==== create-resources ====

- Add create-scons-on-py3.patch: Fix build with scons using python3
as interpreter.

==== cronie ====
Subpackages: cron

- Ensure that /etc/cron.{hourly,daily,weekly,monthly} have proper
permissions and owner. This is racy but prevents some LPE vectors
- Requires smtp_daemon (not just Recommends) as it's needed by
run-crons script [bsc#1064834]
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== goffice ====
Version update (0.10.35 -> 0.10.36)
Subpackages: goffice-lang libgoffice-0_10-10

- Update to version 0.10.36:
+ Bug Fixes:
- Engineering format (bgo#785669).
- Crash in 3D plots when X or Y values are missing
(bgo#788437).
- Documentation build with recent gtk-doc (bgo#788710).
- Don't use invalid styles in legend from contour or surface
plots imported from Excel (bgo#788861).
- Add gio-2.0, gmodule-2.0 and gobject-2.0 pkgconfig(*)
BuildRequires:
- Add pkgconfig(libxml-2.0) BuildRequires: required dependency
checked by configure. Note that it was already being used but
not declared.
- Update typelib-1_0-GOffice-0_10 summary for something shorter and
correct GOffice spelling in devel package summary.

==== gthumb ====
Version update (3.5.3 -> 3.6.0)
Subpackages: gthumb-lang

- Update to version 3.6.0:
+ Bugs fixed: Numeric keypad nav keys don't work (bgo#667390).
- Readd bison, flex and itstool BuildRequires since configures
actually do check for them.
- Update to version 3.5.4:
+ Bugs fixed:
- No application icon on Wayland.
- Tags dialog: improved usability. Do not select the entry
content after opening the dialog; add a comma at the end of
the tags entry to simplify the addition of a new tag; support
keyboard navigation (bgo#777234).
- Hi-DPI: "High" quality zoom is pixelated on hi-dpi monitors
(bgo#779340).
- Web services: fixed errors and removed features no longer
supported by the APIs:
. Facebook: fixed authorization process; removed photo
importer.
. PicasaWeb: removed album creation; remember application
authorization (bgo#784142).
. Photobucket: removed uploader.
- Image viewer: use a white background for transparency
(bgo#780207).
- Fixed saving of uris in settings (bgo#783498).
- Color manager: fixed crash when no device is found
(bgo#789347).
- Do not save selections. This broke workflows where selections
were involved.
- Removed obsolete file gthumb.convert (bgo#767034).
+ Updated manual translations.
+ Updated translations.
- Update Url to https://wiki.gnome.org/Apps/gthumb: current
gThumb's web page.
- Point fdupes to the data directory instead of the build root,
which is a practice that must be avoided.
- Drop pkgconfig(sm) and its --with-smclient=xsmp configure
parameter: not needed/used anymore since its parameter no longer
exist.
- Drop bison, flex, pkgconfig(ice) and itstool BuildRequires: they
are not needed/used anymore.
- Replace pkgconfig(libsoup-gnome-2.4) with pkgconfig(libsoup-2.4):
libsoup is the required dependency and was already in use. They
are different files but live in the same package-devel.

==== hddtemp ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== icecream ====
Subpackages: icecream-clang-wrappers

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== icinga ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== kernel-source ====
Version update (4.14.1 -> 4.14.2)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- ipmi_si: fix memory leak on new_smi (git-fixes).
- commit 4ca3b35
- Linux 4.14.2 (bnc#1012628).
- af_netlink: ensure that NLMSG_DONE never fails in dumps
(bnc#1012628).
- vxlan: fix the issue that neigh proxy blocks all icmpv6 packets
(bnc#1012628).
- net: cdc_ncm: GetNtbFormat endian fix (bnc#1012628).
- fealnx: Fix building error on MIPS (bnc#1012628).
- net/sctp: Always set scope_id in sctp_inet6_skb_msgname
(bnc#1012628).
- ima: do not update security.ima if appraisal status is not
INTEGRITY_PASS (bnc#1012628).
- serial: omap: Fix EFR write on RTS deassertion (bnc#1012628).
- serial: 8250_fintek: Fix finding base_port with activated
SuperIO (bnc#1012628).
- tpm-dev-common: Reject too short writes (bnc#1012628).
- rcu: Fix up pending cbs check in rcu_prepare_for_idle
(bnc#1012628).
- mm/pagewalk.c: report holes in hugetlb ranges (bnc#1012628).
- ocfs2: fix cluster hang after a node dies (bnc#1012628).
- ocfs2: should wait dio before inode lock in ocfs2_setattr()
(bnc#1012628).
- ipmi: fix unsigned long underflow (bnc#1012628).
- mm/page_alloc.c: broken deferred calculation (bnc#1012628).
- mm/page_ext.c: check if page_ext is not prepared (bnc#1012628).
- coda: fix 'kernel memory exposure attempt' in fsync
(bnc#1012628).
- ipmi: Prefer ACPI system interfaces over SMBIOS ones
(bnc#1012628).
- commit 295c90a
- apparmor: fix oops in audit_signal_cb hook (bnc#1069562).
- Refresh patches.suse/0001-AppArmor-basic-networking-rules.patch.
- commit d091ad8
- bio: ensure __bio_clone_fast copies bi_partno (bnc#1069605).
- commit 59c6ade

==== ldns ====
Version update (1.6.17 -> 1.7.0)

- disable DANE verification when building with openssl < 1.1 to fix
build on distributions that have openssl 1.0.x
- Update descriptions.
- Update to version 1.7.0
* Ldns built with openssl-1.1.0 [bsc#1042653]
* Fix #551 change Regent to Copyright holder in BSD license in some of
the headings of the file, to match the opensource.org BSD license.
* -e option makes ldns-compare-zones exit with status code 2 on difference
* Filter out specified RR types with ldns-read-zone -e and -E options
* bugfix #563: Correct DNSKEY from DSA private key.
* bugfix #562: ldns-keygen match DSA key maximum size with library.
And check keysizes with all algorithms.
* ldns-verify-zone accepts only one single zonefile as argument.
* bugfix #573: ldns-keygen write private keys with mode 0600.
* Fix configure to make ldns compile with LibreSSL 2.0
* drill now also accepts dig style -y option
(-y <[algo:]name:key> i.s.o. -y <name:key[:algo]>)
* OPENPGPKEY draft rr types. Enable with: --enable-rrtype-openpgpkey
* bugfix #608: Correct comment about escaped characters
* CDS and CDNSKEY rr type from RFC 7344. --enable-rrtype-cds configure
option removed
* fix: Memory leak in ldns_pkt_rr_list_by_name()
* fix: Memory leak in ldns_dname2buffer_wire_compress()
* bugfix #613: Allow tab as whitespace too in last rdata field of types
of variable length.
* bugfix: strip trailing whitespace from $ORIGIN lines in zone files
* Let ldns-keygen output .ds files only for KSK keys
* Parse RFC7218 TLSA mnemonics, but do not output them
* Let ldns-dane use SPKI as the default selector i.s.o. Cert
* bugfix: Fit left over NSEC3s once more before adding empty non terminals
* bugfix #605: Determine default trust anchor location at compile time
* bugfix #697: Double free with ldns-dane create
* bugfix #623: Do not redefine bool type and boolean values
* bugfix #570: Add TLSA, CDS, CDNSKEY and OPENPGPKEY RR types to ldnsx
* bugfix #575: ldns_pkt_clone() does not copy timestamp field
* bugfix #584: ldns-update fixes. Send update to port 53, bring manpage
in sync with the usage text, and don't alter the ldns_resolver passed
to ldns_update_soa_zone_mname(). Created a ldns_resolver_clone()
function in the process.
* bugfix #633: ldns_pkt_clone() parameter isn't const.
* bugfix: ldns-dane manpage correction
* RFC7553 RR Type URI is supported by default.
* Fix ECDSA signature generation, do not omit leading zeroes.
* bugfix: Get rid of superfluous newline in ldns-keyfetcher
* bugfix: -U option to ldns-signzone to sign with every algorithm
* const function parameters whenever possible.
* bugfix #725: allow RR-types on the type bitmap window border
* Add type CSYNC support, RFC 7477.
* Prepare for ED25519, ED448 support: todo convert* routines in dnssec.h,
once openssl has support for signing with these algorithms. The dns
algorithm number is not yet allocated. These features are not fully
implemented yet, openssl (1.1) does not support the algorithms enough
to generate keys and sign and verify with them.
* Fix drill axfr ipv4/ipv6 queries.
* Fix for openssl 1.1.0 API changes.
* bugfix #825: Module import breaks with newer SWIG versions.
* bugfix #769: Add support for :: in an IPv6 address
* bugfix #708: warnings and errors with xcode 6.1/7.0
* bugfix #754: Memory leak in ldns_str2rdf_ipseckey
* bugfix #661: Fail NSEC3 signing when NSEC domainname length would
overflow.
* bugfix #771: hmac-sha224, hmac-sha384 and hmac-sha512 keys.
* bugfix #680: ldns fails to reject invalidly formatted RFC 7553 URI RRs.
* bugfix #678: Use poll i.s.o. select to support > 1024 fds
* Use OpenSSL DANE functions for verification (unless explicitly disabled
with --disable-dane-ta-usage).
* Bumb .so version
* Include OPENPGPKEY RR type by default
* rdata processing for SMIMEA RR type
* Fix crash in displaying TLSA RR's.
* Update ldns-key2ds man page to mention GOST and SHA384 hash functions.
* Add sha384 and sha512 tsig algorithm.
* Clarify data ownership with consts for tsig parameters.
* bugfix: Fix detection of DSA support with OpenSSL >= 1.1.0
* bugfix #1160: Provide sha256 for release tarballs
* --enable-gost-anyway compiles GOST support with OpenSSL >= 1.1.0 even
when the GOST engine is not available.
- Dropped patch ldns-perl-5.22.patch

==== libchewing ====
Version update (0.4.0+git20150820.285b47d -> 0.5.1+git20171114.3df07c9)
Subpackages: chewing-data chewing-utils libchewing3

- Update to version 0.4.0+git20171114.3df07c9:
* CMakeLists.txt: Add stress
* sort data/tsi.sr
* Add Carpalx keyboard layout support
* Fix warning in GCC
* Let CHEWING_DATA_PREFIX and TEST_DATA_DIR be absolute
* Fix wrong CHEWING_DATADIR definition in CMake build
* Fix jk_selection
* an API to convert phone to bopomofo
* Test chewing_phone_to_bopomofo with invalid phone
* Implement has_userphrase with chewing_userphrase_lookup
* libchewing.texi: Fix format tweaks
* Adjust behavior of chewing_phone_to_bopomofo
* Fix array index out of bound error in stress.c
* Make stress.c less verbose
* Prefer https for web links
* stress.c: Don't force set data path
* Fix #235: Unable to input some Bopomofos with ET26 layout
* prevent memory leak in error case of GetDefaultUserPhrasePath
* stress: clean_userphrase before each test
* stress: clean up temp ~userphrase after test
* stress: fix -extra argument parsing
* refactoring key tables in chewing test
* simplify simulate.c
* testchewing: support read input from file
* stress: support read input from file
* Fix PinYinData keySeq buffer overflow in PinYinInput()
* Fix trying to allocate buffer of negative size
* Fix access violation due to negative cursor position
* stress.c: more verbose output
* Fix heap-buffer-overflow when read wordSeq
* Use strncmp to avoid buffer overflow
* tree: avoid undefined allocation of 0 bytes (CERT MEM04-C; CWE-131)
* pinyin: avoid null-pointer dereference
* chewingutil: fix dead assignment
* Revert "libchewing.texi: Add chewing_bopomofo_String"
* Fix memory leak in Discard2
* Fix memory leak in UserUpdatePhrase().
* code clean up, use new DestroyUserPhraseData()
* userphrase-hash: avoid double free in TerminateUserphrase
* test-userphrase: add test_userphrase_double_free
* hash: fix hash item offset calculating in uhash.dat
* hash: fix memory leak in HashFileOffsetWithUserPhrase
* hash: fix memory access alignment
* Fix ChoiceEndChoice expression always true
* hash: follow consistent coding style
* Update jvc-convert of KB layout Hsu
* Auto learn phrases only after committing
* Implement chewing_set_autoLearn() and chewing_get_autoLearn()
* Fix indent in test/stress.c
* Fix build with internal sqlite3
* Fix: chewing_handle_Space() cannot input space when buffer is empty
* hash: remove goto statement
* Remove API changes/compatibility report link
* hash: follow consistent coding style

==== lomoco ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== mailman ====

- remove distributable flag (which is always true):
drops SuSEconfig.mailman-SuSE, mailman-SuSE.patch, mailman-SuSE2.patch
- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== mcelog ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== openssl ====
Version update (1.0.2m -> 1.1.0g)
Subpackages: libopenssl-devel

- Update to 1.1.0g release

==== osc ====
Version update (0.161.1 -> 0.162.0)

- 0.162.0
- Additional file content check with SHA256 when using OBS 2.9
- support deb format with control.tar.xz

==== postgresql ====
Version update (9.6 -> 10)
Subpackages: postgresql-contrib postgresql-devel postgresql-docs
postgresql-server

- instead of hardcoding version 10, just check if the prio is
smaller than 80.
- simplify the postgresql-install-alternatives to only require the
pg version and go from there.
supported calls of the script are:
/usr/share/postgresql/install-alternatives postgresqlXY
/usr/share/postgresql/install-alternatives XY
where XY can currently be: 92 93 94 95 96 10
- CVE-2017-14798, bsc#1062722: Fix LPE via postgres init script.
This only affected SysV-init based systems (i.e. SLE11).
- postgresql-test was missing a %files section.
- Move the start/stop script to /usr/share/postgresql
- Add a script for handling update-alternatives as subpackages
get installed/uninstalled, so that the implementation packages
don't have to repeat the logic (postgresql-install-alternatives).
- Add the postgresql-test subpackage.
- Fix some dependencies.
- Save the enabled and running state when upgrading from the
obsolete postgresql-init package.
- properly guard the systemd macro in %pre server so it wont be
used on sle11
- add Requires(pre) so we have groupadd/useradd available
- Refine the dependencies between the "dummy" packages and the
actual implementation of PostgreSQL. The dummy packages now
require an arbitrary implementation and recommend the default
version.
- Move the contents of postgresql-init to the server package.
- bump to 10
- Bump version and defaultpackage to 9.6 in SLE12 (bsc#1046324).

==== postgresql10 ====
Version update (9.6.4 -> 10.1)
Subpackages: libecpg6 libpq5

- port /usr/share/postgresql/install-alternatives usage to the new
scheme
- update to 10.1
* Security Issues
- CVE-2017-15098: Memory disclosure in JSON functions
- CVE-2017-15099: INSERT ... ON CONFLICT DO UPDATE fails to
enforce SELECT privileges
Prior to this release, the "INSERT ... ON CONFLICT DO UPDATE"
would not check to see if the executing user had permission
to perform a "SELECT" on the index performing the conflicting
check. Additionally, in a table with row-level security
enabled, the "INSERT ... ON CONFLICT DO UPDATE" would not
check the SELECT policies for that table before performing
the update.
This fix ensures that "INSERT ... ON CONFLICT DO UPDATE"
checks against table permissions and RLS policies before
executing.
* Bug Fixes and Improvements
This update also fixes a number of bugs reported in the last
few months. Some of these issues affect only version 10, but
many affect all supported versions:
- Fix a race condition in BRIN indexing that could cause some
rows to not be included in the indexing.
- Fix crash when logical decoding is invoked from a PL language
function.
- Several fixes for logical replication.
- Restored behavior for CTEs attached to INSERT/UPDATE/DELETE
statements to pre-version 10.
- Prevent low-probability crash in processing of nested trigger
firings.
- Do not evaluate an aggregate function's argument expressions
when the conditions in the FILTER clause evaluate to FALSE.
This complies with SQL-standard behavior.
- Fix incorrect query results when multiple GROUPING SETS
columns contain the same simple variable.
- Fix memory leak over the lifespan of a query when evaluating
a set-returning function from the target list in a SELECT.
- Several fixes for parallel query execution, including fixing
a crash in the parallel execution of certain queries that
contain a certain type of bitmap scan.
- Fix json_build_array(), json_build_object(),
jsonb_build_array(), and jsonb_build_object() to handle
explicit VARIADIC arguments correctly.
- Prevent infinite float values from being casted to the
numeric type.
- Fix autovacuum's ?work item? logic to prevent possible
crashes and silent loss of work items.
- Several fixes for VIEWs around adding columns to the end of a
view.
- Fix for hashability detection of range data types that are
created by a user.
- Improvements on using extended statistics on columns for the
purposes of query planning.
- Prevent idle_in_transaction_session_timeout from being
ignored when a statement_timeout occurred earlier.
- Fix low-probability loss of NOTIFY messages due more than 2
billion transactions processing before any queries are
executed in the session.
- Several file system interaction fixes.
- Correctly restore the umask setting when file creation fails
in COPY or lo_export().
- Fix pg_dump to ensure that it emits GRANT commands in a valid
order.
- Fix pg_basebackup's matching of tablespace paths to
canonicalize both paths before comparing to help improve
Windows compatibility.
- Fix libpq to not require user's home directory to exist when
trying to read the "~/.pgpass" file.
- Several fixes for ecpg.
- This update also contains tzdata release 2017c, with updates
for Fiji, Namibia, Northern Cyprus, Sudan, Tonga, and Turks &
Caicos Islands, plus historical corrections for Alaska,
Apia, Burma, Calcutta, Detroit, Ireland, Namibia, and Pago
Pago.
For more details see:
https://www.postgresql.org/docs/current/static/release-10-1.html
- Use /usr/share/postgresql/install-alternatives in the respective
scriptlets.
- Fix the logic around restart on upgrade and stop on removal.
We bring the binaries, but we don't own the unit file.
- Update to the final 10.0 release. Major enhancements include:
* Logical replication using publish/subscribe
* Declarative table partitioning
* Improved query parallelism
* Significant general performance improvements
* Stronger password authentication based on SCRAM-SHA-256
* Improved monitoring and control
A dump/restore using pg_dumpall, or use of pg_upgrade, is
required for those wishing to migrate data from any previous
release.
Version 10 contains a number of changes that may affect
compatibility with previous releases.
See the release notes for details:
https://www.postgresql.org/docs/10/static/release-10.html
- Reduce the number of version-related macros in the spec file.
- Break a build dependency loop in the server packages that led to
bootstrap problems.
- Update to 10rc1
PostgreSQL 10 RC 1 requires an upgrade from beta 4, or earlier
either using pg_dump / pg_restore or pg_upgrade.
Changes since beta4 include:
* Add psql variables showing server version and psql version.
* Several fixes for partitioning
* Several fixes for logical replication
* Several fixes for transition tables
* Fix for query that could end up in an uninterruptible state
- Adjust dependencies to the new packaging schema.
- update to 10beta4
PostgreSQL 10 beta 4 requires an upgrade from beta 3, or earlier
either using pg_dump / pg_restore or pg_upgrade.
Any bugfixes applied to 9.6 or earlier that also affected 10 are
included in beta 4. Our users and contributors also reported bugs
against 10 beta 3, and many of them have been fixed in this
release. We urge our community to re-test to ensure that these
bugs are actually fixed, including:
- Show foreign tables in information_schema.table_privileges
view. This fix applies to new databases, see the release notes
for the procedure to apply the fix to an existing database.
- Clean up handling of a fatal exit (e.g., due to receipt of
SIGTERM) that occurs while trying to execute a ROLLBACK of a
failed transaction
- Remove assertion that could trigger during a fatal exit
- Correctly identify columns that are of a range type or domain
type over a composite type or domain type being searched for
- Prevent crash when passing fixed-length pass-by-reference data
types to parallel worker processes
- Fix crash in pg_restore when using parallel mode and using a
list file to select a subset of items to restore
- Change ecpg?s parser to allow RETURNING clauses without
attached C variables
- Change ecpg?s parser to recognize backslash continuation of C
preprocessor command lines
- Improve selection of compiler flags for PL/Perl on Windows
- Fix make check to behave correctly when invoked via a non-GNU
make program
Note that some known issues remain unfixed. Before reporting a
bug in the beta, please check the Open Items page.
https://wiki.postgresql.org/wiki/PostgreSQL_10_Open_Items
- update to 10beta3
- hash: Fix write-ahead logging bugs related to init forks
- Fix oddity in error handling of constraint violation in
ExecConstraints for partitioned tables
- Use a real RT index when setting up partition tuple routing
- Fix serious performance problems in json(b) to_tsvector()
- Fix problems defining multi-column range partition bounds
- Fix partitioning crashes during error reporting
- Fix race conditions in replication slot operations
- Fix very minor memory leaks in psql's command.c
- PL/Perl portability fix: avoid including XSUB.h in plperl.c
- Fix inadequate stack depth checking in the wake of expression
execution changes
- Allow creation of C/POSIX collations without depending on libc
behavior
- Fix OBJECT_TYPE/OBJECT_DOMAIN confusion
- Remove duplicate setting of SSL_OP_SINGLE_DH_USE option
- Fix crash with logical replication on a function index
- Teach map_partition_varattnos to handle whole-row expressions
- Fix lock upgrade hazard in ATExecAttachPartition
- Apply ALTER ... SET NOT NULL recursively in ALTER ... ADD
PRIMARY KEY
- hash: Increase the number of possible overflow bitmaps by 8x
- Only kill sync workers at commit time in subscription DDL
- Fix bug in deciding whether to scan newly-attached partition
- Make pg_stop_backup's wait_for_archive flag work on standbys
- Fix handling of dropped columns in logical replication
- Fix local/remote attribute mix-up in logical replication
- bump version in update-alternatives call
- use multibuild
- initial package

==== ppp ====

- Add Requires group(dialout) (boo#1067511).

==== radvd ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== rpcbind ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== rsync ====

- Security fix [bsc#1066644, CVE-2017-16548]
* Missing trailing '\0' character check could lead to remote DoS
* Added rsync-CVE-2017-16548.patch

==== scons ====
Version update (3.0.0 -> 3.0.1)

- Explicitly require python3 for python3 version of scons as
dependency does not get generated automatically
- SCons 3.0.1:
* Fix return value handling in to_String_for_subst()
* Fixe Variables.GenerateHelpText() to now use the sort parameter
* Fix Tool loading logic from exploding sys.path with many
site_scons/site_tools prepended on py3.
* Add additional output with time to process each SConscript file
when using --debug=time.
* Fix broken subst logic with "$$([...])"
* Java/Jar building improvements and fixes
- Packaging changes:
* drop scons-3.0.0-support-python-2-prints.patch, now upstream
* Restore python2 support for SLE 12 and Leap 42.x
- Switch to python3

==== sensors ====
Subpackages: libsensors4 libsensors4-devel

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== smartmontools ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== susepaste ====
Subpackages: susepaste-screenshot

- Cleanup spec file with spec-cleaner

==== syslogd ====
Subpackages: klogd syslog-service

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== tftp ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== tlp ====
Subpackages: tlp-rdw

- Add tlp-1.0-run-mount.patch: Move runtime data from /var/run/tlp
to /run/tlp (boo#1058983)

==== wondershaper ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)

==== words ====

- Replace references to /var/adm/fillup-templates with new
%_fillupdir macro (boo#1069468)


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups