Mailinglist Archive: opensuse-factory (765 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171120 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171120

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
GeoIP (1.6.9 -> 1.6.11)
autofs
build (20171027 -> 20171117)
ceph (12.2.1+git.1509128342.9347aa6662 -> 12.2.1+git.1510221942.af9ea5e715)
corosync
expat (2.2.1 -> 2.2.5)
gdb
git
gpsd
grub2
installation-images-Kubic (14.340 -> 14.342)
kernel-firmware
kernel-source (4.13.12 -> 4.14.0)
konversation (1.7.3 -> 1.7.4)
libqt5-qtlocation
lzop
nano (2.8.7 -> 2.9.0)
nghttp2
opencv (3.2.0 -> 3.3.1)
pciutils-ids (20171018 -> 20171021)
perl-DBD-mysql
php7
python-M2Crypto
python-dbus-python
python-py (1.4.34 -> 1.5.0)
python-setuptools (36.6.0 -> 36.7.2)
rubygem-gem2rpm
skopeo (0.1.24 -> 0.1.26)
strace (4.19 -> 4.20)
xfce4-panel-plugin-whiskermenu (2.1.3 -> 2.1.4)
xournal
yast2-ycp-ui-bindings (3.2.0 -> 4.0.0)
zypp-plugin (0.6.1 -> 0.6.2)

=== Details ===

==== GeoIP ====
Version update (1.6.9 -> 1.6.11)
Subpackages: GeoIP-data libGeoIP1

- Rectify RPM groups.
Remove pointless --with-pic since there are no static libs.
- Update to version 1.6.11:
* Fix use of a NULL pointer when opening a corrupt database with
GeoIP_open
* GeoIP_database_info now returns the full version string rather
than incorrectly truncating it.

==== autofs ====

- Add build require for rpcgen (preparation for removing it from
glibc)

==== build ====
Version update (20171027 -> 20171117)
Subpackages: build-mkbaselibs build-mkdrpms

- prepare for suse_version 1550 in factory (by Dominique)

==== ceph ====
Version update (12.2.1+git.1509128342.9347aa6662 ->
12.2.1+git.1510221942.af9ea5e715)
Subpackages: librados2 librbd1

- Update to version 12.2.1+git.1510221942.af9ea5e715:
+ bsc#1066502
* mon/osd_metadata: sync osd_metadata table
* mon/OSDMonitor: tidy prefix definitions
* mon: implement MDSMonitor::get_store_prefixes
* mon/mgr: sync mgr_command_descs table and mgr_metadata table
* mon/MgrMonitor: populate on-disk cmd descs if empty on upgrade
* mon/MgrMonitor: read cmd descs if empty on update_from_paxos()
+ bsc#1067088
* osd: make the PG's SORTBITWISE assert a more generous shutdown
+ bsc#1066182
* rgw: ListBucketIndexesCR spawns entries_index after listing metadata
* rgw: fix error handling in ListBucketIndexesCR
* rgw: RGWDataSyncControlCR retries on all errors
+ RGW fixes:
* test/rgw: add test_multipart_object_sync
* cls/rgw: increment header version to avoid overwriting bilog entries
* rgw: disable dynamic resharding in multisite environment

==== corosync ====
Subpackages: libcmap4 libcorosync_common4

- corosync race condition when node leaves immediately after
joining(bsc#1067958)
Added: 0007-sync-Call-sync_init-of-all-services-at-once.patch

==== expat ====
Version update (2.2.1 -> 2.2.5)
Subpackages: libexpat-devel libexpat1 libexpat1-32bit

- Expand description of expat-devel.
- Do not generate manpages from docbook
- Temporarily disable profiling due to bug in build system
- Version update to 2.2.5 Tue October 31 2017
* Bug fixes:
- If the parser runs out of memory, make sure its internal
state reflects the memory it actually has, not the memory
it wanted to have.
- The default handler wasn't being called when it should for
a SYSTEM or PUBLIC doctype if an entity declaration handler
was registered.
- Fix a case of mistakenly reported parsing success where
XML_StopParser was called from an element handler
- Function XML_ErrorString was returning NULL rather than
a message for code XML_ERROR_INVALID_ARGUMENT
introduced with release 2.2.1
* Other changes:
- Add argument -N adding notation declarations
- various compiler-specific fixes
- Improve docbook2x-man detection
- drop expat-docbook.patch
* fixed in 0f5186c7b8e503c669e332d944712de010b265f3
- switch to github for release tarballs and website
- Version update to 2.2.4 Sat August 19 2017
* Bug fixes:
[#115] Fix copying of partial characters for UTF-8 input
* Other changes:
[#109] Fix "make check" for non-x86 architectures that default
to unsigned type char (-128..127 rather than 0..255)
[#109] coverage.sh: Cover -funsigned-char
Autotools: Introduce --without-xmlwf argument
[#65] Autotools: Replace handwritten Makefile with GNU Automake
[#43] CMake: Auto-detect high quality entropy extractors, add new
option USE_libbsd=ON to use arc4random_buf of libbsd
[#74] CMake: Add -fno-strict-aliasing only where supported
[#114] CMake: Always honor manually set BUILD_* options
[#114] CMake: Compile man page if docbook2x-man is available, only
[#117] Include file tests/xmltest.log.expected in source tarball
(required for "make run-xmltest")
[#111] Fix some typos in documentation
Version info bumped from 7:5:6 to 7:6:6
- Release 2.2.3 Wed August 2 2017
* Bug fixes:
[#85] Fix a dangling pointer issue related to realloc
* Other changes:
[#91] Linux: Allow getrandom to fail if nonblocking pool has not
yet been initialized and read /dev/urandom then, instead.
This is in line with what recent Python does.
[#86] Check that a UTF-16 encoding in an XML declaration has the
right endianness
[#4] #5 #7 Recover correctly when some reallocations fail
Repair "./configure && make" for systems without any
provider of high quality entropy
and try reading /dev/urandom on those
Ensure that user-defined character encodings have converter
functions when they are needed
Fix mis-leading description of argument -c in xmlwf.1
Rely on macro HAVE_ARC4RANDOM_BUF (rather than __CloudABI__)
for CloudABI
[#100] Fix use of SIPHASH_MAIN in siphash.h
[#23] Test suite: Fix memory leaks
Version info bumped from 7:4:6 to 7:5:6
- Release 2.2.2 Wed July 12 2017
* Security fixes:
[#43] Protect against compilation without any source of high
quality entropy enabled, e.g. with CMake build system;
* [MOX-006] Fix non-NULL parser parameter validation in XML_Parse;
resulted in NULL dereference, previously;
* Bug fixes:
[#69] Fix improper use of unsigned long long integer literals
* Other changes:
[#73] Start requiring a C99 compiler
[#49] Fix "==" Bashism in configure script
[#58] Address compile warnings
[#68] Fix "./buildconf.sh && ./configure" for some versions
of Dash for /bin/sh
[#72] CMake: Ease use of Expat in context of a parent project
with multiple CMakeLists.txt files
[#72] CMake: Resolve mistaken executable permissions
[#76] Address compile warning with -DNDEBUG (not recommended!)
[#77] Address compile warning about macro redefinition
* Added patch expat-docbook.patch to compile the man pages with
docbook-to-man
* Cleaned spec file with spec-cleaner

==== gdb ====

- Support --without=testsuite and disable testsuite for qemu-linux-user
builds

==== git ====
Subpackages: git-core git-cvs git-daemon git-email git-gui git-svn git-web gitk

- split off p4 to a subpackage (bsc#1067502)
- do not buildrequire asciidoc (dependent on Python 2) when
not building docs
- switch to Python 3 for tests

==== gpsd ====

- Rename python subpackage to python2

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- 0001-add-support-for-UEFI-network-protocols.patch:
* Workaround http data access in firmware
* Fix DNS device path parsing for efinet device
* Relaxed UEFI Protocol requirement
* Support Intel OPA (Omni-Path Architecture) PXE Boot (bsc#1015589)

==== installation-images-Kubic ====
Version update (14.340 -> 14.342)

- merge gh#openSUSE/installation-images#215
- add fixed.ko (bsc#1067827)
- 14.342
- merge gh#openSUSE/installation-images#213
- move cryptsetup into initrd to allow reading of encrypted volumes
- 14.341
- merge gh#openSUSE/installation-images#212
- squashfs.ko might depend on zstd_decompress

==== kernel-firmware ====
Subpackages: ucode-amd

- Remove iwlwifi-*-34.ucode since they seem breaking with 4.13.x
TW kernel (bsc#1068838)
- Update Intel WiFi firmwares:
the files are still not included in linux-firmware.git, hence
applied individually.
* For security updates (CVE-2017-13080 CVE-2017-13081 bsc#1066295)
* For new chipset models (FATE#322675)
iwlwifi-3160-17.ucode
iwlwifi-3168-29.ucode
iwlwifi-7260-17.ucode
iwlwifi-7265-17.ucode
iwlwifi-7265D-29.ucode
iwlwifi-8000C-31.ucode
iwlwifi-8000C-34.ucode
iwlwifi-8265-31.ucode
iwlwifi-8265-34.ucode
iwlwifi-9000-pu-b0-jf-b0-33.ucode
iwlwifi-9260-th-b0-jf-b0-33.ucode
WHENCE-iwlwifi-update.patch

==== kernel-source ====
Version update (4.13.12 -> 4.14.0)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Update to 4.14-final.
- commit c152297
- rpm/kernel-binary.spec.in: rename kGraft to KLP (fate#323682)
- commit 0ed191d

==== konversation ====
Version update (1.7.3 -> 1.7.4)
Subpackages: konversation-lang

- Update to 1.7.4:
* Fixed a bug causing the size of a custom chat text view font
set via the configuration dialog to be ignored. A font size
modification done via the Enlarge/Decrease Font Size actions
is now applied on top of the configured size (or the system
default font size, respectively).

==== libqt5-qtlocation ====
Subpackages: libQt5Location5 libQt5Positioning5 libqt5-qtlocation-devel

- Drop pkgconfig(geoclue) BuildRequires: geoclue is obsoleted by
geoclue2, and it is not used during compilation of this package
so just drop it.

==== lzop ====

- Remove bias from descriptions.

==== nano ====
Version update (2.8.7 -> 2.9.0)
Subpackages: nano-lang

- GNU nano 2.9.0:
* introduce the ability to record and replay keystrokes:
(M-: to start and stop recording, M-; to play the macro back)
* make ^Q and ^S do something useful by default
(^Q starts a backward search, and ^S saves the current file)
* change ^W to start always a forward search,
* show the number of open buffers (when more than one) in the title bar
* no longer ask to press Enter when there are errors in an rc file
* retire the options '--quiet' and 'set quiet' and 'set backwards'
* make indenting and unindenting undoable
* look in $XDG_CONFIG_HOME for a nanorc file
* look in $XDG_DATA_HOME for the history files
* add a history stack for executed commands (^R^X)
* do not overwrite the position-history file of another nano
* fix a score of tiny bugs

==== nghttp2 ====

- Drop forgotten python2 build dependency

==== opencv ====
Version update (3.2.0 -> 3.3.1)
Subpackages: opencv-devel

- Update licensing information
- change requires of python-numpy-devel to build in Leap and
to not break factory in future
- fix build error/unresolvable for Leap 42.2 and 42.3
- Update to version 3.3.1:
* Lots of various bugfixes
- Update source url
- Rename python subpackage to python2
- Do not explicitly require python-base for python subpackages
- Update to 3.3
- Dropped obsolete patches
* opencv-gcc6-fix-pch-support-PR8345.patch
* opencv-gles.patch
- Updated opencv-build-compare.patch

==== pciutils-ids ====
Version update (20171018 -> 20171021)

- Update to 20171021

==== perl-DBD-mysql ====

- Fixed build with libmariadb [bsc#1067882]
- Added patch:
* perl-DBD-mysql-4.043-Fix-build-failures-for-MariaDB.patch

==== php7 ====
Subpackages: apache2-mod_php7 php7-bcmath php7-bz2 php7-calendar php7-ctype
php7-curl php7-dba php7-devel php7-dom php7-exif php7-fastcgi php7-ftp php7-gd
php7-gettext php7-gmp php7-iconv php7-imap php7-json php7-ldap php7-mbstring
php7-mysql php7-odbc php7-openssl php7-pdo php7-pear php7-pear-Archive_Tar
php7-pgsql php7-shmop php7-snmp php7-sockets php7-sqlite php7-sysvsem
php7-sysvshm php7-tidy php7-tokenizer php7-wddx php7-xmlreader php7-xmlwriter
php7-xsl php7-zlib

- Add php-cli as provides to php7

==== python-M2Crypto ====

- use generic way to require python-typing now that python3 provides it

==== python-dbus-python ====
Subpackages: python2-dbus-python python3-dbus-python

- drop unneeded epydoc requirement (API docs were not built anyway)

==== python-py ====
Version update (1.4.34 -> 1.5.0)
Subpackages: python2-py python3-py

- update to version 1.5.0:
* python 2.6 and 3.3 are no longer supported
* deprecate py.std and remove all internal uses
* fix #73 turn py.error into an actual module
* path join to / no longer produces leading double slashes
* fix #82 - remove unsupportable aliases
* fix python37 compatibility of path.sysfind on windows by correctly
replacing vars
* turn iniconfig and apipkg into vendored packages and ease
de-vendoring for distributions
* fix #68 remove invalid py.test.ensuretemp references
* fix #25 - deprecate path.listdir(sort=callable)
* add TerminalWriter.chars_on_current_line read-only property that
tracks how many characters have been written to the current line.

==== python-setuptools ====
Version update (36.6.0 -> 36.7.2)
Subpackages: python2-setuptools python3-setuptools

- Trim bias from description.
- specfile:
* add missing url field
- update to version 36.7.2:
* #701: Fixed duplicate test discovery on Python 3.
- update to version 36.7.1:
* #1193: Avoid test failures in bdist_egg when
PYTHONDONTWRITEBYTECODE is set.
- changes from version 36.7.0:
* #1054: Support setup_requires in setup.cfg files.
- changes from version 36.6.1:
* #1132: Removed redundant and costly serialization/parsing step in
EntryPoint.__init__.
* #844: bdist_egg --exclude-source-files now tested and works on
Python 3.

==== rubygem-gem2rpm ====

- disable 2.2 on suse_version 1315

==== skopeo ====
Version update (0.1.24 -> 0.1.26)

- Update to skopeo v0.1.26. This includes a fix for CVE-2017-14992.
- Disable containers/storage integration by default (through
containers_image_storage_stub), as it is very dodgy and not widely used.

==== strace ====
Version update (4.19 -> 4.20)

- Update to strace 4.20
* Improvements
* Implemented decoding of NETLINK_NETFILTER netlink message types and flags.
* Implemented decoding of SECCOMP_GET_ACTION_AVAIL operation of seccomp
syscall.
* Updated lists of ARPHRD_*, BPF_*, ETH_P_*, LOOP_*, MADV_*,
MEMBARRIER_CMD_*, MFD_*, SECCOMP_*, SO_*, SOL_*, TCP_*, and UFFD_FEATURE_*
constants.
* Added decoding of statx syscall on hppa.
* Updated lists of ioctl commands from Linux 4.14.
* Bug fixes
* Fixed powerpc personality support on powerpc64.

==== xfce4-panel-plugin-whiskermenu ====
Version update (2.1.3 -> 2.1.4)
Subpackages: xfce4-panel-plugin-whiskermenu-lang

- update to 2.1.4:
- Fix excessive padding on panel button. (bxo#13611)
- Fix blurry category buttons with high DPI.
- Fix blurry profile picture with high DPI.
- Fix panel icon too big with high DPI. (bxo#13893)
- Translation updates

==== xournal ====

- Switch BuildRequires to pkgconfig based ones wherever possible.

==== yast2-ycp-ui-bindings ====
Version update (3.2.0 -> 4.0.0)

- Fixed segfault when comparing YCPValueWidgetIDs with
YStringWidgetIDs (fate#324098)
- 4.0.0

==== zypp-plugin ====
Version update (0.6.1 -> 0.6.2)

- Don't use a shebang in the module
- version 0.6.2


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >