Mailinglist Archive: opensuse-factory (765 mails)

< Previous Next >
Re: [opensuse-factory] nvidia is killed by kernel 4.13.12 beware
On 13/11/17 03:33 PM, Bruno Friedmann wrote:
On lundi, 13 novembre 2017 20.56:42 h CET Robert Munteanu wrote:
> On Mon, Nov 13, 2017 at 9:47 PM, Bruno Friedmann <bruno@xxxxxxxxxxx> wrote:
>> On lundi, 13 novembre 2017 20.35:36 h CET Daniele wrote:
>>> # modprobe nvidia
>>> modprobe: ERROR: could not find module by name='nvidia'
>>> modprobe: ERROR: could not insert 'nvidia': Unknown symbol in module, or
>>> unknown parameter (see dmesg)
>>>
>>> nothing in dmesg
>>>
>>> Daniele.
>>
>> Kernel nvidia module disagree with symbol. I'm actually finishing rebuild
>> them locally to test if just a rebuild is needed or more.
>>
>> Stay tune if I can reboot.
>
> Finished recovering from this :-) You need to install libelf-devel for
> the driver to build properly. So
>
> # zypper in libelf-devel
> # zypper in -f nvidia-gfxG04-kmp-default
> # reboot
>
> and you should be good to go.
>
> Robert

I was aware of libelf-devel and this one was not enough to make things working
correctly.

In the meantime I've rebuild locally the whole rpm and those once installed
are working. I've reported that a rebuild of rpm against directly the right
kernel has worked.

https://bugzilla.opensuse.org/show_bug.cgi?id=1067929


This should be addressed in the next snapshot.

--
Cheers!

Roman
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups