Mailinglist Archive: opensuse-factory (765 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171111 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171111

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick (7.0.7.8 -> 7.0.7.10)
PackageKit
SDL2 (2.0.6 -> 2.0.7)
acpid (2.0.27 -> 2.0.28)
alsa-utils
antlr
apr
apr-util (1.6.0 -> 1.6.1)
blog
bluedevil5 (5.11.2 -> 5.11.3)
breeze (5.11.2 -> 5.11.3)
breeze-gtk (5.11.2 -> 5.11.3)
breeze4-style (5.11.2 -> 5.11.3)
cellwriter (1.3.4 -> 1.3.6)
ceph (12.2.1+git.1507910930.aea79b8b7a -> 12.2.1+git.1509128342.9347aa6662)
chasen
cmake (3.9.4 -> 3.9.5)
corosync
cups (2.2.5 -> 2.2.6)
cups-filters
dracut
drkonqi5 (5.11.2 -> 5.11.3)
fftw3 (3.3.5 -> 3.3.6)
filesystem
glusterfs (3.6.6 -> 3.8.15)
gnome-calculator (3.25.92 -> 3.26.0)
gnome-photos (3.26.1 -> 3.26.2)
gnome-settings-daemon (3.26.1 -> 3.26.2)
gnome-shell (3.26.1 -> 3.26.2)
gnome-tweak-tool (3.26.2.1 -> 3.26.3)
gnutls (3.6.0 -> 3.6.1)
google-noto-fonts (20161025 -> 20170919)
grub2
gstreamer-plugins-libav
ibus (1.5.16 -> 1.5.17)
icewm (1.3.12 -> 1.4.2)
kactivitymanagerd (5.11.2 -> 5.11.3)
kde-cli-tools5 (5.11.2 -> 5.11.3)
kde-gtk-config5 (5.11.2 -> 5.11.3)
kde-user-manager (5.11.2 -> 5.11.3)
keyutils
kgamma5 (5.11.2 -> 5.11.3)
khotkeys5 (5.11.2 -> 5.11.3)
kinfocenter5 (5.11.2 -> 5.11.3)
kio
kmenuedit5 (5.11.2 -> 5.11.3)
krb5
kscreen5 (5.11.2 -> 5.11.3)
kscreenlocker (5.11.2 -> 5.11.3)
ksshaskpass5 (5.11.2 -> 5.11.3)
ksysguard5 (5.11.2 -> 5.11.3)
kwin5 (5.11.2 -> 5.11.3)
less
libdrm (2.4.87 -> 2.4.88)
libetonyek (0.1.6 -> 0.1.7)
libkdecoration2 (5.11.2 -> 5.11.3)
libkscreen2 (5.11.2 -> 5.11.3)
libksysguard5 (5.11.2 -> 5.11.3)
libuv (1.10.1 -> 1.15.0)
libvirt (3.8.0 -> 3.9.0)
lilv (0.22.0 -> 0.24.2)
linphone
milou5 (5.11.2 -> 5.11.3)
miniupnpc (2.0.20170509 -> 2.0.20171102)
mjpegtools
multipath-tools
mutter (3.26.1 -> 3.26.2)
ncurses
openssl (1.0.2l -> 1.0.2m)
openssl-1_0_0 (1.0.2l -> 1.0.2m)
oxygen5 (5.11.2 -> 5.11.3)
pcre
permissions (20171025 -> 20171106)
pidgin
plasma-nm5 (5.11.2 -> 5.11.3)
plasma5-addons (5.11.2 -> 5.11.3)
plasma5-desktop (5.11.2 -> 5.11.3)
plasma5-integration (5.11.2 -> 5.11.3)
plasma5-openSUSE
plasma5-pa (5.11.2 -> 5.11.3)
plasma5-workspace (5.11.2 -> 5.11.3)
polkit-kde-agent-5 (5.11.2 -> 5.11.3)
powerdevil5 (5.11.2 -> 5.11.3)
python-PySocks (1.6.6 -> 1.6.7)
python-base
python-wxWidgets-3_0
sendmail
simple-scan (3.26.1 -> 3.26.2)
systemd-presets-branding-openSUSE
systemsettings5 (5.11.2 -> 5.11.3)
tbb
vinagre
virglrenderer
virt-manager
xml-security-c
yast2-users (3.2.12 -> 4.0.0)
yast2-vm (3.2.3 -> 3.2.4)
ypserv

=== Details ===

==== ImageMagick ====
Version update (7.0.7.8 -> 7.0.7.10)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-7_Q16HDRI3
libMagickCore-7_Q16HDRI4 libMagickWand-7_Q16HDRI4 perl-PerlMagick

- update to 7.0.7-10
* Fixed a problem with resource bookkeeping in
AcquireMatrixInfo().
- update to 7.0.7-9
* Encode JSON control characters.
* Added support for reading mipmaps in dds images.
- removed unneded ImageMagick-relax-filter.t.patch

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Drop py_requires from PackageKit: there are no python scripts in
the main package.
- Drop python-devel BuildRequires: we do not package the python
packagend anyway.
- Have post/postun script for PackageKit-gtk3-module post/postun
only for suse_version < 1330: newer versions have file triggers
to trigger schema compilation.

==== SDL2 ====
Version update (2.0.6 -> 2.0.7)

- update to 2.0.7
* Added audio stream conversion functions.
* Added functions to query and set the SDL memory allocation
functions.
* Added locking functions for multi-threaded access to
the joystick and game controller APIs.
* Some functions are now thread-safe.
- removed patches, merged upstream
* dbus.diff
* SDL2-ppc64-declaration-after-statement.patch
* SDL-bnc1062784-check-overflow-xcf-props.patch

==== acpid ====
Version update (2.0.27 -> 2.0.28)

- Update to version 2.0.28
* Fix intermittent "Address already in use"
* inotify: process all inotify messages in buffer
* Use proper lengths for inotify buffers.

==== alsa-utils ====

- drop unused requirement for python-docutils

==== antlr ====
Subpackages: antlr-devel antlr-java

- Explicitly require python2

==== apr ====
Subpackages: apr-devel libapr1

- Do not require python for building - its not needed anyways
(fate#323526)

==== apr-util ====
Version update (1.6.0 -> 1.6.1)
Subpackages: apr-util-devel libapr-util1

- APR-util 1.6.1
* apr_crypto: Fix compatibility with LibreSSL. PR 61596.
* sdbm: better database/page validation to fail cleanly when
corrupted [bsc#1064990], CVE-2017-12618

==== blog ====

- Change description of blog-plymouth in same manner as used by
the release notes

==== bluedevil5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: bluedevil5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== breeze ====
Version update (5.11.2 -> 5.11.3)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style
breeze5-style-lang breeze5-wallpapers

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== breeze-gtk ====
Version update (5.11.2 -> 5.11.3)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== breeze4-style ====
Version update (5.11.2 -> 5.11.3)

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== cellwriter ====
Version update (1.3.4 -> 1.3.6)

- updated to v1.3.6:
- includes fixes from 1.3.5
- see ChangeLog for all changes
- clean with spec-cleaner
- drop cellwriter-no-copy-dt-needed-entries.patch, fixed upstream

==== ceph ====
Version update (12.2.1+git.1507910930.aea79b8b7a ->
12.2.1+git.1509128342.9347aa6662)
Subpackages: librados2 librbd1

- Update to version 12.2.1+git.1509128342.9347aa6662:
+ common/common_init: disable ms subsystem log gathering for clients
+ spec file: add %{_sysctldir}/90-ceph-osd.conf to ceph-osd
* ceph.spec.in,debian/rules: change aio-max-nr to 1048576
* sysctl.d: set kernel.pid_max=4194304 (bsc#1061461)

==== chasen ====
Subpackages: perl-Text-ChaSen

- Add chasen-initialize-memory.patch to make ipadic build
reproducibly (boo#1061219)

==== cmake ====
Version update (3.9.4 -> 3.9.5)

- update to 3.9.5:
* Autogen: Don't add AUTOMOC_MOC_OPTIONS to moc-predefs command

==== corosync ====
Subpackages: libcmap4 libcorosync_common4

- gcc: snprintf gives warning: ?%s? directive output may be truncated writing
8 bytes into a region of size between 1 and 255(bsc#1066090)
Added: 0006-Fix-compile-warnings-with-GCC-7.2.1.patch
- coroparse: uidgid with empty uid or gid results into add uid 0(bsc#1066585)
Added: 0005-do-not-convert-empty-uid-gid-to-0.patch

==== cups ====
Version update (2.2.5 -> 2.2.6)
Subpackages: cups-client cups-config cups-devel libcups2 libcups2-32bit
libcupscgi1 libcupsimage2 libcupsmime1 libcupsppdc1

- Version upgrade to 2.2.6:
CUPS 2.2.6 is a general bug fix release.
For details see https://github.com/apple/cups/releases
Changes include:
* DBUS notifications could crash the scheduler (Issue #5143)
(see also bsc#1061066 "DBUS library aborts caller process")

==== cups-filters ====

- Obsolete also debuginfo subpackages of the packages marked as
Obsoletes in this specfile (bsc#1047897)

==== dracut ====

- Ensure 0541-Make-sure-70-persistent-net.rules-is-included-in-ini.patch
is not applied on SLE.

==== drkonqi5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: drkonqi5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== fftw3 ====
Version update (3.3.5 -> 3.3.6)
Subpackages: fftw3-devel libfftw3-3 libfftw3_threads3

- update to 3.3.6-pl2
* Bugfix: MPI Fortran-03 headers were missing in FFTW 3.3.6-pl1.
* Bugfix: FFTW 3.3.6 had the wrong libtool version number, and generated
shared libraries of the form libfftw3.so.2.6.6 instead of
libfftw3.so.3.*.
* The fftw_make_planner_thread_safe() API introduced in 3.3.5 didn't
work, and this 3.3.6 fixes it. Sorry about that.
* compilation fixes for IBM XLC
* compilation fixes for threads on Windows
* fix SIMD autodetection on amd64 when (_MSC_VER > 1500)

==== filesystem ====

- Add /usr/share/metainfo: this is the new location defined by
AppStream to replace /usr/share/appdata.

==== glusterfs ====
Version update (3.6.6 -> 3.8.15)
Subpackages: libgfapi0 libgfrpc0 libgfxdr0 libglusterfs0

- Explicitly require python2 as python3 is not yet supported
- Add missing Requires: libacl-devel to the devel subpackage
* glfs.h #includes <sys/acl.h>
- Update to version 3.8.15
* fixes build with OpenSSL 1.1 (bsc#1055466)
* Mandatory lock support for Multiprotocol environment
* Gluster/NFS disabled by default
* Geo-replication for Sharded Volumes
* Tiering aware Geo-replication
* Enhance Quota enable/disable in glusterd
* Automagic unsplit-brain by [ctime|mtime|size|majority] for AFR
* Granular Entry self-heal for AFR
* Tons of bugfixes
* for more details see the NEWS file
- spec cleanup
- Install License files/docu

==== gnome-calculator ====
Version update (3.25.92 -> 3.26.0)
Subpackages: gnome-calculator-lang gnome-shell-search-provider-gnome-calculator

- Update to version 3.26.0:
+ Fix gettext-domain.
+ Updated translations.

==== gnome-photos ====
Version update (3.26.1 -> 3.26.2)
Subpackages: gnome-photos-lang gnome-shell-search-provider-gnome-photos

- Update to version 3.26.2:
+ Bugs fixed: Can't discard all edits directly from the overview
without previewing the BaseItem (bgo#788715).
+ Updated translations.
- Update Url to https://wiki.gnome.org/Design/Apps/Photos: current
Photos' web page.
- Drop %glib2_gsettings_schema_requires macro: the functionality is
covered by file triggers now.
- Add fdupes BuildRequires and its macro for removal of duplicates
under the data directory.

==== gnome-settings-daemon ====
Version update (3.26.1 -> 3.26.2)
Subpackages: gnome-settings-daemon-lang

- Avoid running fdupes across hardlink boundaries.
- Fix an error in the description.
- Update to version 3.26.2:
+ Housekeeping:
- Ignore more virtual file systems (bgo#788879).
- Fix the Empty Trash button in Settings not working
(bgo#737624).
+ Media-keys: Fix custom binding command changes not getting
applied (bgo#789782).
+ Minor cleanups.
+ Updated translations.

==== gnome-shell ====
Version update (3.26.1 -> 3.26.2)
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar gnome-shell-lang

- Move SLE-Classic function to gnome-shell-extensions package
(bsc#1065611).
+ Remove gs-sle-classic-ext.patch
+ Remove SLEClassicExt.js
- Update to version 3.26.2:
+ Dump javascript stack on aborts, traps and segfaults
(bgo#789237).
+ Misc. bug fixes: bgo#788607, bgo#789018, bgo#789231.
+ Updated translations.
- Update Url to https://wiki.gnome.org/Projects/GnomeShell: current
GNOME Shell's project web page.
- Drop %glib2_gsettings_schema_requires macro: the functionality is
covered by file triggers now.
- Drop fixed upstream patches:
gnome-shell-unset-primary-and-bottom-monitor-when-headless.patch
and gnome-shell-spawn-wifi-panel-for-wep-configuration.patch.
- Rebase patches: gnome-shell-private-connection.patch and
gnome-shell-osk-dont-popup-when-not-needed.patch.

==== gnome-tweak-tool ====
Version update (3.26.2.1 -> 3.26.3)
Subpackages: gnome-tweak-tool-lang

- Update to version 3.26.3:
+ Updated translations.

==== gnutls ====
Version update (3.6.0 -> 3.6.1)
Subpackages: libgnutls-dane0 libgnutls-devel libgnutls30 libgnutls30-32bit

- GnuTLS 3.6.1:
* Fix interoperability issue with openssl when safe renegotiation
was used
* gnutls_x509_crl_sign, gnutls_x509_crt_sign,
gnutls_x509_crq_sign, were modified to sign with a better
algorithm than SHA1. They will now sign with an algorithm that
corresponds to the security level of the signer's key.
* gnutls_x509_*_sign2() functions and gnutls_x509_*_privkey_sign()
accept GNUTLS_DIG_UNKNOWN (0) as a hash function option. That
will signal the function to auto-detect an appropriate hash
algorithm to use.
* Remove support for signature algorithms using SHA2-224 in TLS.
TLS 1.3 no longer uses SHA2-224 and it was never a widespread
algorithm in TLS 1.2
* Refuse to use client certificates containing disallowed
algorithms for a session, reverting a change on 3.5.5
* Refuse to resume a session which had a different SNI advertised
That improves RFC6066 support in server side.
* p11tool: Mark all generated objects as sensitive by default.
* p11tool: added options --sign-params and --hash. This allows
testing signature with multiple algorithms, including RSA-PSS.

==== google-noto-fonts ====
Version update (20161025 -> 20170919)
Subpackages: google-noto-fonts-doc noto-sans-fonts

- update to version 20170919
- new: Adlam Sans Serif Font
- new: Adlam Unjoined Sans Serif Font
- new: Anatolian Hieroglyphs Sans Serif Font
- new: Arabic Sans Serif Font
- new: Chakma Sans Serif Font
- new: Display Sans Serif Font
- new: Osage Sans Serif Font

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- grub2-xen-pv-firmware.cfg: remove linemode=1 from cmdline for
SUSE installer. openQA expects ncurses interface. (bsc#1066919)
- use python3 for autogen.sh (fate#323526)
- Do not check that PReP partition does not contain an ELF during installation
(bsc#1065738).
* grub2-install-remove-useless-check-PReP-partition-is-empty.patch

==== gstreamer-plugins-libav ====

- Add gst-libav-ffmpeg-3.4-hackfix.patch: Workaround api change in
ffmpeg 3.4 and newer (bgo#789193).

==== ibus ====
Version update (1.5.16 -> 1.5.17)
Subpackages: ibus-branding-openSUSE-KDE ibus-gtk ibus-gtk-32bit ibus-gtk3
ibus-lang libibus-1_0-5 libibus-1_0-5-32bit python-ibus typelib-1_0-IBus-1_0

- Enable python3 build
- Update to 1.5.17
* ui/gtk3: Emojier supports Ctrl-c,v,x and Ctrl-Shift-c
* Make all emoji dicts for fully qualified
* ui/gtk3: Fix SEGV of Emojier on de_DE.UTF-8
* ui/gtk3: Do not activate emoji cells on mouse until mouse moves
* ui/gtk3: Fix SEGV of XKeysymToKeycode() on Wayland
* client/gtk2: include the scaling factor in Wayland
* Add IBus portal service to support Flatpack
* ui/gtk3: Switcher should ignore mouse until it moves
* client/gtk2: Do not send key events to GtkIMContextSimple
* ui/gtk3: Fix PropertyPanel position in workarea
* ui/gtk3: Fix to enable menu button on PropertyPanel
* ui/gtk3: Increase timeout of window filter in PropertyPanel
* ui/gtk3: Unset GDK_CORE_DEVICE_EVENTS
* ui/gtk3: Unref Panel and Indicator when double panels run
* engine: Add Malay and Mongolian keymaps
* Update translations

==== icewm ====
Version update (1.3.12 -> 1.4.2)
Subpackages: icewm-config-upstream icewm-default icewm-lite

- Bring back full icewm-preferences.patch from 1.3 series to actually
work
- Use prefoverride instead of preferences in the sysconfig to make
sure take priority over theme
- Move programs config option to /etc from /usr/share
- Partially revert icewm-preferences.patch to previous revision, otherwise
the icewm default desktop background is used instead of the openSUSE/SLE
specific one, breaking openQA all over the place
- Update to 1.4.2
- Rebase patches
- icewm-susemenu.patch: rebase "suseprog" function
- icewm-preferences.patch: rebase, only IconPath hunk not in upstream now
- icewm-mate.patch: rebase several hunks in which context changed
- Drop patches that were accepted upstream
- icewm-session-desktop.patch
- icewm-exit-fork.patch
- icewm-mail.patch
- Swap "sgmltool" for "asciidoc"

==== kactivitymanagerd ====
Version update (5.11.2 -> 5.11.3)

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* [resources] Nicely quit threads

==== kde-cli-tools5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kde-cli-tools5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== kde-gtk-config5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kde-gtk-config5-gtk2 kde-gtk-config5-gtk3 kde-gtk-config5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Be flexible to systems without a gtkrc file in /etc (kde#382291)

==== kde-user-manager ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kde-user-manager-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== keyutils ====
Subpackages: keyutils-devel libkeyutils1 libkeyutils1-32bit

- add keyutils-devel for baselibs, to allow biarch LTP builds.
(bsc#1061591)

==== kgamma5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kgamma5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== khotkeys5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: khotkeys5-devel khotkeys5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== kinfocenter5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kinfocenter5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== kio ====
Subpackages: kio-core kio-devel kio-lang

- Add fix-handling-of-KCookieAdvice_AcceptForSession.patch to
fix the "Accept For Session" cookie setting that was not properly
respected (boo#1049975, kde#386325)

==== kmenuedit5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kmenuedit5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== krb5 ====
Subpackages: krb5-32bit krb5-devel krb5-server

- Remove build dependency doxygen, python-Cheetah, python-Sphinx,
python-libxml2, python-lxml, most of which are python 2 programs.
Consequently remove -doc subpackage. Users are encouraged to use
online documentation. (bsc#1066461)

==== kscreen5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kscreen5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Don't re-align outputs when QMLOutput in clone mode moves
* Keep the unified QMLOutput always in center

==== kscreenlocker ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kscreenlocker-lang libKScreenLocker5

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== ksshaskpass5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: ksshaskpass5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== ksysguard5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: ksysguard5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== kwin5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: kwin5-devel kwin5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Don't use the global KConfig object on the OpenGL freeze detection thread
(kde#372114)
* Fix rendering issues of subsurfaces by using proper clipping (kde#385924)
* Fix viewport for screenshot on multiple screens
* Set scale on glScissor calls
* Fix glScissor calls with y-offset screens
* Fix viewport on vertically stacked monitors (kde#386099,kde#385655)

==== less ====

- Let lessopen.sh also handle UTF-8 for (g)roff input, only apparmor
as breaker of /usr/bin/file re,mains as "file" is not allowed to
read files within the tool lessopen.sh

==== libdrm ====
Version update (2.4.87 -> 2.4.88)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1

- Update to version 2.4.88:
+ amdgpu: Fix wrappers for AMDGPU_VM IOCTL.

==== libetonyek ====
Version update (0.1.6 -> 0.1.7)

- Version update to 0.1.7:
* Fix a few issues found by Coverity.
* Correctly compute cell row and column.
* Improve reconstruction of gradients.
* Improve resolution of cell styles.
* Parse non-RGB colors.
* Improve handling of table border lines.
* Convert cell values to text in presentation and text documents.
* Handle following-paragraph and following-layout styles.
* Allow building with different versions of mdds (1.2 is the default).
* Require C++11 for build.
* Fix several issues found by oss-fuzz.
* Disable error output from libxml2.
* Improve lookup of parent styles.
* Never insert a page break in a footnote.
* Drop outdated MSVC project files.
* Various small fixes and improvements.
- Drop merged patches:
* 0001-fix-test-on-i686.patch
* fix-brain-fart.diff
* libetonyek-0.1.6-drop_test.patch
* mdds-1.2.diff

==== libkdecoration2 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== libkscreen2 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== libksysguard5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: libksysguard5-devel libksysguard5-helper libksysguard5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== libuv ====
Version update (1.10.1 -> 1.15.0)

- Do not use source URL as fetching fails over ipv6
- Update to version 1.15.0:
* win: fix buffer size in uv__getpwuid_r()
* unix: use fchmod() in uv_fs_copyfile()
* unix: support copying empty files
* unix: truncate destination in uv_fs_copyfile()
* linux: increase thread stack size with musl libc
* test: clean up semaphore after use
* unix: check for NULL in uv_os_unsetenv for parameter name
* For extensive list of changes since last release see provided
ChangeLog
- Small spec file cleanup

==== libvirt ====
Version update (3.8.0 -> 3.9.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- apparmor: add rules for new mediation features
apparmor-rules-for-new-mediation-features.patch,
apparmor-fine-grained-mount-rules.patch
bsc#1066124, boo#1065123
- spec: unconditionally enable the wireshark dissector
- Replace %{with_sle_build} by ! 0%{?is_opensuse}
bsc#940315
- Update to libvirt 3.9.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
c44b29aa-apparmor-dnsmasq-ptrace.patch,
441d3eb6-qemu-tls-client-verify-server-cert.patch

==== lilv ====
Version update (0.22.0 -> 0.24.2)

- Revert devel package name to original, causes unresolvables.
- Switch to python3
- Run spec cleaner
- Rename devel subpackage
- Update to version 0.24.2
- Remove patch lilv-python-bindings-fix.diff it's now incorporated
by upstream.
- Upstream changes:
Fix saving state to paths that contain URI delimiters
Fix comparison of restored states with paths
Add new hand-crafted Pythonic bindings with full test
coverage.
Add lv2apply utility for applying plugins to audio files
Add lilv_world_get_symbol()
Add lilv_state_set_metadata() for adding state banks/comments
/etc (based on patch from Hanspeter Portner)
Fix crash when state contains non-POD properties
Fix crash if NULL predicate passed to lilv_world_find_nodes()
Fix state file versioning
Unload contained resources when bundle is unloaded
Do not instantiate plugin when data fails to parse
Support re-loading plugins
Replace bundles if bundle with newer plugin version is loaded
Fix loading dyn-manifest from bundles with spaces in path
Check lv2:binary predicate for UIs
Add LILV_URI_ATOM_PORT and LILV_URI_CV_PORT defines
Fix documentation installation
Fix outdated comment references to lilv_uri_to_path()

==== linphone ====
Subpackages: liblinphone++9 liblinphone-data liblinphone-devel liblinphone-lang
liblinphone9

- Use linphone_gtkui conditionally everywhere

==== milou5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: milou5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Fix i18ncd -> i18ndc.

==== miniupnpc ====
Version update (2.0.20170509 -> 2.0.20171102)

- Build 2.0.20171102
* Fix CVE-2017-8798 Thanks to tin/Team OSTStrom
* bnc#1038601 - (CVE-2017-8798) VUL-0: CVE-2017-8798: miniupnp: integer
signedness error

==== mjpegtools ====
Subpackages: libmjpegutils-2_0-0

- Drop pkgconfig(gdk-x11-2.0), pkgconfig(gobject-2.0) and
pkgconfig(gtk+-x11-2.0) BuildRequires and pass --without-gtk, no
longer build gtk2 support.

==== multipath-tools ====
Subpackages: kpartx multipath-tools-rbd

- added sample code for libmpathpersist (bsc#1066376)
* added libmpathpersist-example.c
- multipath-tools.spec: package libmultipath.so symlink in -devel
package (bsc#1066376). We *do not* package header files for
libmultipath, as the APIs are not public.

==== mutter ====
Version update (3.26.1 -> 3.26.2)
Subpackages: libmutter-1-0 mutter-data mutter-lang

- Update to version 3.26.2:
+ Work with clients that require older linux_dmabuf protocol
(bgo#788558).
+ Prevent crash when closing maximized windows (bgo#788666).
+ Use the correct monitor for HiDPI scaling of shell chrome
(bgo#788820).
+ Enable XWayland core dumps (bgo#789086).
+ Fixes:
- Unredirection of fullscreen windows (bgo#788493).
- List of supported monitor scales on X11 (bgo#788901).
- Handling of trackball settings on wayland (bgo#787804).
- Miscellaneous:
. Multi-monitor regressions and crashes (bgo#788607,
bgo#788860, bgo#789153, bgo#786929, bgo#789501).
. Bug fixes: bgo#788572, bgo#788569, bgo#784314, bgo#789227,
bgo#789223, bgo#782344, bgo#789552, bgo#789553, bgo#789300.
+ Updated translations.
- Drop fixed upstream patches:
mutter-wayland-dma-buf-modifiers-fix.patch,
mutter-x11-Protect-XChangeProperty-call.patch,
mutter-handle-no-to-no-monitor.patch and
mutter-preferred-mode.patch.
- Drop %glib2_gsettings_schema_requires macro: the functionality is
covered by file triggers now.
- Point fdupes to the /usr directory instead of the build root,
which is a practice that must be avoided.

==== ncurses ====
Subpackages: libncurses6 ncurses-devel ncurses-utils tack terminfo terminfo-base

- Add ncurses patch 20171028
+ improve man/curs_inwstr.3x, correct end-logic for lib_inwstr.c
(report by Midolikawa H).
+ fix typo in a few places for "improvements" (patch by Sven Joachim).
+ clear the other half of a double-width character on which a line
drawing character is drawn.
+ make test/ncurses.c "s" test easier to understand which subtests are
available; add a "S" wide-character overlap test-screen.
+ modify test/ncurses.c C/c tests to allow for extended color pairs.
+ add endwin() call in error-returns from test/ncurses.c omitted in
recent redesign of its menu (cf: 20170923).
+ improve install of hashed-db by removing the ".db" file as done for
directory-tree terminal databases.
+ repair a few overlooked items in include/ncurses_defs from recent
port/refactoring of test-programs (cf: 20170909).
+ add test/padview.c, to compare pads with direct updates in view.c

==== openssl ====
Version update (1.0.2l -> 1.0.2m)
Subpackages: libopenssl-devel

- Revert version back to 1.0.2m to get security fixes quickly to
Tumbleweed
* OpenSSL Security Advisory [02 Nov 2017] (bsc#1066242,bsc#1056058)
- Switch to 1.1.0f release as default again

==== openssl-1_0_0 ====
Version update (1.0.2l -> 1.0.2m)
Subpackages: libopenssl-1_0_0-devel libopenssl1_0_0 libopenssl1_0_0-32bit

- Update to 1.0.2m
OpenSSL Security Advisory [02 Nov 2017]
* bn_sqrx8x_internal carry bug on x86_64
(CVE-2017-3736) (bsc#1066242)
* Malformed X.509 IPAddressFamily could cause OOB read
(CVE-2017-3735) (bsc#1056058)
- refreshed openssl-1.0.2i-fips.patch
- revert upstream commit 0ab24083a16c8a4dd35833031bbeaeb0437a7219
as we don't have the added function and FIPS is not interesting
for openSUSE anyway
* added 0001-Set-FIPS-thread-id-callback.patch

==== oxygen5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== pcre ====
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0
pcre-devel

- add pcre-8.41-stack_frame_size_detection.patch to fix pcre stack
frame size detection because modern compilers broke it by cloning
and inlining pcre match() function [bsc#1058722]

==== permissions ====
Version update (20171025 -> 20171106)

- Update to version 20171106:
* Allow setuid root for singularity (group only) bsc#1028304

==== pidgin ====
Subpackages: libpurple libpurple-lang libpurple-plugin-sametime libpurple-tcl

- Correct the licence to GPL-2.0.
- Explicitly require python2

==== plasma-nm5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma-nm5-lang plasma-nm5-openconnect plasma-nm5-openvpn
plasma-nm5-pptp plasma-nm5-vpnc

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Do not set password field as readonly, it doesn't make sense
* Disable password field when password is not needed (kde#386426)
* Make sure we store password for all users when kwallet is diabled
(kde#386343)

==== plasma5-addons ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma5-addons-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Use wakeOne() instead of notify_one()

==== plasma5-desktop ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma5-desktop-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Default X font DPI to 96 on wayland

==== plasma5-integration ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma5-integration-plugin plasma5-integration-plugin-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* Show shortcuts in menus

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.11.3

==== plasma5-pa ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma5-pa-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== plasma5-workspace ====
Version update (5.11.2 -> 5.11.3)
Subpackages: plasma5-session plasma5-workspace-devel plasma5-workspace-lang
plasma5-workspace-libs

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* DictEngine: set a scheme for the URLs, otherwise webengine won't handle them
* Align logout screen action buttons to the top (kde#371249)
* Sync xwayland DPI font to wayland dpi

==== polkit-kde-agent-5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: polkit-kde-agent-5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== powerdevil5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: powerdevil5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* None

==== python-PySocks ====
Version update (1.6.6 -> 1.6.7)
Subpackages: python2-PySocks python3-PySocks

- specfile:
* update copyright year
- update to version 1.6.7:
* Make SocksiPy legacy functions kwarg-compatible. See issue #71.
* Use setuptools in setup.py to support wheel. See issue #73.
* Test and logging enhancements

==== python-base ====
Subpackages: libpython2_7-1_0 libpython2_7-1_0-32bit python-devel python-xml

- Call python2 instead of python in macros

==== python-wxWidgets-3_0 ====
Subpackages: python-wxWidgets-3_0-lang

- Explicitly require python2
- Provide naming consistent with python singlespec
- Do not use py_requires as it is not needed anymore

==== sendmail ====
Subpackages: libmilter1_0

- Apply former patches only if openssl 1.1.0+ are installed
- support build with openssl 1.1 (bsc#1067222)
* add patches from Fedora:
sendmail-8.15.2-openssl-1.1.0-fix.patch
sendmail-8.15.2-openssl-1.1.0-ecdhe-fix.patch (rh#1473971)

==== simple-scan ====
Version update (3.26.1 -> 3.26.2)
Subpackages: simple-scan-lang

- Update to version 3.26.2:
+ Updated translations.
- Add pkgconfig(glib-2.0) BuildRequires: new dependency.
- Drop %glib2_gsettings_schema_*, %desktop_database_*,
%icon_theme_cache_* post(un) scriplets and
%glib2_gsettings_schema_requires macro: the functionality now is
covered by file triggers.
- Drop libjpeg-devel BuildRequires as it's no longer needed/used.

==== systemd-presets-branding-openSUSE ====

- Enable ModemManager.service by default (bsc#1038402).
- Move common entries into default-SUSE.preset (bsc#1060676)

==== systemsettings5 ====
Version update (5.11.2 -> 5.11.3)
Subpackages: systemsettings5-devel systemsettings5-lang

- Update to 5.11.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.11.3.php
- Changes since 5.11.2:
* map rows to the source model (kde#386454)
* Fix DBus startup notification
- Remove patches, now upstream:
* 0001-Fix-DBus-startup-notification.patch

==== tbb ====

- Build python2 and python3 bindings
- Do not bundle python bindings with shared library

==== vinagre ====
Subpackages: vinagre-lang

- Change appstream file location due to appstream-glib >= 0.7.3.

==== virglrenderer ====

- Clean up spec file with spec-cleaner
- Use source url
- Add gpg signature
- Make building more verbose
- Explicitly require python2

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- bsc#1067263 - virt-install: ERROR unicode argument expected, got
'str'
virtinst-fix-replace-StringIO-with-io.patch

==== xml-security-c ====

- support building with openssl 1.1 (bsc#1067411)
* add xml-security-c-1.7.3_openssl1.1.patch from Fedora

==== yast2-users ====
Version update (3.2.12 -> 4.0.0)

- Remove the support for encrypting home directory (fate#323541)
- 4.0.0

==== yast2-vm ====
Version update (3.2.3 -> 3.2.4)

- bsc#1007599 - yast virtualization module does not work well with
NM
- bsc#1066160 - yast2-vm lacks dependencies
- bsc#1008719 - Installing hypervisor (KVM) should also install
network config
- Cleanup some whitespace issues in VirtConfig.rb and changelog
- 3.2.4

==== ypserv ====

- Cleanup /var/yp on de-installation
- Remove old SysV init support
- Use systemd tmpfiles.d to create /var/yp hierachy


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages