Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171013 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171013

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
PackageKit
binutils
boost
btrfsprogs (4.13 -> 4.13.2)
bubblewrap (0.1.8 -> 0.2.0)
digikam
drbd
fcitx-libpinyin (0.5.0 -> 0.5.3)
fcitx-zhuyin
gfxboot (4.5.22 -> 4.5.23)
gnome-builder (3.26.0 -> 3.26.1)
help2man (1.47.4 -> 1.47.5)
ibus-libpinyin (1.8.0 -> 1.9.1)
ibus-libzhuyin (1.7.8 -> 1.8.0)
keybinder-3.0 (3.0 -> 0.3.2)
krita (3.3.0 -> 3.3.1)
lftp (4.7.7 -> 4.8.2)
libfabric (1.5.0 -> 1.5.1)
libinput (1.8.2 -> 1.8.3)
libpinyin (1.7.0 -> 2.1.0)
libqt5-qtwebengine
librest
libsrtp
libtirpc
libzhuyin
lightdm
mozjs52
nagios (4.3.2 -> 4.3.4)
nfs-utils
nghttp2
obs-service-download_files (0.5.1.git.1455712026.9c0a4a0 ->
0.6.0.git.1502884469.0993a01)
openvpn
perl-List-MoreUtils-XS (0.423 -> 0.426)
perl-Text-CSV_XS (1.05 -> 1.32)
perl-TimeDate (1.20 -> 2.30)
publicsuffix (20170713 -> 20170910)
python-libvirt-python (3.7.0 -> 3.8.0)
qemu (2.10.0 -> 2.10.1)
qemu-linux-user (2.10.0 -> 2.10.1)
remmina (1.2.0~rcgit.20 -> 1.2.0~rcgit.21)
rp-pppoe
subversion
texinfo
thin-provisioning-tools (0.7.2 -> 0.7.3)
tracker-miners (2.0.1 -> 2.0.2)
unison
virt-manager
vm-install (0.9.03 -> 0.9.04)
wireshark (2.4.1 -> 2.4.2)
yast2-core (3.2.2 -> 4.0.0)
yast2-theme (4.0.1 -> 4.0.3)
ypbind

=== Details ===

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module PackageKit-lang libpackagekit-glib2-18
typelib-1_0-PackageKitGlib-1_0

- Add PK-zypp-return-error-invalid-package-ids.patch: Return error
if invalid package IDs are detected in zypp backend (bsc#981011).

==== binutils ====
Subpackages: binutils-devel

- Add s390x-8fe09d7.diff to fix typo in ELF notes.
- Update binutils-2.29-branch.diff to @a45d8fd5ffbf888 fixing PR 22220.

==== boost ====
Subpackages: boost-license1_65_1 boost_1_65-devel boost_1_65-jam
libboost_atomic1_65_1 libboost_atomic1_65_1-devel libboost_chrono1_65_1
libboost_chrono1_65_1-devel libboost_container1_65_1
libboost_container1_65_1-devel libboost_context1_65_1
libboost_context1_65_1-devel libboost_coroutine1_65_1
libboost_coroutine1_65_1-devel libboost_date_time1_65_1
libboost_date_time1_65_1-devel libboost_fiber1_65_1 libboost_fiber1_65_1-devel
libboost_filesystem1_65_1 libboost_filesystem1_65_1-devel libboost_graph1_65_1
libboost_graph1_65_1-devel libboost_graph_parallel1_65_1
libboost_graph_parallel1_65_1-devel libboost_headers1_65_1-devel
libboost_iostreams1_65_1 libboost_iostreams1_65_1-devel libboost_locale1_65_1
libboost_locale1_65_1-devel libboost_log1_65_1 libboost_log1_65_1-devel
libboost_math1_65_1 libboost_math1_65_1-devel libboost_mpi1_65_1
libboost_mpi1_65_1-devel libboost_program_options1_65_1
libboost_program_options1_65_1-devel libboost_python-py2_7-1_65_1
libboost_python-py2_7-1_65_
1-devel libboost_python-py3-1_65_1 libboost_python-py3-1_65_1-devel
libboost_random1_65_1 libboost_random1_65_1-devel libboost_regex1_65_1
libboost_regex1_65_1-devel libboost_serialization1_65_1
libboost_serialization1_65_1-devel libboost_signals1_65_1
libboost_signals1_65_1-devel libboost_system1_65_1 libboost_system1_65_1-devel
libboost_test1_65_1 libboost_test1_65_1-devel libboost_thread1_65_1
libboost_thread1_65_1-devel libboost_timer1_65_1 libboost_timer1_65_1-devel
libboost_type_erasure1_65_1 libboost_type_erasure1_65_1-devel
libboost_wave1_65_1 libboost_wave1_65_1-devel

- Setup MPI environment prior to building boost.
- Switch to OpenMPI2 as OpenMPI1 is becoming deprecated.

==== btrfsprogs ====
Version update (4.13 -> 4.13.2)
Subpackages: btrfsprogs-udev-rules libbtrfs0

- update to version 4.13.2:
* subvol list:
* don't list toplevel subvolume among deleted (broken since 4.8.3)
* minor adjustments of uuid print format
* subvol delete:
* fix swapped behaviour of --commit-each and --commit-after
* fix potentially lost sync if subvolumes are from different filesystems
* check: add cache for metadata blocks, should improve performance
* other:
* new tests, testsuite updates
* doc updates
* cleanups
- update to version 4.13.1:
* image: speed up generating the sanitized names, do not generate unprintable
chars
* completion: add missing commands, better mount point detection
* restore: add zstd support; libzstd detected automatically, will be
requested by default in the future, or can be configured out
* other:
* misc fixes found by sparse
* doc enhancements, ioctl manual page started
* updated and new tests
* build fixes

==== bubblewrap ====
Version update (0.1.8 -> 0.2.0)

- update to version 0.2.0
- bwrap now automatically detects the new
user namespace restrictions in Red Hat Enterprise Linux 7.4:
bubblewrap: check for max_user_namespaces == 0.
- The most notable features are new arguments --as-pid1, and
- -cap-add/--cap-drop. These were added for running systemd (or in general a
"full" init system) inside bubblewrap. But the capability options are also
useful for unprivileged callers to potentially retain capbilities inside the
sandbox (for example CAP_NET_ADMIN), when user namespaces are enabled.
Conversely, privileged callers (uid 0) can conversely drop capabilities
(without
user namespaces). Contributed by Giuseppe Scrivano.
- With --dev, add /dev/fd and /dev/core symlinks
which should improve compatibility with older software.

==== digikam ====
Subpackages: kipi-plugins kipi-plugins-lang

- Add 0001-Disable-detection-of-OpenGL-for-GLES-platforms.patch
Disable OpenGL detection on embedded platforms (e.g. ARM)
Currently digikam depends on Desktop GL and fails to build when
using a Qt5OpenGL build with GLES, see kde#383715

==== drbd ====
Subpackages: drbd-kmp-default

- bsc#1062749, disable buildrt against SLE15 x86_64 temporarily.
This change will be removed when rt is ready.

==== fcitx-libpinyin ====
Version update (0.5.0 -> 0.5.3)

- Update to 0.5.3
* Update translation.
* Use libpinyin 2.1.0
- Update to 0.5.1
* Fix a typo: continous -> continuous
* [trans] Update Translation
* QWidget is under QtWidgets in Qt5

==== fcitx-zhuyin ====

- Avoid running fdupes across partition boundaries.
- Drop ldconfig call: not needed for plugins.
- Change the install libdir for libzhuyin.

==== gfxboot ====
Version update (4.5.22 -> 4.5.23)

- merge gh#openSUSE/gfxboot#27
- fix linear framebuffer activation (bsc#1061383)
- add gfx mode number and framebuffer address to debug status
- 4.5.23

==== gnome-builder ====
Version update (3.26.0 -> 3.26.1)
Subpackages: gnome-builder-lang gnome-builder-plugin-beautifier
gnome-builder-plugin-clang gnome-builder-plugin-cmake
gnome-builder-plugin-ctags gnome-builder-plugin-devhelp
gnome-builder-plugin-gettext gnome-builder-plugin-gnome-code-assistance
gnome-builder-plugin-html-completion gnome-builder-plugin-jedi
gnome-builder-plugin-jhbuild gnome-builder-plugin-mingw
gnome-builder-plugin-symbol-tree gnome-builder-plugin-sysmon
gnome-builder-plugin-todo gnome-builder-plugin-vala-pack
gnome-builder-plugin-xml-pack

- Remove filler wording from description.
- Update to version 3.26.1:
+ Fixes:
- When using the XML editing extensions.
- Error propragation when loading git repositories.
- Home and End keys when in Vim normal mode.
- Various bugs in debugger.
- For various keyboard shortcut activation.
- The python indenter when using compose keys with e or f.
- (Re)selection of text when entering the search bar. This had
the side effect of it appearing that your search term was
silently being dropped after a few characters were typed.
- A leak of editor views which was caused by Python lambda's in
the html-preview plugin.
+ Improvements:
- To Vim chords y$, yfX, de, db, and dw.
- When pasting from external clipboard content.
+ Additions:
- Flathub repo to list of known Flatpak runtime sources, which
allows building against an org.kde.Sdk.
- A new condensed "omni gutter" to reduce the width of the
gutter in languages that support debugging.
+ Builder:
- Now bundles uncrustify when built from Flatpak.
- No longer includes tracing in stable flatpak build.
- Builder will avoid showing the greeter when loading a project
using the `gnome-builder -p project_file` command line
argument. This speeds up direct loading of a project by about
half.
- Builder will attempt to use "gio trash" on the host when
running.
+ The vsplit vim command now accepts a filename to open.
+ Use GNotification instead of manual D-Bus RPCs.
+ Significantly reduce chatter when notifying about builds.
+ Unsaved file buffers now use atomic renames when interacting
with code diagnostic engines.
+ The editor attempts to avoid propagating resize events to the
root window, which should help speed up the editor a fair
amount.
+ Preferences loading has been delayed until project load time.
This helps reduce application startup time.
+ The cursor now properly returns to the editor when leaving the
global search entry.
+ The Fpaste plugin was removed as upstream API is changed too
drastically to keep this plugin working.
+ Icons are now properly displayed in the document popover menu.
+ Tweaks to various UI CSS styling.
+ The debugger and profiler plugins now try harder to locate
sources through .Debug or .Sdk flatpak runtimes when libraries
missing debug symbols are encountered.
+ Preferences now properly release their addins on destruction.
+ The workbench was leaking addins on shutdown. They are now
properly released, and the window is hidden before releasing
addins to avoid showing widgets as they are destroyed.
+ Updated translations.
- Drop Fpaste plugin sub-package: Removed upstream.

==== help2man ====
Version update (1.47.4 -> 1.47.5)

- Update to 1.47.5
* Refresh Brazilian Portuguese translation from translation project
copy (trivial date change).
* Update Swedish translation (thanks to Sebastian Rasmussen).
* Use POSIX compliant TZ when setting UTC (thanks to Paul Eggert).
* Update copyright years.

==== ibus-libpinyin ====
Version update (1.8.0 -> 1.9.1)

- Update 1.9.1
* add sort candidate option to setup dialog
- Update 1.9.0
* change dconf key name to lower case
* use libpinyin 1.9.91
* fixes config in setup dialog

==== ibus-libzhuyin ====
Version update (1.7.8 -> 1.8.0)

- Update to 1.8.0
* fixes processCommit method.
* clean code.
* fixes a warning.
- Use libpinyin 2.1.0
- Remove invalid %post and %postun.
- Trim time-sensitive wording in summary.
- Update to 1.7.91
* merge libzhuyin data.
- Update to 1.7.10
* fix issue 31 - full width punctuation input with wrong symbol
* fix issue 32 - full/half width shortcut key switch with extra space output
* fix issue 33 - fixes full/half width symbol input problem

==== keybinder-3.0 ====
Version update (3.0 -> 0.3.2)

- Update summaries. Replace ancient RPM macros by new constructs.
- update to version 0.3.2:
* Fix ``keybinder_bind`` and others to not crash on non-X11
displays. It simply returns FALSE, failing to bind the key.
* Add new API:
gboolean keybinder_supported()
Return TRUE if on key bindings are implemented for this
configuration.
* Fix deprecated directives in build system
- update to vesion 0.3.1
- rename package to keybinder-3.0
- fix version number (it's 0.3.1, not 3.0)
- ugly obsoletes hacks to fix that versioning error

==== krita ====
Version update (3.3.0 -> 3.3.1)
Subpackages: krita-lang

- Update to 3.3.1:
* See https://krita.org/en/item/krita-3-3-1/
* Krita would crash if you would restart Krita after closing
Krita with the reference images docker set to floating
* Krita 3.3.0 could not read .kra backup files or .kra files that
were unzipped, then zipped up manually
* Merge down does not remove locked layers anymore
* Various performance improvements, especially for macOS
* Improve the look and feel of dragging and dropping layers
* Improve the tooltips in the brush preset selector
* Fix a memory leak in the color selectors
* Don't allow the fill tool to be used on group layers
* Add brightness and contrast sliders for textured brushes
* Add paste-at-cursor
* Improve performance of the cpu canvas
* Fix a crash on closing Krita when there is something on the
clipboard
* Add a button to open a file layer's image in Krita

==== lftp ====
Version update (4.7.7 -> 4.8.2)

- update to 4.8.2:
* fixed a memory leak
* fixed a core dump on exit
- includes changes from 4.8.1:
* improved rate limiting to allow per-host limits
* ftp: make prefer-epsv default "no"
* ftp: fixed quote command and ftp:use-stat-for-list setting
* switched to libidn2
* fixed configure --disable-rpath
* fixed coredump when a parent directory was deleted
- includes changes from 4.8.0:
* mirror: improved performance of --scan-all-first for big trees
* mirror: new --flat option to flatten the target directory structure
* mmv: new command for file moving; redirect mv to mmv in certain cases
* fixed compilation with newer openssl (1.1.0 and later)
* du: allow multiple --exclude options to be combined
* new setting cmd:nullglob for `glob' command prefix
* http: use proppatch to set last-modified property
* new settings net:connection-limit-timer and ftp:too-many-re
* ftp: dynamically ajust connection limit
* ftp: fixed core dump on LINK/SYMLINK when the command is not supported
* get1: fixed -o option
* sftp,fish: connect-program setting is now passed to the shell for execution
* get/mget/put/mput: add -P option for parallel transfers and long options
* fixed "local glob"
- build with libidn2
- package desktop file

==== libfabric ====
Version update (1.5.0 -> 1.5.1)

- Update to v1.5.1
- Core
- Fix initialization used by DL providers to avoid crash
- Add checks for null hints and improperly terminated strings
- Check for invalid core names passed to fabric open
- Provide consistent provider ordering when using DL providers
- Fix OFI_LIKELY definitions when GNUC is not present
- GNI
- Add ability to detect local PE rank
- Fix compiler/config problems
- Fix CQ read error corruption
- Remove tests of deprecated interfaces
- PSM
- Fix CQ corruption reporting errors
- Always generate a completion on error
- PSM2
- Fix CQ corruption reporting errors
- Always generate a completion on error
- Add checks to handle out of memory errors
- Add NULL check for iov in atomic readv/writev calls
- Fix FI_PEEK src address matching
- Fix bug in scalable endpoint address resolution
- Fix segfault bug in RMA completion generation
- Sockets
- Fix missing FI_CLAIM src address data on completion
- Fix CQ corruption reporting errors
- Fix serialization issue wrt out of order CPU writes to Tx ring buffer
- Verbs
- Allow modifying rnr retry timout to improve performance
- Add checks to handle out of memory errors
- Fix crash using atomic operations for MSG EPs
- Fix dependency to libfabric1 for libfabric-devel in baselibs.conf

==== libinput ====
Version update (1.8.2 -> 1.8.3)
Subpackages: libinput-udev libinput10

- Update to version 1.8.3:
* Two user-visible fixes: The Wacom Mobile Studio Pro pad device
was previously ignored because of its accelerometer tag, this
is fixed now. And touchpads that are explicitly disabled by the
user now stay disabled after a lid open event.
* The rest is all related to the test suite to make sure it still
runs correctly. Finally, a stray printf was removed from
libinput-debug-events.

==== libpinyin ====
Version update (1.7.0 -> 2.1.0)

- Move documentation to libpinyin-devel. Manpages do not belong
into libpinyin13 (SLPP guideline).
- Avoid running fdupes across partition boundaries.
- Update to 2.1.0
* support sort option in pinyin_guess_candidates function
- Enable zhuyin support.
- Update to 2.0.92
* reduce memory consumption after imported user dictionary;
* merge libzhuyin code;
* fixes autoconf;
* multiple sentence candidates;

==== libqt5-qtwebengine ====

- Fixes to make fonts readable again with FreeType 2.8.1 (boo#1061344):
* clip-ft-glyph.diff
* harmony-fix.diff

==== librest ====

- Use librest-0_7-0 as shared library name, similar to how it is
done for libmwaw-0_3.
- Drop redundant %clean section; use %_smp_mflags for parallel
build.

==== libsrtp ====

- remove openssl 1.1 incompatible headers from the -devel package
(bsc#1055277#c8)
- Drop option --enable-openssl which doesn't work with OpenSSL 1.1
(bsc#1055277)
* this drops GCM support

==== libtirpc ====
Subpackages: libtirpc-netconfig libtirpc3 libtirpc3-32bit

- Rectify RPM groups and summaries,
and update old macro/variable constructs.

==== libzhuyin ====

- Move documentation to libzhuyin7-devel. Manpages do not belong
into libzhuyin7 (SLPP guideline).
- Adhere to package naming guidelines and use package versions,
not SO versions for package names.
- Avoid running fdupes across partition boundaries.
- Rename %soname to %sover to better reflect its use.
- Change the install libdir.

==== lightdm ====
Subpackages: liblightdm-gobject-1-0 lightdm-lang

- Have update-alternatives handle Xinit's integration of the
displaymanager, replacing /etc/sysconfig/displaymanager
(boo#1053863).

==== mozjs52 ====

- Added additional compiler flags on the condition
of building for ppc64le using gcc7 or newer.
(see bmo#1399248)

==== nagios ====
Version update (4.3.2 -> 4.3.4)
Subpackages: nagios-www

- update to 4.3.4
* Improved config file parsing (Mark Felder)
* Fixed configure script to check for existence of /run for lock
file (in regards to CVE-2017-12847, Bryan Heden)
* Use absolute paths when deleting check results files (Emmanuel Dreyfus)
* Add sanity checking in reassign_worker (sq5bpf)
* xodtemplate.c wrong option-deprecation code warning (alex2grad / John
Frickson)
* On-demand host check always use cached host state (John Frickson)
* 'รก' causes Serivce Status Information to not be displayed (John Frickson)
* New Macro(s) to generate URL for host / service object (John Frickson)
* Fix minor map issues (Troy Lea)
* Fix lockfile issues (Bryan Heden)
* Switch order of daemon_init and drop_priveleges (CVE-2017-12847, Bryan
Heden)
* Add an OpenRC init script (Michael Orlitzky)
- only require insserv on older SUSE distributions

==== nfs-utils ====
Subpackages: nfs-client nfs-doc nfs-kernel-server

- fix incorrect dependency in
/usr/lib/systemd/system/nfs-client.target.d/nfs.conf
When yast restarts "nfs" it should propagate to nfs-client,
but doesn't.
(boo#1053691)

==== nghttp2 ====

- Don't use jemalloc on ppc or %arm, where it is broken.

==== obs-service-download_files ====
Version update (0.5.1.git.1455712026.9c0a4a0 -> 0.6.0.git.1502884469.0993a01)

- Update to version 0.6.0.git.1502883896.50fa599: (boo#1053984)
* make enforcement of IPv4 and SSL verification optional.

==== openvpn ====

- Do bound check in read_key before using values(CVE-2017-12166 bsc#1060877).
[+ 0002-Fix-bounds-check-in-read_key.patch]

==== perl-List-MoreUtils-XS ====
Version update (0.423 -> 0.426)

- updated to 0.426
see /usr/share/doc/packages/perl-List-MoreUtils-XS/Changes
0.426 2017-10-02
- release 0.425_001 as 0.426
0.425_001 2017-09-27
- Fix broken format in part (fixes issues/4, thanks Andreas Schwab
for reporting and testing the fix)
- Fix gcc 4.7 sequence point warning (fixes issues/5, thanks Andreas
Schwab for reporting and testing the fix)
- Fix incorrect padname resolving for perl > 5.21.6 (Fixes RT#122883,
thanks Alexander Bluhm <alexander.bluhm@xxxxxxx> for reporting).
- Fix compiling issue on CentOS 4 & CentOS 5 (thanks Alex Karelas
<alex.karelas@xxxxxxxxx> for reporting and testing the fix)
- obsolete format.patch and undefined.patch

==== perl-Text-CSV_XS ====
Version update (1.05 -> 1.32)

- updated to 1.32
see /usr/share/doc/packages/perl-Text-CSV_XS/ChangeLog
1.32 - 2017-09-15, H.Merijn Brand
* Add keep_headers attribute to csv ()
* Fix on_in when used in combination with key
* Fail on invalid arguments to csv
* Fix header method on EOL = CR (RT#122764)
1.31 - 2017-06-13, H.Merijn Brand
* Fix already decoded BOM in headers
* New options in csv-check
* Some perlcritic
* "escape" is alias for "escape_char" for consistency.
* Code cleanup and more tests (Devel::Cover)
* Improve csv-check auto-sep-detection
1.30 - 2017-06-08, H.Merijn Brand
* Add csv (..., out => ...) syntax examples (issue 7)
* Disable escape_null for undefined escape_char
* Fix ->say for bound columns (RT#121576)
* Update to Devel::PPPort 3.36
* Tested under 5.26.0 and 5.27.0
* Doc changes and additions
1.29 - 2017-04-25, H.Merijn Brand
* More docs for bind_colmns (RT#121350)
* New attribute "strict" (also addresses RT#121350)
1.28 - 2017-03-22, H.Merijn Brand
* Fix length problem with bound empty fields and UTF-8 (RT#120655)
1.27 - 2017-03-02, H.Merijn Brand
* Remove unneeded done_testing (Paul Howarth)
* Attribute sep/sep_char is not allowed to be undefined
* Increased test coverage: added errors 1008 and 1014
* Default for escape_null in csv () is now false
* It's 2017
* New error code for illegal argument(s)/parameter(s) (RT#119827)
* Fix tests for perl without dot in @INC
* Fix crlf issue for csv () on Windows (RT#120466)
1.26 - 2016-11-29, H.Merijn Brand
* Disable some Unicode related tests for unhealthy $PERL_UNICODE
(RT#117856)
* is_missing (0) on empty line returns 1 for keep_meta_info = true
(issue 27 on github)
1.25 - 2016-08-28, H.Merijn Brand
* Allow lc, uc, and coderef for csv () headers attribute
* Document for eof when the last line has an error (RT#115954)
* Allow csv () to call header () with all supported arguments
* Add some docs for bind_columns
1.24 - 2016-07-09, H.Merijn Brand
* Fix typo in docs example code (issue#4, joevak)
* Set auto-wrap on for csv2xls with embedded newlines
* Add examples/csv2xlsx, the MSExcel-2007+ version of csv2xls
Includes new feature to merge multiple CSV's into a single xlsx
* Slight modification in examples
* Fix parse error in complex option combo (RT#115953)
- requires perl-5.6.2 or newer
1.23 - 2016-03-25, H.Merijn Brand
* Skip unsupported encodings
* Reorganize Unicode section and mention layers (Dan Book)
* Amend some UTF-8 tests for PERL_UNICODE settings
* Fix crash on error in parsing with bound columns (RT#113279)
* Add predefined filters (not_blank, not_empty, filled)
1.22 - 2016-02-23, H.Merijn Brand
* Small doc updates regarding blank_is_undef
* Precedence error in doc
* Add new method header
1.21 - 2016-01-06, H.Merijn Brand
* Add confusion option to rewrite example
* Alias %_ to row in hashref mode for csv function attributes
on_in and before_out
* Examples now use defined-or and thus require perl-5.10 or up
* Fix
ending with allow_loose_escapes (reported by Bas Bloemsaat)
* It's 2016
* Clarify $csv->csv (...) documentation (RT#110941)
1.20 - 2015-10-09, H.Merijn Brand
* Use "say" in synopsis
* Remove needless special characters in doc section
* Change doc =item attributes for new to =head for index
* Add known_attributes function/method
* Add contributor notes
* Allow undef as value for aliased attributes
1.19 - 2015-06-17, H.Merijn Brand
* Guard tests against $PERL_UNICODE
* Numeric options were sometimes interpreted as boolean
* Safer meta_info use
1.18 - 2015-05-22, H.Merijn Brand
* Add quote_empty attribute
* Add database NULL documentation
* Inherit csv attributes in csv () when called in void context
* micro-optimisation for combine/print (empty fields will be faster)
1.17 - 2015-04-24, H.Merijn Brand
* Enable overruling $csv in csv ()
* Allow encoding to be shortened to enc in csv ()
* Allow filter to alter content
* Add say (print with default eol => $\)
* Allow MS sep=; on first line (RT#100304)
1.16 - 2015-03-02, H.Merijn Brand
* filter made more useful (access to other fields)
1.15 - 2015-02-11, H.Merijn Brand
* Remove perl recommendation from META as it breaks cpan clients
1.14 - 2015-02-02, H.Merijn Brand
* Move to github
* Add csv (filter => {});
* Change csv ()'s void context behavior
1.13 - 2015-01-03, H.Merijn Brand
* Simplify code path for old perl
* Fix quote_binary (#RT100676)
* Fix csv () for hashrefs with aliased headers
* Update copyright to 2015
1.12 - 2014-11-01, H.Merijn Brand
* Add field number to error_diag
* Fixed non-IO parsing multi-byte EOL
* Fixed a possible missed multi-byte EOL
* Allow hashref for csv ()'s headers attribute
* Allow encoding on all output handles in csv ()
* Include doc changes as ticketed in the Text::CSV queue
* Fix parallel testing issue
* Allow csv as method call (not using the object)
* Rename quote_null to escape_null
* Give meaning to keep_meta_info on output (RT#99941)
1.11 - 2014-08-16, H.Merijn Brand
* Fixed eof (RT#97742)
* Check for attribute conflicts early
* csv (in => [..]) now defaults to *STDOUT for out
* Support for multi-byte quote_char
* New attribute "key" for csv ()
1.10 - 2014-08-04, H.Merijn Brand
* Support for scalar ref in out: csv (out => \(my $x = ""), ...)
* Support for multi-byte sep_char
* Simplified the cache coding
1.09 - 2014-06-09, H.Merijn Brand
* Missed defined-or need in csv2xls (RT#95787)
1.08 - 2014-05-17, H.Merijn Brand
* Documentation updates
* Allow disjointed CSV cell fragment lists
1.07 - 2014-04-28, H.Merijn Brand
* Allow ref to scalar for csv (in => ...)
* Allow CODE ref to in attribute
* Allow * in fragment cellspec's bottom-right cell
1.06 - 2014-04-20, H.Merijn Brand
* Fix possible fail in tests on Windows (Thanks Mithaldu for explaing)
* Only close file handles in csv () for files
* new callbacks for csv ()

==== perl-TimeDate ====
Version update (1.20 -> 2.30)

- updated to 2.30
see /usr/share/doc/packages/perl-TimeDate/ChangeLog
2.30 -- Mon Feb 18 13:31:03 CST 2013
* Syncing distribution version number with Date::Parse, not functional changes
- remove TimeDate-deprecated_array_use.patch and TimeDate-podfile-patch
and regenerat with cpanspec

==== publicsuffix ====
Version update (20170713 -> 20170910)

- Update to version 20170910:
* Add pixolino.com domain (#456)
* Add Fancy Bits domains to the PSL (#495)
* Update AWS Elastic Beanstalk domains. (#484)
* Add domreg.merit.edu registry (#293)
* Update WeDeploy/Liferay domains. (#510)
* Add v-info.info (#508)
* Add debian.net (#516)
* .br updated - 18 new 2nd level city domains (#507)
- Update to version 20170809:
* Update Futureweb OG Private Domains (#498)
* Add byen.site (#490)

==== python-libvirt-python ====
Version update (3.7.0 -> 3.8.0)

- Update to 3.8.0
- Add all new APIs and constants in libvirt 3.8.0

==== qemu ====
Version update (2.10.0 -> 2.10.1)
Subpackages: qemu-arm qemu-block-curl qemu-block-dmg qemu-block-gluster
qemu-block-iscsi qemu-block-rbd qemu-block-ssh qemu-extra qemu-ipxe qemu-ksm
qemu-kvm qemu-lang qemu-ppc qemu-s390 qemu-seabios qemu-sgabios qemu-tools
qemu-vgabios qemu-x86

- Add dependencies on ovmf (uefi) for the qemu-x86 and qemu-arm
packages
- Fix s390-netboot.img to be included with qemu-s390 package, not
qemu-ppc
- Update to v2.10.1, a stable, bug-fix-only release
* fixes bsc#1056386 CVE-2017-13673, bsc#1056334 CVE-2017-13672,
bsc#1057585 CVE-2017-14167
* Patches dropped (upstream):
0034-slirp-fix-clearing-ifq_so-from-pend.patch
0035-s390-ccw-Fix-alignment-for-CCW1.patch
0038-s390x-ais-for-2.10-stable-disable-a.patch
0039-s390x-cpumodel-remove-ais-from-z14-.patch
* Patches renamed:
0036-target-i386-cpu-Add-new-EPYC-CPU-mo.patch
- > 0034-target-i386-cpu-Add-new-EPYC-CPU-mo.patch
0037-chardev-baum-fix-baum-that-releases.patch
- > 0035-chardev-baum-fix-baum-that-releases.patch
0040-io-fix-temp-directory-used-by-test-.patch
- > 0036-io-fix-temp-directory-used-by-test-.patch
0041-io-fix-check-for-handshake-completi.patch
- > 0037-io-fix-check-for-handshake-completi.patch
0042-crypto-fix-test-cert-generation-to-.patch
- > 0038-crypto-fix-test-cert-generation-to-.patch
0043-vhost-user-disable-the-broken-subpr.patch
- > 0039-vhost-user-disable-the-broken-subpr.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
- Fix failures and potential failures in qemu-testsuite
0040-io-fix-temp-directory-used-by-test-.patch
0041-io-fix-check-for-handshake-completi.patch
0042-crypto-fix-test-cert-generation-to-.patch
0043-vhost-user-disable-the-broken-subpr.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
- Fix migration issue on s390
0038-s390x-ais-for-2.10-stable-disable-a.patch
0039-s390x-cpumodel-remove-ais-from-z14-.patch
- Fix case of not being able to build from rpm sources due to
undefined macro (boo#1057966)
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
- Fix baum that release brlapi twice (bsc#1060045)
0037-chardev-baum-fix-baum-that-releases.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10

==== qemu-linux-user ====
Version update (2.10.0 -> 2.10.1)

- Update to v2.10.1 a stable, bug-fix-only release
* Patches dropped (upstream):
0034-slirp-fix-clearing-ifq_so-from-pend.patch
0035-s390-ccw-Fix-alignment-for-CCW1.patch
0038-s390x-ais-for-2.10-stable-disable-a.patch
0039-s390x-cpumodel-remove-ais-from-z14-.patch
* Patches renamed:
0036-target-i386-cpu-Add-new-EPYC-CPU-mo.patch
- > 0034-target-i386-cpu-Add-new-EPYC-CPU-mo.patch
0037-chardev-baum-fix-baum-that-releases.patch
- > 0035-chardev-baum-fix-baum-that-releases.patch
0040-io-fix-temp-directory-used-by-test-.patch
- > 0036-io-fix-temp-directory-used-by-test-.patch
0041-io-fix-check-for-handshake-completi.patch
- > 0037-io-fix-check-for-handshake-completi.patch
0042-crypto-fix-test-cert-generation-to-.patch
- > 0038-crypto-fix-test-cert-generation-to-.patch
0043-vhost-user-disable-the-broken-subpr.patch
- > 0039-vhost-user-disable-the-broken-subpr.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
* Patches added:
0040-io-fix-temp-directory-used-by-test-.patch
0041-io-fix-check-for-handshake-completi.patch
0042-crypto-fix-test-cert-generation-to-.patch
0043-vhost-user-disable-the-broken-subpr.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
* Patches added:
0038-s390x-ais-for-2.10-stable-disable-a.patch
0039-s390x-cpumodel-remove-ais-from-z14-.patch
- Patch queue updated from git://github.com/openSUSE/qemu.git opensuse-2.10
* Patches added:
0037-chardev-baum-fix-baum-that-releases.patch

==== remmina ====
Version update (1.2.0~rcgit.20 -> 1.2.0~rcgit.21)
Subpackages: remmina-lang remmina-plugin-rdp remmina-plugin-vnc
remmina-plugin-xdmcp

- Upgraded to 1.2.0-rcgit.21
Implemented enhancements:
* Feature Request: Create custom Terminal Color Schemes for SSH #1235
* Enter key doesn't "Connect" when in Edit menu and password field is in
focus #1233
* Feature request - Option - Floating Desktop Name [$5] #815
* Don't close connection windows when main window is closed #785
* File association for connections #485
* Implementation of dynamic resolution update for RDP #1292 (giox069)
* Shortcutkey viewonly #1289 (antenore)
* Simplify pthreads library detection #1274 (jabl)
* Custom Color schemes for SSH #1272 (antenore)
* RDP client keyboard mapping with GTK3 #1265 (giox069)
* Make building the VNC plugin optional #1263 (diogocp)
Fixed bugs:
* copy / paste and charset #1300
* Changes user name ssh tunnel (vnc over ssh) do not save. #1255
* SSH username ignored for Tunnels for RDP #1254
* Can't Specify X :display for XDMCP. #1251
* "Remember last view mode for each connection" not respected in
v1.2.0-rcgit.19 #1247
* Remmina always remember password #1224
* Host key not working with SPICE plugin connected to KVM client. #1035
* Shortcutkey viewonly #1289 (antenore)
Merged pull requests:
* Fix charset conversion in VNC clipboard #1303 (giox069)
* Add support for application/x-remmina MIME type, fixes #485 #1299 (giox069)
* Reverted the notfication for the floating toolbar #1297 (antenore)
* Fixes for notifications #1294 (giox069)
* Server name is notified to the user everytime we enter a tab #1290
(antenore)
* Exit strategy for Gnome Shell 3.26 #1287 (giox069)
* Fix gtk redrawing in RDP plugin #1286 (giox069)
* Gtk deprecations #1285 (giox069)
* Add Keywords entry #1277 (mfvescovi)
* Runtime paths for AppImage #1271 (giox069)
* Get ssh_username from remmina profile - fixes #1255 #1267 (antenore)
* Better button labelling and new save button #1250 (antenore)

==== rp-pppoe ====

- Add pppoe.service for run pppoe as client (boo#1060710).
- Refresh pppoe.spec.
- Drop SLE 11 support.

==== subversion ====
Subpackages: libsvn_auth_gnome_keyring-1-0 subversion-bash-completion
subversion-devel subversion-perl subversion-python subversion-server
subversion-tools

- Disable kwallet support on openSUSE built with openssl 1.1, because
otherwise the libopenssl pulled in by libserf and libqt4 create
a conflict (boo#1042629)

==== texinfo ====
Subpackages: info makeinfo

- Avoid also provide libtool() on texinfo specific perl linkage
- Drop require on perl(Locale::Messages) as long as we bundle
perl-libintl-perl (the system one leaves tests failing)
- Do not provide perl() - the modules are not globally available
(bsc#1062028)
- Change perl requires to be exactly the perl version makeinfo was
built against. We ship a perl loadable module which is hard
linked to the right version.

==== thin-provisioning-tools ====
Version update (0.7.2 -> 0.7.3)

- Update to version 0.7.3:
* Misc internal changes
* Updates to tests

==== tracker-miners ====
Version update (2.0.1 -> 2.0.2)
Subpackages: tracker-miner-files tracker-miners-lang

- Update to version 2.0.2:
+ tracker-miner-fs: Fix initialization when there's a startup
timeout.
+ tracker-extract: Don't store 0-length strings on MSOffice
metadata.
+ Updated translations.

==== unison ====

- Wrap specfile conditionals to fix quilt setup

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- Upstream bug fixes (bsc#1027942)
3b769643-dont-add-URI-into-params-for-tunneled-migration.patch
6dfc4de1-add-support-for-parsing-formatting-SR-IOV-VFs.patch
083dfcc8-Show-details-about-the-network-of-SR-IOV-VF-pool.patch
- Add Recommends: python3-virt-bootstrap
Change 'Requires: libvirt-python' to 'Requires: python-libvirt-python'
virt-manager.spec
- Add corrections to sle15 detection (bsc#1054986)

==== vm-install ====
Version update (0.9.03 -> 0.9.04)

- remove udchp on SLE15 only
- PV PXE booting is broken under python 3 (bsc#1047602)
- Version 0.9.04

==== wireshark ====
Version update (2.4.1 -> 2.4.2)
Subpackages: libwireshark10 libwiretap7 libwscodecs1 libwsutil8 wireshark-ui-qt

- Wireshark 2.4.2:
This release fixes minor vulnerabilities that could be used to
trigger dissector crashes or infinite loops by making Wireshark
read specially crafted packages from the network or a capture
file (boo#1062645):
* CVE-2017-15192: BT ATT dissector crash (wnpa-sec-2017-42)
* CVE-2017-15193: MBIM dissector crash (wnpa-sec-2017-43)
* CVE-2017-15191: DMP dissector crash (wnpa-sec-2017-44)
* CVE-2017-15190: RTSP dissector crash (wnpa-sec-2017-45)
* CVE-2017-15189: DOCSIS infinite loop (wnpa-sec-2017-46)

==== yast2-core ====
Version update (3.2.2 -> 4.0.0)

- Fixed newly uncovered warnings: Wterminate, Wint-in-bool-context,
sys/sysmacros (bsc#982942, bsc#434048).
- 4.0.0

==== yast2-theme ====
Version update (4.0.1 -> 4.0.3)
Subpackages: yast2-branding-openSUSE yast2-branding-openSUSE-Oxygen

- Fixed the check box style in the MultiSelectionBox widget
to use the same icons as the usual CheckBox widgets, the check
boxes were almost invisible (bsc#1062356)
- 4.0.3
- improve auto-selected.png and add also svg source for it
(bsc#1054965)
- 4.0.2

==== ypbind ====

- Require libnss_nis2, else NIS accounts are never visible


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups