Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
[opensuse-factory] Re: USB problems on TW
  • From: nicholas cunliffe <ndcunliffe@xxxxxxxxx>
  • Date: Mon, 16 Oct 2017 20:05:19 +0100
  • Message-id: <CA+=73Tu-A7bspfBbwSkTSS32hw14nVVMSZbs78Ci77NW8Nj=NA@mail.gmail.com>
having more time, I appear to have solved my own problem, since uas is
also a module then a simple:
sudo rmmod uas usb-storage, followed by modprobe did the trick

On 16 October 2017 at 16:13, nicholas cunliffe <ndcunliffe@xxxxxxxxx> wrote:
Hi, within the last few weeks? i have developed usb issues on TW.
After a reboot a usb key is detected and can be mounted, thereafter
USB is unusable. lsusb shows no external devices (tried with seveal).

some possibly relevant errors from journald include:

xhci_hcd 0000:00:14.0: Cannot set link state.
usb 2-1: USB disconnect, device number 2
xHCI host controller not responding, assume dead
xhci_hcd 0000:00:14.0: HC died; cleaning up

i considered unloading and then reloading the usb storage module but its in
use:
rmmod: ERROR: Module usb_storage is in use by: uas

thanks for any workarounds for this, the current situation is unworkable

Nicholas
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References