Mailinglist Archive: opensuse-factory (458 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20171007 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20171007

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
Mesa (17.2.1 -> 17.2.2)
ceph (12.2.0+git.1505141259.1264bae1a8 -> 12.2.1+git.1507226092.b783a015b9)
colord
cpupower
docbook-xsl-stylesheets (1.79.0 -> 1.79.2)
drbd (9.0.8+git.c8bc3670 -> 9.0.9+git.bffac0d9)
grub2
libaec
libcdr (0.1.3 -> 0.1.4)
libevent
libmtp (1.1.13 -> 1.1.14)
libqca-qt5 (2.1.1 -> 2.1.3)
libreoffice
libzmf (0.0.1 -> 0.0.2)
openldap2
python-numpy (1.13.1 -> 1.13.3)
thin-provisioning-tools (0.7.1 -> 0.7.2)
xfce4-branding-openSUSE
xfce4-panel (4.12.0 -> 4.12.1)
xfce4-panel-plugin-battery (1.0.5 -> 1.1.0)
xfce4-panel-plugin-cpufreq (1.1.2 -> 1.1.3)
xfce4-panel-plugin-datetime (0.6.2 -> 0.7.0)
xfce4-panel-plugin-eyes (4.4.4 -> 4.5.0)
xfce4-panel-plugin-fsguard (1.0.2 -> 1.1.0)
xfce4-panel-plugin-mpc (0.4.5 -> 0.5.0)
xfce4-panel-plugin-smartbookmark (0.4.6 -> 0.5.0)
xfce4-panel-plugin-verve (1.0.1 -> 1.1.0)
xfce4-panel-plugin-wavelan (0.5.12 -> 0.6.0)
xfce4-panel-plugin-xkb (0.5.6 -> 0.8.1)
xfce4-power-manager (1.4.4 -> 1.6.0)
yast2 (3.3.8 -> 4.0.10)
yast2-add-on (3.3.0 -> 4.0.0)
yast2-ca-management (3.3.0 -> 4.0.0)
yast2-instserver (3.3.0 -> 4.0.0)
yast2-pkg-bindings (4.0.0 -> 4.0.1)

=== Details ===

==== Mesa ====
Version update (17.2.1 -> 17.2.2)
Subpackages: Mesa-dri-devel Mesa-libEGL-devel Mesa-libEGL1 Mesa-libGL-devel
Mesa-libGL1 Mesa-libglapi0 Mesa-libva libgbm1 libvdpau_r300 libvdpau_r600
libvdpau_radeonsi libvulkan_radeon libwayland-egl1 libxatracker2

- update to 17.2.2
* several Vulkan ANV/RADV driver fixes including Wayland WSI
improvements, RadeonSI / i965 / VC4 OpenGL fixes among other
work, some fixes to common Gallium3D code, support for LLVM 5.0
in Gallium3D when using the SCons build system, and a range of
other fixes/improvements.
- Drop gallium svga driver for arm/aarch64. The svga driver is a vmware
guest driver, thus only usable on x86(_64) platforms
- Also enable OpenCL on arm (32bit), llvm4 has reached Factory

==== ceph ====
Version update (12.2.0+git.1505141259.1264bae1a8 ->
12.2.1+git.1507226092.b783a015b9)
Subpackages: librados2 librbd1

- Update to version 12.2.1+git.1507226092.b783a015b9:
+ Revert "SIGPIPE suppression for platforms without SO_NOSIGPIPE or
MSG_NOSIGNAL"
+ msgr: add a mechanism for Solaris to avoid dying on SIGPIPE
- Update to version 12.2.1+git.1507108986.dc637a73e2:
+ rgw: defer constructing keystone engine unless url is configured
(issue#21400, pr#17775)
- Update to version 12.2.1+git.1506764331.9e2e945bd0:
(upstream luminous 9d8acf6f3f85dd1410629cc680474e38f3be9838)
+ upstream Luminous v12.2.1
https://ceph.com/releases/v12-2-1-luminous-released/
- Update to version 12.2.0+git.1506009682.0e5b4307f3
(upstream luminous a931cf68120d99661b785cc794e2b6965d621f06):
+ ceph-disk: fix mountpoint check for systemctl enable --runtime
(bsc#1051598)
+ spec file:
* ceph-fuse requires fuse; make that dependency explicit
* drop obsolete qemu symlink hack in librbd1 %post

==== colord ====
Subpackages: colord-color-profiles colord-lang libcolord2 libcolorhug2

- Collapse files section for gtk-doc.

==== cpupower ====
Subpackages: libcpupower0

- Added missing references.
[bsc#1041332,bsc#996052,bsc#976983]

==== docbook-xsl-stylesheets ====
Version update (1.79.0 -> 1.79.2)

- Update to version 1.79.2
- Rebase docbook-xsl-stylesheets-non-recursive_string_subst.patch
- callout-gen is removed

==== drbd ====
Version update (9.0.8+git.c8bc3670 -> 9.0.9+git.bffac0d9)

- bsc#1061981, update to 9.0.9
* fix occasionally forgotten resyncs in installations where
diskless primaries are present.
* fix an issue that causes unexpected split-brain upon connect.
* in a cluster with a diskless primary, when a server goes away,
and is not outdated, outdate it upon reconnect.
* fix update of exposed data UUID on diskless primaries.
* fix a possible OOPS when in a debug message regarding bitmap
locking
* fix discard bigger than 1MiB
* fix left over bits in bitmap on SyncSource after resync
* fix peers becoming unexpectedly displayed as D_OUTDATED at the
end of a resync
* fix a race between auto promote and auto demote of multiple volumes
in a single resource
* Speed up down of many resources by using call_rcu() instead
of synchronize_rcu()
* Make it compatible with the soon to be released 4.13 kernel
- Modify reproducible.patch since part of the patch is merged

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Build diskboot_tpm.img as separate image to diskboot.img to prevent failure
in booting on some bogus firmware. To use the TPM image you have to use
suse-enable-tpm option of grub2-install (bsc#1052401)
* 0013-tpm-i386-pc-diskboot-img.patch

==== libaec ====
Subpackages: libaec0 libsz2

- Add baselibs.conf: build libsz2 and libaec0 for biarch setups
(needed by hdf5).

==== libcdr ====
Version update (0.1.3 -> 0.1.4)

- Trim build characteristics from description.
- Version update to 0.1.4:
* Fix several issues found by oss-fuzz.
* Require C++11 for build.
* Fix issues found by coverity.
* Various code cleanups.

==== libevent ====

- Trim description of secondary packages and SRPM.
Rectify RPM group.
- Add baselibs.conf: build libevent-2_1-8-32bit (needed by
libqt5-qtwebengine).

==== libmtp ====
Version update (1.1.13 -> 1.1.14)
Subpackages: libmtp-devel libmtp-udev libmtp9

- updated to 1.1.14 release
- lots of new USB ids
- 64bit file bugfixes
- bugfixes

==== libqca-qt5 ====
Version update (2.1.1 -> 2.1.3)
Subpackages: libqca-qt5-devel libqca-qt5-plugins

- Update to 2.1.3
* No changelog provided
- Drop libqca-qt5-2.1.1-explicit-signed-char.patch, merged upstream
- Update Url
- Remove libbotan-devel build requirement, we explicitly disable
building the botan plugin anyway (boo#1055322)

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-sifr
libreoffice-icon-theme-tango libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Added Esperanto to list of languages.

==== libzmf ====
Version update (0.0.1 -> 0.0.2)

- Version update to 0.0.2:
* Allow build with boost older than 1.56.
* Require C++11 for build.
* Fix various issues found by oss-fuzz.
* Minor code cleanups.
- Drop merged patch:
* libzmf-old-boost.patch

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data openldap2-client
openldap2-devel

- Add openldap-r-only.dif so that openldap2's own tools also
link against libldap_r rather than libldap.
- Make libldap equivalent to libldap_r (like Debian) to avoid
crashes in threaded programs which unknowingly get both
libraries inserted into their process image.
[rh#1370065, boo#996551]
- use existing groups instead of inventing new ones

==== python-numpy ====
Version update (1.13.1 -> 1.13.3)
Subpackages: python2-numpy python3-numpy

- updated line numbers in patches
- update to version 1.13.3:
* #9390 BUG: Return the poly1d coefficients array directly
* #9555 BUG: Fix regression in 1.13.x in distutils.mingw32ccompiler.
* #9556 BUG: Fix true_divide when dtype=np.float64 specified.
* #9557 DOC: Fix some rst markup in numpy/doc/basics.py.
* #9558 BLD: Remove -xhost flag from IntelFCompiler.
* #9559 DOC: Removes broken docstring example (source code, png,
pdf)...
* #9580 BUG: Add hypot and cabs functions to WIN32 blacklist.
* #9732 BUG: Make scalar function elision check if temp is
writeable.
* #9736 BUG: Various fixes to np.gradient
* #9742 BUG: Fix np.pad for CVE-2017-12852
* #9744 BUG: Check for exception in sort functions, add tests
* #9745 DOC: Add whitespace after "versionadded::" directive so it
actually...
* #9746 BUG: Memory leak in np.dot of size 0
* #9747 BUG: Adjust gfortran version search regex
* #9757 BUG: Cython 0.27 breaks NumPy on Python 3.
* #9764 BUG: Ensure _npy_scaled_cexp{,f,l} is defined when needed.
* #9765 BUG: PyArray_CountNonzero does not check for exceptions
* #9766 BUG: Fixes histogram monotonicity check for unsigned bin
values
* #9767 BUG: Ensure consistent result dtype of count_nonzero
* #9771 BUG: MAINT: Fix mtrand for Cython 0.27.
* #9772 DOC: Create the 1.13.2 release notes.
* #9794 DOC: Create 1.13.3 release notes.
- changes from version 1.13.2:
* #9390 BUG: Return the poly1d coefficients array directly
* #9555 BUG: Fix regression in 1.13.x in distutils.mingw32ccompiler.
* #9556 BUG: Fix true_divide when dtype=np.float64 specified.
* #9557 DOC: Fix some rst markup in numpy/doc/basics.py.
* #9558 BLD: Remove -xhost flag from IntelFCompiler.
* #9559 DOC: Removes broken docstring example (source code, png,
pdf)...
* #9580 BUG: Add hypot and cabs functions to WIN32 blacklist.
* #9732 BUG: Make scalar function elision check if temp is
writeable.
* #9736 BUG: Various fixes to np.gradient
* #9742 BUG: Fix np.pad for CVE-2017-12852
* #9744 BUG: Check for exception in sort functions, add tests
* #9745 DOC: Add whitespace after "versionadded::" directive so it
actually...
* #9746 BUG: Memory leak in np.dot of size 0
* #9747 BUG: Adjust gfortran version search regex
* #9757 BUG: Cython 0.27 breaks NumPy on Python 3.
* #9764 BUG: Ensure _npy_scaled_cexp{,f,l} is defined when needed.
* #9765 BUG: PyArray_CountNonzero does not check for exceptions
* #9766 BUG: Fixes histogram monotonicity check for unsigned bin
values
* #9767 BUG: Ensure consistent result dtype of count_nonzero
* #9771 BUG, MAINT: Fix mtrand for Cython 0.27.

==== thin-provisioning-tools ====
Version update (0.7.1 -> 0.7.2)

- Update to version 0.7.2:
* Misc internal changes
* Updated documentation and manpages

==== xfce4-branding-openSUSE ====
Subpackages: libgarcon-branding-openSUSE libxfce4ui-branding-openSUSE
midori-branding-openSUSE openSUSE-xfce-icon-theme
thunar-volman-branding-openSUSE xfce4-notifyd-branding-openSUSE
xfce4-panel-branding-openSUSE xfce4-power-manager-branding-openSUSE
xfce4-session-branding-openSUSE xfce4-settings-branding-openSUSE
xfdesktop-branding-openSUSE xfwm4-branding-openSUSE

- fix exo-branding provides / obsoletes
- adapt to changes in exo package (exo-1 subdir patch removed)

==== xfce4-panel ====
Version update (4.12.0 -> 4.12.1)
Subpackages: libxfce4panel-1_0-4 libxfce4panel-2_0-4 xfce4-panel-lang

- update to vesion 4.12.1
- maintenance release.
- translation updates.
- Clock: fixed compiler warnings.
- Preferences: support for xfpanel-switch (if installed).
- DirectoryMenu: fixed bugs bxo#10331 and bxo#11742
- Tasklist: fixed background color issue.
- ApplicationsMenu: fixed uninitialized variable.
- make distcheck fix/workaround.

==== xfce4-panel-plugin-battery ====
Version update (1.0.5 -> 1.1.0)
Subpackages: xfce4-panel-plugin-battery-lang

- Remove redundant %clean section.
- update to 1.1.0
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0

==== xfce4-panel-plugin-cpufreq ====
Version update (1.1.2 -> 1.1.3)
Subpackages: xfce4-panel-plugin-cpufreq-lang

- update to version 1.1.3
- translation updates

==== xfce4-panel-plugin-datetime ====
Version update (0.6.2 -> 0.7.0)
Subpackages: xfce4-panel-plugin-datetime-lang

- Remove redundant %clean section.
- update to version 0.7
port to gtk+3/libxfce4ui-2/libxfce4panel-2.0

==== xfce4-panel-plugin-eyes ====
Version update (4.4.4 -> 4.5.0)
Subpackages: xfce4-panel-plugin-eyes-lang

- update to version 4.5.0:
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0
- translation updates

==== xfce4-panel-plugin-fsguard ====
Version update (1.0.2 -> 1.1.0)
Subpackages: xfce4-panel-plugin-fsguard-lang

- update to version 1.1.0
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0

==== xfce4-panel-plugin-mpc ====
Version update (0.4.5 -> 0.5.0)
Subpackages: xfce4-panel-plugin-mpc-lang

- update to version 0.5.0
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0
- fix changing volume via mousewheel
- fix icon flickering on mousehover
- properly resize button/image on set_size event

==== xfce4-panel-plugin-smartbookmark ====
Version update (0.4.6 -> 0.5.0)
Subpackages: xfce4-panel-plugin-smartbookmark-lang

- + xfce4-panel-plugin-smartbookmark-0.5.0-defaults.patch
- - xfce4-panel-plugin-smartbookmark-0.4.2-defaults.patch
- update to version 0.5.0
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0
- fix value changes saving in prefs dialog (#12666)
- fix boolean logic in GtkSwitch use

==== xfce4-panel-plugin-verve ====
Version update (1.0.1 -> 1.1.0)
Subpackages: xfce4-panel-plugin-verve-lang

- update to version 1.1.0
- add ability to use xfce4-verve-plugin as a smartbookmark plugin
- add ability to direct commands starting in ! or \ to DuckDuckGo
- run commands through shell by default, to allow aliases,
variables, etc.
- use wordexp to expand directory names (when available), to
allow variables, etc.
- add an optional label on the left side of the plugin
- expand properties window to configure the new features
- increase maximum width of plugin
- do not package ChangeLog file, NEWS is enough

==== xfce4-panel-plugin-wavelan ====
Version update (0.5.12 -> 0.6.0)
Subpackages: xfce4-panel-plugin-wavelan-lang

- update to version 0.6.0
- port to gtk+3/libxfce4ui-2/libxfce4panel-2.0
- translation updates
- do not package ChangeLog; NEWS is good enough

==== xfce4-panel-plugin-xkb ====
Version update (0.5.6 -> 0.8.1)
Subpackages: xfce4-panel-plugin-xkb-lang

- update to version 0.8.1
* Add caps lock indicator for "system" layout style
* Translation updates
- Fix the build with libxklavier 5.3:
xfce4-xkb-plugin-0.8.0-downgrade-libxklavier-requirement.diff
- update to version 0.8.0
* New plugin is not compatible with previous versions
you will have to add and configure it again!
* Port to GTK+3
* Add xfconf support
* Add new "system" layout style
* Allow adjusting widget size
* Allow displaying language name instead of country name
* Allow hiding tooltip icon
* Load flags from XDG_DATA_HOME if present
* Fix Indian flag filename
* Fix charset for layout names
* Translation updates
- update to version 0.7.1
- fix crash in xkb_util_normalize_group_name
- 0.7.0
- this is a fairly major rework - keyboard layouts are now
configured through xfce4-keyboard-settings and managed by
xfsettingsd; xkb-plugin only manages per window/application
layout prefs and just acts as a layout indicator otherwise
- many crashes/leaks fixed
- more descriptive layout/variant names in tooltips/popup menus
- xfce 4.10 panel compatibility
- text labels are scaled to the size of text area
- more flags added
- layout configs should no longer be lost (this is really handled
by the code moved to xfce4-settings though)
- XKB settings not managed by XFCE should no longer be overwritten
(again, this is really handled by xfce4-settings now)
- now depends on garcon (used to launch xfce4-keyboard-settings)
- package NEWS instead of ChangeLog file

==== xfce4-power-manager ====
Version update (1.4.4 -> 1.6.0)
Subpackages: xfce4-panel-plugin-power-manager xfce4-power-manager-lang

- update to version 1.6.0
- port to GTK3
- port to gdbus
- drop LXDE panel plugin
- screensaver fixes / improvements
- various crash fixes
- memory leaks fixed
- many other improvements, see ChangeLog and NEWS file

==== yast2 ====
Version update (3.3.8 -> 4.0.10)

- Disable vnc, ssh,... installation in install.inf if it is not
supported. (bnc#1055279, bnc#1058071)
- 4.0.10
- Stop using tmpnam, it is no longer supported in perl 5.26
(bsc#1061620)
- 4.0.9
- Add support for merging to workflow extensions from modules
(bsc#1049297)
- 4.0.8
- fix starting gnome control center (bsc#1058376)
- 4.0.7
- systemd services (bsc#1045658)
- reverted a command change that broke brittle tests
- 4.0.6
- systemd services (bsc#1045658)
- add SystemdService.find_many for a speed-up
- SystemdUnit fix for units with multiple dots in name
- consistent logging of systemctl calls
- 4.0.5
- Fix handling of PGP signatures when running in insecure mode
(bsc#1054663)
- 4.0.4
- Added methods to Yast2::FsSnapshot allowing to finish the
Snapper configuration (part of fate#318196).
- 4.0.3
- Add support to disable buttons on CWM::Dialog
- Add a method WorkflowManager#merge_product_workflow which allows
to merge a product workflow (fate#322267)
- 4.0.2
- Added UI:TextHelpers with a wrap_text method moved from
yast2-network (bsc#1055643)
- 4.0.1
- Fixed the cursor theme in the installation (the DMZ theme has
been replaced by DMZ-White and DMZ-Black) (bsc#1051664)
- 4.0.0
- Restore Packages::Repository and Packages::Product in order
to retain compatibility with yast2-packager 3.3.2 which is
the version on Factory until storage-ng is finally
merged (bsc#1055677)
- 3.3.10
- Move Packages::Repository and Packages::Product to yast2-packager
(FATE#322276)
- 3.3.9

==== yast2-add-on ====
Version update (3.3.0 -> 4.0.0)

- Display also the repository path in the URL column if it is
defined (fate#323886)
- 4.0.0
- Removed support for floppy (fate#319096)
- 3.3.1

==== yast2-ca-management ====
Version update (3.3.0 -> 4.0.0)

- Fix directory navigation when trying to go one level up ".."
(bsc#1024214)
- 4.0.0

==== yast2-instserver ====
Version update (3.3.0 -> 4.0.0)

- Stop using tmpnam, it is no longer supported in perl 5.26
(bsc#1061620)
- 4.0.0

==== yast2-pkg-bindings ====
Version update (4.0.0 -> 4.0.1)

- Add a CompareVersions function (related to fate#323273)
- 4.0.1


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups