Mailinglist Archive: opensuse-factory (826 mails)

< Previous Next >
Re: [opensuse-factory] Cups behaviour in actual TW
On 10/02/2017 03:21 PM, Axel Braun wrote:
Am Montag, 2. Oktober 2017, 14:24:14 CEST schrieb Antonio Larrosa:
On 10/02/2017 08:04 AM, Bruno Friedmann wrote:
If you do
export QT_DISABLE_PRINTER_DISCOVERY=1
on konsole before running the KDE/Qt application that tries to print, it
should disable the discovery and use the printer configuration as usual.

You can of course also set QT_DISABLE_PRINTER_DISCOVERY=1 in
/etc/environment or in ~/.profile to fix the option for all applications.

Can you (both) try that and see if that fixes the problems?

After logging off and on again, KDE print dialog now only shows the two
queues
as visible in cups.

Maybe we make this a default setting?


If we can't find a better solution, I guess that could be an option. But I'd
prefer to fix it properly so the discovered printer can be used automatically.

Just to know better your configuration... you only have one computer (no cups
print server, just cups configured on the same computer) with one printer
(brother MFC-9340CDW) connected by wifi, BRW3C77E658BC0F.local resolves as
192.168.1.103 and you only configured the lpd connection in your local cups,
right?

Can you send me your local cups configuration (/etc/cups/*.conf) and the
output of running "avahi-browse -art" ? (directly if you prefer, so we don't
spam the list) . Note you might have to install avahi-utils if you don't have
it, since avahi-browse is included there.

Thanks,

--
Antonio Larrosa
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >