Mailinglist Archive: opensuse-factory (421 mails)

< Previous Next >
Re: [opensuse-factory] Can I remove locks in TW
On 2017-09-26 13:14, Fabian Wein wrote:
Problem: libdrm-devel-2.4.80-1.1.x86_64 requires libdrm2 = 2.4.80, but
this requirement cannot be provided
  deleted providers: libdrm2-2.4.80-1.1.x86_64
 Solution 1: keep obsolete libdrm2-2.4.80-1.1.x86_64
 Solution 2: remove lock to allow removal of libdrm-devel-2.4.80-1.1.x86_64
 Solution 3: break libdrm-devel-2.4.80-1.1.x86_64 by ignoring some of
its dependencies

I you tell me it is save to remove all locks I'm happy to do this :)

Hi Fabian,

A clean Tumbleweed install does not have any locks and usually upgrades
just fine. The problems start when you have packages or repos that do
not come from the (nicely integrated+tested) main Tumbleweed repos.

I usually do
zypper dup --no-recommends --no-allow-vendor-change --force-resolution

You should properly review the proposed changes - especially the list of
to-be-removed packages and the list of vendor-changes.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References