Mailinglist Archive: opensuse-factory (421 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170924 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170924

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick (7.0.6.7 -> 7.0.7.1)
Mesa (17.2.0 -> 17.2.1)
NetworkManager (1.8.2 -> 1.8.4)
NetworkManager-branding-openSUSE
adwaita-icon-theme (3.25.91 -> 3.26.0)
akonadi-runtime
amarok
apache-commons-collections
apache-commons-daemon
apache-commons-io
apache-commons-pool2
apache-pdfbox
appstream-glib
attica-qt5 (5.37.0 -> 5.38.0)
avalon-framework
baloo5 (5.37.0 -> 5.38.0)
bea-stax
bind
binutils (2.28 -> 2.29)
bluez (5.46 -> 5.47)
bluez-qt (5.37.0 -> 5.38.0)
breeze5-icons (5.37.0 -> 5.38.0)
btrfsprogs (4.12.1 -> 4.13)
bubblewrap
cglib
clutter
cogl
digikam (5.6.0 -> 5.7.0)
e2fsprogs
ecj
elfutils
emacs
evolution-rss
exiv2
extra-cmake-modules (5.37.0 -> 5.38.0)
flatpak
flex
fluidsynth (1.1.6 -> 1.1.7)
folks
frameworkintegration (5.37.0 -> 5.38.0)
gdb
gdm
geany-plugins (1.30 -> 1.31)
glib2
glibmm2_4 (2.52.0 -> 2.52.1)
gnome-backgrounds (3.25.4 -> 3.26.2)
gnome-bluetooth (3.26.0 -> 3.26.1)
gnome-documents (3.25.91 -> 3.26.0)
gnome-session
gnome-settings-daemon
gnome-shell
gom
gpg2 (2.2.0 -> 2.2.1)
gpm
grilo-plugins
grub2
gstreamer-editing-services (1.12.2 -> 1.12.3)
gtk4
gtkmm3 (3.22.1 -> 3.22.2)
gvfs
hdf5
icu4j
jakarta-taglibs-standard
java-1_8_0-openjdk
k3b
kactivities-stats (5.37.0 -> 5.38.0)
kactivities5 (5.37.0 -> 5.38.0)
karchive (5.37.0 -> 5.38.0)
kauth (5.37.0 -> 5.38.0)
kbookmarks (5.37.0 -> 5.38.0)
kcmutils (5.37.0 -> 5.38.0)
kcodecs (5.37.0 -> 5.38.0)
kcompletion (5.37.0 -> 5.38.0)
kconfig (5.37.0 -> 5.38.0)
kconfigwidgets (5.37.0 -> 5.38.0)
kcoreaddons (5.37.0 -> 5.38.0)
kcrash (5.37.0 -> 5.38.0)
kdbusaddons (5.37.0 -> 5.38.0)
kde-l10n
kdeclarative (5.37.0 -> 5.38.0)
kded (5.37.0 -> 5.38.0)
kdelibs4support (5.37.0 -> 5.38.0)
kdesignerplugin (5.37.0 -> 5.38.0)
kdesu (5.37.0 -> 5.38.0)
kdewebkit (5.37.0 -> 5.38.0)
kdnssd-framework (5.37.0 -> 5.38.0)
kdoctools (5.37.0 -> 5.38.0)
kemoticons (5.37.0 -> 5.38.0)
kernel-firmware (20170823 -> 20170906)
kernel-source (4.13.1 -> 4.13.3)
kfilemetadata5 (5.37.0 -> 5.38.0)
kglobalaccel (5.37.0 -> 5.38.0)
kguiaddons (5.37.0 -> 5.38.0)
khtml (5.37.0 -> 5.38.0)
ki18n (5.37.0 -> 5.38.0)
kiconthemes (5.37.0 -> 5.38.0)
kidletime (5.37.0 -> 5.38.0)
kimageformats (5.37.0 -> 5.38.0)
kinit (5.37.0 -> 5.38.0)
kio (5.37.0 -> 5.38.0)
kitemmodels (5.37.0 -> 5.38.0)
kitemviews (5.37.0 -> 5.38.0)
kjobwidgets (5.37.0 -> 5.38.0)
kjs (5.37.0 -> 5.38.0)
kjsembed (5.37.0 -> 5.38.0)
kmediaplayer (5.37.0 -> 5.38.0)
knewstuff (5.37.0 -> 5.38.0)
knotifications (5.37.0 -> 5.38.0)
knotifyconfig (5.37.0 -> 5.38.0)
korganizer
kpackage (5.37.0 -> 5.38.0)
kparts (5.37.0 -> 5.38.0)
kpeople5 (5.37.0 -> 5.38.0)
kplotting (5.37.0 -> 5.38.0)
kpty (5.37.0 -> 5.38.0)
kross (5.37.0 -> 5.38.0)
krunner (5.37.0 -> 5.38.0)
kservice (5.37.0 -> 5.38.0)
ktexteditor (5.37.0 -> 5.38.0)
ktextwidgets (5.37.0 -> 5.38.0)
kunitconversion (5.37.0 -> 5.38.0)
kwallet (5.37.0 -> 5.38.0)
kwayland (5.37.0 -> 5.38.0)
kwidgetsaddons (5.37.0 -> 5.38.0)
kwindowsystem (5.37.0 -> 5.38.0)
kxmlgui (5.37.0 -> 5.38.0)
kxmlrpcclient5 (5.37.0 -> 5.38.0)
libKF5ModemManagerQt (5.37.0 -> 5.38.0)
libKF5NetworkManagerQt (5.37.0 -> 5.38.0)
libfm-extra (1.2.3 -> 1.2.5)
libfreehand (0.1.1 -> 0.1.2)
libgda
libinput (1.8.1 -> 1.8.2)
libpcap
libqt4
libqt5-qtbase
libraw (0.18.2 -> 0.18.4)
libsolv (0.6.28 -> 0.6.29)
libvirt (3.6.0 -> 3.7.0)
libwpd (0.10.1 -> 0.10.2)
libwpg (0.3.1 -> 0.3.2)
libzip
libzypp (16.15.6 -> 16.17.0)
make
man-pages (4.12 -> 4.13)
mpfr (3.1.5 -> 3.1.6)
mutt (1.8.3 -> 1.9.0)
mutter
ncurses
netcdf (4.4.1 -> 4.4.1.1)
obs-service-set_version
openjpeg2
openmpi
openucx (1.3+git44 -> 1.2.1)
orca (3.25.4 -> 3.26.0)
osc (0.159.0 -> 0.160.0)
osinfo-db
oxygen5-icon-theme (5.37.0 -> 5.38.0)
parted
patterns-base
pcre
permissions (20170602 -> 20170913)
pesign-obs-integration
plasma-framework (5.37.0 -> 5.38.0)
plasma5-pk-updates (0.2 -> 0.3.1)
postfix
prison-qt5 (5.37.0 -> 5.38.0)
psmisc
pulseaudio (11.0 -> 11.1)
purple-facebook (0.9.4 -> 0.9.5)
python-cairo
python-iniparse
python-libvirt-python (3.6.0 -> 3.7.0)
python-lxml (3.8.0 -> 4.0.0)
python-numpy (1.12.1 -> 1.13.1)
python-pyOpenSSL (17.0.0 -> 17.2.0)
python-pyasn1 (0.3.4 -> 0.3.5)
python-setuptools (34.2.0 -> 36.5.0)
python3 (3.6.1 -> 3.6.2)
python3-base (3.6.1 -> 3.6.2)
rdma-core
rhino
rubygem-gem2rpm
saxon6
saxon9
shadow
solid (5.37.0 -> 5.38.0)
sonnet (5.37.0 -> 5.38.0)
spamassassin
sudo
syntax-highlighting (5.37.0 -> 5.38.0)
sysprof (3.25.92 -> 3.26.0)
system-config-printer
system-users
systemd
tagsoup
tcl (8.6.6 -> 8.6.7)
tcpdump (4.9.1 -> 4.9.2)
threadweaver (5.37.0 -> 5.38.0)
timezone
timezone-java
tk (8.6.6 -> 8.6.7)
tomcat
totem
totem-pl-parser (3.25.90 -> 3.26.0)
udisks2 (2.1.8 -> 2.6.5)
umbrello
unbound (1.6.4 -> 1.6.6)
utempter
vde2
virt-manager (1.4.2 -> 1.4.3)
virtualbox (5.1.26_k4.13.1_1 -> 5.1.26_k4.13.3_1)
vm-install (0.9.02 -> 0.9.03)
vsftpd
webkit2gtk3
whois (5.2.16 -> 5.2.18)
wxWidgets-3_0
wxWidgets-3_0-nostl
xen
xf86-input-libinput (0.25.1 -> 0.26.0)
xiterm
xmlgraphics-commons
xmlgraphics-fop
yast2-country (3.3.0 -> 4.0.2)
yast2-nis-client (3.2.1 -> 4.0.0)
yast2-pkg-bindings (3.2.4 -> 4.0.0)
yast2-samba-server (3.2.1 -> 3.2.2)
zypper (1.13.32 -> 1.13.35)

=== Details ===

==== ImageMagick ====
Version update (7.0.6.7 -> 7.0.7.1)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-7_Q16HDRI3
perl-PerlMagick

- updated to 7.0.7-1
* Fixed numerous memory leaks.
* Added -define tiff:write-layers=true to add support for writing
layered tiff files.
* Don't overwrite symbolic links when the shred policy is enabled.
* Support -metric ssim, structual similarity index.
* Fixed thread safety issue inside the pango and librsvg decoder.
* Fixed bug with writing tIME chunk when timezone has a negative
offset.
* Support CubicSpline resize filter. Define the lobes with the
- define filter:lobes={2,3,4}.
* Prevent assertion failure when creating PDF thumbnail.

==== Mesa ====
Version update (17.2.0 -> 17.2.1)
Subpackages: Mesa-dri-devel Mesa-libEGL-devel Mesa-libEGL1 Mesa-libGL-devel
Mesa-libGL1 Mesa-libglapi0 Mesa-libglapi0-32bit Mesa-libva libOSMesa8
libOSMesa8-32bit libgbm1 libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libvulkan_radeon libwayland-egl1 libxatracker2

- update to 17.2.1
* drop upstreamed patches
n_force-xlocale-funcs.patch
u_gallivm-correct-channel-shift-logic-on-big-endian.patch
u_llvmpipe-lp_build_gather_elem_vec-BE-fix-for-3x16-lo.patch
* fdo#100613 - Regression in Mesa 17 on s390x (zSystems)
* fdo#101709 - [llvmpipe] piglit gl-1.0-scissor-offscreen regression
* fdo#102454 - glibc 2.26 doesn't provide anymore xlocale.h
* fdo#102467 - [src/mesa/state_tracker/st_cb_readpixels.c:178]: (warning)
Redundant assignment
* fdo#102502 - [bisected] Kodi crashes since commit 707d2e8b - gallium:
fold u_trim_pipe_prim call from st/mesa to drivers
* many fixes for RADV a glsl

==== NetworkManager ====
Version update (1.8.2 -> 1.8.4)
Subpackages: NetworkManager-devel libnm-glib-vpn1 libnm-glib4 libnm-util2
libnm0 typelib-1_0-NM-1_0 typelib-1_0-NMClient-1_0
typelib-1_0-NetworkManager-1_0

- Update to version 1.8.4:
+ No longer install NetworkManager-wait-online.service in
network-online.target.wants directory (rh#1455704).
+ Fix nmcli device connect wifi for APs that support both
WPA-PSK and WPA-EAP (rh#1492064).
+ Fix crash unregistering object manager in libnm on restart of
NetworkManager.
+ Improve handling externally managed slaves devices.
+ Don't reset MAC address of software devices to fake permanent
address.
+ For dhclient use "timeout" option in configuration file,
instead of the command line option which is only supported by
downstream.
+ Perform the public-suffix check only for the hostname-derived
domain.
+ Fix memory leak in connectivity check.
+ Better restore device managed state on rollback of checkpoint.
+ Skip addition of default-route if it already exists.
+ Bug fix detecting error condition when deleting route in
platform.
- Drop NM-dhcp-improve-parsing-interface-statement.patch: Fixed
upstream.

==== NetworkManager-branding-openSUSE ====

- Apply %{branding_name} also to summary and description.

==== adwaita-icon-theme ====
Version update (3.25.91 -> 3.26.0)

- Update to version 3.26.0:
+ Thunderbolt status icons.
+ System settings icons.

==== akonadi-runtime ====

- Reduce runtime Requires, akonadi-runtime shouldn't be used anymore,
but just built against
- Needed for libqt4-sql-mysql removal

==== amarok ====
Subpackages: amarok-lang

- Add gstreamer-plugins-ugly Recommends: Provide mp3 playback by
default for users.

==== apache-commons-collections ====

- Fix build with jdk9 by specifying java source and target 1.6
- Added patch:
* commons-collections-3.2.2-tf.javadoc.patch
- Fix unresolved symbols when building tf.javadoc

==== apache-commons-daemon ====

- Fix jdk9 build by specifying java source and target 1.6

==== apache-commons-io ====

- Fix build with jdk9 by specifying source and target level 1.6

==== apache-commons-pool2 ====

- Fix javadoc build

==== apache-pdfbox ====

- Added patches:
* pdfbox-1.8.12-bouncycastle.patch
+ Fix build of javadoc against bouncycastle API >= 1.4.7
* pdfbox-1.8.12-sourcetarget.patch
+ Make java source and target level ant properties
+ Leave the default 1.5
- Specify java source and target level 1.6 in order to allow
building with jdk9

==== appstream-glib ====
Subpackages: appstream-glib-lang libappstream-builder8 libappstream-glib8

- Update openSUSE-appstream-process: exit early if as-builder does
not end with exit 0.

==== attica-qt5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== avalon-framework ====

- Specify java source and target level 1.6 in order to allow build
with jdk9
- Clean spec file a fix rpmlint warning

==== baloo5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Avoid useless copies from it.next(), add const REVIEW: 129378
* Remove useless includes REVIEW: 129650
* Fix directory based search.

==== bea-stax ====
Subpackages: bea-stax-api

- Don't require java-1_5_0-gcj-compat and build with source and
target level 1.6
- Removed patch:
* bea-stax-target15.patch
- Added patch:
* bea-stax-target16.patch
- change the source and target levels and fix a problem with
the encoding of one file

==== bind ====
Subpackages: bind-chrootenv bind-doc bind-utils idnkit libbind9-140 libdns165
libidnkit1 libirs141 libisc160 libisccc140 libisccfg140 liblwres141

- bind-openssl11.patch: add a patch for enabling
openssl 1.1 support (builds for 1.0 and 1.1 openssl).
(bsc#1042635)

==== binutils ====
Version update (2.28 -> 2.29)
Subpackages: binutils-devel

- Update to 2.29 (@5d25156), upstream fix for PR21884, as
well as PRs 18808 18841 21840 21988 21910 21962 21964.
- Last fixes for PR21884 weren't complete, adjust
binutils-2.29-branch.diff some more for this.
- Update to 2.29 branch (@de44148c), fixing PR21884, a segfault
in ld while building memtest86+ .
Changes binutils-2.29-branch.diff.
- Update to 2.29 branch, fixing PR21847, affecting the ppc64le
ABI in corner cases since 2.29 release.
Adds binutils-2.29-branch.diff.
- Remove binutils-2.29-gold-mips.patch, obsolete by the update.
- Add binutils-2.29-gold-mips.patch to fix build on SLE-11.
- Update to binutils 2.29.
* The MIPS port now supports microMIPS eXtended Physical Addressing (XPA)
instructions for assembly and disassembly.
* The MIPS port now supports the microMIPS Release 5 ISA for assembly and
disassembly.
* The MIPS port now supports the Imagination interAptiv MR2 processor,
which implements the MIPS32r3 ISA, the MIPS16e2 ASE as well as a couple
of implementation-specific regular MIPS and MIPS16e2 ASE instructions.
* The SPARC port now supports the SPARC M8 processor, which implements the
Oracle SPARC Architecture 2017.
* The MIPS port now supports the MIPS16e2 ASE for assembly and disassembly.
* Add support for ELF SHF_GNU_MBIND and PT_GNU_MBIND_XXX.
* Add support for the wasm32 ELF conversion of the WebAssembly file format.
* Add --inlines option to objdump, which extends the --line-numbers option
so that inlined functions will display their nesting information.
* Add --merge-notes options to objcopy to reduce the size of notes in
a binary file by merging and deleting redundant notes.
* Add support for locating separate debug info files using the build-id
method, where the separate file has a name based upon the build-id of
the original file.
GAS
* Add support for ELF SHF_GNU_MBIND.
* Add support for the WebAssembly file format and wasm32 ELF conversion.
* PowerPC gas now checks that the correct register class is used in
instructions. For instance, "addi %f4,%cr3,%r31" warns three times
that the registers are invalid.
* Add support for the Texas Instruments PRU processor.
* Support for the ARMv8-R architecture and Cortex-R52 processor has been
added to the ARM port.
GNU ld
* Support for -z shstk in the x86 ELF linker to generate
GNU_PROPERTY_X86_FEATURE_1_SHSTK in ELF GNU program properties.
* Add support for GNU_PROPERTY_X86_FEATURE_1_SHSTK in ELF GNU program
properties in the x86 ELF linker.
* Add support for GNU_PROPERTY_X86_FEATURE_1_IBT in ELF GNU program
properties in the x86 ELF linker.
* Support for -z ibtplt in the x86 ELF linker to generate IBT-enabled
PLT.
* Support for -z ibt in the x86 ELF linker to generate IBT-enabled
PLT as well as GNU_PROPERTY_X86_FEATURE_1_IBT in ELF GNU program
properties.
* Add support for ELF SHF_GNU_MBIND and PT_GNU_MBIND_XXX.
* Add support for ELF GNU program properties.
* Add support for the Texas Instruments PRU processor.
* When configuring for arc*-*-linux* targets the default linker emulation will
change if --with-cpu=nps400 is used at configure time.
* Improve assignment of LMAs to orphan sections in some edge cases where a
mixture of both AT>LMA_REGION and AT(LMA) are used.
* Orphan sections placed after an empty section that has an AT(LMA) will now
take an load memory address starting from LMA.
* Section groups can now be resolved (the group deleted and the group members
placed like normal sections) at partial link time either using the new
linker option --force-group-allocation or by placing FORCE_GROUP_ALLOCATION
into the linker script.
- Includes binutils-bso21193.diff, binutils-bso21333.diff and
fix-security-bugs.diff.
- Remove ld-dtags.diff, instead configure with --enable-new-dtags.
- Refresh binutils-build-as-needed.diff.
- Remove binutils-2.28-branch.diff.

==== bluez ====
Version update (5.46 -> 5.47)
Subpackages: bluez-cups bluez-devel libbluetooth3

- update to version 5.47:
This release contains various fixes to GATT, A2DP and BR/EDR vs
LE bearer handling. There?s also a notable SDP fix for CVE-2017-
1000250 (part of the recently announced BlueBorne vulnerabilities).
Feature-wise, there?s now support for adding the appearance and
local name to advertising data through the Advertising D-Bus
interface. The btmon tool is now also able to better decode most
Bluetooth 5.0 HCI commands and events.
The Bluetooth Mesh Profile specification was released recently,
and this BlueZ release comes with initial support for it in the
form of a new meshctl tool. Using this tool it?s possible to
provision mesh devices through the GATT Provisioning Bearer
(PB-GATT), as well as communicate with them (e.g. configure them)
using the GATT Proxy protocol.

==== bluez-qt ====
Version update (5.37.0 -> 5.38.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotests: remove now unnecessary compat code
* autotests: fix failure to find fakebluez in the bin dir.
* Autotests: Fix finding fakebluez binary (kde#383453)

==== breeze5-icons ====
Version update (5.37.0 -> 5.38.0)

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== btrfsprogs ====
Version update (4.12.1 -> 4.13)
Subpackages: btrfsprogs-udev-rules libbtrfs0

- update to version 4.13:
* convert: reiserfs support
* check: new option --force to allow check of a mounted filesystem (no repair)
* mkfs: --rootdir will now copy special files
* dump-tree: minor output changes
* inspect rootid: accept file as arugment
* dev usage: don't calculate slack space for missing devices
* fi du: don't print error on EMPTY_SUBVOL (inode number 2)
* build:
* fixed support for sanitization features on gcc (tsan, asan, ubsan)
* fix PIE build
* other:
* misc cleanups and stability fixes
* travis CI enhancements
* new tests, fuzzed images
* testsuite cleanups
- Removed patches:
- 0163-btrfs-progs-fsck-fix-segfault.patch - will be upstreamed
- local-version-override.patch - not needed anymore
- btrfs-support-pie.patch - upstremed

==== bubblewrap ====

- add group

==== cglib ====

- Specify java source and target 1.6 in order to allow building
with jdk9
- Fix javadoc generation
- Clean spec file

==== clutter ====
Subpackages: clutter-lang libclutter-1_0-0 typelib-1_0-Clutter-1_0

- Drop the SLE12 / Leap42 build_wayland_backend conditional.

==== cogl ====
Subpackages: gstreamer-plugins-cogl libcogl-pango20 libcogl20
typelib-1_0-Cogl-1_0 typelib-1_0-CoglPango-1_0

- Drop the SLE12 / Leap42 build_wayland_backend conditional.

==== digikam ====
Version update (5.6.0 -> 5.7.0)
Subpackages: kipi-plugins kipi-plugins-lang

- Update to 5.7.0:
* https://www.digikam.org/news/2017-09-11-5.7.0_release_announcement/
- New features (from NEWS):
General : Add online handbook reader not dependant of desktop.
General : New tool to export albums by email.
General : New tool to create advance print layout.
General : Send by Mail tool can remove all metadata to attached items.
General : Replaced the minimum and maximum similarity selection boxes in
fuzzy
search, duplicates search and maintenance by a new, generic DIntRangeBox
which makes the look, feel and behavious consistent in all places.
Also, this makes redundant code obsolete and reduces the probability of
bugs.
PrintCreator: Add option to create printing from albums or images selection.
PrintCreator: Add option to customize output image properties to render
printing.
PrintCreator: Tool is now multi-threaded to process images while preview and
printing.
ImageEditor : Add SendByMail and PrintCreator tools support.
Showfoto : Add SendByMail and PrintCreator tools support.
LightTable : Add SendByMail and PrintCreator tools support.
Panorama : Add Hugin 2017.0 support.
Geolocation : Add new tool to export GPS trace to KML file from geolocation
editor.
- Many bugs fixed
- Drop fix-build-cmake39.patch, now upstream
- Drop find_libastro-qt5.patch, 42.1 is no longer supported and
its Qt5 is too old anyway
- Drop unneeded exiv2 requirement, digikam uses libexiv2 only
- Add libkvkontakte-devel and libmediawiki-devel build requirements
(both have been released as KF5 versions meanwhile) to enable the
corresponding kipi plugins
- Build with opencv-devel instead of opencv-qt5-devel, the latter
doesn't exist any more

==== e2fsprogs ====
Subpackages: e2fsprogs-devel libcom_err-devel libcom_err2 libcom_err2-32bit
libext2fs-devel libext2fs2

- ignore errors for install-info calls in post scripts,
otherwise installing with "--excludedocs" fails

==== ecj ====

- Don't build against the java-bootstrap package; it is gone

==== elfutils ====
Subpackages: libasm1 libdw1 libelf1 libelf1-32bit

- Restore obsolete on libebl.
- Update package descriptions.
- Rename libebl1 to libebl-plugins as these are not linked,
but dlopened using their unversioned libebl_$ARCH.so name.
- Have libelf1 require libebl-plugins (libebl.a, which does the
dlopen call, is staticly built into libelf1). This is necessary
for pahole to display its results. [boo#1049871]

==== emacs ====
Subpackages: emacs-info emacs-nox emacs-x11 etags

- Add patch emacs-25.2-bsc1058425.patch to fix bsc#1058425
VUL-0: emacs: GNU Emacs 25.2 enriched text remote code execution

==== evolution-rss ====
Subpackages: evolution-plugin-rss evolution-plugin-rss-lang

- Drop the pre- SLE12 / Leap42 conditional for _evo_errordir.

==== exiv2 ====

- Add fix-crash.patch to prevent crashes in gwenview with certain
images (boo#1051782)
- Update source tarball to the fixed upstream re-release and remove
the workaround in the spec file
- Replace gcc-version-check.patch with the version committed
upstream

==== extra-cmake-modules ====
Version update (5.37.0 -> 5.38.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Fix python bindings compilation after
7af93dd23873d0b9cdbac192949e7e5114940aa6
* Forgot to add the test
* Fix the fix
* Fix build with older CMake versions.
* Revert "RFC: Make ECMAddTests respect BUILD_TESTING"
* Revert "doc: Add 'Since' note"
* Set CMAKE_*_OUTPUT_DIRECTORY to run tests without installing.
* Include a module for finding qml imports as runtime dependencies
* doc: Add 'Since' note
* RFC: Make ECMAddTests respect BUILD_TESTING

==== flatpak ====
Subpackages: flatpak-builder libflatpak0 typelib-1_0-Flatpak-1_0

- Drop the SLE12 / Leap42 conditional definition for _userunitdir.

==== flex ====
Subpackages: libfl-devel libfl2

- Fix RPM categories.

==== fluidsynth ====
Version update (1.1.6 -> 1.1.7)

- Update to version 1.1.7:
* consistently relicense libfluidsynth under LGPL-2.1+
* fluid_synth_set_channel_type() was not exported properly
* fix calculations for modulators
* fix SysEx parsing issues
* fix mangling with illegal sample loops, causing audible glitches
* fix inverse logic of audio.jack.multi option
* fix channel fine tune RPN to use correct range
* fix timing problems when changing the sequencers scale from a callback event
* workaround incorrectly rendered audio when requesting more than 64 frames
from fluid_synth_write_*()
* adjust ALSA MIDI port type
* avoid voice_count becoming negative
* avoid notes with a fixed key generator playing forever
* avoid TCP/IP connections from closing in an undefined manner
* a lot of memory leaks, NULL dereferences and SegFaults
* add support of vorbis-compressed sf3 sound fonts
* add sostenuto pedal to the synth
* add vbr quality when encoding with libsndfile
* re-implement routing reverb and chorus to distinct buffers in
fluid_synth_nwrite_float()
* add IPv6 support to socket API
- remove the following patches as they got fixed upstream:
* fluidsynth-fix-build-lash.diff
* jackmulti.diff
* reverb_mixer.diff

==== folks ====
Subpackages: folks-lang libfolks-data libfolks-eds25 libfolks-telepathy25
libfolks25

- Drop build support of deprecated libsocialweb backend.

==== frameworkintegration ====
Version update (5.37.0 -> 5.38.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Return high-resolution line edit clear icon
* Fix accepting dialogs with ctrl+return when buttons are renamed

==== gdb ====

- Disable guile extensions for new distros, the gdb support
is incompatible with guile 2.2.

==== gdm ====
Subpackages: gdm-lang gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Add gdm-check-for-Xwayland.patch: don't try wayland session if
Xwayland isn't installed on the system (bgo#787837).

==== geany-plugins ====
Version update (1.30 -> 1.31)
Subpackages: geany-plugins-lang

- Update to version 1.31:
+ General:
- New plugin: keyrecord (gh#geany/geany-plugins#460).
- Add a note to plugins which are currently orphaned and might
not receive further fixes (gh#geany/geany-plugins#540).
Affected plugins:
. Geanydoc.
. GeanyExtrasel.
. GeanyInsertNum.
. GeanyLua.
. GeanyPG.
. GeanyPrj.
. GeanyVC.
. PrettyPrinter.
. Scope.
. Shiftcolumn.
. Treebrowser.
+ Addons: Enable Mark Word also for newly opened documents
(gh#geany/geany-plugins#563).
+ Automark: Extend documentation (gh#geany/geany-plugins#582).
+ GeanyDoc: Make OK the default button in interactive mode
(gh#geany/geany-plugins#566).
+ GeanyExtrasel: Fix issues related to Scintilla Rectancle select
(gh#geany/geany-plugins#568).
+ GeanyLua, GeanyMacro, GeanyNumbersBookmarks: Pass a GdkKeymap
to gdk_keymap_* functions to prevent crashes on Windows and
critical warnings on other platforms
(gh#geany/geany-plugins#586).
+ GeniusPaste: Update configuration for shipped pastebins
(gh#geany/geany-plugins#551).
+ GitChangebar: Fix spurious line wrapping
(gh#geany/geany-plugins#564).
+ LineOperations: Add a feature to keep unique lines
(gh#geany/geany-plugins#560).
+ PrettyPrinter: Add missing README, COPYING, NEWS and AUTHORS
files (gh#geany/geany-plugins#580).
+ ProjectOrganizer: Fix a crash by ensuring project is open
before trying to expand the tree (gh#geany/geany-plugins#555,
gh#geany/geany-plugins#557, gh#geany/geany-plugins#559).
+ Scope: Correct a misleading error message
(gh#geany/geany-plugins#561).
+ Spellcheck:
- Stop processing if the document gets invalid to prevent
crashes while file gets closed during long check runs
(gh#geany/geany-plugins#547).
- Add style mappings for Rust and PHPSCRIPT.
+ Updatechecker: Remove deprecated soup call
(gh#geany/geany-plugins#541).
+ Updated translations.

==== glib2 ====
Subpackages: glib2-devel glib2-lang glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Avoid running fdupes across hardlink boundaries.
Replace some old RPM macros.
- Update RPM groups and package summaries.

==== glibmm2_4 ====
Version update (2.52.0 -> 2.52.1)
Subpackages: glibmm2_4-devel libgiomm-2_4-1 libglibmm-2_4-1

- Update to version 2.52.1:
+ Gio: TlsDatabase: Fix memory leak in a vfunc (bgo#783360).
+ Documentation: Update docs of get_*_name().

==== gnome-backgrounds ====
Version update (3.25.4 -> 3.26.2)
Subpackages: gnome-backgrounds-lang

- Update to version 3.26.2:
+ Include meson files in the tarball.
+ Make sure Signpost_of_the_Shadows.jpg gets installed.
- Drop fdupes BuildRequires and fdupes macro, no longer needed nor
serves any purpose.
- Update to version 3.26.1:
+ Fix build issue.
- Changes from version 3.26.0:
+ Updated translations.

==== gnome-bluetooth ====
Version update (3.26.0 -> 3.26.1)
Subpackages: gnome-bluetooth-lang libgnome-bluetooth13
typelib-1_0-GnomeBluetooth-1_0

- Update to version 3.26.1:
+ Fix installation of Bluetooth icons.
+ Fix Bluetooth icon names for bluetooth-sendto in various
translations.

==== gnome-documents ====
Version update (3.25.91 -> 3.26.0)
Subpackages: gnome-documents-lang gnome-documents_books-common
gnome-shell-search-provider-documents

- Update to version 3.26.0:
+ Updated translations.

==== gnome-session ====
Subpackages: gnome-session-core gnome-session-default-session gnome-session-lang

- Enable SLE-Classic session working on Wayland.
Add sle-classic.desktop in folder '{_datadir}/wayland-sessions/'
(bsc#1058797)

==== gnome-settings-daemon ====
Subpackages: gnome-settings-daemon-lang

- Rebase gnome-settings-daemon-more-power-button-actions.patch,
part of the patch have been merged upstream.
- Rebase gnome-settings-daemon-bring-back-updates-plugin.patch,
gnome-settings-daemon-initial-keyboard.patch and
gnome-settings-daemon-notify-idle-resumed.patch for SLE build.

==== gnome-shell ====
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar gnome-shell-lang

- Fix JS warning, define classes with 'var' instead of 'const'
(bgo#785084)
+ Update aboutMenu.js
+ Update gnome-shell-domain.patch
- Add gnome-shell-app-workaround-pkexec.patch: app: Work around
pkexec restriction when launching (bgo#763531).
- Add gnome-shell-dateMenu-fixes.patch: Fix gnome-weather and
notification icon (bgo#787423, bgo#766368).
- Add gnome-shell-fix-crash-hint-actor-NULL.patch: StEntry: fix
crash when hint actor is NULL (bgo#787580).
- Update sle-classic patches to version 3.26.0:
+ Update SLEClassicExt.js
+ Update gnome-shell-1007468-lock-screen-SUSE-logo-missing.patch
+ Update gnome-shell-disable-ibus-when-not-installed.patch
+ Update gnome-shell-domain.patch
+ Update gnome-shell-gdm-login-applet.patch
+ Update gs-fate318433-prevent-same-account-multi-logins.patch
+ Update gs-sle-classic-ext.patch

==== gom ====

- Split out python3-gom: the python/gi binding were wrongly
packaged as part of the -devel package.
- Run spec-cleaner: adds pkgconfig-BuildRequires.

==== gpg2 ====
Version update (2.2.0 -> 2.2.1)

- GnuPG 2.2.1:
* gpg: Fix formatting of the user id in batch mode key generation
if only "name-email" is given.
* gpgv: Fix annoying "not suitable for" warnings.
* wks: Convey only the newest user id to the provider. This is
the case if different names are used with the same addr-spec.
* wks: Create a complying user id for provider policy mailbox-only.
* wks: Add workaround for posteo.de.
* scd: Fix the use of large ECC keys with an OpenPGP card.
* dirmngr: Use system provided root certificates if no specific
HKP certificates are configured. If bu

==== gpm ====
Subpackages: libgpm2

- Update description and remove two unnecessary ldconfig calls.

==== grilo-plugins ====
Subpackages: grilo-plugin-tracker grilo-plugin-youtube grilo-plugins-lang

- Drop SLE12 / Leap42 build conditionals, enable lua and chroma
unconditionally.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Use /boot/<arch>/loader/linux to determine if install media
is SUSE instead of /contents file (bsc#1054453)
- Use the pvops-enabled default kernel if the traditional xen
pv kernel and initrd are not found (bsc#1054453)
- Fix reboot in UEFI environments (bsc#1047331)
* Add grub2-efi-Move-grub_reboot-into-kernel.patch
* Refresh grub2-efi-Free-malloc-regions-on-exit.patch

==== gstreamer-editing-services ====
Version update (1.12.2 -> 1.12.3)
Subpackages: libges-1_0-0 typelib-1_0-GES-1_0

- Update to version 1.12.3:
+ track_element: Always emit "control-binding-removed" signal.
+ Revert "timeline: Return FALSE when commiting an empty
timeline".
+ xml-formatter: Save encoder and muxer advanced settings.
+ Enhance some pad linking issue debug logging.
+ smartmixer: Give a unique name to each compositor instances.
+ pipeline: Allow up to 2 seconds queueing in the playsink video
queue.
+ asset:
- Add a function to stop proxying an asset.
- Clear loading error when reload is requested.
+ nlecomposition: Properly update segment->start/stop on commit.
+ timeline: Remove trackelements initating move from the moving
context.
+ xml-formatter: Serialize encoding profiles in reverse order.
+ pipeline: Make sure tracks are unlinked on NULL->NULL state
changes.

==== gtk4 ====

- Drop the SLE12 / Leap42 build_wayland_backend conditional, build
with wayland unconditionally.

==== gtkmm3 ====
Version update (3.22.1 -> 3.22.2)

- Update to version 3.22.2:
+ Gtk:
- Editable, RecentChooser, Scale: Fix memory leaks
(bgo#783360).
- PrintJob: Fix a call to Glib::throw_exception().
+ Documentation: Gdk::RGBA: Update ctor(ustring) docs from GTK+
(bgo#784483).

==== gvfs ====
Subpackages: gvfs-backend-afc gvfs-backend-samba gvfs-backends gvfs-fuse
gvfs-lang

- Rebase gvfs-nds.patch for gvfs 1.34.0, including identations and
warnings fixes.

==== hdf5 ====
Subpackages: libhdf5-100 libhdf5_hl100

- fix compiler flag substitution
- Add libsz2-devel to list of Requires for -devel packages, this
is required for compilation against hdf5 when szlib support is
enabled.
- Minor specfile cleanups using spec-cleaner.
- Enabled szlib support through libaec's szlib API

==== icu4j ====

- Added patches:
* icu4j-taglet.patch
+ implement com.sun.tools.doclets.Taglet interface instead of
the deprecated
com.sun.tools.doclets.internal.toolkit.taglets.Taglet
+ Fixes java.lang.ClassCastException with jdk9
* icu4j-jdk9.patch
+ Extend the jdk9 test, so that it accepts versions that start
with 9
+ Make source, target and encoding consistent all over the
build
- Specify source and target level 1.6 in order to allow building
with jdk9

==== jakarta-taglibs-standard ====

- Modified patch:
* jakarta-taglibs-standard-1.1.1-build.patch
+ Don't hardcode java source and target levels
- Specify source and target level 1.6 in order to allow building
with jdk9
- Clean spec file and fix some rpmlint errors

==== java-1_8_0-openjdk ====
Subpackages: java-1_8_0-openjdk-headless

- Make the requirements for mozilla-nss requires_ge instead of
requires_eq
- Don't require java-bootstrap-devel, build with the non-bootstrap
java.
- Added patch:
* zero-atomic_copy64.patch
- Fix wrong assembly for ppc and (maybe for) s390

==== k3b ====

- Ensure description is neutral.

==== kactivities-stats ====
Version update (5.37.0 -> 5.38.0)

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Refactor of the query which combines linked and used resources
* Switched debugging output off
* Reloading the model when the resource gets unlinked
* Fixed the query when merging linked and used resources

==== kactivities5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== karchive ====
Version update (5.37.0 -> 5.38.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Tag some more private classes with hidden visibility
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kauth ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kbookmarks ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kcmutils ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Add .arconfig
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kcodecs ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kcompletion ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kconfig ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Fix labels of DeleteFile/RenameFile actions
* kconfigini: Strip leading whitespace when reading entry values.
* KAuthorized: Fix API documentation for authorizeAction()

==== kconfigwidgets ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Deprecate KStandardAction::Help
* Deprecate KStandardAction::SaveOptions
* Improve KStandardAction apidox.
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Fix labels of DeleteFile/RenameFile actions (kde#382450)
* Fix doxygen comments
* Use "document-close" as icon for KStandardAction::close
* API dox: fix wrong usage of @see

==== kcoreaddons ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* DesktopFileParser: add fallback lookup in ":/kservicetypes5/*"
* Add support for uninstalled plugins in kcoreaddons_add_plugin
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* desktopfileparser: Fix non-compliant key/value parsing. (kde#310674)

==== kcrash ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kdbusaddons ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotests: prepare for CMAKE_RUNTIME_OUTPUT_DIRECTORY being set

==== kde-l10n ====
Subpackages: kde-l10n-cs kde-l10n-da kde-l10n-da-data kde-l10n-da-doc
kde-l10n-de kde-l10n-de-data kde-l10n-de-doc kde-l10n-el kde-l10n-en_GB
kde-l10n-en_GB-data kde-l10n-en_GB-doc kde-l10n-es kde-l10n-es-data
kde-l10n-es-doc kde-l10n-fr kde-l10n-fr-data kde-l10n-hu kde-l10n-it
kde-l10n-it-data kde-l10n-it-doc kde-l10n-ja kde-l10n-pl kde-l10n-pl-data
kde-l10n-pt kde-l10n-pt_BR kde-l10n-pt_BR-data kde-l10n-ru kde-l10n-ru-data
kde-l10n-zh_CN kde-l10n-zh_TW

- Remove kdesu manpage translations to avoid file conflicts
with kde-cli-tools >= 5.10.95

==== kdeclarative ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kded ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kded-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* support X-KDE-OnlyShowOnQtPlatforms

==== kdelibs4support ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Fix typo, sorry
* kstandarddirstest: Stabilize test on CI
* Fix a few CMake warnings

==== kdesignerplugin ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kdesu ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kdewebkit ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kdnssd-framework ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kdoctools ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kdoctools-devel libKF5DocTools5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* CMake: Fix target name shortening when build dir has special characters
(kde#377573)
* Add CC BY-SA 4.0 International and set it as default

==== kemoticons ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotests: fix running tests in parallel, by doing more specific cleanups

==== kernel-firmware ====
Version update (20170823 -> 20170906)
Subpackages: ucode-amd

- Update to version 20170906:
* Update Intel OPA hfi1 firmware
* amdgpu: update psp and acg_smu firmware for vega10
* rtlwifi: rtl8822be: Add firmware for new driver/device
* qcom: add firmware files for Adreno A3xx

==== kernel-source ====
Version update (4.13.1 -> 4.13.3)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.13.3 (bnc#1012628).
- Refresh
patches.suse/0001-x86-entry-64-Refactor-IRQ-stacks-and-make-them-NMI-s.patch.
- commit 76ecbd3
- Refresh
patches.suse/0001-objtool-Don-t-report-end-of-section-error-after-an-e.patch.
- Refresh
patches.suse/0002-x86-head-Remove-confusing-comment.patch.
- Refresh
patches.suse/0003-x86-head-Remove-unused-bad_address-code.patch.
- Refresh
patches.suse/0004-x86-head-Fix-head-ELF-function-annotations.patch.
- Refresh
patches.suse/0005-x86-boot-Annotate-verify_cpu-as-a-callable-function.patch.
- Refresh
patches.suse/0006-x86-xen-Fix-xen-head-ELF-annotations.patch.
- Refresh
patches.suse/0007-x86-xen-Add-unwind-hint-annotations.patch.
- Refresh
patches.suse/0008-x86-head-Add-unwind-hint-annotations.patch.
- Delete
patches.suse/0007-x86-xen-Add-unwind-hint-annotations-fix.patch.
Update to the submitted v2.
- commit 27de3c0
- drm/amdgpu: revert tile table update for oland (boo#1027378,
boo#1039806, bko#194761).
- Delete
patches.fixes/drm-amdgpu-revert-update-tile-table-for-oland-hainan.patch.
- commit 51745cf
- Linux 4.13.2 (bnc#1012628 bsc#1055826).
- Delete
patches.drivers/rt2800-fix-TX_PIN_CFG-setting-for-non-MT7620-chips.
- Delete
patches.fixes/Bluetooth-validate-output-buffer-length-for-config-r.patch.
- commit 96d9efa
- rpm/kernel-docs.spec.in: Fix a thinko for xmlto buildreq condition
- commit 0ef59d3
- Bluetooth: validate output buffer length for config requests
and responses (bnc#1057389 CVE-2017-1000251).
- commit c0b7e1f
- fix annotations of xen-head.S (bnc#1058115).
- commit d4c88a5
- rpm/kernel-docs.spec.in: make unpack scripts executable
- commit 1ba3766
- x86/head: Add unwind hint annotations (bnc#1058115).
- x86/xen: Add unwind hint annotations (bnc#1058115).
- x86/xen: Fix xen head ELF annotations (bnc#1058115).
- x86/boot: Annotate verify_cpu() as a callable function
(bnc#1058115).
- x86/head: Fix head ELF function annotations (bnc#1058115).
- x86/head: Remove unused 'bad_address' code (bnc#1058115).
- x86/head: Remove confusing comment (bnc#1058115).
- objtool: Don't report end of section error after an empty
unwind hint (bnc#1058115).
- commit 53af152
- objtool: Assume unannotated UD2 instructions are dead ends
(bnc#1058115).
- objtool: Fix gcov check for older versions of GCC (bnc#1058115).
- objtool: Fix objtool fallthrough detection with function padding
(bnc#1058115).
- objtool: Fix validate_branch() return codes (bnc#1058115).
- objtool: Handle GCC stack pointer adjustment bug (bnc#1058115).
- x86/asm: Add ASM_UNREACHABLE (bnc#1058115).
- x86/asm: Fix UNWIND_HINT_REGS macro for older binutils
(bnc#1058115).
- x86/asm: Make objtool unreachable macros independent from GCC
version (bnc#1058115).
- objtool: Skip unreachable warnings for 'alt' instructions
(bnc#1058115).
- objtool: Track DRAP separately from callee-saved registers
(bnc#1058115).
- Refresh patches.suse/0001-x86-unwind-Add-the-ORC-unwinder.patch.
Take all ORC upstream patches. This will go to stable & SLE15 too.
- commit 831ca01
- Refresh
patches.suse/0001-x86-entry-64-Refactor-IRQ-stacks-and-make-them-NMI-s.patch.
- Refresh patches.suse/0001-x86-unwind-Add-the-ORC-unwinder.patch.
- Refresh
patches.suse/0002-x86-entry-64-Initialize-the-top-of-the-IRQ-stack-bef.patch.
- Refresh
patches.suse/0002-x86-kconfig-Make-it-easier-to-switch-to-the-new-ORC-.patch.
- Refresh
patches.suse/0003-x86-dumpstack-Fix-occasionally-missing-registers.patch.
- Refresh
patches.suse/0003-x86-kconfig-Consolidate-unwinders-into-multiple-choi.patch.
- Refresh
patches.suse/0004-x86-dumpstack-Fix-interrupt-and-exception-stack-boun.patch.
- Refresh
patches.suse/0005-objtool-Add-ORC-unwind-table-generation.patch.
- Refresh
patches.suse/0006-objtool-x86-Add-facility-for-asm-code-to-provide-unw.patch.
- Refresh
patches.suse/0007-x86-entry-64-Add-unwind-hint-annotations.patch.
- Refresh
patches.suse/0008-x86-asm-Add-unwind-hint-annotations-to-sync_core.patch.
- Delete
patches.suse/0001-linkage-new-macros-for-assembler-symbols.patch.
- Delete
patches.suse/0003-DWARF-EH-frame-based-stack-unwinding.patch.
- Delete patches.suse/stack-unwind-disable-kasan.patch.
Update upstream status of ORC and drop already-disabled DWARF unwinder.
- commit 2e9b944
- rpm/constraints.in: build ARM on at least 2 cpus
- commit b7edeaf
- rpm/constraints.in: increase memory for kernel-syzkaller
And see if it helps. If so, push it to packaging...
- commit 7193e65

==== kfilemetadata5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kfilemetadata5-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* in automatic tests, find python interpreter and use it for python test
scripts

==== kglobalaccel ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Revert upstream commit to avoid major regressions (kde#384597):
* 0001-Revert-KGlobalAccel-port-to-KKeyServer-s-new-method-.patch
- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* KGlobalAccel: port to KKeyServer's new method symXModXToKeyQt, to fix
numpad keys (kde#183458)

==== kguiaddons ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Tag another private class with hidden visibility

==== khtml ====
Version update (5.37.0 -> 5.38.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== ki18n ====
Version update (5.37.0 -> 5.38.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotests: fix when fr_FR is installed. semanticTags() needs English.

==== kiconthemes ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kidletime ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Qt5DBus is only required with HAVE_XSCREENSAVER

==== kimageformats ====
Version update (5.37.0 -> 5.38.0)

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kinit ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kinit-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* klauncher: fix appId matching for flatpak apps
* Drop KLAUNCHER_VERBOSE_OUTPUT ifdefs

==== kio ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kio-core kio-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Too many changes to list here
- Dropped patches, now upstream:
* fix-applying-special-file-attributes.patch
* KDesktopPropsPlugin-create-destination-dir.patch
* Really-rate-limit-INF_PROCESSED_SIZE-messages.patch

==== kitemmodels ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kitemviews ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kjobwidgets ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Initialize the "Pause" button state in the widget tracker

==== kjs ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kjsembed ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kmediaplayer ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== knewstuff ====
Version update (5.37.0 -> 5.38.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuffCore5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* kmoretoolstest2 doesn't seem interactive, make it run as autotest
* Adapt KMoreTools unittests so they can run without "make install".

==== knotifications ====
Version update (5.37.0 -> 5.38.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Don't block starting notification service (kde#382444)
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== knotifyconfig ====
Version update (5.37.0 -> 5.38.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== korganizer ====

- Require kdepim-runtime, korganizer is pretty useless without the
ical resources

==== kpackage ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kpackage-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* refactor kpackagetool away from stringy options
* autotests: fix running tests in parallel
* kpackagetool: fix memory leak detected by LeakSanitizer

==== kparts ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Unhide ReadOnlyPart::doOpenStream & Co to doxygen skipping private methods
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kpeople5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kpeople5-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotest: use QTRY_COMPARE to make the test more robust

==== kplotting ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kpty ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kross ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kross-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Use the application domain when doing i18n of actions

==== krunner ====
Version update (5.37.0 -> 5.38.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Clear previous actions on update
* Use QUrls from match to create mimeData in base implementation
* Add remote runners over DBus

==== kservice ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kservice-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* autotests: fix running tests in parallel

==== ktexteditor ====
Version update (5.37.0 -> 5.38.0)
Subpackages: ktexteditor-devel

- Add 0001-Disable-KAuth-integration.patch
* Streamlined way to disable KAuth support from ktexteditor
- Remove patches, folded into the above:
* 0001-Revert-KAuth-integration-in-document-saving-vol.-2.patch
* 0002-Revert-KAuth-integration-in-document-saving.patch
- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Port Document/View scripting API to QJSValue-based solution
* Show icons in icon border context menu
* Use config.h more
* Fix compilation on windows with editorconfig-c-core available
* Replace KStandardAction::PasteText with KStandardAction::Paste
* Support fractional scaling in generating the sidebar preview
* Fix build with QT_NO_ACCESSIBILITY
* Switch from QtScript to QtQml

==== ktextwidgets ====
Version update (5.37.0 -> 5.38.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== kunitconversion ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== kwallet ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Don't use find_file for finding files in our own source dir

==== kwayland ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kwayland-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Treat input RGB buffers as premultiplied
* Update SurfaceInterface outputs when an output global gets destroyed
* KWayland::Client::Surface track output destruction
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Avoid sending data offers from an invalid source. (kde#383054)

==== kwidgetsaddons ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* simplify setContents by letting Qt do more of the work
* KSqueezedTextLabel: Add isSqueezed() for convenience
* KSqueezedTextLabel: Small improvements to API docs
* [KPasswordLineEdit] Set focus proxy to line edit (kde#383653)
* [KPasswordDialog] Reset geometry property
* Tag some more private classes with hidden visibility
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
- Dropped patches, now upstream:
* 0001-KPasswordDialog-Reset-geometry-property.patch
* 0001-KPasswordLineEdit-Set-focus-proxy-to-line-edit.patch

==== kwindowsystem ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Restore behaviour of KKeyServer::symXToKeyQt
* KKeyServer: fix handling of KeypadModifier.

==== kxmlgui ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Save up a bunch of stat() calls on application start
* Fix KHelpMenu position on Wayland
* Remove checks for Qt < 5.6, now that even 5.7 is required.
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN
* Drop broken mid-button click handling (kde#383162)
* KUndoActions: use actionCollection to set the shortcut
* autotest: output filename on error

==== kxmlrpcclient5 ====
Version update (5.37.0 -> 5.38.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== libKF5ModemManagerQt ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== libfm-extra ====
Version update (1.2.3 -> 1.2.5)

- new upstream version 1.2.5
* Fixed 'Launch in Terminal' issue when custom args were ignored.
* Fixed crash with non-UTF regex search pattern.
* Added 'termite' into the terminals database.
* Fixed possible crash on FmPlacesView.
* Fixed crash on non-existent directory listing job.
* Added conversion of all URIs schemes to file:/// by mapping them
to FUSE-mounted local paths if that is possible. This is required
for non-gio applications to open files mounted by gvfs.
* Added new MIME type for rar files to the archivers.list file.
* Fixed crash in _fm_template_update().
* Fixed incorrect initialization of FmPlacesViewClass, it should
not call fm_get_home_dir() but initialized with NULL, that will do
the same at runtime.
* Fixed FTBFS when libmenu-cache was installed to non-standard
location.
* Added check for edit name "/" for remote root directory so
display name should be used in such cases as more sensible one.
* Fixed wrong width requested by FmCellRendererText (1.2.4
regression).
* Updated list of MIME types handled by xarchiver.
* Don't show error message when attempting to rename file into the
same.
* Fixed crash after file info job finished on a folder that already
left.
* Changed limitations on libfm-pref-apps.desktop to show only in
LXDE.
* Fixed incomplete file copy job pausing in some cases.
* Fixed missing 'Empty Trash Can' option in desktop's trash context
menu.
Changes on 1.2.4 since 1.2.3:
* Fixed crash in templates on file that was deleted instantly after
creation.
* Fixed handling %c in desktop entry Exec key: launch may fail if
the application name contains spaces so it needs quoting.
* Fixed missing folder info update on folder attributes change.
* Use G_SPAWN_DO_NOT_REAP_CHILD on application launch, that should
fix a problem with pkexec.
* Corrected missing newline at end of generated shortcut desktop
entry.
* Improved file type detection, it failed in some cases such as
DOCX.
* Returned back the workaround on thumbnailers which don't save any
of Thumb::MTime or Thumb::URI in the thumbnail.
* Fixed wrong treating files like ".purple" as having extension
"purple".
* Fixed invalid desktop entry save if 'Cancel' was pressed in the
file
properties dialog window.
* Fixed issues on dropping folders into Places for bookmarking them.
* Fixed crash in expand_exec_macros() on missing Exec line.
* Rewritten broken rubberband rendering in icon view for GTK3.
* Eliminated usage of GVolumeMonitor if no FmFolder object was
created.
* Fixed renaming of desktop entries on copy operation error: it was
the file name which was set in renaming dialog but it was
compared with display name instead when decided whether "Rename"
button should be active or not.
* Fixed dropping files onto applications shortcuts on the desktop:
those should be not "inode/x-shortcut" but
"application/x-desktop" instead and therefore handled as any other
applications, i.e. allow drop.
* Added 'urxvtc' into the terminals database.
* Fixed adding user-defined MIME associations into mimeapps.list
config.
* Few UI adaptations to work with GTK+ 3.10 or newer.
* Fixed creating shortcuts on paths with basename started with '?'.
* Fixed pointer-related issues with GTK+ 3.10 or newer.
* Added 'terminology' into the terminals database.
* Fixed stuck tooltip on entering empty folder.
* Fixed crash on cancelling FmDirListJob while retrieving is in
progress.
* Fixed incomplete cleanup on folder reloading.
* Corrected autoscrolling to position in view to not include extra
space (so not show all the column/row at once but only fully show
exactly the item). This may fix a problem with double-click at the
end of the file name which is already visible so no scrolling is
needed, but if another file in the column/row has longer name then
it could bring a scrolling of the column/row, and second click
lands out of item area.
* Fixed timer shown in progress dialog, it should show 01:00, not
00:60.
* Fixed stuck tooltip after right-click on file in view, seen
rarely.
* Disabled following symlinked directories on recursive search,
that may give undesired results duplicating files and in some rare
cases even may lead to endless recursion and endless number of
files found.
* Fixed few small issues with icon view interactive search:
+ search should be not activated by space key;
+ cursor was missing in the entry.
* Fixed the background of the name of selected file with GTK+ 3.0.
* Fixed not-ignored invalid Path= line on launch a desktop entry.
* Fixed testing URIs like http://some.host.com for MIME type.
* Dropped using shortcuts to URIs like http://host/ as directories,
no directory should be in principle used in shortcuts.
* Fixed possible data loss on cross-partition data movement.
* Fixed incorrect data in the search dialog date selection window.
- Removed all the previously added patches from Git, they are all
now included upstream:
* [SF#902] Handle NULL returned by fm_mime_type_from_native_file()
correctly
+ libfm-1.2.3-Fix-SF902.patch
+ libfm-Additional-fix-after-SF902.patch
* [SF#922] Fix handling %c in desktop entry Exec key
+ libfm-1.2.3-Fix-SF922.patch
* [SF#914] Fix missing folder info update on folder attributes
+ libfm-1.2.3-Fix-SF914.patch
* Use G_SPAWN_DO_NOT_REAP_CHILD on application launch, that should
fix a problem with pkexec
+ libfm-1.2.3-Use-G_SPAWN_DO_NOT_REAP_CHILD-on-applicaton-launch.patch
* [SF#946] Add missing newline at end of generated shortcut
+ libfm-1.2.3-Fix-SF946.patch
* [SF#925,938] Improve file type detection, it fails in some cases
such as DOCX
+ libfm-1.2.3-Fix-SF925-and-SF938.patch
* Return back the workaround on thumbnailers which don't save
Thumb::MTime
+ libfm-1.2.3-Return-back-the-workaround-on-thumbnailers.patch
* [SF#937] Fix wrong treating files like ".purple" as having
extension "purple"
+ libfm-1.2.3-Fix-SF937.patch
* [SF#935] Fix invalid desktop entry save if 'Cancel' was pressed
in dialog
+ libfm-1.2.3-Fix-SF935.patch
* [SF#915] Always do gtk_drag_finish() in FmDndDest even if drop
was failed
+ libfm-1.2.3-Fix-SF915.patch
* FmDndDest: reset cached data if drag context was changed
+ libfm-1.2.3-Reset-cached-data-if-drag-context-was-changed.patch
* Fix uninitialized data in drag-motion callback of FmPlacesView
+ libfm-1.2.3-Fix-uninitialized-data-in-drag-motion-callback.patch
* [SF#953] Fix crash in expand_exec_macros() on missing Exec line
in desktop entry
+ libfm-1.2.3-Fix-SF953.patch
* [SF#921] Rewrite broken rubberband rendering in icon view for
GTK3
+ libfm-1.2.3-Fix-SF921.patch
* [SF#932] Fix renaming of desktop entries on copy operation error
+ libfm-1.2.3-Fix-SF932.patch
* Fix dropping files onto applications shortcuts on the desktop
+ libfm-1.2.3-Fix-dropping-files-onto-applications.patch
* Fix desktop file name for urxvt in terminals.list
+ libfm-1.2.3-Fix-desktop-file-name-for-urxvt.patch
* [SF#954] Add urxvtc data into the terminals.list file
+ libfm-1.2.3-Fix-SF954.patch
* [SF#950] Fix adding user-defined MIME associations into
mimeapps.list config
+ libfm-1.2.3-Fix-SF950.patch
* [SF#959] Fix autoscroll issues with GTK+ 3
+ libfm-1.2.3-Fix-SF959.patch
* [SF#965] Fix stuck tooltip on entering empty folder
+ libfm-1.2.3-Fix-SF965.patch
* Fix crash on cancelling FmDirListJob while retrieving is in
progress
+ libfm-1.2.3-Fix-crash-on-cancelling-FmDirListJob.patch
* [SF#919] Fix incomplete cleanup on folder reloading
+ libfm-1.2.3-Fix-SF919.patch
* [SF#967] Fix timer shown in progress dialog, it should show
01:00, not 00:60
+ libfm-1.2.3-Fix-SF967.patch

==== libfreehand ====
Version update (0.1.1 -> 0.1.2)

- Version update to 0.1.2:
* Fix several hangs and leaks when reading damaged files found with the
help of american-fuzzy-lop.
* Fix build with recent clang.
* Make --help output of all command-line tools more help2man-friendly.
* Require C++11 for build.
* Parse more features:
* text on path
* more text attributes
* stroke patterns
* arrows
* paragraph attributes
* custom line and fill styles
* text effects
* Write correct rotation center of a textbox.
* Fix an issue found by oss-fuzz.
* Fix several issues found by Coverity.
* Various code cleanups and other small improvements.

==== libgda ====
Subpackages: libgda-5_0-4 libgda-5_0-4-lang libgda-5_0-bdb libgda-5_0-sqlite
libgda-ui-5_0-4 libgda-ui-5_0-plugins

- Fix build with JRE 9:
+ Add libgda-jre9.patch: detect JRE 9's version string.
- Do not run fdupes across default partition boundaries.
- Run spec-cleaner.
- Add libgda-utf.patch: Do not use UTF-8 chars in headers parsed
by glib-mkenums. In the build root, this fails otherwise.

==== libinput ====
Version update (1.8.1 -> 1.8.2)
Subpackages: libinput-udev libinput10

- Update to new bugfix release 1.8.2
* Change in experience is that 2-slot touchpads (e.g. most
Lenovos before kernel 4.12) do not support 3fg pinch anymore
- instead we assume swipe for three fingers, which makes
gestures a lot more reliable (3-finger swipe is much more
common than 3-finger pinch anyway).

==== libpcap ====
Subpackages: libpcap1 libpcap1-32bit

- Added a patch (disable-remote.diff) to fix applications to FTBFS
if they define HAVE_REMOTE (deb#843384). Patch taken from Debian.

==== libqt4 ====
Subpackages: libqt4-32bit libqt4-qt3support libqt4-qt3support-32bit libqt4-sql
libqt4-sql-32bit libqt4-sql-sqlite libqt4-sql-sqlite-32bit libqt4-x11
libqt4-x11-32bit

- BuildRequire libnsl-devel on current TW and CODE15 targets. The
library has been deprecated in glibc and is now in an own
package.
- Add fix-medium-font.diff (taken from ubuntu) to fix bolder font
in Qt4 apps (boo#956357)
- Force building against openSSL 1.0 (boo#1042657)
- Do not build the MySQL plugin on TW, it would cause an openSSL
version conflict
- Adjust fix-build-icu59.patch to also work if built with c++11
support

==== libqt5-qtbase ====
Subpackages: libQt5Concurrent-devel libQt5Concurrent5 libQt5Core-devel
libQt5Core-private-headers-devel libQt5Core5 libQt5DBus-devel libQt5DBus5
libQt5Gui-devel libQt5Gui-private-headers-devel libQt5Gui5 libQt5Network-devel
libQt5Network5 libQt5OpenGL-devel libQt5OpenGL5 libQt5PlatformHeaders-devel
libQt5PrintSupport-devel libQt5PrintSupport5 libQt5Sql-devel libQt5Sql5
libQt5Sql5-mysql libQt5Sql5-postgresql libQt5Sql5-sqlite libQt5Sql5-unixODBC
libQt5Test-devel libQt5Test5 libQt5Widgets-devel libQt5Widgets5 libQt5Xml-devel
libQt5Xml5 libqt5-qtbase-common-devel libqt5-qtbase-devel
libqt5-qtbase-platformtheme-gtk3

- Add patch to fix crash with XLIB_SKIP_ARGB_VISUALS set:
* qglxconvenience-avoid-null-pointer-deref.patch (boo#1057971, kde#384540)
- Add 0001-Fix-Qt5DBusMacros.cmake-for-CMake-3.9.patch.
Fixes a race condition when building KMail due to the DBus
interface files being used in several places.

==== libraw ====
Version update (0.18.2 -> 0.18.4)
Subpackages: libraw-devel libraw16

- updated to 0.18.4:
* Fix for possible heap overrun in Canon makernotes parser
(CVE-2017-14348)
* Fix for CVE-2017-13735
* CVE-2017-14265: Additional check for X-Trans CFA pattern data
- add libraw-out-of-bounds-kodak.patch, upstream bug #101
- remove libraw-CVE-2017-6887,6886.patch and
libraw-CVE-2017-6890,6899.patch:
no need to patch dcraw.c, it is not used

==== libsolv ====
Version update (0.6.28 -> 0.6.29)
Subpackages: libsolv-devel libsolv-tools perl-solv python-solv

- expose solver_get_recommendations in bindings
- fix bug in solver_prune_to_highest_prio_per_name resulting in
bad solver_get_recommendations output
- support 'without' and 'unless' dependencies
- fix yumobs rule generation bug
- Use same heuristic as upstream to determine src rpms
- bump version to 0.6.29

==== libvirt ====
Version update (3.6.0 -> 3.7.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-storage-core libvirt-daemon-driver-storage-disk
libvirt-daemon-driver-storage-iscsi libvirt-daemon-driver-storage-logical
libvirt-daemon-driver-storage-mpath libvirt-daemon-driver-storage-rbd
libvirt-daemon-driver-storage-scsi libvirt-daemon-driver-uml
libvirt-daemon-driver-vbox libvirt-daemon-lxc libvirt-daemon-qemu
libvirt-daemon-xen libvirt-libs

- cpu: Add new EPYC CPU model
92bd87a2-ryzen-test-data.patch, 5c83b360-epyc-test-data.patch,
a0b62843-epyc-cpu-model.patch
bsc#1052825
- Update to libvirt 3.7.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
8982f3ab-util-hash-header.patch,
0b1ecf7b-virHashCodeGen-mockable.patch,
f536b0dd-tests-arch-independent-hash.patch,
e4cb8500-avoid-malicious-ssh-hostname-as-args.patch
- Support OVMF 4MB firmware images
Adjustment to spec file and suse-ovmf-paths.patch
- supportconfig plugin: list active networks, interfaces and
storage pools

==== libwpd ====
Version update (0.10.1 -> 0.10.2)
Subpackages: libwpd-0_10-10 libwpd-devel

- Upgrade to 0.10.2 bsc#1058025 CVE-2017-14226:
* Require C++11 for build.
* Fix various crashes, leaks and hangs when reading damaged files found
by oss-fuzz.

==== libwpg ====
Version update (0.3.1 -> 0.3.2)
Subpackages: libwpg-0_3-3 libwpg-devel

- Remove requires that are not needed on the devel pkg
- Version bump to 0.3.2:
* Require C++11 for build.
* Fix a couple of issues found by oss-fuzz.
* Improve performance of reading image data from WPG2 files.
* Various minor code cleanups.

==== libzip ====
Subpackages: libzip-devel libzip5

- reverted version update to 1.3.0 due failing i586 tests
- remove libzip-disable-failing-tests.patch again
- add libzip-CVE-2017-12858.patch again
- add libzip-CVE-2017-14107.patch [bsc#1056996]
- update to version 1.3.0:
* Support bzip2 compressed zip archives
* Improve file progress callback code
* Fix zip_fdopen()
* CVE-2017-12858: Fix double free().
* CVE-2017-14107: Improve EOCD64 parsing.
- remove upstreamed libzip-CVE-2017-12858.patch
- added libzip-disable-failing-tests.patch [bsc#1056996#c12]

==== libzypp ====
Version update (16.15.6 -> 16.17.0)

- Support multiple product licenses in repomd (FATE#322276)
- version 16.17.0 (0)
- Propagate 'rpm --import' errors (bsc#1057188)
- Fix typos in zypp.conf
- version 16.16.0 (0)

==== make ====
Subpackages: make-lang

- Print out testsuite results after failure

==== man-pages ====
Version update (4.12 -> 4.13)

- update to 4.13:
see Changes for upstream change log

==== mpfr ====
Version update (3.1.5 -> 3.1.6)
Subpackages: libmpfr4 mpfr-devel

- Update to mpfr 3.1.6 release
* Includes mpfr-3.1.5-p9.patch

==== mutt ====
Version update (1.8.3 -> 1.9.0)
Subpackages: mutt-doc mutt-lang

- Update to neomutt 20170912 which updates to mutt 1.9.0
NeoMutt
Add guix build support
Only match real mailboxes when looking for new mail
Fix the printing of ncurses version in -v output
Bind editor <delete> to delete-char
Fix overflowing colours
Fix empty In-Reply-To generation
Trim trailing slash from completed dirs
Add guix-neomutt.scm
Fix setting custom query_type in notmuch query
Better curses identification
Use the system's wchar_t support
Use the system's md5 tool (or equivalent)
Clean up configure.ac
Teach gen-map-doc about the new opcode header
Rename functions (snake_case)
Rename constants/defines (UPPER_CASE)
Create library of shared functions
Much tidying
Rename globals to match user config
Drop unnecessary functions/macros
Use a standard list implementation
Coverity fixes
Use explicit NUL for string terminators
Drop OPS* in favour of opcodes.h
Upstream
Fix menu color calls to occur before positioning the cursor
When guessing an attachment type, don't allow text/plain if there is a null
character
Add $imap_poll_timeout to allow mailbox polling to time out
Handle error if REGCOMP in pager fails when resizing
Change recvattach to allow nested encryption
Fix attachment check_traditional and extract_keys operations
Add edit-content-type helper and warning for decrypted attachments
Add option to run command to query attachment mime type
Add warning about using inline pgp with format=flowed
- Rename patch mutt-1.8.3.dif which becomes now mutt-1.9.0.dif
- Modify the patches
* aw.listreply.diff
* bsc907453-CVE-2014-9116-jessie.patch
* bug-676388-largefile.patch
* mutt-1.5.15-wrapcolumn.diff
* mutt-1.5.20-sendgroupreplyto.diff
* mutt-1.5.21-mailcap.diff
* mutt-1.5.23-carriage-return.path
* mutt-1.5.9i-pgpewrap.diff
* mutt-1.6.1-opennfs.dif
* patch-1.5.24.vk.pgp_verbose_mime
* widechar.sidebar.dif
- Switch to hunspell as default spell-checking software wrt
fate#323578
- Write SUSE in the skel.muttrc instead of SuSE
- Use the right folder for unpacking instead of symlink
* fixes quilt setup

==== mutter ====
Subpackages: libmutter-1-0 mutter-data mutter-lang

- Add mutter-wayland-fixes.patch: Three bugfix commits from
upstream for wayland (bgo#787570, bgo#787568).
- Add mutter-monitor-refresh-rate.patch: Fix refresh rate for some
users (bgo#787668).
- Add mutter-fix-kinetic-scrolling.patch: Fix kinetic scrolling.
- Drop SLE12 / Leap42 conditionals and build with wayland
unconditionally.

==== ncurses ====
Subpackages: libncurses6 libncurses6-32bit ncurses-devel ncurses-utils tack
terminfo terminfo-base

- Add ncurses patch +20170916
+ minor fix to test/filter.c to avoid clearing the command in one case.
+ modify filter() to discard clr_eos if back_color_erase is set.
- Do not remove ticw.pc as well as tinfow.pc for wide character
ncurses ABI 6 (boo#1056171)
- Add ncurses patch 20170827
+ fix a bug in repeat_char logic (cf: 20170729, report by Chris Clayton).
- Add ncurses patch 20170902
+ amend change for endwin-state for better consistency with the older
logic (report/patch by Jeb Rosen, cf: 20170722).
+ modify check in fmt_entry() to handle a cancelled reset string
(Debian #873746). Make similar fixes in other parts of dump_entry.c
and tput.c
- Add ncurses patch 20170909
+ improve wide-character implementation of myADDNSTR() in frm_driver.c,
which was inconsistent with the normal implementation.
+ save/restore cursor position in Undo_Justification(), matching
behavior of Buffer_To_Window() (report by Leon Winter).
+ modify test/knight to provide the "slow" solution for small screens
using "R", noting that Warnsdorf's method is easily done with "a".
+ modify several test-programs which call use_default_colors() to
consistently do this only if "-d" option is given.
+ additional changes to test with non-standard variants of curses:
+ modify a loop limit in firework.c to work around absense of limit
checks in some libraries.
+ fill the last row of a window with "?" in firstlast if waddch does
not return ERR on the lower-right corner.
+ add checks in test/configure for some functions not in 4.3BSD curses.
+ fix a regression in test/configure (cf: 20170826).
- Split off terminfo-iterm to avoid conflict with package libiterm1
- Add ncurses patch 20170826
+ fixes for "iterm2" (report by Leonardo Brondani Schenkel) -TD
+ corrected a warning from tic about keys which are the same, to skip
over missing/cancelled values.
+ add check in tic for unnecessary use of "2" to denote a shifted
special key.
+ improve checks in trim_sgr0, comp_parse.c and parse_entry.c, for
cancelled string capabilities.
+ add check in _nc_parse_entry() for invalid entry name, setting the
name to "invalid" to avoid problems storing entries.
+ add/improve checks in tic's parser to address invalid input
+ add a check in comp_scan.c to handle the special case where a
nontext file ending with a NUL rather than newline is given to tic
as input (Redhat #1484274).
+ allow for cancelled capabilities in _nc_save_str (Redhat #1484276).
+ add validity checks for "use=" target in _nc_parse_entry (Redhat
[#1484284]).
+ check for invalid strings in postprocess_termcap (Redhat #1484285)
+ reset secondary pointers on EOF in next_char() (Redhat #1484287).
+ guard _nc_safe_strcpy() and _nc_safe_strcat() against calls using
cancelled strings (Redhat #1484291).
+ correct typo in curs_memleaks.3x (Sven Joachim).
+ improve test/configure checks for some curses variants not based on
X/Open Curses.
+ add options for test/configure to disable checks for form, menu and
panel libraries.
- Add ncurses patch 20170819
+ update "iterm" entry -TD
+ add "iterm2" entry (report by Leonardo Brondani Schenkel) -TD
+ regenerate llib-* files.
+ regenerate HTML manpages.
+ improve picsmap test-program:
+ reduce memory used for tsearch
+ add report in log file showing cumulative color coverage.
+ add -x option to clear/tput to make the E3 extension optional
(cf: 20130622).
+ add options -T and -V to clear command for compatibility with tput.
+ add usage message to clear command (Debian #371855).
+ improve usage messages for tset and tput.
+ minor fixes to "RDGB" extension and reset_color_pairs().
- Add ncurses patch 20170812
+ improve description of -R option in infocmp manual page (report by
Stephane Chazelas).
+ add reset_color_pairs() function.
+ add user_caps.5 manual page to document the terminfo extensions used
by ncurses.
+ improve build scripts, using SIGQUIT vs SIGTRAP; add other configure
script fixes from work on xterm, lynx and tack.
+ modify install-rule for ncurses-examples to put the data files in
/usr/share/ncurses-examples
+ improve tracemunch, by changing address-parameters of add_wch(),
color_content() and pair_content() to dummy parameters.
+ minor optimization to _nc_change_pair, to return quickly when the
current screen is marked for clearing.
+ in-progress changes to improve performance of test/picsmap.c for
loading image files.
+ modify allocation for SCREEN's color-pair table to start small, grow
on demand up to the existing limit.
+ add "RGB" extension capability for direct-color support, use this to
improve color_content().
+ improve picsmap test-program:
+ if no palette file is needed, attempt to load one based on $TERM,
checking first in the current directory, then by adding ".dat"
suffix, and finally in the data-directory, e.g.,
/usr/share/ncurses-examples
+ add "-l" option for logging
+ add "-d" option for debugging
+ add "-s" option for stepping automatically through list of images,
with time delay.
+ use tsearch to improve time for loading color table for images.
+ update config.guess, config.sub from
http://git.savannah.gnu.org/cgit/config.git

==== netcdf ====
Version update (4.4.1 -> 4.4.1.1)

- Update to version 4.4.1.1:
- Fixed an issue where ncgen would potentially crash or write
incorrect netCDF4 binary data under very specific
circumstances [gh#Unidata/netcdf-c#323].
- Updated documentation related to netCDF variable names and
DAP2 access to reflect the undefined behavior potentially
observed when DAP2 reserved keywords are used as netCDF
variable names.
- Fixed an issue with nc_inq_type() not returning proper value
in some circumstances [gh#Unidata/netcdf-c#317].
- Corrected an issue related to test failures when
- -disable-utilities or -DENABLE_UTILITIES=OFF are specified
when building with autotools or cmake, respectively
[gh#Unidata/netcdf-c#313].
- Corrected a behavioral issue with the _NCProperties attribute
taking up too much space [gh#Unidata/netcdf-c#300],
[gh#Unidata/netcdf-c#301].
- Corrected behavior for nc-config so that, if nf-config is
found in system, the proper fortran-related information will
be conveyed [gh#Unidata/netcdf-c#296].
- Add netcdf-disable-szip-linking.patch: Disable building with
szip support for now, since test nc_test4/tst_interops5.c fails
otherwise; this is likely to be fixed with version 4.5.0 of
netcdf, but requires big enough changes that we don't backport
it here. Necessitates BuildRequires on libtool and running
autoreconf before configure.

==== obs-service-set_version ====

- Avoid half-converting Debian native pkgs to non-native pkgs
- Simplify the pip version handling
- travis: Do not use "--use-mirrors" when using pip
- travis: Test python 3.6

==== openjpeg2 ====

- Add security fixes:
openjpeg2-CVE-2016-10504.patch (CVE-2016-10504, bsc#1056351),
openjpeg2-CVE-2016-10505.patch (CVE-2016-10505, bsc#1056363),
openjpeg2-CVE-2016-10506.patch (CVE-2016-10506, bsc#1056396),
openjpeg2-CVE-2017-12982.patch (CVE-2017-12982, bsc#1054696),
openjpeg2-CVE-2017-14039.patch (CVE-2017-14039, CVE-2017-14164,
bsc#1056622, bsc#1057511),
openjpeg2-CVE-2017-14040.patch (CVE-2017-14040, bsc#1056621),
openjpeg2-CVE-2017-14041.patch (CVE-2017-14041, bsc#1056562),
openjpeg2-CVE-2017-14151.patch (CVE-2017-14151, bsc#1057336),
openjpeg2-CVE-2017-14152.patch (CVE-2017-14152, bsc#1057335),
most of which are critical, including heap and stack overwrites,
over-reads and division by zero errors.

==== openmpi ====
Subpackages: openmpi-config openmpi-devel openmpi-libs

- Remove --enable-mpi-thread-multiple configure option as it
silently disabled Infiniband support. (bsc#1058811, boo#1058750)
- Reenable fortan08 bindings as gcc >= 5 is now the default

==== openucx ====
Version update (1.3+git44 -> 1.2.1)
Subpackages: libucm0 libucp0 libucs0 libuct0

- Rediff openucx-s390x-support.patch as p1 to be in line with
potential git-generated patches.
- Switch to version 1.2.1 (Fate#324050)
Previous 1.3+ version was based on a development branch.
Supported platforms
- Shared memory: KNEM, CMA, XPMEM, SYSV, Posix
- VERBs over InfiniBand and RoCE.
VERBS over other RDMA interconnects (iWarp, OmniPath, etc.) is available
for community evaluation and has not been tested in context of this release
- Cray Gemini and Aries
- Architectures: x86_64, ARMv8 (64bit), Power64
Features:
- Added support for InfiniBand DC and UD transports, including accelerated
verbs for Mellanox devices
- Full support for PGAS/SHMEM interfaces, blocking and non-blocking APIs
- Support for MPI tag matching, both in software and offload mode
- Zero copy protocols and rendezvous, registration cache
- Handling transport errors
- Flow control for DC/RC
- Dataypes support: contiguous, IOV, generic
- Multi-threading support
- Support for ARMv8 64bit architecture
- A new API for efficient memory polling
- Support for malloc-hooks and memory registration caching

==== orca ====
Version update (3.25.4 -> 3.26.0)
Subpackages: orca-lang

- Update to version 3.26.0:
+ Web:
- Add support for aria-errormessage.
- Add support for aria-keyshortcuts.
- Fix several issues related to presentation of plain text
content.
+ LibreOffice:
- Filter out checked event from window which isn't active.
- Work around event-ordering issue.
+ General:
- Fix incorrect presentation of old ancestors.
- Fix issue related to presentation of status bars.
- Remove unneeded try/except around
Gdk.notify_startup_complete().
+ Updated translations.

==== osc ====
Version update (0.159.0 -> 0.160.0)

- 0.160
- support fissile build type
- Container support for the package cache
- Remove all untracked files during "osc clean"
- Support the commit of a deleted, but non-existent package
- triggerreason --multibuild-package option
- improved status display
- improved request listing filters

==== osinfo-db ====

- bsc#1057733 - libosinfo db entry for caasp wrong
add-caasp-support.patch
- bsc#1056028 - Not able to install OES2018 as guest on Xen
add-oes-support.patch

==== oxygen5-icon-theme ====
Version update (5.37.0 -> 5.38.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== parted ====
Subpackages: libparted0

- Make SUSE parted pass all tests in upstream test suite
- add: tests-set-optimal-blocks-for-scsi_debug.patch
- add: tests-increase-scsi_debug-tmo.patch
- add: tests-use-wait_for_dev_to_-functions.patch
- add: tests-wait_for_-loop.patch
- add: tests-update-t0220-t0280-for-swap-flag.patch
- add: tests-adapt-to-SUSE.patch
- Fix partition naming for dm devices not ending in a digit and
also fix resizing of dm partitions (bsc#1056508)
- amend: libparted-partition-naming.patch

==== patterns-base ====
Subpackages: patterns-base-apparmor patterns-base-apparmor_opt
patterns-base-base patterns-base-basesystem patterns-base-console
patterns-base-enhanced_base patterns-base-enhanced_base_opt
patterns-base-minimal_base patterns-base-minimal_base_conflicts
patterns-base-sw_management patterns-base-x11 patterns-base-x11_opt
patterns-base-x86

- Add libnss_compat2 and libnss_nis2 to minimal_base: they were
integrated into glibc before.

==== pcre ====
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0
pcre-devel

- RunTest needs much stack, on s390x more than the default
8 MB. [bnc#1046102]

==== permissions ====
Version update (20170602 -> 20170913)

- Update to version 20170913:
* Allow setuid for shadow newuidmap, newgidmap bsc#979282, bsc#1048645)
- Update to version 20170906:
* permissions - copy dbus-daemon-launch-helper from / to /usr - bsc#1056764
* permissions: Adding suid bit for VBoxNetNAT (bsc#1033425)

==== pesign-obs-integration ====

- To support PKCS#7 kernel module signing, copy sign-file.c from
SLE-15 v4.12 kernel source to replace the kernel-sign-file script
to align upstream. (bsc#1049122)

==== plasma-framework ====
Version update (5.37.0 -> 5.38.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Add patch to fix Plasma Dialogs (kde#384776):
* 0001-Pass-item-to-rootObject-since-it-s-now-a-singleton.patch
- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* [ConfigModel] Guard against adding a null ConfigCategory
* [ConfigModel] Allow programmatically adding and removing ConfigCategory
* [EventPluginsManager] Expose pluginPath in model
* [Icon Item] Don't needlessly unset imagePath
* [FrameSvg] Use QPixmap::mask() instead of deprecated convoluted way via
alphaChannel()
* [FrameSvgItem] Create margins/fixedMargins object on demand
* HTML-escape applet name in undo notification
* fix check state for menu items
* Force Plasma style for QQC2 in applets
* Install the PlasmaComponents.3/private folder
* Guard failed testItem creation
* [Service] Restore /dev/null usage
* [Service] Use KConfig::SimpleConfig
* Drop remains of "locolor" themes
* Get rid of QSignalMapper
* [Theme] Use KConfig SimpleConfig
* Avoid some unnecessary theme content lookups
* fix check
* ignore spurious resize events to empty sizes (kde#382340)
- Dropped patches, now upstream:
* 0001-ignore-spurious-resize-events-to-empty-sizes.patch

==== plasma5-pk-updates ====
Version update (0.2 -> 0.3.1)

- Update to 0.3.1. Changes:
* concat the string
* reload the cache when the updates had been installed meanwhile manually
* Re-check selected packages once any is selected/deselected
* Remove Plasma/PopupApplet from desktop file
* Add notification about required restart/logout
* Fix typo in icon name
* Use new breeze icons
* Make it compile with GCC < 5
* Simplify the logic a bit
* Change the refresh logic and avoid unnecessary calls to the Packagekit
Daemon
* Add a checkbox to select/deselect all packages
* Use native plasma components
- Remove patches, now upstream:
* 0001-Add-notification-about-required-restart-logout.patch
* 0002-Remove-Plasma-PopupApplet-from-desktop-file.patch
* fix-typo-in-icon-name.patch
* use-new-breeze-icons.patch
* use-native-plasma-components.patch
* change-refresh-logic.patch
* gcc48.diff
* add-desktopfile-translations.patch
- Add patch to fix relogin/restart notification (boo#951580)
* 0001-Add-DefaultEvent-flag-to-fix-notification-for-relogi.patch
- Add patch to fix translation of status string:
* 0001-concat-the-string.patch
- Generate an updated plasma-pk-updates-lang.tar.xz

==== postfix ====
Subpackages: postfix-doc

- Add libnsl-devel build requires for glibc obsoleting libnsl

==== prison-qt5 ====
Version update (5.37.0 -> 5.38.0)

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== psmisc ====

- Add patch psmisc-23.0-killall-signals.patch to fix boo#1058990
by prior scanning for signal names in the arguments of killall

==== pulseaudio ====
Version update (11.0 -> 11.1)
Subpackages: libpulse-devel libpulse-mainloop-glib0 libpulse0
pulseaudio-bash-completion pulseaudio-esound-compat pulseaudio-module-bluetooth
pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc
pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils

- Update to 11.1
* Fix a crash in filter modules related to flat volumes and volume
sharing
* Fix a crash when the bluetooth adapter reports weird MTU size
* Disable bluetooth MTU autodetection by default
* Add mixer handling back for hardware that doesn't have any alsa-lib
configuration
* Prioritize USB devices over built-in sound cards (11.0 was supposed
to have this feature, but the implementation turned out to be
incomplete)

==== purple-facebook ====
Version update (0.9.4 -> 0.9.5)

- update to version 0.9.5
* Don't fail on groupchats with only two members including self (Those are
created by the "Marketplace" feature)
* Use FetchContactsDeltaQuery for contact sync
* Don't disconnect when trying to join a chat after being kicked
* Extract target url from fbrpc:// URLs
* Handle new style topic/groupchat membership events
* Fix setting channel topics (tid=t_id.1234 is no longer valid)
* Fix creating threads, inviting, kicking members (misc api changes)
* Add everyone to "Facebook Friends" group and persist Non-Friends
* Don't save access token if not remembering password
* Save names of non-friends in the local alias in blist.xml
* Add "Mark messages as read only when available" setting

==== python-cairo ====
Subpackages: python-cairo-common-devel python2-cairo python2-cairo-devel
python3-cairo

- Update to version 1.15.1:
+ Fixes:
- Improved support for Python filesystem paths including
os.PathLike. See pathlike for details.
- Various minor fixes.
+ Changes: Expose cairo.Path.
+ Tests: Improved test coverage from ~70% to ~90%.
- Changes from version 1.15.0:
+ New Features:
- Add Surface.map_to_image() and Surface.unmap_image().
- Add RasterSourcePattern.
- Add Glyph.
- Add Rectangle.
- Add TextCluster.
- Add ScaledFont.text_to_glyphs() and
ScaledFont.glyph_extents().
- Add Context.show_text_glyphs().
- Add TextExtents.
+ Changes:
- Pycairo instances wrapping the same underlying cairo object
now hash and compare equally e.g. context.get_target() ==
context.get_target().
- Functions which returned a cairo error with Status.NO_MEMORY
no longer raise MemoryError, but a subclass of Error and
MemoryError. Similarly errors with Status.READ_ERROR and
Status.WRITE_ERROR no longer raise IOError, but a subclass of
Error and IOError.
- Some functions which previously returned a tuple now return a
tuple subclass like Rectangle, Glyph, TextCluster and
TextExtents.
- Changes from version 1.14.1:
+ Fixes: Fix a crash with Surface.get_device().
- Changes from version 1.14.0:
+ General: Requires at least cairo 1.13.1.
+ Tests: Optional Hypothesis tests.
+ New Features:
- Add Surface.set_device_scale() and
Surface.get_device_scale().
- Add Device.
- Add Surface.get_device().
- Add ScriptDevice and ScriptMode.
- Add ScriptSurface.
- Add Status.JBIG2_GLOBAL_MISSING.
- Add Format.stride_for_width().
- Add TextClusterFlags and SurfaceObserverMode.
- Add Gradient.get_color_stops_rgba().
- Add TeeSurface.
- Add MeshPattern.
- Changes from version 1.13.4:
+ Fixes: Fix a rare crash with get_data() under Python 3 (1.13.3
regression).
- fix requires for devel subpackage
- Update to version 1.13.3:
+ Fix ImageSurface leaking in case
:meth:`get_data() <ImageSurface.get_data>` is used under
Python 3 (gh#pygobject/pycairo#43).
- Changes from version 1.13.2:
+ Fix pip failing to install pycairo in some cases
(gh#pygobject/pycairo#39).
- Changes from version 1.13.1:
+ setup.py install: Fix generated pkg-config file if ``--home``
or ``--user`` is specified (gh#pygobject/pycairo#34).
+ Fix a build error on macOS Sierra (gh#pygobject/pycairo#36)
+ examples: Fix snippet examples when .pyc files are present
(gh#pygobject/pycairo#35).
- For more changes since the last package update, see NEWS inside.
- Implement python single-spec packaging: since pycairo 1.11.0, the
sources for python2 and python3 based bindings have been merged
again.
- Add python2-cairo and python2-cairo-devel provides for
compatibility with the new multipython spec file macros.
- Add Source URL, see https://en.opensuse.org/SourceUrls
- Build with %{optflags}
- Add group to devel package
- trying to get the license right for spdx
- Update to version 1.10.0:
+ New Constants:
- cairo.FORMAT_RGB16_565
+ Bug Fixes:
- context.get_source().get_surface() fails (fdo#33013)
+ Improve/simplify unicode filename and text support.
+ Build related changes.
- Move to using waf for the build as the autotools support is
broken.
- Recompile the generated byte-code with %py_compile, as the
waf-generated byte-code references the build root. This is a bug
in waf, see http://code.google.com/p/waf/issues/detail?id=986
- Update to version 1.8.10:
+ New Classes/Types:
- Win32PrintingSurface
- XCBSurface - add XCB support using xpyb
+ Bug Fixes:
- Fix for libtool 2.2 (fdo#27974).
- Mingw32 and pypy fixes (fdo#25203).
+ Other Changes:
- Tests updated.
- Update to version 1.8.8:
+ General Changes:
- Pycairo 1.8.8 requires cairo 1.8.8 (or later).
- Move from CVS to git.
- Add support for the waf build tool.
+ Updated methods
- The PDF/PS/SVGSurface constructors now accept None as a
filename.
- Update to version 1.8.6:
+ Bug Fixes:
- ImageSurface.create_from_png _read_func fix
- ToyFontFace type fix
- fdo#19221: restore cairo.Matrix '*' operator to the way it
originally worked.
+ Documentation completed
- Update to version 1.8.4:
+ General Changes:
- Pycairo 1.8.4 requires cairo 1.8.4 (or later) and Python 2.6
+ Bug Fixes:
- fdo#20674: Add get/set_extend for Gradient Patterns
+ New Classes:
- cairo.ToyFontFace
+ New Methods:
- Pattern.get_extend
- Pattern.set_extend
- ToyFontFace.get_family
- ToyFontFace.get_slant
- ToyFontFace.get_weight
+ Deleted Methods:
- SurfacePattern.get_extend
- SurfacePattern.set_extend
+ Other Changes:
- Threading for surfaces with stream functions has been
reenabled.
- Documentation updates.
- Stop re-defining _prefix.
- Remove unneeded BuildRequires: gtk2-devel, libjpeg-devel,
python-numeric, update-desktop-files.
- Add BuildRequires: cairo-devel, fdupes.
- Remove Suggests on python-numeric (Numeric support was removed).
- Remove Suggests on python-gtk since, well, there's no real reason
to put it.
- Stop running suse_update_config.
- Use fdupes.

==== python-iniparse ====

- Add missing python-six runtime dependency

==== python-libvirt-python ====
Version update (3.6.0 -> 3.7.0)

- Update to 3.7.0
- Add all new APIs and constants in libvirt 3.7.0

==== python-lxml ====
Version update (3.8.0 -> 4.0.0)
Subpackages: python2-lxml python3-lxml

- spec changes:
- add fdupes
- update to 4.0.0:
Features added:
- The ElementPath implementation is now compiled using Cython,
which speeds up the .find*() methods quite significantly.
- The modules lxml.builder, lxml.html.diff and lxml.html.clean
are also compiled using Cython in order to speed them up.
- xmlfile() supports async coroutines using async with and await.
- iterwalk() has a new method skip_subtree() that prevents
walking into the descendants of the current element.
- RelaxNG.from_rnc_string() accepts a base_url argument to allow
relative resource lookups.
- The XSLT result object has a new method .write_output(file)
that serialises output data into a file according to the
<xsl:output> configuration.
Bugs fixed:
- GH#251: HTML comments were handled incorrectly by the
soupparser. Patch by mozbugbox.
- LP#1654544: The html5parser no longer passes the useChardet
option if the input is a Unicode string, unless explicitly
requested. When parsing files, the default is to enable it when
a URL or file path is passed (because the file is then opened in
binary mode), and to disable it when reading from a file(-like) object.
Note: This is a backwards incompatible change of the default configuration.
If your code parses byte strings/streams and depends on character
detection, please pass the option guess_charset=True explicitly, which
already worked in older lxml versions.
- LP#1703810: etree.fromstring() failed to parse UTF-32 data with BOM.
- LP#1526522: Some RelaxNG errors were not reported in the error log.
- LP#1567526: Empty and plain text input raised a TypeError in soupparser.
- LP#1710429: Uninitialised variable usage in HTML diff.
- LP#1415643: The closing tags context manager in xmlfile() could continue
to output end tags even after writing failed with an exception.
- LP#1465357: xmlfile.write() now accepts and ignores None as input argument.
- Compilation under Py3.7-pre failed due to a modified function signature.
Other changes:
- The main module source files were renamed from lxml.*.pyx to plain *.pyx
(e.g. etree.pyx) to simplify their handling in the build process. Care was
taken to keep the old header files as fallbacks for code that compiles
against the public C-API of lxml, but it might still be worth validating
that third-party code does not notice this change.
- Ensure neutrality of description. Adjust RPM categories.

==== python-numpy ====
Version update (1.12.1 -> 1.13.1)
Subpackages: python2-numpy python3-numpy

- Update to version 1.13.1
* bugfix release for problems found in 1.13.0; major changes:
+ fixes for the new memory overlap detection and temporary
elision
+ reversion of the removal of the boolean binary - operator
* 1.13.0 Highlights:
+ Operations like a + b + c will reuse temporaries on some
platforms
+ Inplace operations check if inputs overlap outputs and
create temporaries
+ New __array_ufunc__ attribute provides improved ability for
classes to override default ufunc behavior.
+ New np.block function for creating blocked arrays.
* 1.13.0 New functions:
+ New np.positive ufunc.
+ New np.divmod ufunc provides more efficient divmod.
+ New np.isnat ufunc tests for NaT special values.
+ New np.heaviside ufunc computes the Heaviside function.
+ New np.isin function, improves on in1d.
+ New np.block function for creating blocked arrays.
+ New PyArray_MapIterArrayCopyIfOverlap added to NumPy C-API.
* deprecations, compatibility notes, etc see full changelog at

https://github.com/numpy/numpy/blob/master/doc/changelog/1.13.0-changelog.rst
- dropped xlocale.patch (now upstream)
- do not apply 'sed 1d' command to exec_command.py

==== python-pyOpenSSL ====
Version update (17.0.0 -> 17.2.0)
Subpackages: python2-pyOpenSSL python3-pyOpenSSL

- update to 17.2.0:
- Deprecated ``OpenSSL.rand`` - callers should use ``os.urandom()`` instead.
- Fixed a bug causing ``Context.set_default_verify_paths()`` to not work with
cryptography ``manylinux1`` wheels on Python 3.x.
- Fixed a crash with (EC)DSA signatures in some cases.
- Removed the deprecated ``OpenSSL.rand.egd()`` function.
Applications should prefer ``os.urandom()`` for random number generation.
- Removed the deprecated default ``digest`` argument to
``OpenSSL.crypto.CRL.export()``.
Callers must now always pass an explicit ``digest``.
- Fixed a bug with ``ASN1_TIME`` casting in ``X509.set_notBefore()``,
``X509.set_notAfter()``, ``Revoked.set_rev_date()``,
``Revoked.set_nextUpdate()``,
and ``Revoked.set_lastUpdate()``. You must now pass times in the form
``YYYYMMDDhhmmssZ``. ``YYYYMMDDhhmmss+hhmm`` and ``YYYYMMDDhhmmss-hhmm``
will no longer work. `#612 <https://github.com/pyca/pyopenssl/pull/612>`_
- Deprecated the legacy "Type" aliases: ``ContextType``, ``ConnectionType``,
``PKeyType``, ``X509NameType``, ``X509ExtensionType``, ``X509ReqType``,
``X509Type``, ``X509StoreType``, ``CRLType``, ``PKCS7Type``, ``PKCS12Type``,
``NetscapeSPKIType``.
The names without the "Type"-suffix should be used instead.
- Added ``OpenSSL.crypto.X509.from_cryptography()`` and
``OpenSSL.crypto.X509.to_cryptography()``
for converting X.509 certificate to and from pyca/cryptography objects.
- Added ``OpenSSL.crypto.X509Req.from_cryptography()``,
``OpenSSL.crypto.X509Req.to_cryptography()``,
``OpenSSL.crypto.CRL.from_cryptography()``, and
``OpenSSL.crypto.CRL.to_cryptography()``
for converting X.509 CSRs and CRLs to and from pyca/cryptography objects.
- Added ``OpenSSL.debug`` that allows to get an overview of used library
versions
(including linked OpenSSL) and other useful runtime information using
``python -m OpenSSL.debug``.
- Added a fallback path to ``Context.set_default_verify_paths()`` to
accommodate
the upcoming release of ``cryptography`` ``manylinux1`` wheels.
- Drop python-pyOpenSSL=replace-expired-cert.patch . Applied upstream.
- Drop python-pyOpenSSL-always-overflow.patch. Applied upstream.

==== python-pyasn1 ====
Version update (0.3.4 -> 0.3.5)
Subpackages: python2-pyasn1 python3-pyasn1

- updated to upstream release 0.3.5
- Codecs signatures unified and pass the options kwargs through the
call chain
- Explicit tag encoding optimized to avoid unnecessary copying
- End-of-octets sentinel encoding optimized
- Refactored ASN.1 codecs properties to silently enforce proper
length and chunk size encoding modes
- Fixed DER encoder to always produce primitive encoding
- Fixed crash at SequenceOf native decoder
- Fixed Real.prettyPrint() to fail gracefully on overflow
- Fixed a couple of crashes when debug mode is enabled

==== python-setuptools ====
Version update (34.2.0 -> 36.5.0)
Subpackages: python2-setuptools python3-setuptools

- update to 36.5.0:
* #170: When working with Mercurial checkouts, use Windows-friendly
syntax for suppressing output.
* Inspired by #1134, performed substantial refactoring of
``pkg_resources.find_on_path`` to facilitate an optimization
for paths with many non-version entries.
* #1075: Add new ``Description-Content-Type`` metadata field. `See here for
documentation on how to use this field.
<https://packaging.python.org/specifications/#description-content-type>`_
* #1068: Sort files and directories when building eggs for
deterministic order.
* #196: Remove caching of easy_install command in fetch_build_egg.
Fixes issue where ``pytest-runner-N.N`` would satisfy the installation
of ``pytest``.
* #1129: Fix working set dependencies handling when replacing conflicting
distributions (e.g. when using ``setup_requires`` with a conflicting
transitive dependency, fix #1124).
* #1133: Improved handling of README files extensions and added
Markdown to the list of searched READMES.
* #1135: Improve performance of pkg_resources import by not invoking
``access`` or ``stat`` and using ``os.listdir`` instead.
* #1131: Make possible using several files within ``file:`` directive
in metadata.long_description in ``setup.cfg``.
* fix #1105: Fix handling of requirements with environment
markers when declared in ``setup.cfg`` (same treatment as
for #1081).
* #462: Don't assume a directory is an egg by the ``.egg``
extension alone.
* #1093: Fix test command handler with extras_require.
* #1112, #1091, #1115: Now using Trusty containers in
Travis for CI and CD.
* #1092: ``pkg_resources`` now uses ``inspect.getmro`` to
resolve classes in method resolution order.
* #1102: Restore behavior for empty extras.
- update to 36.2.2
v36.2.2
-------
* #1099: Revert commit a3ec721, restoring intended purpose of
extras as part of a requirement declaration.
v36.2.1
-------
* fix #1086
* fix #1087
* support extras specifiers in install_requires requirements
v36.2.0
-------
* #1081: Environment markers indicated in ``install_requires``
are now processed and treated as nameless ``extras_require``
with markers, allowing their metadata in requires.txt to be
correctly generated.
* #1053: Tagged commits are now released using Travis-CI
build stages, meaning releases depend on passing tests on
all supported Python versions (Linux) and not just the latest
Python version.
v36.1.1
-------
* #1083: Correct ``py31compat.makedirs`` to correctly honor
``exist_ok`` parameter.
* #1083: Also use makedirs compatibility throughout setuptools.
v36.1.0
-------
* #1083: Avoid race condition on directory creation in
``pkg_resources.ensure_directory``.
* Removed deprecation of and restored support for
``upload_docs`` command for sites other than PyPI.
Only warehouse is dropping support, but services like
`devpi <http://doc.devpi.net/latest/>`_ continue to
support docs built by setuptools' plugins. See
`this comment
<https://bitbucket.org/hpk42/devpi/issues/388/support-rtd-model-for-building-uploading#comment-34292423>`_
for more context on the motivation for this change.
- update to 36.0.1
* #1042: Fix import in py27compat module that still
referenced six directly, rather than through the externs
module (vendored packages hook).
* #980 and others: Once again, Setuptools vendors all
of its dependencies. It seems to be the case that in
the Python ecosystem, all build tools must run without
any dependencies (build, runtime, or otherwise). At
such a point that a mechanism exists that allows
build tools to have dependencies, Setuptools will adopt
it.
* #1015: Fix test failures on Python 3.7.
* #1024: Add workaround for Jython #2581 in monkey module.
* #992: Revert change introduced in v34.4.1, now
considered invalid.
* #1016: Revert change introduced in v35.0.0 per #1014,
referencing #436. The approach had unintended
consequences, causing sdist installs to be missing
files.
- remove fix-sle11-test-failure.patch: this doesn't build for
SLE11 anymore, so no need to patch it anymore

==== python3 ====
Version update (3.6.1 -> 3.6.2)
Subpackages: python3-curses python3-dbm python3-tk

- distutils-reproducible-compile.patch: ensure distutils order files
before compiling, which works around bsc#1049186
- Add libnsl-devel build requires for glibc obsoleting libnsl
- update to 3.6.2
* bugfix release, over a hundred bugs fixed
* see Misc/NEWS for details
- drop upstreamed test-socket-aead-kernel49.patch
- add Provides: python3-typing (fixes bsc#1050653)
- drop duplicate Provides: python3

==== python3-base ====
Version update (3.6.1 -> 3.6.2)
Subpackages: libpython3_6m1_0 python3-idle

- Fix test broken with OpenSSL 1.1 (bsc#1042670)
* add 0001-3.6-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-3093.patch
- fix missing %{?armsuffix}
- distutils-reproducible-compile.patch: ensure distutils order files
before compiling, which works around bsc#1049186
- Add libnsl-devel build requires for glibc obsoleting libnsl
- update to 3.6.2
* bugfix release, over a hundred bugs fixed
* see Misc/NEWS for details
- drop upstreamed test-socket-aead-kernel49.patch
- add Provides: python3-typing (fixes bsc#1050653)
- drop duplicate Provides: python3

==== rdma-core ====
Subpackages: libibcm1 libibumad3 libibverbs libibverbs1 libmlx4-1 libmlx5-1
librdmacm1 rdma-core-devel rsocket

- Update to rdma-core v15
* Remove dracut requirement

==== rhino ====

- Make build with the new version of java-1_5_0-gcj-compat, where
javac is not just a simple link to gcj, but a wrapper script that
runs Eclipse Compiler for Java(tm)
- Make buildable with different versions of OpenJDK

==== rubygem-gem2rpm ====

- add ruby 2.5 support

==== saxon6 ====

- Specify java source and target 1.6 to fix build with jdk9

==== saxon9 ====
Subpackages: saxon9-scripts

- We don't need to specify -Xdoclint:none, since doclint is
disabled by default

==== shadow ====

- boo#1048645:
Set suid bit for newuidmap and newgimap
- Revert the changes for bsc#1023895 back
Pulls in too many deps into ring0.
Next version of shadow plans to have no conditional man pages.
- run spec-cleaner
- bsc#1023895:
man page contained invalid options because they depend
on compile flags and we shipped pre built ones.
New BuildRequires: docbook-xsl-stylesheets docbook_4 xml2po
xsltproc

==== solid ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* None

==== sonnet ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== spamassassin ====
Subpackages: perl-Mail-SpamAssassin

- Add support for building with OpenSSL 1.1 (bsc#1055252)
* add 0001-bug-7361-Allow-building-against-OpenSSL-1.1.0.patch
* add spamassassin-dont_use_SSLv3_methods.patch
- Fix build with Perl 5.26
* https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7367
* add 0001-Fix-bug-7367-Don-t-assume-cwd-.-is-in-INC-it-may-be-.patch

==== sudo ====

- remove "--with-insults" and disable insults by default. Now
insults sets are included but user must enable it in the sudoers
file [bsc#1053911]

==== syntax-highlighting ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5SyntaxHighlighting5

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Add syntax definition for Adblock Plus filter lists
* Rewrite the Sieve syntax definition
* Add highlighting for QDoc configuration files
* Add highlight definition for Tiger
* Escape hyphen in rest.xml regular expressions (kde#383632)
* fix: plaintext is highlighted as powershell
* indexer: Use qWarning for every error message
* Add syntax highlighting for Metamath
* Lesscss highlighting: Add generated reference as unit test
* Rebased Less syntax highlighting on SCSS one (kde#369277)
* Add Pony highlighting
* Rewrite the email syntax definition

==== sysprof ====
Version update (3.25.92 -> 3.26.0)
Subpackages: sysprof-lang

- Update to version 3.26.0:
+ No changes, stable bump only.

==== system-config-printer ====
Subpackages: python3-cupshelpers system-config-printer-applet
system-config-printer-common system-config-printer-dbus-service
udev-configure-printer

- Drop SLE12 conditionals, unconditionally use Adwaita icon theme
and python3.
+ Drop python3-to-python2.diff.

==== system-users ====
Subpackages: system-group-hardware system-group-wheel system-user-bin
system-user-daemon system-user-games system-user-mail system-user-man
system-user-news system-user-nobody system-user-upsd system-user-uucp
system-user-wwwrun

- uuidd does not need group daemon, Copy&Paste error.
- udev needs groups kvm and lp: [bsc#1058703]
- Add group kvm to system-group-hardware
- Move group lp from system-user-lp to system-group-hardware
- Add system-user-uuidd.conf (boo#1057937#c3).

==== systemd ====
Subpackages: libsystemd0 libsystemd0-32bit libudev-devel libudev1
libudev1-32bit systemd-32bit systemd-bash-completion systemd-logger
systemd-sysvinit udev

- Import commit 58ea3c819cca1639ef8c922505c573ba5e262b3d
334945091 shutdown: fix incorrect fscanf() result check (#6806)
027202892 shutdown: don't remount,ro network filesystems. (#6588)
(bsc#1035386)
bc77b53a5 shutdown: don't be fooled when detaching DM devices with BTRFS
(boo#1055641)
d9d293847 util: make get_block_device() available
421ce7382 tmpfiles: silently ignore any path that passes through autofs
(#6506) (bsc#1045472)
ca8f90e62 device: make sure to remove all device units sharing the same sysfs
path (#6679)
- Make use of "%tmpfiles_create" in %post of the logger subpackage
- Add scripts-udev-convert-lib-udev-path.sh (bsc#1050152)
This script takes care of converting /lib/udev into a symlink
pointing to /usr/lib/udev when upgrading a distro using an old
version of udev.
- Make use of "%make_build" rpm macro
- Renumber scripts to start at index 100
- Introduce scripts-systemd-upgrade-from-pre-210.sh
It collects all existing hacks done in %post to fix old/deprecated
settings in systemd older than 210. This includes hacks needed to
fix system that are migrating from SysV.
There shouldn't be any functional changes.
- Move scripts for packaging workaround/fixes in /usr/lib/systemd/scripts
It also renames fix-machines-subvol-for-rollbacks.sh into
scripts-systemd-fix-machines-btrfs-subvol.sh
Note that the "scripts-systemd-" prefix is used for those scripts so
we can gather them. Why not using a directory instead ? because osc
doesn't allow that.

==== tagsoup ====

- Fix build with jdk9: specify source and target level 1.6
- Added patch:
* tagsoup-1.2.1-jdk9.patch
+ Don't specify java source and target levels on command-line
+ Give path to the built classes to javadoc

==== tcl ====
Version update (8.6.6 -> 8.6.7)

- New version: 8.6.7:
* (bug)[c09edf] Bad caching with custom resolver
* (bug)[4dbdd9] Memleak in test var-8.3
* (bug)[2bf561] Allow empty command as alias target
* ** POTENTIAL INCOMPATIBILITY ***
* (bug)[4d5ae7] Crash in async connects host no address
* (bug)[838e99] treat application/xml as text => http 2.8.10
* (bug)[3cc1d9] Thread finalization crash in zippy
* (bug)[be003d] Fix [scan 0x1 %b], [scan 0x1 %o]
* (bug)[eb6b68] Fix stringComp-14.5
* (bug)[b26e38] Fix zlib-7.8
* (bug)[1ae129] Fix memleak in [history] destruction
* (feature) Provisional Tcl 9 support in msgcat and tcltest
=> msgcat 1.6.1 => tcltest 2.4.1
* (bug)[824752] Crash in Tcl_ListObjReplace()
* (bug)[79614f] invalidate VFS mounts on sytem encoding change
* (bug) TclOO fix stops crash mixing Itcl and snit
* (update) Reconcile libtommath updates; purge unused files
* ** POTENTIAL INCOMPATIBILITY ***
* (bug)[b87ad7] Repair drifts in timer clock
* (bug)[39f630] Revise Tcl_LinkVar to tolerate some prefixes
* ** POTENTIAL INCOMPATIBILITY ***
* (bug)[d0f7ba] Improper NAN optimization. expr-22.1[01]
* (bug)[25842c] zlib stream finalization
* (enhancement) [clock] and [encoding] are now ensembles
* (enhancement) several [clock] subcommands bytecoded
* (bug)[900cb0] Fix OO unexport introspection
* (bug)[42202b] Nesting imbalance in coro injection
* (bug)[bc4322] http package support for safe interps
* (bug)[f34cf8] [file join a //b] => /b
* (bug)[8bd13f] Windows threads and pipe
* (bug)[f9fe90] [file join //a b] EIAS violation
* (bug)[601522] [binary] field spec overflow -> segfault
* (bug)[6ca52a] http memleak handling keep-alive=> http 2.8.11
* (bug)[a3fb33] crash in [lsort] on long lists
* (bug)[67aa9a] Tcl_UtfToUniChar() revised handling invalid UTF-8
* ** POTENTIAL INCOMPATIBILITY ***
* (bug)[2738427] Tcl_NumUtfChars() corner case utf-4.9
* (update) Update Unicode data to 10.0
* ** POTENTIAL INCOMPATIBILITY ***
* (TIP 473) Let [oo::copy] specify target namespace
* (bug)[46f801] Repair autoloader fragility
* (bug)[adb198] Plug memleak in TclJoinPath
* (bug)[fb2208] Repeatable tclIndex generation
- Included Itcl is now version 4.0.5.
- Add zlib-devel to BuildRequires, don't use included zlib sources

==== tcpdump ====
Version update (4.9.1 -> 4.9.2)

- Disabled ikev2pI2 test that fails on some architectures
* Added patch tcpdump-ikev2pI2.patch
- Update to version 4.9.2 [bsc#1057247]
* Security fixes:
- CVE-2017-11108 segfault in STP decoder
- Segfault in ESP decoder with OpenSSL 1.1
- CVE-2017-11543 buffer overflow in SLIP decoder
- CVE-2017-13011 buffer overflow in bittok2str_internal()
- CVE-2017-12989 infinite loop in the RESP parser
- CVE-2017-12990 infinite loop in the ISAKMP parser
- CVE-2017-12995 infinite loop in the DNS parser
- CVE-2017-12997 infinite loop in the LLDP parser
- CVE-2017-11541 buffer over-read in safeputs()
- CVE-2017-11542 buffer over-read in PIMv1 decoder
- CVE-2017-12893 buffer over-read in the SMB/CIFS parser
- CVE-2017-12894 buffer over-read in several protocol parsers
- CVE-2017-12895 buffer over-read in the ICMP parser
- CVE-2017-12896 buffer over-read in the ISAKMP parser
- CVE-2017-12897 buffer over-read in the ISO CLNS parser
- CVE-2017-12898 buffer over-read in the NFS parser
- CVE-2017-12899 buffer over-read in the DECnet parser
- CVE-2017-12900 buffer over-read in the in several protocol parsers
- CVE-2017-12901 buffer over-read in the EIGRP parser
- CVE-2017-12902 buffer over-read in the Zephyr parser
- CVE-2017-12985 buffer over-read in the IPv6 parser
- CVE-2017-12986 buffer over-read in the IPv6 routing header parser
- CVE-2017-12987 buffer over-read in the 802.11 parser
- CVE-2017-12988 buffer over-read in the telnet parser
- CVE-2017-12991 buffer over-read in the BGP parser
- CVE-2017-12992 buffer over-read in the RIPng parser
- CVE-2017-12993 buffer over-read in the Juniper protocols parser
- CVE-2017-12994 buffer over-read in the BGP parser
- CVE-2017-12996 buffer over-read in the PIMv2 parser
- CVE-2017-12998 buffer over-read in the IS-IS parser
- CVE-2017-12999 buffer over-read in the IS-IS parser
- CVE-2017-13000 buffer over-read in the IEEE 802.15.4 parser
- CVE-2017-13001 buffer over-read in the NFS parser
- CVE-2017-13002 buffer over-read in the AODV parser
- CVE-2017-13003 buffer over-read in the LMP parser
- CVE-2017-13004 buffer over-read in the Juniper protocols parser
- CVE-2017-13005 buffer over-read in the NFS parser
- CVE-2017-13006 buffer over-read in the L2TP parser
- CVE-2017-13007 buffer over-read in the Apple PKTAP parser
- CVE-2017-13008 buffer over-read in the IEEE 802.11 parser
- CVE-2017-13009 buffer over-read in the IPv6 mobility parser
- CVE-2017-13010 buffer over-read in the BEEP parser
- CVE-2017-13012 buffer over-read in the ICMP parser
- CVE-2017-13013 buffer over-read in the ARP parser
- CVE-2017-13014 buffer over-read in the White Board protocol parser
- CVE-2017-13015 buffer over-read in the EAP parser
- CVE-2017-13016 buffer over-read in the ISO ES-IS parser
- CVE-2017-13017 buffer over-read in the DHCPv6 parser
- CVE-2017-13018 buffer over-read in the PGM parser
- CVE-2017-13019 buffer over-read in the PGM parser
- CVE-2017-13020 buffer over-read in the VTP parser
- CVE-2017-13021 buffer over-read in the ICMPv6 parser
- CVE-2017-13022 buffer over-read in the IP parser
- CVE-2017-13023 buffer over-read in the IPv6 mobility parser
- CVE-2017-13024 buffer over-read in the IPv6 mobility parser
- CVE-2017-13025 buffer over-read in the IPv6 mobility parser
- CVE-2017-13026 buffer over-read in the ISO IS-IS parser
- CVE-2017-13027 buffer over-read in the LLDP parser
- CVE-2017-13028 buffer over-read in the BOOTP parser
- CVE-2017-13029 buffer over-read in the PPP parser
- CVE-2017-13030 buffer over-read in the PIM parser
- CVE-2017-13031 buffer over-read in the IPv6 fragmentation header parser
- CVE-2017-13032 buffer over-read in the RADIUS parser
- CVE-2017-13033 buffer over-read in the VTP parser
- CVE-2017-13034 buffer over-read in the PGM parser
- CVE-2017-13035 buffer over-read in the ISO IS-IS parser
- CVE-2017-13036 buffer over-read in the OSPFv3 parser
- CVE-2017-13037 buffer over-read in the IP parser
- CVE-2017-13038 buffer over-read in the PPP parser
- CVE-2017-13039 buffer over-read in the ISAKMP parser
- CVE-2017-13040 buffer over-read in the MPTCP parser
- CVE-2017-13041 buffer over-read in the ICMPv6 parser
- CVE-2017-13042 buffer over-read in the HNCP parser
- CVE-2017-13043 buffer over-read in the BGP parser
- CVE-2017-13044 buffer over-read in the HNCP parser
- CVE-2017-13045 buffer over-read in the VQP parser
- CVE-2017-13046 buffer over-read in the BGP parser
- CVE-2017-13047 buffer over-read in the ISO ES-IS parser
- CVE-2017-13048 buffer over-read in the RSVP parser
- CVE-2017-13049 buffer over-read in the Rx protocol parser
- CVE-2017-13050 buffer over-read in the RPKI-Router parser
- CVE-2017-13051 buffer over-read in the RSVP parser
- CVE-2017-13052 buffer over-read in the CFM parser
- CVE-2017-13053 buffer over-read in the BGP parser
- CVE-2017-13054 buffer over-read in the LLDP parser
- CVE-2017-13055 buffer over-read in the ISO IS-IS parser
- CVE-2017-13687 buffer over-read in the Cisco HDLC parser
- CVE-2017-13688 buffer over-read in the OLSR parser
- CVE-2017-13689 buffer over-read in the IKEv1 parser
- CVE-2017-13690 buffer over-read in the IKEv2 parser
- CVE-2017-13725 buffer over-read in the IPv6 routing header parser
* Dropped patch tcpdump-reverted-test-scripts-fix.patch
- Reverted upstream commit that makes some tests to fail when
compiling with openssl-1.1.0
* Upstream commit 68cc39dd64688829be2632d9cd24f7efa3da79bb
* Added patch tcpdump-reverted-test-scripts-fix.patch
* Removed patch tcpdump-ikev2pI2-test-fails-ppc.patch

==== threadweaver ====
Version update (5.37.0 -> 5.38.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.38.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.38.0.php
- Changes since 5.37.0:
* Do not leak symbols of pimpl classes, protect with Q_DECL_HIDDEN

==== timezone ====

- Do not require java-bootstrap, since it does not exist any more;
use java < 1.8 instead

==== timezone-java ====

- Do not require java-bootstrap, since it does not exist any more;
use java < 1.8 instead

==== tk ====
Version update (8.6.6 -> 8.6.7)

- Change licence to "TCL".
- New version 8.6.7:
* (bug)[a2abc4] Wrong warp cursor position on 2nd display
* (bug)[fa3229] menu-38.1
* (bug)[2cf3d6] button-5.24
* (bug)[1534455,2945130] Key release events get _L vs _R right.
* (bug)[8c4216] listbox-4.1
* (bug)[eb2681] listbox-13.1
* (bug)[3126428] ttk::button react to image change
* (bug)[1082213] wrapped text don't start lines with whitespace
* (bug)[3217462] tri-state button on non-native theme
* (bug)[3588460] Fix file dialog -typevariable
* (bug)[e36963] event generate .e <diaeresis>
* (bug)[6aea69] grid-23
* (bug)[f60c54] combobox-3
* (bug)[f32502] crash drawing many dashed objects
* (bug)[dac92f] text-2.[89]
* (bug)[7a838c] X11 ring buffer overflow
* (bug)[d4fb4e] imgPhoto-4.75
* (bug)[1403ea] Limits on text line size on Windows
* (bug)[ae32eb] textDisp fails in text custom config
* (bug)[7d967c] crash after IME restart
* (bug)[c492c9] disabled combobox arrow appearance
* (bug)[6b3644] Fix -alpha for 16-bit color PNG
* (bug)[775273] artifacts on Ubuntu 16.10+
* (bug)[28a3c3] test BTree memleaks plugged
* (bug)[db8c54] Stop freed mem access in warp pointer callback
* (bugs) Fix calculation of ttk::notebook tab widths
* (bug)[291296] notebook tab management
* (bug)[3f323b] variable struct size on XCode 8.3.1
* (bug)[a5ba1c] race condition on Win clipboard cleanup
* (bug)[2433781] center image on button
* (bug)[434d29] type mismatch with recent Xft
* (bug)[bc43fd] paneconfigure get pane heights right
* (bug)[adc028] menu avoid unreleasable global grab
* (bug)[92e028,c5eb90] User switch forced theme reset
* (bug)[62c5b7] segfault in [text] replace
* (bug)[b601ce] Resource exhaustion processing corrupt GIF
* (bug)[28d0b8] Follow ICCCM advice on X selection protocol
* (bug)[4966ca] Scidb race in notebook tab selection

==== tomcat ====
Subpackages: tomcat-admin-webapps tomcat-el-3_0-api tomcat-jsp-2_3-api
tomcat-lib tomcat-servlet-3_1-api tomcat-webapps

- Added patch:
* tomcat-8.0.44-javadoc.patch
- generate documentation with the same source level as class
files
- fixes build with jdk9

==== totem ====
Subpackages: nautilus-totem totem-lang totem-plugin-brasero totem-plugins

- Build Totem-1.0.gir first as workaround for parallel build being
fragile (bgo#786248).

==== totem-pl-parser ====
Version update (3.25.90 -> 3.26.0)
Subpackages: libtotem-plparser-mini18 libtotem-plparser18
typelib-1_0-TotemPlParser-1_0

- Update to version 3.26.0:
+ Updated translations.

==== udisks2 ====
Version update (2.1.8 -> 2.6.5)
Subpackages: libudisks2-0

- Update to version 2.6.5 (fate#323354)
* switch to new maintained codestream at
https://github.com/storaged-project/udisks
* Detailed changelog in /usr/share/doc/packages/udisks2/NEWS

==== umbrello ====

- Remove unnecessary ldconfig call, there are no shared libraries
in here.

==== unbound ====
Version update (1.6.4 -> 1.6.6)
Subpackages: libunbound2 unbound-anchor

- update to 1.6.6
Features:
- unbound-control dump_infra prints port number for address if not 53.
- Fix #1344: RFC6761-reserved domains: test. and invalid.
- Fix #1349: allow suppression of pidfiles (from Daniel Kahn Gillmor).
With the -p option unbound does not create a pidfile.
- Added stats for queries that have been ratelimited by domain
recursion.
- Patch to show DNSCrypt status in help output, from Carsten
Strotmann.
- Fix #1407: Add ECS options check to unbound-checkconf.
- Fix #1415: [dnscrypt] shared secret cache, patch from
Manu Bretelle.
Bug Fixes:
- fixup of dnscrypt_cert_chacha test (from Manu Bretelle).
- First fix for zero b64 and hex text zone format in sldns.
- Better fixup of dnscrypt_cert_chacha test for different escapes.
- Fix that infra cache host hash does not change after reconfig.
- Fix python example0 return module wait instead of error for pass.
- enhancement for hardened-tls for DNS over TLS. Removed duplicated
security settings.
- Fix for unbound-checkconf, check ipsecmod-hook if ipsecmod is turned
on.
- Fix #1331: libunbound segfault in threaded mode when context is
deleted.
- Fix pythonmod link line option flag.
- Fix openssl 1.1.0 load of ssl error strings from ssl init.
- Fix 1332: Bump verbosity of failed chown'ing of the control socket.
- Redirect all localhost names to localhost address for RFC6761.
- Fix #1350: make cachedb backend configurable (from JINMEI Tatuya).
- Fix tests to use .tdir (from Manu Bretelle) instead of .tpkg.
- upgrade aclocal(pkg.m4 0.29.1), config.guess(2016-10-02),
config.sub(2016-09-05).
- annotate case statement fallthrough for gcc 7.1.1.
- flex output from flex 2.6.1.
- snprintf of thread number does not warn about truncated string.
- squelch TCP fast open error on FreeBSD when kernel has it disabled,
unless verbosity is high.
- remove warning from windows compile.
- Fix compile with libnettle
- Fix DSA configure switch (--disable dsa) for libnettle and libnss.
- Fix #1365: Add Ed25519 support using libnettle.
- Fix #1394: mix of serve-expired and response-ip could cause a crash.
- Remove unused iter_env member (ip6arpa_dname)
- Do not reset rrset.bogus stats when called using stats_noreset.
- Do not add rrset_bogus and query ratelimiting stats per thread, these
module stats are global.
- Fix #1397: Recursive DS lookups for AS112 zones names should recurse.
- Fix #1398: make cachedb secret configurable.
- Remove spaces from Makefile.
- Fix issue on macOX 10.10 where TCP fast open is detected but not
implemented causing TCP to fail. The fix allows fallback to regular
TCP in this case and is also more robust for cases where connectx()
fails for some reason.
- Fix #1402: squelch invalid argument error for fd_set_block on windows.
- Fix to reclaim tcp handler when it is closed due to dnscrypt buffer
allocation failure.
- Fix #1415: patch to free dnscrypt environment on reload.
- iana portlist update
- Small fixes for the shared secret cache patch.
- Fix WKS records on kvm autobuild host, with default protobyname
entries for udp and tcp.
- Fix #1414: fix segfault on parse failure and log_replies.
- zero qinfo in handle_request, this zeroes local_alias and also the
qname member.
- new keys and certs for dnscrypt tests.
- fixup WKS test on buildhost without servicebyname.
- updated contrib/fastrpz.patch to apply with configparser changes.
- Fix 1416: qname-minimisation breaks TLSA lookups with CNAMEs.
- Fix #1424: cachedb:testframe is not thread safe.
- Fix #1417: [dnscrypt] shared secret cache counters, and works when
dnscrypt is not enabled. And cache size configuration option.
- Fix #1418: [ip ratelimit] initialize slabhash using
ip-ratelimit-slabs.
- Recommend 1472 buffer size in unbound.conf
- update to 1.6.5
* Fix install of trust anchor when two anchors are present, makes both
valid. Checks hash of DS but not signature of new key. This fixes
installs between sep11 and oct11 2017.

==== utempter ====
Subpackages: libutempter0 utempter-devel

- Pre-require group(%{utmpGroup})

==== vde2 ====

- Patch for openssl 1.1 compatibility
* add vde2-openssl_1.1_compatibility.patch from Debian

==== virt-manager ====
Version update (1.4.2 -> 1.4.3)
Subpackages: virt-install virt-manager-common

- Update to virt-manager 1.4.3 (bsc#1027942)
virt-manager-1.4.3.tar.bz2
* Improve install of debian/ubuntu non-x86 media (Viktor Mihajlovski, Andrew
Wong)
* New virt-install ?graphics listen.* (Pavel Hrdina)
* New virt-install ?disk snapshot_policy= (Pavel Hrdina)
* New virt-install ?cpu cache.* (Lin Ma)
* Several bug fixes
- Dropped the following patch contained in new tarball
e902fa55-force-binary-mode-with-FTP-servers.patch
- Add .treeinfo detection for SUSE distros (bsc#1054986)
virtinst-add-sle15-detection-support.patch
- bsc#1058666 - virt-manager has a dependency on
typelib(AppIndicator3) = 0.1
virt-manager.spec
- bsc#1056028 - Not able to install OES2018 as guest on Xen
virtinst-detect-oes-distros.patch

==== virtualbox ====
Version update (5.1.26_k4.13.1_1 -> 5.1.26_k4.13.3_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- mark VBoxNetNAT with the correct permissions line. (bsc#1033425)

==== vm-install ====
Version update (0.9.02 -> 0.9.03)

- bsc#1056738 - vm-install: Can't install SLE15 PV guest on SLE11
SP4 host
- Version 0.9.03

==== vsftpd ====

- Add "vsftpd-die-with-session.patch" to fix a bug in vsftpd that
would cause SSL protocol errors, aborting the connection, whenever
system errors occurred that were supposed to be non-fatal.
[bsc#1044292]
- Add "vsftpd-mdtm-in-utc.patch" to fix interoperability issue with
various ftp clients that arose when vsftpd is configured with
option "use_localtime=YES". Basically, it's fine to use local time
stamps in directory listings, but responding to MDTM commands with
any time zone other than UTC directly violates RFC3659 and leads
FTP clients to misinterpret the file's time stamp. [bsc#1024961]
- Add "vsftpd-append-seek-pipe.patch" to allow the FTP server to
append to a file system pipe. [bsc#1048427]
- Add "vsftpd-3.0.3-address_space_limit.patch" to create the new
configuration option "address_space_limit", which determines the
memory limit vsftpd configures for its own process (given in
bytes). The previously hard-coded limit (100 MB) may not be
sufficient for vsftpd servers running with certain PAM modules
enabled, and in such cases administrators may wish to raise the
limit to match their system's requirements. [bsc#1042137]
- Don't rely on the vsf_findlibs.sh script to figure out the list
of libraries the build needs to link. The script is wildly
unreliable and it's hard to predict what results it will produce.
Also, the results it *does* produce are invisble in the build
log. We stumbled across this issue when vsftpd suddendly had
build failures on i586 platforms because the script decided to
try and link "-lnsl" even though the library was neither
installed nor required.
- Drop the explicit specification of the LDFLAGS and LINK variables
from the call to make. The value of LDFLAGS we passed is the
default anyway and giving LINK has no effect since it's not used
anywhere in the Makefile.

==== webkit2gtk3 ====
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
libwebkit2gtk3-lang typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Drop gcc6-c++ build conditionals for SLE12 / Leap42.

==== whois ====
Version update (5.2.16 -> 5.2.18)

- whois 5.2.18:
* Fix querying Verisign registry with parameters
* Fix return code for queries like "nameserver name.example.com"
- includes changes from 5.2.17:
* Fix whois referrals for .com, .net, .jobs, .bz, .cc and .tv,
broken by an ICANN-mandated output change:
https://www.icann.org/resources/pages/rdds-labeling-policy-2017-02-01-en
* Add various India NIXI delegated domains TLD servers
* Updated the list of new gTLDs

==== wxWidgets-3_0 ====
Subpackages: libwx_baseu-suse3 libwx_baseu_net-suse3 libwx_baseu_xml-suse3
libwx_gtk2u_adv-suse3 libwx_gtk2u_aui-suse3 libwx_gtk2u_core-suse3
libwx_gtk2u_gl-suse3 libwx_gtk2u_html-suse3 libwx_gtk2u_media-suse3
libwx_gtk2u_propgrid-suse3 libwx_gtk2u_qa-suse3 libwx_gtk2u_richtext-suse3
libwx_gtk2u_stc-suse3 libwx_gtk2u_xrc-suse3

- Disable building WebView (the built-in browser widget),
as pkconfig(webkit-1.0) (= webkit1gtk2) is going away.

==== wxWidgets-3_0-nostl ====
Subpackages: libwx_baseu-suse-nostl3 libwx_baseu_net-suse-nostl3
libwx_baseu_xml-suse-nostl3 libwx_gtk2u_adv-suse-nostl3
libwx_gtk2u_core-suse-nostl3 libwx_gtk2u_html-suse-nostl3
libwx_gtk2u_qa-suse-nostl3

- Disable building WebView (the built-in browser widget),
as pkconfig(webkit-1.0) (= webkit1gtk2) is going away.

==== xen ====
Subpackages: xen-doc-html xen-libs xen-tools xen-tools-domU

- bsc#1057358 - Cannot Boot into SLES12.3 with Xen hypervisor when
Secure Boot is Enabled
xen.spec
- bsc#1055695 - XEN: 11SP4 and 12SP3 HVM guests can not be restored
update from v6 to v9 to cover more cases for ballooned domUs
libxc.sr.superpage.patch
- bsc#1026236 - remove suse_vtsc_tolerance= cmdline option for Xen
drop the patch because it is not upstream acceptable
remove xen.suse_vtsc_tolerance.patch
- bsc#1055695 - XEN: 11SP4 and 12SP3 HVM guests can not be restored
after the save using xl stack
libxc.sr.superpage.patch
- Unignore gcc-PIE
the toolstack disables PIE for firmware builds as needed
- Upstream patches from Jan (bsc#1027519)
592fd5f0-stop_machine-fill-result-only-in-case-of-error.patch
596f257e-x86-fix-hvmemul_insn_fetch.patch
5982fd99-VT-d-don-t-panic-warn-on-iommu-no-igfx.patch
598c3630-VT-d-PI-disable-when-CPU-side-PI-is-off.patch
598c3706-cpufreq-only-stop-ondemand-governor-if-started.patch
5992f1e5-x86-grant-disallow-misaligned-PTEs.patch (Replaces xsa227.patch)
5992f20d-gnttab-split-maptrack-lock-to-make-it-useful-again.patch (Replaces
xsa228.patch)
5992f233-gnttab-correct-pin-status-fixup-for-copy.patch (Replaces
xsa230.patch)
59958e76-gnttab-dont-use-possibly-unbounded-tail-calls.patch (Replaces
xsa226-1.patch)
59958ebf-gnttab-fix-transitive-grant-handling.patch (Replaces xsa226-2.patch)
59958edd-gnttab-avoid-spurious-maptrack-handle-alloc-failures.patch
- bsc#1044974 - xen-tools require python-pam
xen.spec

==== xf86-input-libinput ====
Version update (0.25.1 -> 0.26.0)

- Update to version 0.26
* A few patches that have been sitting on master for a while, of
which two are documentation patches. The most interesting patch
is for tablets: previously we didn't send a separate motion
event before the button event which caused some clients to
trigger the button event on the previous stylus position.
- obsoletes U_Only-initialize-properties.patch

==== xiterm ====
Subpackages: fbiterm gtkiterm libiterm1

- Conflict libiterm1 with terminfo-iterm: terminfo-iterm is an
alternative to xiterm, and the conflict is meant to be.

==== xmlgraphics-commons ====

- Fix build with jdk9: specify java source and target level 1.6

==== xmlgraphics-fop ====

- Fix build with jdk9: specify java source and target 1.6 and fix
javadoc build

==== yast2-country ====
Version update (3.3.0 -> 4.0.2)
Subpackages: yast2-country-data

- Removed dependency on yast-storage (bsc#1058869):
Assume hardware clock running on UTC if no check for windows
partition possible because yast-storage is not available
- 4.0.2
- Augment "Uzhgorod" (Europe/Uzhgorod) with "Ukraine ..." to
prevent an unknown country from being offered (bsc#1054917)
- 4.0.1
- improve language selection to support also CaaSP needs
(FATE#323837)
- 4.0.0
- Add a widget for language selection (fate#322276)
- Move keyboard selection widget to lib/y2country/widgets
directory
- 3.3.2
- merge storage-ng branch to master (fate#318196)
- note: all changes below with this date belong to the merge
- 3.3.1
- Merged master to storage-ng branch
- remove last remaining old storage reference
- Version temporarily bumped to 3.3.x to prioritize the
storage-ng branch
- readded check for Windows based on storage-ng
- storage-ng: commented installation-related code relying on the
old yast2-storage
- Version temporarily bumped to 3.2.x to prioritize this branch

==== yast2-nis-client ====
Version update (3.2.1 -> 4.0.0)

- added libnsl-devel to BuildRequires for upstream changes
- 4.0.0

==== yast2-pkg-bindings ====
Version update (3.2.4 -> 4.0.0)

- Keep enabled recommended packages for the next solver runs
when doing distribution upgrade (bsc#1059065)
- 4.0.0
- Rename PrdMarkLicenseUnconfirmed to PrdMarkLicenseNotConfirmed
(FATE#322276)
- 3.3.2
- Add a Pkg.PrdHasLicenseConfirmed and
Pkg.PrdMarkLicenseUnconfirmed (FATE#322276)
- Pkg.PrdGetLicenseToConfirm always returns the license, no matter
whether is confirmed or not
- Add a second argument to Pkg.PrdGetLicenseToConfirm in order
get the license translated to the given language
- 3.3.1
- Add functions to handle product licenses (FATE#322276)
- 3.3.0

==== yast2-samba-server ====
Version update (3.2.1 -> 3.2.2)

- Drop NT style PDC/BDC configuration wizard (fate#323806)
- 3.2.2

==== zypper ====
Version update (1.13.32 -> 1.13.35)
Subpackages: zypper-aptitude zypper-log

- Fix missing package names in installation report (bsc#1058695,
fixes #134)
- version 1.13.35
- Summary: Differ between unsupported and packages with unknown
support status (bsc#1057634)
- Use HTTPS by default for repository URLs derived from obs://
- version 1.13.34
- Return '107' if some rpm %post configuration script failed
(bsc#1047233)
- version 1.13.33


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >