Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
Re: [opensuse-factory] Digest verification failed - was New Tumbleweed snapshot 20170909 released!
Same here,

I've discarded and retried numerous times. No change.

Maybe the file Is corrupt on some mirrors?

cheers

w
On Monday, 11 September 2017 21:57:55 CEST Mari Donkers wrote:
Still files corrupted on server?

Retrieving: qemu-ipxe-1.0.0-1.1.noarch.rpm
.....................................................[done (570.7 KiB/s)]

Warning: Digest verification failed for file
'qemu-ipxe-1.0.0-1.1.noarch.rpm'
[/var/cache/zypp/packages/download.opensuse.org-oss/suse/noarch/qemu-ipxe-1.
0.0-1.1.noarch.rpm]

expected c04b57aa707b80ed5fa20cced01d7fd7946a34d0
but got 101bc1cc84b9894745a6089f6fe138623f2efd92

Accepting packages with wrong checksums can lead to a corrupted system
and in extreme cases even to a system compromise.

However if you made certain that the file with checksum '101b..' is
secure, correct
and should be used within this operation, enter the first 4 characters
of the checksum
to unblock using this file on your own risk. Empty input will discard
the file.

Unblock or discard? [101b/...? shows all options] (discard):

Best regards,
Mari

On 11-09-17 18:37, Dominique Leuenberger wrote:
Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&versi
on=Tumbleweed&build=20170909

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
Mesa (17.1.6 -> 17.2.0)
bind
brltty (5.4 -> 5.5)
device-mapper (1.02.141 -> 1.02.142)
dracut
iproute2 (4.12 -> 4.13)
libarchive (3.3.1 -> 3.3.2)
libgusb (0.2.10 -> 0.2.11)
libva
libva-gl
lvm2 (2.02.172 -> 2.02.173)
lynx
ocfs2-tools
open-iscsi
openldap2
openmpi
python-cryptography
python-ldap (2.4.42 -> 2.4.44)
python-pyasn1 (0.3.2 -> 0.3.4)
python-pyasn1-modules (0.0.11 -> 0.1.4)
wireshark
yast2-users (3.2.11 -> 3.2.12)

=== Details ===

==== Mesa ====
Version update (17.1.6 -> 17.2.0)
Subpackages: Mesa-dri-devel Mesa-libEGL-devel Mesa-libEGL1
Mesa-libGL-devel Mesa-libGL1 Mesa-libglapi0 Mesa-libglapi0-32bit
Mesa-libva libOSMesa8 libOSMesa8-32bit libgbm1 libvdpau_r300
libvdpau_r600 libvdpau_radeonsi libvulkan_radeon libwayland-egl1
libxatracker2

- u_svga-Fix-build-on-ppc64le.patch

* This let us compile the code on ppc64le, but it no-ops the log

function.

- update to 17.2.0

* many RADV/ANV Vulkan driver improvements
* Vulkan and OpenGL performance improvements
* more work towards OpenGL 4.6 compliance
* a wealth of other open-source driver improvements
* initial Raven Ridge support (used on Vega-class graphics)
* Intel Cannonlake Support

- adjusted archlinux_0001-Fix-linkage-against-shared-glapi.patch

==== bind ====
Subpackages: bind-chrootenv bind-doc bind-utils idnkit libbind9-140
libdns165 libidnkit1 libirs141 libisc160 libisccc140 libisccfg140
liblwres141

- Enable JSON statistics

==== brltty ====
Version update (5.4 -> 5.5)
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi
brltty-driver-espeak brltty-driver-speech-dispatcher
brltty-driver-xwindow libbrlapi0_6 python3-brlapi xbrlapi

- Update to version 5.5

+ HandyTech's Actilino is supported.
+ HumanWare's Braille Note Touch is supported.
+ The Orbit 20 is supported.

+ Various other changes; please read ChangeLog :
- Drop brltty-udev-rule.patch, brltty-polkit-fixes.patch,

brltty-5.0-speechd.diff,
brltty-5.4-latex-tables-executable.patch,
brltty-braillenote-usb.patch, brltty.format-error.patch,
brltty.makedev.patch, and brltty.ocaml.patch: fixed upstream.

- Add brltty-5.5-systemd-install.patch: fix systemd service

directory on lib64

- polkit policy is now named org.a11y.brlapi.policy
- API version is now 0.6.6
- Don't create rcbrltty (why were we symlinking a systemd unit

file here? Seems wrong)

- Update filename in /var/adm/update-messages to match documentation,

and build-compare pattern

==== device-mapper ====
Version update (1.02.141 -> 1.02.142)
Subpackages: libdevmapper-event1_03 libdevmapper1_03
libdevmapper1_03-32bit

- Dropped udev rule patches (bsc#1054363)

* dropped udev_rules-update.diff
* dropped device-mapper-dmsetup-export.patch
* dropped udev-Check-for-DM_NR_VALID_PATHS.patch
* dropped Import-ID_FS_XXX-variables-bnc909358.patch
* dropped 69-dm-lvm-metad.rules-Do-not-process-rules-for-multi.patch

- Dropped several not-upstreamed patches, some of them neither have

history reference nor patch header, some were temporary workaround
fix.
- device-mapper-gcc-warnings.patch
- device-mapper-type_punning.diff
- fix-closedown-before-thread-finish.patch
- libdm-iface-not-output-error-message-inside-retry-loop.patch
- pvcreate-enhance-the-error-message.patch
- pvmove_support_clustered_vg.diff
- version-plugins-in-libdir.patch

- Update to LVM2.2.02.173
- Sync our lvm.conf with V2.02.173

==== dracut ====

- 90multipath: Remove compat rule that is no longer needed (bsc#1054539)

* adds 0536-90multipath-drop-67-kpartx-compat.rules.patch

- Don't detect crc32.ko as built-in (bsc#1054538)

* adds 0537-dracut-init.sh-ignore-crc32.ko-in-builtin-test.patch

- Enable systemd-based core dumps for initrd (bsc#1054809)

* adds 0538-Enable-core-dumps-with-systemd-from-initrd.patch

- Add missing coreutils dependency for initrd macros (bsc#1055492).

==== iproute2 ====
Version update (4.12 -> 4.13)

- Update to new upstream release 4.13

* extended ack support
* ip monitor: support IFLA_EVENT
* many BPF improvements
* new command rdma
* fixes for issues reported by Coverity
* updated documentation and examples
* bridge: distinguish between ext. learned vs offloaded FDBs
* ip netns: make /var/run/netns bind-mount recursive
* geneve: support for modifying geneve device
* utils: return default family when rtm_family is not

RTNL_FAMILY_IPMR/IP6MR

* tc: m_tunnel_key: add csum/nocsum option
* tc filter: add support for chain index
* tc action: introduce support for goto chain action
* tc: flower: add support for tcp flags
* tc: add support for TRAP action
* tc: flower: add support for matching on ip tos and ttl
* ip: add support for GRE ignore-df knob
* ip route get: extend to return matching fib route
* ip route get: extend for mpls routes
* ss: enclose IPv6 address in brackets
* vti: print keys in hex not dotted notation

- Refresh

adjust-installation-directories-for-openSUSE-SLE.patch
split-link-and-compile-steps-for-binaries.patch

==== libarchive ====
Version update (3.3.1 -> 3.3.2)
Subpackages: bsdtar libarchive-devel libarchive13

- update to version 3.3.2

* NFSv4 ACL support for Linux (librichacl)

- fix-CVE-2017-14166.patch (boo#1057514)

==== libgusb ====
Version update (0.2.10 -> 0.2.11)

- Update to version 0.2.11:
+ New Features: Add g_usb_context_set_flags().
+ Bugfix: Fix the actual required GLib version.

==== libva ====
Subpackages: libva-drm1 libva-x11-1 libva1

- Fix RPM groups. Trim obvious "Linux" from description.
- Remove some %if..%endif blocks which are not necessary and

which do not affect the build.

==== libva-gl ====
Subpackages: libva-egl1 libva-glx1

- Fix RPM groups. Trim obvious "Linux" from description.
- Remove some %if..%endif blocks which are not necessary and

which do not affect the build.

==== lvm2 ====
Version update (2.02.172 -> 2.02.173)
Subpackages: liblvm2app2_2 liblvm2cmd2_02

- Dropped udev rule patches (bsc#1054363)

* dropped udev_rules-update.diff
* dropped device-mapper-dmsetup-export.patch
* dropped udev-Check-for-DM_NR_VALID_PATHS.patch
* dropped Import-ID_FS_XXX-variables-bnc909358.patch
* dropped 69-dm-lvm-metad.rules-Do-not-process-rules-for-multi.patch

- Dropped several not-upstreamed patches, some of them neither have

history reference nor patch header, some were temporary workaround
fix.
- device-mapper-gcc-warnings.patch
- device-mapper-type_punning.diff
- fix-closedown-before-thread-finish.patch
- libdm-iface-not-output-error-message-inside-retry-loop.patch
- pvcreate-enhance-the-error-message.patch
- pvmove_support_clustered_vg.diff
- version-plugins-in-libdir.patch

- Update to LVM2.2.02.173
- Sync our lvm.conf with V2.02.173

==== lynx ====

- Add --with-zlib and --with-bzip2 to configure, to allow

decompressing directly via zlib and support bzip2.

- Add libbz2-devel and zlib-devel to BuildRequires

==== ocfs2-tools ====

- Add fsck.ocfs2-fix-compile-error-when-glibc-upgrade.patch (bsc#1057008)

==== open-iscsi ====
Subpackages: iscsiuio

- Start iscsi logins before remote filesystems (bsc#1028323),

updating:
* open-iscsi-SUSE-latest.diff.bz2

==== openldap2 ====
Subpackages: libldap-2_4-2 libldap-2_4-2-32bit libldap-data
openldap2-client openldap2-devel

- updated
0014-ITS-8714-Send-out-EXTENDED-operation-message-from-back-sock.patch -
Added OpenLDAP new feature implementing OpenLDAP ITS#8714

0014-ITS-8714-Send-out-EXTENDED-operation-message-from-back-sock.patch

==== openmpi ====
Subpackages: openmpi-config openmpi-devel openmpi-libs

- Update _service to allow auto updates from github

==== python-cryptography ====
Subpackages: python2-cryptography python3-cryptography

- Disable memleak tests to fix build with OpenSSL 1.1 (bsc#1055478)

* add skip_openssl_memleak_test.patch

==== python-ldap ====
Version update (2.4.42 -> 2.4.44)

- update to upstream release 2.4.44

* GIL fix

- update to upstream release 2.4.43

* SASL bind fix

==== python-pyasn1 ====
Version update (0.3.2 -> 0.3.4)
Subpackages: python2-pyasn1 python3-pyasn1

- updated to upstream release 0.3.4

Revision 0.3.4, released 07-09-2017

- Fixed Native encoder to handle SEQUENCE/SET objects without

the componentType property

- Added missing component-less SEQUENCE/SET objects dict duck-typing
support - Fixed unnecessary duplicate tags detection at NamesType.tagMap
- Fixed crash at SEQUENCE and SEQUENCE OF CER encoder when running

in schemaless mode

- Fixed Character types instantiation from OctetString type -- double

unicode decoding may have scrambled the data
Revision 0.3.3, released 27-08-2017

- Improved ASN.1 types instantiation performance
- Improved BER/CER/DER decoder performance by not unconditionally casting

substrate into str/bytes.

- Fixed exponential index size growth bug when building ambiguous

NamedTypes tree

- Fixed constructed types decoding failure at BER codec if running

in schema-less mode

- Fixed crash on prettyPrint'ing a SEQUENCE with no defined components
- Fixed SetOf ordering at CER/DER encoder
- Fixed crash on conditional binascii module import
- Fix to TagSet hash value build

==== python-pyasn1-modules ====
Version update (0.0.11 -> 0.1.4)

- Update to upstream release 0.1.4

* more onversion pinning

- Update to upstream release 0.1.2

* Tests refactored into proper unit tests
* pem.readBase64fromText() convenience function added
* Pinned to pyasn1 0.3.4+

==== wireshark ====
Subpackages: libwireshark10 libwiretap7 libwscodecs1 libwsutil8
wireshark-ui-qt

- downgrade to lua51-devel in order to drop Lua 5.2 from Factory

(can't upgrade to 5.3 because that is still not supported)

==== yast2-users ====
Version update (3.2.11 -> 3.2.12)

- Do not freeze while parsing authorized_keys (bsc#1053564)
- 3.2.12


--
„Stäbchen nahe seiner Mitte packen. Spitzes Ende im Mund anfeuchten. In
Zahnzwischenraum einführen, stumpfe Seite dicht am Zahnfleisch. Vorsichtig hin
und her bewegen.“
-
„Mir schien“, sagte Wonko der Verständige, „eine Zivilisation die so weit den
Verstand verloren hat, dass sie eine Reihe detaillierter Anweisungen nötig
hat, um ein Päckchen Zahnstocher zu benutzen, ist keine Zivilisation, in der
ich noch leben und bei Verstand bleiben kann.“
< Previous Next >
Follow Ups