Mailinglist Archive: opensuse-factory (331 mails)

< Previous Next >
Re: [opensuse-factory] Re: Next steps for Firefox on TW
Hi,

Am 04.09.2017 um 12:18 schrieb Andreas Stieger:
On 08/11/2017 09:51 AM, Wolfgang Rosenauer wrote:
- (almost) missing NPAPI support:
I know there are quite some people who rely on Java plugins still.
This fact leads to a requirement to add Firefox ESR to TW in parallel.
(Please let me know if you don't think so ;-))

I do not think may people care fatally, or if they do they we may still
take the decision to longer offer it in Tumbleweed.

ok, fine for me. So first update to >= 55 and then see if we really need to
provide ESR52.

- Firefox 52 and 55 profiles are incompatible (more specific backwards
incompatible)

There is some info in that:
https://bugzilla.opensuse.org/show_bug.cgi?id=1053314#c3

 Firefox profiles for version 55+ can be "refreshed" to work with
Firefox 52 via about:support (though I have not tested this
personally).  Presumably this would also work for certain other "old"
versions of Firefox.  See:
https://bugzilla.mozilla.org/show_bug.cgi?id=1357428#c2

As far as I know the "refresh" function just resets _everything_ to default. So
the user will lose most of his personal settings doing so but then honestly I
haven't tried it yet.

- it's technically possible to update MozillaFirefox to 55.0 now

I think this should be done now for Tumbleweed, and the fast release
cycle be followed going forward in Tumbleweed. This is entirely within
the Tumbleweed development model and positioning. I also think we do not
need to ship an ESR version in parallel on TW.

ok, we'll move on like this but only in a few days since I'm currently away with
limited chances to do anything.


Wolfgang
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
References