Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
Re: [opensuse-factory] New Tumbleweed 20170815 the missing lua dependencies
  • From: Stratos Zolotas <strzol@xxxxxxxxx>
  • Date: Wed, 16 Aug 2017 20:33:07 +0300
  • Message-id: <CAOvAxR=_FBq_D6a_y5PnEYYc4KOzZWn9Ryr9h4KJzynx=7WyxQ@mail.gmail.com>
I had similar issues and a file conflict because I selected to keep
obsolete packages, probably they are related.

Computing distribution upgrade...
2 Problems:
Problem: kodi-17.3-2.1.x86_64 requires libtag1 = 1.11, but this
requirement cannot be provided
Problem: mpv-0.25.0-8.3.x86_64 requires liblua.so.5.1()(64bit), but
this requirement cannot be provided

Problem: kodi-17.3-2.1.x86_64 requires libtag1 = 1.11, but this
requirement cannot be provided
deleted providers: libtag1-1.11-1.5.x86_64
Solution 1: deinstallation of kodi-17.3-2.1.x86_64
Solution 2: keep obsolete libtag1-1.11-1.5.x86_64
Solution 3: break kodi-17.3-2.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c): 2

Problem: mpv-0.25.0-8.3.x86_64 requires liblua.so.5.1()(64bit), but
this requirement cannot be provided
deleted providers: liblua5_1-5.1.5-13.12.x86_64
Solution 1: Following actions will be done:
deinstallation of mpv-0.25.0-8.3.x86_64
deinstallation of mpv-bash-completion-3.3.13-8.3.noarch
deinstallation of mpv-zsh-completion-0.25.0-8.3.noarch
deinstallation of smplayer-skins-15.2.0-1.9.noarch
deinstallation of smplayer-lang-17.7.0-1.1.noarch
Solution 2: keep obsolete liblua5_1-5.1.5-13.12.x86_64
Solution 3: break mpv-0.25.0-8.3.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c): 2
Resolving dependencies...
Computing distribution upgrade...
2 Problems:
Problem: taglib-1.11.1-1.1.x86_64 requires libtag1 = 1.11.1-1.1, but
this requirement cannot be provided
Problem: kodi-17.3-2.1.x86_64 requires libtag1 = 1.11, but this
requirement cannot be provided

Problem: taglib-1.11.1-1.1.x86_64 requires libtag1 = 1.11.1-1.1, but
this requirement cannot be provided
uninstallable providers:
libtag1-1.11.1-1.1.i586[http-download.opensuse.org-2f924f4b]

libtag1-1.11.1-1.1.x86_64[http-download.opensuse.org-2f924f4b]
libtag1-1.11.1-1.1.i586[repo-oss]
libtag1-1.11.1-1.1.x86_64[repo-oss]
Solution 1: keep obsolete taglib-1.11-1.5.x86_64
Solution 2: remove lock to allow removal of libtag1-1.11-1.5.x86_64
Solution 3: break taglib-1.11.1-1.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c): 1

Problem: kodi-17.3-2.1.x86_64 requires libtag1 = 1.11, but this
requirement cannot be provided
deleted providers: libtag1-1.11-1.5.x86_64
Solution 1: deinstallation of amarok-2.8.0-26.2.x86_64
Solution 2: deinstallation of kodi-17.3-2.1.x86_64
Solution 3: keep obsolete libtag_c0-1.11-1.5.x86_64
Solution 4: break kodi-17.3-2.1.x86_64 by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/4/s/r/c] (c): 3
Resolving dependencies...
Computing distribution upgrade...

The following 4 items are locked and will not be changed by any action:
Installed:
liblua5_1 libtag1 libtag_c0 taglib

Checking for file conflicts:
................................................................................[error]
Detected 1 file conflict:

File /usr/lib/liblua.so.5.3
from install of
liblua5_3-5-32bit-5.3.4-1.1.x86_64 (openSUSE:Tumbleweed)
conflicts with file from package
liblua5_3-32bit-5.3.3-2.2.x86_64 (@System)

File conflicts happen when two packages attempt to install files with
the same name but different contents. If you continue, conflicting
files will be replaced losing the previous content.
Continue? [yes/no] (no): yes


On Wed, Aug 16, 2017 at 7:50 PM, Bruno Friedmann <bruno@xxxxxxxxxxx> wrote:
Beside a constant flow of obs build error due to missing lua53 from diverse
project trying to install the snapshot give some errors in term of deps.

Problem: pandoc-1.19.2.1-6.6.x86_64 requires liblua.so.5.1()(64bit), but this
requirement cannot be provided
deleted providers: liblua5_1-5.1.5-13.12.x86_64
Solution 1: Following actions will be done:
deinstallation of pandoc-1.19.2.1-6.6.x86_64
deinstallation of libmpv1-0.25.0-8.3.x86_64
deinstallation of ghc-hslua-0.4.1-2.15.x86_64
deinstallation of python3-pandocfilters-1.4.1-1.1.noarch
deinstallation of python3-jupyter_nbconvert-5.1.1-1.2.noarch
deinstallation of subtitlecomposer-lang-0.6.4-5.4.noarch
deinstallation of python3-jupyter_notebook-5.0.0-1.2.noarch
Solution 2: keep obsolete liblua5_1-5.1.5-13.12.x86_64

Pandoc is coming for oss repository ?

My choice was CTRL+C
as information I'm using a --no-recommend way of life.

I'm afraid to not know against which component reporting a bug ?
Any thoughs.

I guess, due to the quality of the work done globally at openSUSE project that
in one day or 2 it will simply resolve by itself.
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >