Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
Re: [opensuse-factory] NVIDIA gfx driver RPMs available for Tumbleweed ...
Stefan Dirsch [10.08.2017 11:11]:
On Thu, Aug 10, 2017 at 10:07:47AM +0200, Werner Flamme wrote:
Stefan Dirsch [09.08.2017 15:56]:
Hi

Since yesterday there are NVIDIA gfx driver RPMs available for
Tumbleweed. Feel free to give them a try by adding the repository
manually via

zypper ar https://download.nvidia.com/opensuse/tumbleweed
nvidia-tumbleweed

Stefan,

until yesterday I used the "Alternative, based on OBS" on page
<https://en.opensuse.org/SDB:NVIDIA_the_hard_way> for my Leap
host, since I use obs://Kernel:/stable/standard here (due to
Skylake, which is not covererd by the 4.4 kernel).

Yesterday I tried to rebuild, but I don't get all files from it. I
only get

nvidia-gfxG04-384.59-0.nosrc.rpm
nvidia-gfxG04-kmp-default-384.59_k4.11.8_2-0.x86_64.rpm

Seems you haven't read the README file referenced on this Wiki page.
You need to specify the right specfile for the build to generate also
the userspace packages.

I read, and I used both commands for x86_64. Only the output was ... not
satisfying.

But this was yesterday, and today - using the commands from
.bash_history - it works... I hate cases like that, irreproducible
failures :-\ Now there are

nvidia-computeG04-384.59-0.x86_64.rpm
nvidia-gfxG04-384.59-0.nosrc.rpm
nvidia-gfxG04-kmp-default-384.59_k4.11.8_2-0.x86_64.rpm
nvidia-glG04-384.59-0.x86_64.rpm
x11-video-nvidiaG04-384.59-0.nosrc.rpm
x11-video-nvidiaG04-384.59-0.x86_64.rpm

BTW, there are some warnings during build, and one error:

---snip---
[ 204s] nvidia-gfxG04-kmp-default.x86_64: E: spurious-executable-perm
(Badness: 50)
/usr/src/kernel-modules/nvidia-384.59-default/nvidia-uvm/uvm8_get_rm_ptes_test.c
[ 204s] The file is installed with executable permissions, but was
identified as one
[ 204s] that probably should not be executable. Verify if the
executable bits are
[ 204s] desired, and remove if not. NOTE: example scripts should be
packaged under
[ 204s] %docdir/examples, which will avoid this warning.
---pins---

The packages are built, though :)

In case you try the RPMs once more, please run "nvidia-installer
--uninstall" before.

I will do at home.

Before using the nvidia-installer, I tried to run my box using the
modules from the new TW repo. I didn't get any better output than
before. Whatever was broken, nvidia-installer fixed it.

Thank you!

Werner

--


< Previous Next >