Mailinglist Archive: opensuse-factory (649 mails)

< Previous Next >
Re: [opensuse-factory] External Drive for a Backup - errors
Hello,

Am Dienstag, 8. August 2017, 18:31:00 CEST schrieb james:
Vojtěch Zeisek:
Dne úterý 8. srpna 2017 18:19:00 CEST, james napsal(a):
Vojtěch Zeisek:
Dne úterý 8. srpna 2017 13:44:00 CEST, james napsal(a):

Duplicity requires several Python packages. If I remember
correctly, I had to manually install python-paramiko,
python-pycrypto, python-ecdsa, might be something else. After it
duplicity worked correctly. I think, as it has many
possibilities, it doesn't have these packages as required.

Did you ask/tell the package maintainer about these dependencies? They
are not even listed as Recommends, so IMHO this might count as a bug.

I install as many as the ones you mentioned plus a few from some
web
sites and I still get this:

http://susepaste.org/89123762

This is weird. What is the complete command? Do all backed up files
have names with only ASCII characters?

It is just a GUI program. No commands that I'm currently aware of. The
files I want are from my /home dir.

Reading the backtrace indicates that Vojtěch's question points in the
right direction - duplicity probably fails at a filename that is not
valid utf-8.

Unfortunately the error handler also breaks at the invalid utf-8 which
makes debugging this harder :-(

You can try comment out line 79 of /usr/lib64/python2.7/site-packages/
duplicity/util.py by prepending a #
# e = unicode(e).encode('utf-8')

This won't fix your problem, but with some luck you'll at least get a
useful error message ;-)

Please open a bugreport for duplicity - assuming that filenames are
always valid utf-8 is quite optimistic. Handling them as binary is a
better idea.


Regards,

Christian Boltz
--
für die Bewertung des Risikos gilt Martins Hypothese:
Das Risiko ist proportional zur Größe der Schlagzeile in der
BILD-Zeitung. [Martin zu
http://blog.koehntopp.de/archives/3211-Wieso-wir-uns-veroeffentlichen.html]

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >