Mailinglist Archive: opensuse-factory (724 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170728 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170728

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
GraphicsMagick
evince (3.24.0 -> 3.24.1)
gdm
gnome-control-center (3.24.2 -> 3.24.3)
gnome-session
gnome-settings-daemon (3.24.2 -> 3.24.3)
gthumb
k3b
libqt5-qtdeclarative
libreoffice (5.4.0.2 -> 5.4.0.3)
mcelog (1.48 -> 1.53)
mosh (1.3.0 -> 1.3.2)
mpg123 (1.25.3 -> 1.25.4)
nasm
patterns-kde
patterns-media
polkit-default-privs
rsync
samba (4.6.5+git.32.af7a173b7a1 -> 4.6.6+git.36.67c8c47724e)
sshfs (2.8 -> 2.9)
tcpdump (4.9.0 -> 4.9.1)
vcdimager
webkit2gtk3 (2.16.5 -> 2.16.6)
xdm
xdmbgrd

=== Details ===

==== GraphicsMagick ====
Subpackages: GraphicsMagick-devel libGraphicsMagick-Q16-3
libGraphicsMagick3-config libGraphicsMagickWand-Q16-2

- Trim descriptions. Redo summaries and RPM groups.

==== evince ====
Version update (3.24.0 -> 3.24.1)
Subpackages: evince-plugin-comicsdocument evince-plugin-djvudocument
evince-plugin-dvidocument evince-plugin-pdfdocument evince-plugin-psdocument
evince-plugin-tiffdocument evince-plugin-xpsdocument libevdocument3-4
libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0

- Update to version 3.24.1:
+ Remove support for tar and tar-like commands in commics backend
(CVE-2017-1000083, bgo#784630).
+ Improve performance of the links sidebar (bgo#779614).
+ Improve performance of scrolling in thumbnails sidebar
(bgo#691448).
+ Don't copy remote files before thumbnailing (bgo#780351).
+ Fix toggling layers that are not in the current visible range
of pages (bgo#780139).
+ Fix ev_page_accessible_get_range_for_boundary() to ensure the
start and end offsets it returns are within the allowed range
(bgo#777992).
+ Fix crash with Orca screen reader (bgo#777992).
+ Updated translations.
- Drop evince-comics-remove-tar-commands-support.patch: Fixed
upstream.
- Following the above: Drop libtool BuildRequires and stop passing
autoreconf, no longer needed as we do not carry any patches.

==== gdm ====
Subpackages: gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Do not BuildRequire pkgconfig(xorg-server) on s390(x). There are
no graphic devices on s390x and Xorg is not in use.

==== gnome-control-center ====
Version update (3.24.2 -> 3.24.3)
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-user-faces

- Update to version 3.24.3:
+ Memory leak and correctness fixes.
+ Network:
- Update connection titles when they change.
- Sort connections by title.
+ Wacom:
- Make the calibrator only reactive to the tablet being
calibrated.
- Fix undesired cursor offsets after the calibration is
applied.
- Recognize and pair pad devices with others on the same
tablet.
+ Updated translations.

==== gnome-session ====
Subpackages: gnome-session-core gnome-session-default-session

- Do not build wayland subpackage on s390/s390x, xwayland doesn't
exist there [bsc#1047173].

==== gnome-settings-daemon ====
Version update (3.24.2 -> 3.24.3)

- Update to version 3.24.3:
+ Color: Fix smearing out of Night Light effect.
+ Keyboard: Only add the "us" layout if the system config cannot
be determined.
+ Media-keys: Fix grabbing of previously disabled shortcuts.
+ Wacom:
- Fix touchscreens being assigned the wrong output.
- Exclude non-display attached devices from remapping.
- Disable gnome-settings-daemon-initial-keyboard.patch: Needs
rebase.

==== gthumb ====
Subpackages: gthumb-lang

- Forcefully enable PIE in the spec file, as the configure uses
- fPIC, which disables are automatism.

==== k3b ====

- Add Don-t-suggest-to-install-libburn.patch to not suggest to the
user to install libburn on startup. The message is actually
misleading as k3b would actually use cdrskin which is packaged
separately in openSUSE. But let's stick to prefer the proven
cdrecord for now, people can still install cdrskin if they'd
prefer to use it. (boo#1050715)

==== libqt5-qtdeclarative ====
Subpackages: libQtQuick5 libqt5-qtdeclarative-devel libqt5-qtdeclarative-tools

- Add patch to revert upstream commit introducing a massive memory
leak (QTBUG-62117):
* revert-delay-deletion-of-qsgtextures.patch

==== libreoffice ====
Version update (5.4.0.2 -> 5.4.0.3)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-draw
libreoffice-filters-optional libreoffice-gnome libreoffice-gtk3
libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-sifr
libreoffice-icon-theme-tango libreoffice-impress libreoffice-kde4
libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de libreoffice-l10n-el
libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr libreoffice-l10n-hu
libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-pt_BR libreoffice-l10n-ru libreoffice-l10n-zh_CN
libreoffice-l10n-zh_TW libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreofficekit

- Version update to 5.4.0.3:
* More bugfixes on 5.4 branch for the final release

==== mcelog ====
Version update (1.48 -> 1.53)

- Update to version 1.53:
* Add service file
* dmi: Handle NULL DMI string
* Compress some fields in mempage.
* Add coverity fixes
* Fix typo in man page
* mcelog: Check whether we successfully changed directory for trigger.
* mcelog version: Add ability for OS to define version
* Document .os_release in README
* Set SO_PASSCRED on listen sockets
* memutil.h: add missing include for va_list

==== mosh ====
Version update (1.3.0 -> 1.3.2)

- Update to version 1.3.2:
* Platform support:
+ Explicitly enable binding to both IPv4 and IPv6 addresses.
(Giel van Schijndel)
+ Restore perl 5.8.8 support for RHEL5.
(Alexander Chernyakhovsky)
+ Make tests detect UTF-8 locale with a helper executable.
(John Hood)
+ Don't print /etc/motd on IllumOS. (John Hood)
+ Print {,/var}/run/motd.dynamic on Ubuntu. (John Hood)
+ Fix build on Haiku. (Adrien Destugues)
+ Disable unicode-later-combining.test for tmux 2.4.
This fixes build failures. (John Hood)
* Bug fixes:
+ In tests, explicitly set 80x24 tmux window, for newer versions
of tmux. (John Hood)
+ Work around JuiceSSH rendering bug. (John Hood)
+ Do not move cursor for SCROLL UP and SCROLL DOWN--
fixes an issue with tmux 2.4. (John Hood)

==== mpg123 ====
Version update (1.25.3 -> 1.25.4)
Subpackages: libmpg123-0 libmpg123-0-32bit mpg123-esound mpg123-openal
mpg123-pulse

- Update to version 1.25.4
libmpg123:
* Prevent harmless call to memcpy(NULL, NULL, 0).
* More early checking of ID3v2 encoding values to avoid bogus
text being stored.

==== nasm ====

- memory_fixes.patch: Fix usage-after-free and buffer overflow
bugs (bsc#1047925, bsc#1047936, CVE-2017-11111, CVE-2017-10686)
- Restrict %fdupes to manpage directory
- Enable unit tests in %check target

==== patterns-kde ====
Subpackages: patterns-kde-devel_kde patterns-kde-devel_kde_frameworks
patterns-kde-devel_qt5 patterns-kde-kde patterns-kde-kde_edutainment
patterns-kde-kde_games patterns-kde-kde_ide patterns-kde-kde_imaging
patterns-kde-kde_internet patterns-kde-kde_multimedia patterns-kde-kde_office
patterns-kde-kde_plasma patterns-kde-kde_telepathy patterns-kde-kde_utilities
patterns-kde-kde_utilities_opt patterns-kde-kde_yast
patterns-kde-sw_management_kde

- Drop libtunepimp-devel from suggestions

==== patterns-media ====

- Fluendo should not be needed anymore thus drop it
- Add the x86 pattern to the DVD - it provides glibc-32bit (needed
by steam and such) and used to be pulled in automatically until
we stopped adding glibc-32bit to the base pattern.

==== polkit-default-privs ====

- Added new tuned method verify_profile_ignore_missing (bnc#1048961)

==== rsync ====

- Try more in supporting all scenarios bsc#1046197#c24
* rsync-both-compressions.patch

==== samba ====
Version update (4.6.5+git.32.af7a173b7a1 -> 4.6.6+git.36.67c8c47724e)
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit
libsmbclient-devel libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap0
libsmbldap0-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-libs
samba-libs-32bit samba-winbind samba-winbind-32bit

- fix cephwrap_chdir(); (bsc#1048790).
- Update to 4.6.6
+ CVE-2017-11103: Orpheus' Lyre KDC-REP service name validation;
(bsc#1048278).

==== sshfs ====
Version update (2.8 -> 2.9)

- update to 2.9
* various bugfixes

==== tcpdump ====
Version update (4.9.0 -> 4.9.1)

- Disable ikev2pI2 test that fails on ppc, ppc64 and ppc64le
* Added patch tcpdump-ikev2pI2-test-fails-ppc.patch
- Update to version 4.9.1 [bsc#1047873]
* CVE-2017-11108/Fix bounds checking for STP.
* Make assorted documentation updates and fix a few typos in output.
* Fixup -C for file size >2GB
* Show AddressSanitizer presence in version output.
* Fix a bug in test scripts.
* Fix a use-after-free when the requested interface does not exist.

==== vcdimager ====
Subpackages: libvcdinfo0

- Fix scriptlet running order

==== webkit2gtk3 ====
Version update (2.16.5 -> 2.16.6)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.16.6:
+ Fix rendering of spin buttons with GTK+ >= 3.20 when the entry
width is too short.
+ Fix the build when Wayland target is enabled and X11 disabled.
+ Fix several crashes and rendering issues.
+ Security fixes: CVE-2017-7039, CVE-2017-7018, CVE-2017-7030,
CVE-2017-7037, CVE-2017-7034, CVE-2017-7055, CVE-2017-7056,
CVE-2017-7064, CVE-2017-7061, CVE-2017-7048, CVE-2017-7046.

==== xdm ====
Subpackages: xdm-xsession

- fix usage of readlink in Xsession (boo#1050328)
- %post
* make previous change in /etc/sysconfig/displaymanager instead
of /var/adm/fillup-templates/sysconfig.displaymanager
- %post
* Do no try to start Xserver on platforms which may ship without
graphics card (bsc#1039497)

==== xdmbgrd ====

- Update xdmbgrd-piggyback.dif to not include PID in piggyback
temp filenames to generate reproducible output


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages