Mailinglist Archive: opensuse-factory (603 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170706 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170706

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
PackageKit
attica-qt5 (5.34.0 -> 5.35.0)
audacity
automake (1.15 -> 1.15.1)
baloo5 (5.34.0 -> 5.35.0)
bluez-qt (5.34.0 -> 5.35.0)
breeze5-icons (5.34.0 -> 5.35.0)
extra-cmake-modules (5.34.0 -> 5.35.0)
frameworkintegration (5.34.0 -> 5.35.0)
geany (1.30 -> 1.30.1)
gettext-runtime
gnome-characters (3.22.0 -> 3.24.0)
kactivities-stats (5.34.0 -> 5.35.0)
kactivities5 (5.34.0 -> 5.35.0)
karchive (5.34.0 -> 5.35.0)
kauth (5.34.0 -> 5.35.0)
kbookmarks (5.34.0 -> 5.35.0)
kcmutils (5.34.0 -> 5.35.0)
kcodecs (5.34.0 -> 5.35.0)
kcompletion (5.34.0 -> 5.35.0)
kconfig (5.34.0 -> 5.35.0)
kconfigwidgets (5.34.0 -> 5.35.0)
kcoreaddons (5.34.0 -> 5.35.0)
kcrash (5.34.0 -> 5.35.0)
kdbusaddons (5.34.0 -> 5.35.0)
kdeclarative (5.34.0 -> 5.35.0)
kded (5.34.0 -> 5.35.0)
kdelibs4support (5.34.0 -> 5.35.0)
kdesignerplugin (5.34.0 -> 5.35.0)
kdesu (5.34.0 -> 5.35.0)
kdewebkit (5.34.0 -> 5.35.0)
kdnssd-framework (5.34.0 -> 5.35.0)
kdoctools (5.34.0 -> 5.35.0)
kemoticons (5.34.0 -> 5.35.0)
kfilemetadata5 (5.34.0 -> 5.35.0)
kglobalaccel (5.34.0 -> 5.35.0)
kguiaddons (5.34.0 -> 5.35.0)
khtml (5.34.0 -> 5.35.0)
ki18n (5.34.0 -> 5.35.0)
kiconthemes (5.34.0 -> 5.35.0)
kidletime (5.34.0 -> 5.35.0)
kimageformats (5.34.0 -> 5.35.0)
kinit (5.34.0 -> 5.35.0)
kio (5.34.0 -> 5.35.0)
kitemmodels (5.34.0 -> 5.35.0)
kitemviews (5.34.0 -> 5.35.0)
kjobwidgets (5.34.0 -> 5.35.0)
kjs (5.34.0 -> 5.35.0)
kjsembed (5.34.0 -> 5.35.0)
kmediaplayer (5.34.0 -> 5.35.0)
knewstuff (5.34.0 -> 5.35.0)
knotifications (5.34.0 -> 5.35.0)
knotifyconfig (5.34.0 -> 5.35.0)
kpackage (5.34.0 -> 5.35.0)
kparts (5.34.0 -> 5.35.0)
kpeople5 (5.34.0 -> 5.35.0)
kplotting (5.34.0 -> 5.35.0)
kpty (5.34.0 -> 5.35.0)
kross (5.34.0 -> 5.35.0)
krunner (5.34.0 -> 5.35.0)
kservice (5.34.0 -> 5.35.0)
ktexteditor (5.34.0 -> 5.35.0)
ktextwidgets (5.34.0 -> 5.35.0)
kunitconversion (5.34.0 -> 5.35.0)
kwallet (5.34.0 -> 5.35.0)
kwayland (5.34.0 -> 5.35.0)
kwidgetsaddons (5.34.0 -> 5.35.0)
kwindowsystem (5.34.0 -> 5.35.0)
kxmlgui (5.34.0 -> 5.35.0)
kxmlrpcclient5 (5.34.0 -> 5.35.0)
libKF5ModemManagerQt (5.34.0 -> 5.35.0)
libKF5NetworkManagerQt (5.34.0 -> 5.35.0)
libtunepimp
lightdm
oxygen5-icon-theme (5.34.0 -> 5.35.0)
plasma-framework (5.34.0 -> 5.35.0)
prison-qt5 (5.34.0 -> 5.35.0)
solid (5.34.0 -> 5.35.0)
sonnet (5.34.0 -> 5.35.0)
syntax-highlighting (5.34.0 -> 5.35.0)
threadweaver (5.34.0 -> 5.35.0)
yast2-trans (84.87.20170627.4e7fec5c -> 84.87.20170703.c20fb749)

=== Details ===

==== PackageKit ====
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module libpackagekit-glib2-18 typelib-1_0-PackageKitGlib-1_0

- Explicitly call autoreconf, as one of the patches touches the
build system. As long as the version of automake available is the
same as was used to bootstrap the tarball, there is no issue, but
if the version changes, the call must be explicit.
- Add autoconf-archive BuildRequires in order to actually be able
to successfully bootstrap.

==== attica-qt5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Improve error notification

==== audacity ====
Subpackages: audacity-lang

- Adjust usage of gccN-c++ for Leap42 and SLE12

==== automake ====
Version update (1.15 -> 1.15.1)

- Update to version 1.15.1:
* The code has been adapted to remove a warning present since
Perl 5.22 stating that "Unescaped left brace in regex is
deprecated". This warning has become an hard error in Perl 5.26
* The generated Makefiles do not rely on the obsolescent GZIP
environment variable which was used for passing arguments to
'gzip'. Compatibility with old versions has been preserved.
* Miscellaneous changes:
- Drop no longer needed patches:
* automake-perl-5.22.patch
* automake-fix-tests-gzip.patch
- Add keyring
- Small spec file cleanup

==== baloo5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Fix title of FAQ doc

==== bluez-qt ====
Version update (5.34.0 -> 5.35.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Pass an explicit list of arguments. This prevents QProcess from trying to
handle our space containing path through a shell
* Fix property changes being missed immediately after an obejct is added
(kde#377405)

==== breeze5-icons ====
Version update (5.34.0 -> 5.35.0)

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* update awk mime as it's a script language BUG:376211 (kde#376211)
* CMakeLists.txt - Do not find bash on Windows

==== extra-cmake-modules ====
Version update (5.34.0 -> 5.35.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* restore hidden-visibility testing with Xcode 6.2
* ecm_qt_declare_logging_category(): more unique include guard for header
* Drop modules from attic that are not useful anymore
* Add or improve "Generated. Don't edit" messages and make consistent
* Add a new FindGperf module
* Change default pkgconfig install path for FreeBSD

==== frameworkintegration ====
Version update (5.34.0 -> 5.35.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== geany ====
Version update (1.30 -> 1.30.1)
Subpackages: geany-lang libgeany0

- Update to version 1.30.1
+ Editor: fix auto-completion and calltip popup position on
multi-monitor setups (gh#geany/geany#1422).
+ Updated translations.

==== gettext-runtime ====
Subpackages: gettext-tools

- Explicitly call autoreconf, as we have patches touching the build
system. Implicit calling automake/autoconf works only as long as
the version on the system is the same as was used to bootstrap
originally.

==== gnome-characters ====
Version update (3.22.0 -> 3.24.0)
Subpackages: gnome-shell-search-provider-gnome-characters

- Update to version 3.24.0:
+ characterList: Add NULL check for character name.
+ characterlist.ui: Improve the 'no result' strings.
+ searchProvider: add clipboardText to result meta.
+ categoryList: Make IBus detection robuster.
+ Updated translations.

==== kactivities-stats ====
Version update (5.34.0 -> 5.35.0)

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Fix kactivities-stats into tier3

==== kactivities5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use Q_DECL_OVERRIDE
* Add the Boost include directories to where the compiler is. Necessary to
fix Windows where Boost is not installed in standard lookup paths.

==== karchive ====
Version update (5.34.0 -> 5.35.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* [autotests] provide more debug output when qdatetime comparison fails
* Add .arcconfig
* API dox: note CamelCase includes by @class tag

==== kauth ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag value instead of nullptr
* Remove HelperProxy::authorizeAction
* Verify that whoever is calling us is actually who he says he is

==== kbookmarks ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kcmutils ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag constructor instead of nullptr

==== kcodecs ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use Q_FALLTHROUGH here
* API dox: note CamelCase includes by @class tag with more classes
* Use --key-positions instead of -k to fix Windows builds
* Generate gperf output at build time
* add .arcconfig

==== kcompletion ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: note CamelCase includes by @class tag with more classes

==== kconfig ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* tests: use QIODevice::Text in kconfigcompiler_test
* tests: use right QProcess API in kconfigcompiler_test
* API dox: note CamelCase includes by @class tag with more classes

==== kconfigwidgets ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: add some minimal docs to more namespace
* API dox: note CamelCase includes by @class tag with more classes

==== kcoreaddons ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Fixes to 26a262180155
* Ensure proper per thread seeding in KRandom.
* API dox: in example use KDBusService only after commandline is handled
* API dox: Use doxygen notation to have comments used
* API dox: add some minimal docs to more namespace
* API dox: note CamelCase includes by @class tag with more classes
* Remove qDebug from removeDir/removeFile as discussed in
https://phabricator.kde.org/D5856
* Do not watch QRC's paths (kde#374075)

==== kcrash ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag constructor instead of nullptr

==== kdbusaddons ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: add some minimal docs to namespace KDBusConnectionPool
* API dox: note CamelCase includes by @class tag with more classes
* Don't include the pid in the dbus path when on flatpak

==== kdeclarative ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Add upstream patch to account for behavioural change in Qt 5.8+
regarding ungrab events:
* 0001-Don-t-rely-on-QQuickWindow-delivering-QEvent-Ungrab-.patch
- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Consistently emit MouseEventListener::pressed signal
* Use explicit flag constructor instead of nullptr
* Don't leak MimeData object (kde#380270)
* API Dox: note forwarding CamelCase files as class headers
* API Dox: add some non-empty class/namespace docs where missing

==== kded ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kded-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kdelibs4support ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Register is deprecated
* tests: use right QProcess API in kmimetypetest
* Same treatment for the configure_file part of that statement too
* Handle having spaces in the path to CMAKE_SOURCE_DIR

==== kdesignerplugin ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kdesu ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API Dox: note forwarding CamelCase files as class headers

==== kdewebkit ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kdnssd-framework ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kdoctools ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kdoctools-devel libKF5DocTools5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* add entity kmplayer

==== kemoticons ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Fix: Qt5::DBus is only privately used

==== kfilemetadata5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kfilemetadata5-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* use /usr/bin/env to locate python2
* Use right QProcess API
* fix build against Android NDK (API Level 21 is required)

==== kglobalaccel ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kguiaddons ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: Use doxygen notation to have comments used
* API dox: add some minimal docs to more namespaces
* API dox: note CamelCase includes by @class tag

==== khtml ====
Version update (5.34.0 -> 5.35.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Generate kentities gperf output at build time
* Pass `--key-positions=*` to gperf instead of `-k *` because on Windows this
symbol seems to have a special meaning.
* Generate doctypes gperf output at build time

==== ki18n ====
Version update (5.34.0 -> 5.35.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Fix compilation of Python bindings
* API dox: note CamelCase includes by @class tag with more classes
* Extend Programmer's Guide with notes about influence of setlocale()

==== kiconthemes ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* tests: be safer when using QDir::removeRecursively() on teardown
* API dox: note CamelCase includes by @class tag with more classes

==== kidletime ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: fix missing \endlink as needed with \link
* API dox: note CamelCase includes by @class tag

==== kimageformats ====
Version update (5.34.0 -> 5.35.0)

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use Q_FALLTHROUGH

==== kinit ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kinit-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kio ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kio-core kio-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Too many changes to list here
- Dropped patches, now upstream:
* 0001-Identify-PIE-binaries-application-x-sharedlib-as-exe.patch

==== kitemmodels ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flags constructor instead of confusing nullptr
* Update link from websvn.kde.org to commits.kde.org
* API dox: note CamelCase includes by @class tag with more classes

==== kitemviews ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Return QModelIndex() here.
* API dox: note CamelCase includes by @class tag with more classes

==== kjobwidgets ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: note CamelCase includes by @class tag with more classes

==== kjs ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kjsembed ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kmediaplayer ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== knewstuff ====
Version update (5.34.0 -> 5.35.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuffCore5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use a single QNAM (and a disk cache) for HTTP jobs
* Internal cache for provider data on initialisation
* Improve some error messages

==== knotifications ====
Version update (5.34.0 -> 5.35.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag constructor instead of nullptr/0
* Fix KSNIs being unable to register service under flatpak
* API dox: note CamelCase includes by @class tag with more classes
* Remove unneeded string casts
* Use application name instead of pid when creating SNI dbus service

==== knotifyconfig ====
Version update (5.34.0 -> 5.35.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kpackage ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kpackage-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: NULL pointer -> null pointer
* API dox: Use doxygen notation to have comments used
* API dox: note CamelCase includes by @class tag with more classes

==== kparts ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag values or explicit constructor instead of nullptr

==== kpeople5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kpeople5-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Do not export symbols from private libraries
* limit #warning to GCC, part #2
* Fix symbol exporting for KF5PeopleWidgets
* limit #warning to GCC
* Fix symbol exporting for KF5PeopleBackend

==== kplotting ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kpty ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== kross ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kross-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== krunner ====
Version update (5.34.0 -> 5.35.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Use explicit flag value instead of nullptr
* API dox: fix note of CamelCase includes, now prefixed with KRunner

==== kservice ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kservice-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: Use doxygen notation to have comments used
* API dox: note CamelCase includes by @class tag with more classes

==== ktexteditor ====
Version update (5.34.0 -> 5.35.0)
Subpackages: ktexteditor-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Add Q_FALLTHROUGH
* Add missing break
* Unbreak KateSyntaxTest in paths with dots, check only dir entry name for .
* Revert "Add temporary debug output for investigating KateSyntaxTest fail on
CI"
* Add temporary debug output for investigating KateSyntaxTest fail on CI
* Remove duplicated path separator
* Unbreak autotests in paths with spaces, properly escape " chars
* Use explicit flag values or explicit constructor instead of nullptr

==== ktextwidgets ====
Version update (5.34.0 -> 5.35.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* API dox: use class names in image titles, not "KDE widget"
* API dox: note CamelCase includes by @class tag with more classes
* API dox: Use doxygen notation to have comments used
* Fix typo

==== kunitconversion ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* No longer a need for separate KUnitConversion_namespaced_HEADERS var

==== kwallet ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Replace kwalletd4 after migration has finished
* Signal completion of migration agent
* Whitespace fixup
* Only start timer for migration agent if necessary
* Check for unique applicaton instance as early as possible

==== kwayland ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kwayland-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Autotests: solve warning for QProcess::ProcessState metatype registration
* Fix for TestQtSurfaceExtension in path with spaces
* API dox: add some minimal docs to more class to have them covered by doxygen
* API dox: add some minimal docs to class to have them covered by doxygen
* API dox: Use doxygen notation to have comments used
* API dox: fix @link usage
* add requestToggleKeepAbove/below
* Keep QIcon::fromTheme in main thread
* Remove pid changedSignal in Client::PlasmaWindow
* add pid to plasma window management protocol

==== kwidgetsaddons ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* KViewStateSerializer: Fix crash when view is destroyed before state
serializer (kde#353380)
* Use explicit flag values or explicit constructor instead of nullptr
* API dox: fix-up improvements for "null pointer" changes
* API dox: use "null pointer" instead of "0"
* API dox: document enum items directly, not by a separate free-text list
* API dox: fix wrong usage of @see for direct links
* API dox: use @see as last, for consistency
* API dox: move comment before namespace that is documented
* API dox: add some minimal content to have doxygen consider it documented

==== kwindowsystem ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Better fix for NetRootInfoTestWM in path with spaces
* Revert broken fix TestKWindowsystemPlatformWayland in path with spaces
* Un-bitrot debug code
* Fix TestKWindowsystemPlatformWayland & NetRootInfoTestWM in path with spaces
* use Q_FALLTHROUGH
* Use explicit flag values or explicit constructor instead of nullptr
* Add .arcconfig
* API dox: Fix usage of @link, using JavaDoc style

==== kxmlgui ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Set main window as parent of stand-alone popup menus
* API dox: Use doxygen notation to have comments used
* API dox: note CamelCase includes by @class tag with more classes
* use transientparent directly
* When building menu hyerarchies, parent menus to their containers

==== kxmlrpcclient5 ====
Version update (5.34.0 -> 5.35.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* cmake: fix building tests with MSVC

==== libKF5ModemManagerQt ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== libKF5NetworkManagerQt ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== libtunepimp ====
Subpackages: libtunepimp-devel libtunepimp5

- buildconditional for mad

==== lightdm ====
Subpackages: liblightdm-gobject-1-0 lightdm-lang

- Augment patch to also resolve the target of symlink sessions
for detemining the preselected option:
* ignore-known-symlink-sessions.patch

==== oxygen5-icon-theme ====
Version update (5.34.0 -> 5.35.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Remove obviously wrongly-named symbolic links

==== plasma-framework ====
Version update (5.34.0 -> 5.35.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* src/plasmaquick/dialog.cpp - fix build without kwayland
* Add VLC tray icon
* Small improvements in IconItem
* API dox: Use doxygen notation to have comments used
* API dox: note CamelCase includes by @class tag with more classes
* API dox: fix doxygen notation with some post-position comments
* minimize dialog resizes/moves
* set transientparent for menus
* Plasmoid templates: use the image which is part of the package (again)
* Add template for Plasma QML Applet with QML extension
* [WIP] workarounds for menu positioning
* recreate plasmashellsurf on exposed, destoy on hidden
* tests: fix i18ndcheck.sh for paths with special chars

==== prison-qt5 ====
Version update (5.34.0 -> 5.35.0)

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== solid ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Revert "Fix incorrect definition of major(3)/minor(3) macros." This patch
is part of a series which broke the build on MSVC.
* Revert "Adding files missing from last commit." This patch breaks the build
for MSVC.

==== sonnet ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== syntax-highlighting ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5SyntaxHighlighting5

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* Haskell: highlight "julius" quasiquoter using Normal##Javascript rules.
* Haskell: enable hamlet highlighting for "shamlet" quasiquoter too.

==== threadweaver ====
Version update (5.34.0 -> 5.35.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.35.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.35.0.php
- Changes since 5.34.0:
* None

==== yast2-trans ====
Version update (84.87.20170627.4e7fec5c -> 84.87.20170703.c20fb749)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en_GB yast2-trans-en_US
yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi yast2-trans-fr
yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr yast2-trans-hu
yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv yast2-trans-ka
yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt yast2-trans-mk
yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa yast2-trans-pl
yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru yast2-trans-si
yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20170703.c20fb749:
* New POT for text domain 'control'.
* New POT for text domain 'installation'.
* New POT for text domain 'ntp-client'.
* Translated using Weblate (Arabic)
* Translated using Weblate (Catalan)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (French)
* Translated using Weblate (Galician)
* Translated using Weblate (German)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Italian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Slovak)
* Translated using Weblate (Ukrainian)


--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups