Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] Leap 42.3 latest kernel 4.4.71 cannot install Nvidia blob
On 17/06/17 02:05 PM, pit wrote:
Roman Bysh wrote:
> On 17/06/17 12:03 PM, Roman Bysh wrote:
>> On 17/06/17 08:47 AM, pit wrote:
>>> Roman Bysh wrote:
>>>> Hi all,
>>>>
>>>> Has anyone been successful installing the Nvidia blob with kernel 4.4.70x
and 4.4.71x
>>>> while using Leap 42.3?
>>>>
>>>> ERROR: Unable to load the kernel module 'nvidia-drm.ko'.
>>>
>>> No further info (via 'modprobe -v' or from syslog)?
>>> Which version of the BLOB?
>>>
>> I'm using 381.22.
> I have attached the nvidia-installer.log.
> Note:
>
>
/tmp/selfgz1995/NVIDIA-Linux-x86_64-381.22/kernel/nvidia-drm/nvidia-drm-drv.c: In
function ‘nvidia_drm_get_client_capability’:
>
/tmp/selfgz1995/NVIDIA-Linux-x86_64-381.22/kernel/nvidia-drm/nvidia-drm-drv.c:557:31:
warning: unused variable ‘nv_dev’ [-Wunused-variable]
> struct nvidia_drm_device *nv_dev = dev->dev_private;

That is only a warning about unused variables. The compile of that part
finishes fine. The kernel messages at the end are irritating though...

Have you tried compiling/installing 375.66 instead? That one I run both on
4.4 (Leap 42.2 via the nvidia repo) and 4.11 (bumblebee/dkms compile).

If that one works I'd also think it is an issue of the 381 line...

Yes. I tried 375.66 and it gives the same message. It builds but won't load
nvidia-drm.ko
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups