Mailinglist Archive: opensuse-factory (914 mails)

< Previous Next >
Re: [opensuse-factory] New rpm macros to test package versions in spec files
On 31/05/17 17:01, Antonio Larrosa wrote:
On 31/05/17 15:43, Antonio Larrosa wrote:
On 31/05/17 12:37, Nikola Pajkovsky wrote:
[...]

Hmm, I think that's a very good idea. Just note pkg_version is the macro
that returns the package version, so I'll call it %pkg_version_test if
that's ok for you. That could very well replace the %pkg_version_at_least/
%pkg_version_at_most/... "high-level" macros with something probably even
more readable and equally short.


Just wondering... let's do a small poll.

I change my vote to 1.a and 2.f since I like Dominique's idea.

How would you call ...
1) The macro that has one argument (package name) and returns its version
number?

a) pkg_version : 5 votes
b) pkg_version_number
c) package_version : 1 vote
d) pkg_ver

2) The macro that has 3 arguments (package_name, operator, version number) and
tests whether the condition is true or not?
a) pkg_version_test
b) pkg_version_check
c) pkg_version
d) is_pkg_version
e) test_pkg_version
f) pkg_vcmp : 3 votes
g) pkg_versioncmp : 1 vote
h) package_version_compare : 1 vote

So... the winners are: pkg_version and pkg_vcmp
which I submitted at https://build.opensuse.org/request/show/501101

Thanks for sending your opinions!

--
Antonio Larrosa
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >