Mailinglist Archive: opensuse-factory (1009 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170418 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170418

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
corosync
intel-gpu-tools
kio
libdrm (2.4.79 -> 2.4.80)
libssh (0.7.4 -> 0.7.5)
libva (1.7.3 -> 1.8.0)
libva-gl (1.7.3 -> 1.8.0)
mariadb
mozilla-nss (3.29.3 -> 3.29.5)
vaapi-intel-driver (1.7.3 -> 1.8.0)
xf86-video-ati
xf86-video-intel (2.99.917.747_g028c946 -> 2.99.917.770_gcb6ba2da)
xf86-video-nouveau

=== Details ===

==== corosync ====

- [upgrade] Changing the pre-upgrade role for node failed(bsc#1030437)
Added:0001-totemconfig.c-Fixed-Evicted-from-CPG-membership.patch
removed: 0001-totemip.c-Fixed-Evicted-from-CPG-membership.patch

==== intel-gpu-tools ====

- SLE merge
* update to latest version, Stack release 2016Q1
(fate #315643-315645, 319159-319161, 319618)

==== kio ====
Subpackages: kio-core kio-devel

- Add enable-natural-sorting-in-KDirSortFilterProxyModel.patch to
use natural sorting by default in the KDE file dialog and
gwenview, configurable via the "NaturalSorting" option in
kdeglobals (boo#1033668, kde#343452)

==== libdrm ====
Version update (2.4.79 -> 2.4.80)
Subpackages: libdrm-devel libdrm2 libdrm_amdgpu1 libdrm_intel1 libdrm_nouveau2
libdrm_radeon1 libkms1

- Update to version 2.4.80:
+ intel: remove dead code
+ etnaviv: sync uapi header
+ etnaviv: add fence fd support
+ exynos: add C++ support to exynos_drmif header
- SLE merge
* Mesa 17.0.3 build on aarch64 needs libdrm_freedreno >= 2.4.74
(fate#321223)
* latest libdrm version for sle12 (fate #315643-315645, 319159-319161, 319618)

==== libssh ====
Version update (0.7.4 -> 0.7.5)
Subpackages: libssh-devel libssh4

- Update to version 0.7.5
* Fixed a memory allocation issue with buffers
* Fixed PKI on Windows
* Fixed some SSHv1 functions
* Fixed config hostname expansion

==== libva ====
Version update (1.7.3 -> 1.8.0)
Subpackages: libva-drm1 libva-x11-1 libva1 vaapi-dummy-driver

- update to version 1.8.0
* Bump VA API version to 0.40
* API: Change vaRenderPicture semantics that vaRenderPicture no
longer deletes the input buffer automatically.
* API: Add VA_FOURCC_I010 for 10bit surface
* API: Add vaSetErrorCallback and vaSetInfoCallback for error
and info message.
* va/drm: Update the support for Mesa Gallium driver
* va/drm: Fix authentication check for /dev/dri/card0
* Move all utilities and tests to libva-utils
(https://github.com/01org/libva-utils)
- disable obsolete vaapi-tools cause of move of all utilities to
libva-utils
- SLE merge:
* update to latest version, Intel Stack release 2016Q1
(fate #315643-315645, 319159-319161, 319618)
* latest updates for sle12 (fate #315643-315645, 319159-319161,
319618)
- Removed libva-wayland1 from bqaselibs.conf; add it to
baselibs.conf during a wayland build only; ugly I know ... This
is needed since otherwise source validator
("osc service run source_validator") fails on sle
- sync openSUSE Leap/SLE build by making use of %is_opensuse macro;
we don't build wayland on SLE, but enable it on Leap

==== libva-gl ====
Version update (1.7.3 -> 1.8.0)
Subpackages: libva-egl1 libva-glx1

- update to version 1.8.0
* Bump VA API version to 0.40
* API: Change vaRenderPicture semantics that vaRenderPicture no
longer deletes the input buffer automatically.
* API: Add VA_FOURCC_I010 for 10bit surface
* API: Add vaSetErrorCallback and vaSetInfoCallback for error
and info message.
* va/drm: Update the support for Mesa Gallium driver
* va/drm: Fix authentication check for /dev/dri/card0
* Move all utilities and tests to libva-utils
(https://github.com/01org/libva-utils)
- disable obsolete vaapi-tools cause of move of all utilities to
libva-utils
- SLE merge:
* update to latest version, Intel Stack release 2016Q1
(fate #315643-315645, 319159-319161, 319618)
* latest updates for sle12 (fate #315643-315645, 319159-319161,
319618)
- Removed libva-wayland1 from bqaselibs.conf; add it to
baselibs.conf during a wayland build only; ugly I know ... This
is needed since otherwise source validator
("osc service run source_validator") fails on sle
- sync openSUSE Leap/SLE build by making use of %is_opensuse macro;
we don't build wayland on SLE, but enable it on Leap

==== mariadb ====
Subpackages: libmysqlclient-devel libmysqlclient18 libmysqlclient_r18
libmysqld18 mariadb-client mariadb-errormessages

- increase required physical memory in _constraints from 5 GB to
7 GB in order to try to fix i586 build that fails because of
"Out of memory" error

==== mozilla-nss ====
Version update (3.29.3 -> 3.29.5)
Subpackages: libfreebl3 libsoftokn3 mozilla-nss-certs mozilla-nss-tools

- update to NSS 3.29.5
* Rare crashes in the base 64 decoder and encoder were fixed.
(bmo#1344380)
* A carry over bug in the RNG was fixed. (bmo#1345089)
- Allow use of session tickets when there is no ticket wrapping key
(boo#1015499, bmo#1320695) (nss-bmo1320695.patch)

==== vaapi-intel-driver ====
Version update (1.7.3 -> 1.8.0)

- Version 1.8.0 - 31.Mrz.2017
* Improve the quality of the H.264 encoder on SKL+ for CQP and CBR mode
* Improve the quality of the VP8 encoder on BSW+ for CQP and CBR mode
* Add support for H.264 VBR mode on SKL+
* Add support for VP8 VBR mode on BSW+
* Add support for low-power H.264 encoder on BXT and KBL
* Add support for CBR / VBR with low-power H.264 encoder on SKL+
(A HuC Firmware and a HuC supported Linux kernel are required)
* Add support for CSC and scaling with 10bit P010/I010 surface
* Optimize CSC and scaling with 8bit NV12 and I420 surface
* Fix the wrong memory object cache setting on SKL+
* Fix the EU number in media pipeline
* Fix the wrong bit shift in H.264 encoder
* Fix the 48bit graphics address on BSW+
* Fix building on NetBSD
- SLE merge:
* latest version for sle12 (fate #315643-315645, 319159-319161,
319618)
- sync openSUSE Leap/SLE build by making use of %is_opensuse macro;
we don't build wayland on SLE, but enable it on Leap

==== xf86-video-ati ====

- SLE merge (missing fate/bugzilla entries)
* bsc#990066 (we have even newer version than 7.7 meanwhile)
* fate #320388 (factory is building against an even higher
Xserver version, so covered as well)
* fate #315643-315645, 319159-319161, 319618 (we have the latest
available radeon driver X driver)
* bsc#936452, FATE#319131 (seems this macro is no longer been used
also in sle12-sp2)
* bnc#896378 (also handled in factory, but patch is meanwhile
upstream and included in driver release 7.9.0)

==== xf86-video-intel ====
Version update (2.99.917.747_g028c946 -> 2.99.917.770_gcb6ba2da)

- SLE merge:
* FATE#319161 (current git from master at that time)
- Update to 2.99.917.770_gcb6ba2da
* mostly SNA bug fixes
- on sle12 still install intel driver by default on all generations
- do not buildrequire xfont2 on sle

==== xf86-video-nouveau ====

- SLE merge
* latest driver changes for sle12 (fate #315643-315645, 319159-319161, 319618)
* adding missing fate entry: FATE#316743

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups