Mailinglist Archive: opensuse-factory (930 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170328 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170328

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
attica-qt5 (5.31.0 -> 5.32.0)
baloo5 (5.31.0 -> 5.32.0)
bluedevil5 (5.9.3 -> 5.9.4)
bluez-qt (5.31.0 -> 5.32.0)
breeze (5.9.3 -> 5.9.4)
breeze-gtk (5.9.3 -> 5.9.4)
breeze4-style (5.9.3 -> 5.9.4)
breeze5-icons (5.31.0 -> 5.32.0)
extra-cmake-modules (5.31.0 -> 5.32.0)
frameworkintegration (5.31.0 -> 5.32.0)
kactivities-stats (5.31.0 -> 5.32.0)
kactivities5 (5.31.0 -> 5.32.0)
kactivitymanagerd (5.9.3 -> 5.9.4)
karchive (5.31.0 -> 5.32.0)
kauth (5.31.0 -> 5.32.0)
kbookmarks (5.31.0 -> 5.32.0)
kcm_sddm (5.9.3 -> 5.9.4)
kcmutils (5.31.0 -> 5.32.0)
kcodecs (5.31.0 -> 5.32.0)
kcompletion (5.31.0 -> 5.32.0)
kconfig (5.31.0 -> 5.32.0)
kconfigwidgets (5.31.0 -> 5.32.0)
kcoreaddons (5.31.0 -> 5.32.0)
kcrash (5.31.0 -> 5.32.0)
kdbusaddons (5.31.0 -> 5.32.0)
kde-cli-tools5 (5.9.3 -> 5.9.4)
kde-gtk-config5 (5.9.3 -> 5.9.4)
kde-user-manager (5.9.3 -> 5.9.4)
kdeclarative (5.31.0 -> 5.32.0)
kded (5.31.0 -> 5.32.0)
kdelibs4support (5.31.0 -> 5.32.0)
kdesignerplugin (5.31.0 -> 5.32.0)
kdesu (5.31.0 -> 5.32.0)
kdewebkit (5.31.0 -> 5.32.0)
kdnssd-framework (5.31.0 -> 5.32.0)
kdoctools (5.31.0 -> 5.32.0)
kemoticons (5.31.0 -> 5.32.0)
kf5-filesystem
kfilemetadata5 (5.31.0 -> 5.32.0)
kgamma5 (5.9.3 -> 5.9.4)
kglobalaccel (5.31.0 -> 5.32.0)
kguiaddons (5.31.0 -> 5.32.0)
khotkeys5 (5.9.3 -> 5.9.4)
khtml (5.31.0 -> 5.32.0)
ki18n (5.31.0 -> 5.32.0)
kiconthemes (5.31.0 -> 5.32.0)
kidletime (5.31.0 -> 5.32.0)
kimageformats (5.31.0 -> 5.32.0)
kinfocenter5 (5.9.3 -> 5.9.4)
kinit (5.31.0 -> 5.32.0)
kio (5.31.0 -> 5.32.0)
kitemmodels (5.31.0 -> 5.32.0)
kitemviews (5.31.0 -> 5.32.0)
kjobwidgets (5.31.0 -> 5.32.0)
kjs (5.31.0 -> 5.32.0)
kjsembed (5.31.0 -> 5.32.0)
kmediaplayer (5.31.0 -> 5.32.0)
kmenuedit5 (5.9.3 -> 5.9.4)
knewstuff (5.31.0 -> 5.32.0)
knotifications (5.31.0 -> 5.32.0)
knotifyconfig (5.31.0 -> 5.32.0)
kpackage (5.31.0 -> 5.32.0)
kparts (5.31.0 -> 5.32.0)
kpeople5 (5.31.0 -> 5.32.0)
kplotting (5.31.0 -> 5.32.0)
kpty (5.31.0 -> 5.32.0)
kross (5.31.0 -> 5.32.0)
krunner (5.31.0 -> 5.32.0)
kscreen5 (5.9.3 -> 5.9.4)
kscreenlocker (5.9.3 -> 5.9.4)
kservice (5.31.0 -> 5.32.0)
ksshaskpass5 (5.9.3 -> 5.9.4)
ksysguard5 (5.9.3 -> 5.9.4)
ktexteditor (5.31.0 -> 5.32.0)
ktextwidgets (5.31.0 -> 5.32.0)
kunitconversion (5.31.0 -> 5.32.0)
kwallet (5.31.0 -> 5.32.0)
kwayland (5.31.0 -> 5.32.0)
kwidgetsaddons (5.31.0 -> 5.32.0)
kwin5 (5.9.3 -> 5.9.4)
kwindowsystem (5.31.0 -> 5.32.0)
kxmlgui (5.31.0 -> 5.32.0)
kxmlrpcclient5 (5.31.0 -> 5.32.0)
libKF5ModemManagerQt (5.31.0 -> 5.32.0)
libKF5NetworkManagerQt (5.31.0 -> 5.32.0)
libkdecoration2 (5.9.3 -> 5.9.4)
libkscreen2 (5.9.3 -> 5.9.4)
libksysguard5 (5.9.3 -> 5.9.4)
milou5 (5.9.3 -> 5.9.4)
oxygen5 (5.9.3 -> 5.9.4)
oxygen5-icon-theme (5.31.0 -> 5.32.0)
plasma-framework (5.31.0 -> 5.32.0)
plasma-nm5 (5.9.3 -> 5.9.4)
plasma5-addons (5.9.3 -> 5.9.4)
plasma5-desktop (5.9.3 -> 5.9.4)
plasma5-integration (5.9.3 -> 5.9.4)
plasma5-openSUSE
plasma5-pa (5.9.3 -> 5.9.4)
plasma5-session (5.9.2 -> 5.9.4)
plasma5-workspace (5.9.3 -> 5.9.4)
polkit-kde-agent-5 (5.9.3 -> 5.9.4)
powerdevil5 (5.9.3 -> 5.9.4)
prison-qt5 (5.30.0 -> 5.32.0)
solid (5.31.0 -> 5.32.0)
sonnet (5.31.0 -> 5.32.0)
syntax-highlighting (5.31.0 -> 5.32.0)
systemsettings5 (5.9.3 -> 5.9.4)
threadweaver (5.31.0 -> 5.32.0)
zypper-lifecycle-plugin (0.6.1488980214.576f7fb -> 0.6.1490613702.a925823)

=== Details ===

==== attica-qt5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== baloo5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Implement nested tags. REVIEW: 128664
* Upgrade KF5 version to 5.32.0.

==== bluedevil5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== bluez-qt ====
Version update (5.31.0 -> 5.32.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== breeze ====
Version update (5.9.3 -> 5.9.4)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== breeze-gtk ====
Version update (5.9.3 -> 5.9.4)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== breeze4-style ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== breeze5-icons ====
Version update (5.31.0 -> 5.32.0)

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Added missing Plasma Vault icon
* add a preview for the disk quota plasmoid
* Added icons for Plasma Vault
* Renamed the folder-*crypt icons in breeze-dark to follow breeze
* Renamed icons for encrypted and decripted folders
* Added arc config file
* Rewrite tests to not use tier3 frameworks
* add im-youtube icon for babe music player
* update blender icons
* Upgrade KF5 version to 5.32.0.
* Add torrents icon 22px
* add nm-tray icons BUG: 374672
* color-management removed undefined links hopefully BUG: 374843
* system-run is now an action until <= 32px and 48px an app icon BUG: 375970
* Make tier3 dependency for tests optional

==== extra-cmake-modules ====
Version update (5.31.0 -> 5.32.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Detect inotify.
* Upgrade ECM version to 5.32.0.
* Revert "Automatically mark classes with pure virtual functions as
/Abstract/."

==== frameworkintegration ====
Version update (5.31.0 -> 5.32.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kactivities-stats ====
Version update (5.31.0 -> 5.32.0)

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Less debugging output
* Allow to plan ahead and set the order for an item not yet in the list
* Add Boost_INCLUDE_DIR to kactivities-stats autotests.
* Upgrade KF5 version to 5.32.0.

==== kactivities5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kactivitymanagerd ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== karchive ====
Version update (5.31.0 -> 5.32.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix Potential leak of memory pointed to by 'limitedDev'.
* Upgrade KF5 version to 5.32.0.

==== kauth ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kbookmarks ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kcm_sddm ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kcmutils ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.
* [KCModuleQML] Pass the window as context for paletteChanged

==== kcodecs ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kcompletion ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kconfig ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* KConfig: stop exporting and installing KConfigBackend.
* Upgrade KF5 version to 5.32.0.

==== kconfigwidgets ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* KColorScheme: default to application scheme if set by KColorSchemeManager
* KConfigDialogManager: get change signal from metaObject or special property
* Upgrade KF5 version to 5.32.0.
* Fix KCModule::setAuthAction error checking

==== kcoreaddons ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Fix compilation with Qt 5.6.
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Exclude (6)
* Move the isDir() outside of the loop, as spotted by Milian.
* KDirWatch: replace QList<Client *> by std::vector<Client> to save on
new/delete.
* Upgrade KF5 version to 5.32.0.
* KDirWatch: fix memory leak on destruction.

==== kcrash ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdbusaddons ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kde-cli-tools5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kde-gtk-config5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kde-user-manager ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kdeclarative ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kded ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kded-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdelibs4support ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix bug in kfiledialog.cpp that causes crashing when native widgets are
used.
* Port [i] to .at(i) to avoid unwanted detaching.
* Upgrade KF5 version to 5.32.0.

==== kdesignerplugin ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdesu ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdewebkit ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdnssd-framework ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kdoctools ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kdoctools-devel

- Add a new subpackage to track the new shared library provided
by doctools
- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* meinproc5: link to the files, not to the library
* Commit translations from l10n-kf5
* Remove the KF5::XsltKde static library
* Port to categorized logging and clean includes
* Export a proper shared library for KDocTools
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Add function to extract a single file
* Revert "Port to categorized logging and clean includes"
* Port to categorized logging and clean includes
* Fail the build early if xmllint is not available
* Upgrade KF5 version to 5.32.0.
* add entity for application Kst

==== kemoticons ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kf5-filesystem ====

- Extend %kf5_find_lang to support LC_SCRIPTS files as well

==== kfilemetadata5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kfilemetadata5-devel

- Add Make-PlainTextExtractor-match-text-plain-again.patch to fix
metadata extraction for text files which got broken in 5.32.0
- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.
* fix build of kfilemetadata with taglib version 1.9
* New maintainer for kfilemetadata
* [ExtractorCollection] Use mimetype inheritance to return plugins
* add a new property DiscNumber for audio files from multi-disc albums
* add more audio format to automatic test and fix problems

==== kgamma5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kglobalaccel ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kguiaddons ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== khotkeys5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: khotkeys5-devel

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== khtml ====
Version update (5.31.0 -> 5.32.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== ki18n ====
Version update (5.31.0 -> 5.32.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kiconthemes ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix APIDOX as raised by clang's -Wdocumentation
* Upgrade KF5 version to 5.32.0.

==== kidletime ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kimageformats ====
Version update (5.31.0 -> 5.32.0)

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.

==== kinfocenter5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kinit ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kinit-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Add missing documentation for argument to LAUNCHER_EXEC_NEW
* Upgrade KF5 version to 5.32.0.

==== kio ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kio-core kio-devel

- Drop sanitize-url-for-proxy.patch, merged upstream
- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Too many changes to list here
* Commit translations from l10n-kf5
* Cookies KCM: disable "delete" button when there is no current item
* Use the new shared library exported by KDocTools
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Sanitize URLs before passing them to FindProxyForURL
* make sure the cancel action is last
* kio_help: use doOutputBuffer and simplify unicodeError
* rename support: emit proper URL in FileRenamed
* fix rename support: keep trashId rather than expecting it as input
* remote: remove unused include
* remote: remove redundant check
* remote: rename kded module to allow co-installability with plasma-workspace
<= 5.9
* remote: use QUrl::fromLocalFile()
* remote: just check if file exists
* remote: use QDir::mkpath() to create the remoteview folder
* remote: drop Messages.sh
* remote: use same debug category as other slaves
* remote: use json protocol
* remote: don't redefine TRANSLATION_DOMAIN
* remote: slots -> Q_SLOTS
* Import remote ioslave from plasma-workspace
* Fix TODO. We depend on Qt 5.3 by now
* kio_trash: implement renaming of toplevel files and dirs
* [PreviewJob] Remove maximum size for local files by default
* allow to add application actions on an open menu
* Port another use of QDateTime to QElapsedTimer. With proper / 1000 this
time :)
* Fixup previous commit to slave.cpp, divide by 1000 was missing.
* [autotest] KTcpSocketTest was racy and leaky => simplify, fix.
* Port from QDateTime::currentDateTime() to QElapsedTimer
* Upgrade KF5 version to 5.32.0.
* Fix double export in already-exported class
* deprecate DrawFrame, as discussed in
https://git.reviewboard.kde.org/r/129921/

==== kitemmodels ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kitemviews ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kjobwidgets ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kjs ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kjsembed ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kmediaplayer ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kmenuedit5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== knewstuff ====
Version update (5.31.0 -> 5.32.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuffCore5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Fix compilation with Qt 5.6
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== knotifications ====
Version update (5.31.0 -> 5.32.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Removed some dead code.
* Upgrade KF5 version to 5.32.0.
* Added missing @since
* Add support for flatpak portals
* Only use qApp->desktopFileName() when compiling with Qt >= 5.7.0
* Send desktopfilename as part of notifyByPopup hints
* [KStatusNotifierItem] Restore minimized window as normal

==== knotifyconfig ====
Version update (5.31.0 -> 5.32.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kpackage ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kpackage-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* finish support for opening compressed packages
* Upgrade KF5 version to 5.32.0.
* Upgrade Qt5 version requirement to 5.6.0.

==== kparts ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kpeople5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kpeople5-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kplotting ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kpty ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kross ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kross-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== krunner ====
Version update (5.31.0 -> 5.32.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kscreen5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== kscreenlocker ====
Version update (5.9.3 -> 5.9.4)
Subpackages: libKScreenLocker5

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* fix merge
* Implement manual focus on click (kde#348789,kde#374289)
- Remove patches, now upstream:
* 0001-Implement-manual-focus-on-click.patch

==== kservice ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kservice-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* further investigation of the kservicetest unittest failure in CI
* Upgrade KF5 version to 5.32.0.
* Port some left-over debug output to categorized logging

==== ksshaskpass5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== ksysguard5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== ktexteditor ====
Version update (5.31.0 -> 5.32.0)
Subpackages: ktexteditor-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Fix compilation with Qt 5.6
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Remember file type set by user over sessions
* Reset filetype when opening url
* Added getter for word-count configuration value
* vimode_completion unit test failure
* Consistent conversion from/to cursor to/from coordinates
* Update file type on save only if path changes
* EditorConfig support
* add FindEditorConfig to ktexteditor if that proves to be useful, can be
moved to extra-cmake-modules, thought I see its use is rather specialized to
ktexteditor
* Fix: emmetToggleComment action doesn't work
* Use sentence style capitalization with label texts of edit fields
* Reverse meaning of :split, :vsplit to match vi and Kate actions.
* Use C++11 log2() instead of log() / log(2)
* KateSaveConfigTab: put spacer behind last group on Advanced tab, not inside
* KateSaveConfigTab: Remove wrong margin around content of Advanced tab
* Borders config subpage: fix scrollbar visibility combobox being off-placed
* Upgrade KF5 version to 5.32.0.

==== ktextwidgets ====
Version update (5.31.0 -> 5.32.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kunitconversion ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* autotest: test currency conversion from threads.
* Add unittest for currency conversion from
https://git.reviewboard.kde.org/r/122183/
* Upgrade KF5 version to 5.32.0.

==== kwallet ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix -Wdocumentation warning
* Upgrade KF5 version to 5.32.0.
- Build against libqgpgme-devel on openSUSE and SLE13 to enable GPG
encryption, gpgmepp5 is not supported any more
- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php
- use individual libboost-*-devel packages instead of boost-devel
- Update to 5.30.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.30.0.php
- Update to 5.29.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.29.0.php
- Update to 5.28.0
* If Gpgmepp is not found, try to use KF5Gpgmepp
* Use Gpgmepp from GpgME-1.7.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.28.0.php
- Update to 5.27.0
* Check whether kwallet is enabled in Wallet::isOpen(name)
(kde#358260)
* Add missing boost header
* Remove duplicate search for KF5DocTools
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.27.0.php
- Drop upstreamed fix-isOpen-crash-when-wallet-disabled.patch
- Add fix-isOpen-crash-when-wallet-disabled.patch to fix a crash in
drkonqi (and maybe other applications) if kwallet is disabled
(kde#358260)
- Update to 5.26.0
* Move kwallet-query docbook to correct subdir
* Fix wording an -> one
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.26.0.php
- Update to 5.25.0
* Qt >= 5.5 is now required
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.25.0.php
- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php
- Update to 5.23.0
* KWalletd migration: fix error handling, stops the migration
from happening on every single boot.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.23.0.php
- Update to 5.22.0 (boo#980066)
* Disable seession restore for kwalletd5
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php
- Update to 5.21.0 (boo#974793)
* Upgrade Qt version requirement to 5.4.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.21.0.php
- Update to 5.20.0 (boo#970856)
* Make sure KDocTools is looked-up
* Don't pass a negative number to dbus, it asserts in libdbus
* Clean cmake files
* KWallet::openWallet(Synchronous): don't time out after 25 seconds
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.20.0.php
- Update to 5.19.0 (boo#967668)
* Duplicate the file descriptor while opening the file to read the env
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.19.0.php
- Enable gpgmepp5 integration on Leap also
- Update to 5.18.0
* kwalletd: Fix FILE* leak
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.18.0.php
- Update to 5.17.0
* Correctly handle the case where the user deactivated us
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.17.0.php
- Update to 5.16.0 (boo#955067)
* Use KDE_INSTALL_DBUSINTERFACEDIR to install dbus interfaces
* Fixed KWallet configuration file warnings on login (kde#351805)
* Prefix the kwallet-pam output properly
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.16.0.php
- Update to 5.15.0
* No longer automatically close on last use
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.15.0.php
- Enable gpgmepp integration with openSUSE > 13.2
- Update to 5.14.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.14.0.php
- Update to 5.13.0
* The Qt version requirement has been bumped from 5.2 to 5.3
* Debug output has been ported to categorized output, for less
noise by default
* Docbook documentation has been reviewed and updated
* Fix Windows build
* Print a warning with error code when opening the wallet by
PAM fails
* Return the backend error code rather than -1 when opening a
wallet failed
* Make the backend's "unknown cipher" a negative return code
* Watch for PAM_KWALLET5_LOGIN for KWallet5
* Fix crash when MigrationAgent::isEmptyOldWallet() check fails
* KWallet can now be unlocked by PAM using kwallet-pam module
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.13.0.php
- Update to 5.12.0
* Imported and improved the kwallet-query command-line tool.
* Support to overwrite maps entries.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.12.0.php
- Update to 5.11.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.11.0.php
- Update to 5.10.0
* Migration agent now also check old wallet is empty
before starting (kde#346498)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.10.0.php
- Update to 5.9.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.9.0.php
- Drop no longer needed Requires of the devel subpackage:
kconfig-devel and kwindowsystem-devel
- Update to 5.8.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.8.0.php
- Drop 0001-Retrofitting-the-fix-for-a-bug-found-in-Applications.patch,
merged upstream
- Added 0001-Retrofitting-the-fix-for-a-bug-found-in-Applications.patch
(kde#343718)
- Update to 5.7.0
* Automatically detect and convert old ECB wallets to CBC
* Fixed the CBC encryption algorithm
* Ensured wallet list gets updated when a wallet file gets
removed from disk
* Remove stray </p> in user-visible text
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.7.0.php
- Update to 5.6.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.6.0.php
- Update to 5.5.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.5.0.php
- Update to 5.4.0
* Emit 'walletListDirty' signal when the 'kwalletd'
directory is deleted
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.4.0.php
- Update to 5.3.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.3.0.php
- Let new kwalletd5-lang subpackage be recommended by kwalletd5 subpackage
- Update to 5.2.0
* For more details please see:
http://kde.org/announcements/kde-frameworks-5.2.php
- Update to 5.1.0
* For more details please see:
http://www.kde.org/announcements/kde-frameworks-5.1.php
- Define kf5_version within package
- Update to 5.0.0
* Final release of KDE Frameworks 5
* API improvements and cleanups
* Buildsystem fixes
* For more details please see:
http://www.kde.org/announcements/kde-frameworks-5.0.php
- Update to 4.100.0
* API improvements and cleanups
* Buildsystem fixes
* For more details please see:
http://www.kde.org/announcements/announce-frameworks5-beta3.php
- Add baselibs.conf
- Update to 4.99.0
* API improvements and cleanups
* Buildsystem fixes
* For more details please see:
http://www.kde.org/announcements/announce-frameworks5-beta2.php
- Update to 4.98.0
* API improvements and cleanups
* Buildsystem fixes
* For more details please see:
http://www.kde.org/announcements/announce-frameworks5-beta1.php
- Added libgcrypt-devel >= 1.5.0 BuildRequires
- Update to 4.97.0:
* Buildsystem fixes
* For more details please see:
http://www.kde.org/announcements/announce-frameworks5-alpha2.php
- Init kwallet package

==== kwayland ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kwayland-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kwidgetsaddons ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix API dox still referring to KAction
* Fix conversion warnings on MSVC: size_t -> uint
* Fix APIDOX issues raised by clang's -Wdocumentation
* KToolTipWidget: hide tooltip in enterEvent if hideDelay is zero
* autotest: remove dependency on UiTools by compiling the ui files into the
test
* Fix KEditListWidget losing the focus on click of buttons
* Add decomposition of Hangul Syllables into Hangul Jamo
* Upgrade KF5 version to 5.32.0.
* KToolTipWidget: small apidox fix
* KMessageWidget: fix behaviour on overlapping calls of
animatedShow/animatedHide

==== kwin5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: kwin5-devel

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* move the view at the correct index at startup

==== kwindowsystem ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== kxmlgui ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.
* Don't use KConfig keys with backslashes

==== kxmlrpcclient5 ====
Version update (5.31.0 -> 5.32.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== libKF5ModemManagerQt ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== libKF5NetworkManagerQt ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Sync introspections and generated files with NM 1.6.0
* Manager: Fix emitting deviceAdded twice when NM restarts
* Upgrade KF5 version to 5.32.0.

==== libkdecoration2 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== libkscreen2 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== libksysguard5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== milou5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== oxygen5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== oxygen5-icon-theme ====
Version update (5.31.0 -> 5.32.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== plasma-framework ====
Version update (5.31.0 -> 5.32.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Add upstream patch to fix unhovering of desktop items (kde#377441):
* 0001-Handle-applyPrefixes-with-an-empty-string.patch
* Workaround already applied to plasma-workspace
- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Too many changes to list here
* Commit translations from l10n-kf5
* set default hints when repr doesn't export Layout.*
* possible to set expanded=false for a containment
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* [Menu] Improve available space correction for openRelative
* move setImagePath logic into updateFrameData()
* IconItem: Add roundToIconSize property
* same margins as the normal button
* [Desktop Themes] Bump version number
* [SliderStyle] Allow providing a "hint-handle-size" element
* possibility to use a fallback chain as prefix
* Make the dataengine alignment timer more precise
* Connect all connections to action in QMenuItem::setAction
* [ConfigView] Honor KIOSK Control Module restrictions
* Fix disabling the spinner animation when Busy indicator has no opacity
* Fix binding loop regression in FrameSVGItem
* [FrameSvgItemMargins] Don't update on repaintNeeded
* IconItemTest: Fix loadPixmap and loadImage tests
* qml/plasmoid/containmentinterface.cpp - fix compile with Qt5.6
* [WIP]: integrate drop menu and filecopy drop menu
* Applet icons for the Plasma Vault
* fix stylesheet
* Migrate AppearAnimation and DisappearAnimation to Animators
* Use QtQuickControls button, instead of PlasmaComponent's
* Upgrade KF5 version to 5.32.0.
* Align bottom edge to top edge of visualParent in the
TopPosedLeftAlignedPopup case.
* [ConfigModel] Emit dataChanged when a ConfigCategory changes
* use anchors instead of fillHeight
* hardcode padding of scrollview style to 0
* [ScrollViewStyle] Evaluate frameVisible property
* don't regenerate frames when setting every property
* Add kleopatra icon
* [Button Styles] Use Layout.fillHeight instead of parent.height in a Layout
* [ContainmentInterface] Also align containment context menu to panel
* Upgrade Qt5 version requirement to 5.6.0.

==== plasma-nm5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* WiredSetting: Speed has to be set when auto-negotiation is off (kde#376018)

==== plasma5-addons ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== plasma5-desktop ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* [Kicker] Fix highlighting favorites
* Fix invalid reference of toolTipArea.
* [Folder View] Explicitly set prefix as empty in normal state (kde#377441)
* Do apply margin if in right-to-left mode. (kde#376529)
* [AppletAppearance] Silence warning
* [Folder View] Fix action button hover and pressed state
* Disable editing of 'Global Shortcuts' component names (kde#376935)
* Remove accidentally commited .directory file
* Fix switching categories via the filter listview on touchscreens.
- Remove patches, now upstream:
* 0001-Folder-View-Explicitly-set-prefix-as-empty-in-normal.patch

==== plasma5-integration ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* [QDBusMenuBar] Connect to popupRequested signal

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.9.4

==== plasma5-pa ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== plasma5-session ====
Version update (5.9.2 -> 5.9.4)

- Update to 5.9.4
- Update to 5.9.3

==== plasma5-workspace ====
Version update (5.9.3 -> 5.9.4)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* do not add debugger button unless it is meant to be visible
* manage mouse events when out of the window (kde#377545)
* don't emit availableScreenRectChanged when quitting
* try proper order of corona()->availableScreenRect() (kde#377298)
* [Notifications] Keep popup opened during drag
* Ignore NoDisplay=true .desktop entries when matching by Name.
* Preview Centered wallpaper as PreserveAspectFit (kde#375675)
* Only activate kded Appmenu signals if menus are in the window decoration
* Open the correct submenu in kwin menu when activating the Appmenu with a
shortcut
* try harder to make the selected wallpaper visible

==== polkit-kde-agent-5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== powerdevil5 ====
Version update (5.9.3 -> 5.9.4)

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* None

==== prison-qt5 ====
Version update (5.30.0 -> 5.32.0)

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.30.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.
* Fix min qt version, spotted by cfeck
* fix required version of ECM
* Use nullptr everywhere
* Upgrade KF5 version to 5.31.0.

==== solid ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* [UDisks 2 Device] Add description for Floppy Disk
* Upgrade KF5 version to 5.32.0.

==== sonnet ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== syntax-highlighting ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5SyntaxHighlighting5

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Commit translations from l10n-kf5
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Fix autotest
* Add more keyword. Disable spellchecking for keywords
* Fix typo
* Add more keyword
* Add *.RHTML file extension to Ruby on Rails highlighting
* Update SCSS and CSS syntax highlight
* less highlighting: Fix single line comments starting new regions
* Upgrade KF5 version to 5.32.0.
* LaTeX highlighting: fix alignat environment

==== systemsettings5 ====
Version update (5.9.3 -> 5.9.4)
Subpackages: systemsettings5-devel

- Update to 5.9.4
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.4.php
- Changes since 5.9.3:
* Set the correct desktop file name when in a KDE session.

==== threadweaver ====
Version update (5.31.0 -> 5.32.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.32.0
* New feature release
* For more details please see:
* https://www.kde.org/announcements/kde-frameworks-5.32.0.php
- Changes since 5.31.0:
* Upgrade ECM and KF5 version requirements for 5.32.0 release.
* Upgrade KF5 version to 5.32.0.

==== zypper-lifecycle-plugin ====
Version update (0.6.1488980214.576f7fb -> 0.6.1490613702.a925823)

- do not show version number by default (fate#322212)

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages