Mailinglist Archive: opensuse-factory (901 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170303 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170303

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
attica-qt5 (5.30.0 -> 5.31.0)
autoconf
baloo5 (5.30.0 -> 5.31.0)
bluedevil5 (5.9.2 -> 5.9.3)
bluez-qt (5.30.0 -> 5.31.0)
breeze (5.9.2 -> 5.9.3)
breeze-gtk (5.9.2 -> 5.9.3)
breeze4-style (5.9.2 -> 5.9.3)
breeze5-icons (5.30.0 -> 5.31.0)
build (20170112 -> 20170209)
cfitsio (3.390 -> 3.410)
corosync
device-mapper
extra-cmake-modules (5.30.0 -> 5.31.0)
flex
frameworkintegration (5.30.0 -> 5.31.0)
gcin
gmp
ibus-pinyin
java-1_8_0-openjdk
kactivities-stats (5.30.0 -> 5.31.0)
kactivities5 (5.30.0 -> 5.31.0)
kactivitymanagerd (5.9.2 -> 5.9.3)
karchive (5.30.0 -> 5.31.0)
kauth (5.30.0 -> 5.31.0)
kbookmarks (5.30.0 -> 5.31.0)
kcm_sddm (5.9.2 -> 5.9.3)
kcmutils (5.30.0 -> 5.31.0)
kcodecs (5.30.0 -> 5.31.0)
kcompletion (5.30.0 -> 5.31.0)
kconfig (5.30.0 -> 5.31.0)
kconfigwidgets (5.30.0 -> 5.31.0)
kcoreaddons (5.30.1 -> 5.31.0)
kcrash (5.30.0 -> 5.31.0)
kdbusaddons (5.30.0 -> 5.31.0)
kde-cli-tools5 (5.9.2 -> 5.9.3)
kde-gtk-config5 (5.9.2 -> 5.9.3)
kde-user-manager (5.9.2 -> 5.9.3)
kdeclarative (5.30.0 -> 5.31.0)
kded (5.30.0 -> 5.31.0)
kdelibs4support (5.30.0 -> 5.31.0)
kdesignerplugin (5.30.0 -> 5.31.0)
kdesu (5.30.0 -> 5.31.0)
kdewebkit (5.30.0 -> 5.31.0)
kdnssd-framework (5.30.0 -> 5.31.0)
kdoctools (5.30.0 -> 5.31.0)
kemoticons (5.30.0 -> 5.31.0)
kfilemetadata5 (5.30.0 -> 5.31.0)
kgamma5 (5.9.2 -> 5.9.3)
kglobalaccel (5.30.0 -> 5.31.0)
kguiaddons (5.30.0 -> 5.31.0)
khotkeys5 (5.9.2 -> 5.9.3)
khtml (5.30.0 -> 5.31.0)
ki18n (5.30.0 -> 5.31.0)
kiconthemes (5.30.0 -> 5.31.0)
kidletime (5.30.0 -> 5.31.0)
kimageformats (5.30.0 -> 5.31.0)
kinfocenter5 (5.9.2 -> 5.9.3)
kinit (5.30.0 -> 5.31.0)
kio (5.30.0 -> 5.31.0)
kitemmodels (5.30.0 -> 5.31.0)
kitemviews (5.30.0 -> 5.31.0)
kjobwidgets (5.30.0 -> 5.31.0)
kjs (5.30.0 -> 5.31.0)
kjsembed (5.30.0 -> 5.31.0)
kmediaplayer (5.30.0 -> 5.31.0)
kmenuedit5 (5.9.2 -> 5.9.3)
knewstuff (5.30.1 -> 5.31.0)
knotifications (5.30.0 -> 5.31.0)
knotifyconfig (5.30.0 -> 5.31.0)
kpackage (5.30.0 -> 5.31.0)
kparts (5.30.0 -> 5.31.0)
kpeople5 (5.30.0 -> 5.31.0)
kplotting (5.30.0 -> 5.31.0)
kpty (5.30.0 -> 5.31.0)
kross (5.30.0 -> 5.31.0)
krunner (5.30.0 -> 5.31.0)
kscreen5 (5.9.2 -> 5.9.3)
kscreenlocker (5.9.2 -> 5.9.3)
kservice (5.30.0 -> 5.31.0)
ksshaskpass5 (5.9.2 -> 5.9.3)
ksysguard5 (5.9.2 -> 5.9.3)
ktexteditor (5.30.0 -> 5.31.0)
ktextwidgets (5.30.0 -> 5.31.0)
kunitconversion (5.30.0 -> 5.31.0)
kwallet (5.30.0 -> 5.31.0)
kwayland (5.30.0 -> 5.31.0)
kwidgetsaddons (5.30.0 -> 5.31.0)
kwin5 (5.9.2 -> 5.9.3)
kwindowsystem (5.30.0 -> 5.31.0)
kxmlgui (5.30.0 -> 5.31.0)
kxmlrpcclient5 (5.30.0 -> 5.31.0)
libKF5ModemManagerQt (5.30.0 -> 5.31.0)
libKF5NetworkManagerQt (5.30.0 -> 5.31.0)
libgxps (0.2.4 -> 0.2.5)
libinput (1.6.1 -> 1.6.2)
libkdecoration2 (5.9.2 -> 5.9.3)
libkscreen2 (5.9.2 -> 5.9.3)
libksysguard5 (5.9.2 -> 5.9.3)
libqb
lvm2
m4
milou5 (5.9.2 -> 5.9.3)
oxygen5 (5.9.2 -> 5.9.3)
oxygen5-icon-theme (5.30.0 -> 5.31.0)
pcre (8.39 -> 8.40)
perl-Config-Crontab (1.42 -> 1.43)
perl-Log-Log4perl (1.48 -> 1.49)
perl-Net-DNS (1.07 -> 1.08)
perl-libwww-perl (6.19 -> 6.21)
plasma-framework (5.30.0 -> 5.31.0)
plasma-nm5 (5.9.2 -> 5.9.3)
plasma5-addons (5.9.2 -> 5.9.3)
plasma5-desktop (5.9.2 -> 5.9.3)
plasma5-integration (5.9.2 -> 5.9.3)
plasma5-openSUSE
plasma5-pa (5.9.2 -> 5.9.3)
plasma5-workspace (5.9.2 -> 5.9.3)
polkit-kde-agent-5 (5.9.2 -> 5.9.3)
powerdevil5 (5.9.2 -> 5.9.3)
purple-bot-sentry
rpm (4.12.0.1 -> 4.13.0.1)
sane-backends
solid (5.30.0 -> 5.31.0)
sonnet (5.30.0 -> 5.31.0)
spice-gtk
syntax-highlighting (5.30.0 -> 5.31.0)
systemsettings5 (5.9.2 -> 5.9.3)
threadweaver (5.30.0 -> 5.31.0)
wayland (1.12.0 -> 1.13.0)
xcb-util-wm
xmlgraphics-fop
yast2-iscsi-client (3.1.29 -> 3.1.30)

=== Details ===

==== attica-qt5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== autoconf ====

- Explicitly buildrequire m4: there is a plan to remove it from the
implicit buildroot configuration (just like autoconf itself is
no longer part of a long time already).

==== baloo5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== bluedevil5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Add .arcconfig
* ReceiveFileJob: Don't cancel the request right after accepting it

==== bluez-qt ====
Version update (5.30.0 -> 5.31.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== breeze ====
Version update (5.9.2 -> 5.9.3)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Use QPalette::Shadow instead of QPalette::Text to darken inactive tabs
BUG:373088

==== breeze-gtk ====
Version update (5.9.2 -> 5.9.3)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== breeze4-style ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Use QPalette::Shadow instead of QPalette::Text to darken inactive tabs
BUG:373088

==== breeze5-icons ====
Version update (5.30.0 -> 5.31.0)

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== build ====
Version update (20170112 -> 20170209)
Subpackages: build-mkbaselibs build-mkdrpms

- updated confguration for tumbleweed
- Arch linux fixes
- mount swap by label
- allow custom qemu options
- allow to override hostname
- fix build with vm-type lxc

==== cfitsio ====
Version update (3.390 -> 3.410)
Subpackages: cfitsio-devel libcfitsio5

- Update to version 3.410:
* The change made in version 3.40 to include strings.h caused
problems on Windows (and other) platforms, so this change was
backed out. The reason for including it was to define the
strcasecmp and strcasencmp functions, so as an alternative, new
equivalent functions called fits_strcasecmp and
fits_strncasecmp have been added to CFITSIO.as a substitute.
All the previous calls to the str[n]casecmp functions have been
changed to now call fits_str[n]casecmp. In addition, the
previously defined ngp_strcasecmp function (in grparser.c) has
been removed and the calls to it have been changed to
fits_strcasecmp.
* The speed.c utility program was changed to correctly call
the gettimeofday function with a NULL second arguement.
From version 3.400:
* fixed a bug when writing long string keywords with the CONTINUE
convention which caused the CONTINUE'd strings to only be 16
characters long, instead of using up all the available space in
the 80-character header record.
* fixed a missing 'defined' keyword in fitsio.h.
* replaced all calls to strtok (which is not threadsafe) with a
new ffstrtok function which internally calls the threadsafe
strtok_r function. One byproduct of this change is that
<strings.h> must also be included in several of the C source
code files.
* modified the ffphbn function in putkey.c to support TFORM
specifiers that use lowercase 'p' (instead of uppercase) when
referring to a variable-length array column.
* modified the lexical parser in eval.y and eval_y.c to support
bit array columns (with TFORMn = 'X') with greater than 256
elements. Fix to bitcmp function: The internal 'stream' array
is now allocated dynamically rather than statically fixed at
size 256. This was failing when users attempted a row filtering
of a bitcol that was wider than 256X. In bitlgte, bitand, and
bitor functions, replaced static stream[256] array allocation
with dynamic allocation.
* modified the ffiter function in putcol.c to fix a problem which
could cause the iterator function to incorrectly deal with null
values. This only affected TLONG type columns in cases where
sizeof(long) = 8, as well as for TLONGLONG type columns.
* Fix made to uncompress2mem function in zcomprss.c for case
where output uncompressed file expands to over the 2^32 (4Gb)
limit. It now checks for this case at the start, and
implements a 4Gb paging system through the output buffer. The
problem was specifically caused by the d_stream.avail_out
member being of 4-byte type uInt, and thus unable to handle any
memory position values above 4Gb.
* fixed a bug in fpackutil.c when using the -i2f (integer to
float) option in fpack to compress an integer image that is
scaled with non-default values for BSCALE and BZERO. This
required an additional call to ffrhdu to reset the internal
structures that describe the input FITS file.
* modified fits_uncompress_table in imcompress.c to silently
ignore the ZTILELEN keyword value if it larger than the number
of rows in the table
* Tweak strcasecmp/strncasecmp ifdefs to exclude 64-bit MINGW
environment, as it does not lack those functions. (eval_l.c,
fitsio2.h)
* CMakeLists.txt: Set M_LIB to "" for MINGW build environment (in
addition to MSVC).
* Makefile.in: Add *.dSYM (non-XCode gcc leftovers on Macs) to
clean list. Install libs by name rather than using a wildcard.
* configure: Fix rpath token usage for XCode vs. non-XCode gcc on
Macs.
- Rebased cfitsio-zlib.patch to apply cleanly.

==== corosync ====

- L3-Question: corosync logging priority takes no effect(bsc#1023959)
added:
0001-Logsys-Change-logsys-syslog_priority-priority.patch

==== device-mapper ====
Subpackages: libdevmapper-event1_03 libdevmapper1_03 libdevmapper1_03-32bit

- Improve the layout and readability of spec files
* Place subpackages' sections at the bottom of spec file, making
the layout more reasonable: 1. main package's spec sections are
contiguous without a break; 2. subpackage's spec spections can
also be placed together.
* Get rid of wild-card usage in %files section; spec file is a
perfect place for packager to know what files are exactly delivered
with each RPMs; staring at wild-card doesn't give much information.
* Put bsc#xxx at previous line of each SUSE patch at my best, some
are still missing.

==== extra-cmake-modules ====
Version update (5.30.0 -> 5.31.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== flex ====

- Fix de-registration of the info files.

==== frameworkintegration ====
Version update (5.30.0 -> 5.31.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Build with AppStream-Qt again, right version now available
- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== gcin ====
Subpackages: gcin-gtk2 gcin-gtk3 gcin-qt4 gcin-qt5 libgcin-im-client1

- Add gcin-dont-copy-gcin-qt5-header.patch to avoid overwriting
the patched gcin-qt5.h

==== gmp ====
Subpackages: gmp-devel libgmp10 libgmp10-32bit libgmpxx4

- Explicitly BuildRequire m4

==== ibus-pinyin ====

- add patch: ibus-pinyin-fix-select-words-could-be-cleared.patch
* Fix boo#980890: The select words could be cleared while use ibus-pinyin in
Firefox

==== java-1_8_0-openjdk ====
Subpackages: java-1_8_0-openjdk-headless

- Fix build of Sun Elliptical Curves Crypto provider on Tumbleweed.
Fixes bsc#1026102.
- Clean the mozilla-nss requires and move them into the headless
- Add a test to check that ECC is working
* new file TestECDSA.java

==== kactivities-stats ====
Version update (5.30.0 -> 5.31.0)

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kactivities5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kactivitymanagerd ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Merge Plasma/5.8

==== karchive ====
Version update (5.30.0 -> 5.31.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kauth ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kbookmarks ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kcm_sddm ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== kcmutils ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kcodecs ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kcompletion ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kconfig ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kconfigwidgets ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kcoreaddons ====
Version update (5.30.1 -> 5.31.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php
- Drop parse-the-desktop-file-2-times.patch

==== kcrash ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdbusaddons ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kde-cli-tools5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Fix QCommandLineParser usage WRT windowclass parameter

==== kde-gtk-config5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Properly retrieve all boolean properties

==== kde-user-manager ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Merge Plasma/5.8

==== kdeclarative ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kded ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kded-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdelibs4support ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdesignerplugin ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdesu ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdewebkit ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdnssd-framework ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kdoctools ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kdoctools-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kemoticons ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kfilemetadata5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kfilemetadata5-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kgamma5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== kglobalaccel ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kguiaddons ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== khotkeys5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: khotkeys5-devel

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Merge Plasma/5.8
* Fix build with -fno-operator-names

==== khtml ====
Version update (5.30.0 -> 5.31.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== ki18n ====
Version update (5.30.0 -> 5.31.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kiconthemes ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kidletime ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kimageformats ====
Version update (5.30.0 -> 5.31.0)

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kinfocenter5 ====
Version update (5.9.2 -> 5.9.3)

- Introduce and use kf5_version global
- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== kinit ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kinit-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kio ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kio-core kio-devel

- Add patch to fix security issue with proxy configuration (boo#1027520)
* sanitize-url-for-proxy.patch
- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kitemmodels ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kitemviews ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kjobwidgets ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kjs ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kjs-devel kjs-devel-lang libKF5JS5 libKF5JSApi5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kjsembed ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kmediaplayer ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kmenuedit5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== knewstuff ====
Version update (5.30.1 -> 5.31.0)
Subpackages: knewstuff-core-devel knewstuff-devel libKF5NewStuff5
libKF5NewStuffCore5

- Add libKF5NewStuffCore5 to baselibs.conf
libKF5NewStuff5-32bit cannot be installed without it.
- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== knotifications ====
Version update (5.30.0 -> 5.31.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== knotifyconfig ====
Version update (5.30.0 -> 5.31.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kpackage ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kpackage-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kparts ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kpeople5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kpeople5-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kplotting ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kpty ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kross ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kross-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== krunner ====
Version update (5.30.0 -> 5.31.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kscreen5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== kscreenlocker ====
Version update (5.9.2 -> 5.9.3)
Subpackages: libKScreenLocker5

- Add upstream patch to fix screenlocker focus on multiscreen systems:
* 0001-Implement-manual-focus-on-click.patch
- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Merge Plasma/5.8
* Fix crash in Screen Locker KCM on teardown

==== kservice ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kservice-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== ksshaskpass5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Fix git ssh password detection

==== ksysguard5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Merge remote-tracking branch 'origin/Plasma/5.8' into Plasma/5.9
* Fix array allocation for non-continuous cpu numbers

==== ktexteditor ====
Version update (5.30.0 -> 5.31.0)
Subpackages: ktexteditor-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== ktextwidgets ====
Version update (5.30.0 -> 5.31.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kunitconversion ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kwallet ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kwayland ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kwayland-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kwidgetsaddons ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kwin5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: kwin5-devel

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* move the view at the correct index at startup
* We need Breeze 5.9
* Find minimum required Breeze version instead of current version
* Avoid a crash on Kwin decoration KCM teardown

==== kwindowsystem ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kxmlgui ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== kxmlrpcclient5 ====
Version update (5.30.0 -> 5.31.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== libKF5ModemManagerQt ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== libKF5NetworkManagerQt ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== libgxps ====
Version update (0.2.4 -> 0.2.5)

- Update to version 0.2.5:
+ Fix handling of internal documents paths to ensure we always
use "/" instead of the system path separator (bgo#777894).
+ Improve performance when querying archive entries by using a
hash set instead of a GList (bgo#777272).
+ Improve performance when querying documents in archive by using
a GPtrArray instead of a GList (bgo#777269).
+ Fix a user after free in tools.
+ Fix several memory leaks.
+ Fix potential NULL pointer dereference found by coverity
(bgo#776323).
+ Add a missing break in switch statement found by coverity
(bgo#776323).
+ Fix uninitialised variables found by coverity (bgo#776323).
+ Fix several compile warnings.
+ Remove wrong return from print_token() that is void
(bgo#772296).
+ Fix GObject introspection build (bgo#775637).
+ Build: Add support for building with Visual studio
(bgo#771057).

==== libinput ====
Version update (1.6.1 -> 1.6.2)
Subpackages: libinput-udev libinput10

- Update to new upstream release 1.6.2
* The top middle button on the Lenovo *40 series touchpad was
extended by 4mm to match the markings better.
* The Apple onebutton touchpad default to clickfinger behavior.
* libinput-debug-devices now hides the keycode by default. All
"normal" keys simply print as "***" instead of e.g. "KEY_A".

==== libkdecoration2 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== libkscreen2 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== libksysguard5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== libqb ====

- RPM group fix; use find -delete over rm.

==== lvm2 ====
Subpackages: liblvm2app2_2 liblvm2cmd2_02

- Improve the layout and readability of spec files
* Place subpackages' sections at the bottom of spec file, making
the layout more reasonable: 1. main package's spec sections are
contiguous without a break; 2. subpackage's spec spections can
also be placed together.
* Get rid of wild-card usage in %files section; spec file is a
perfect place for packager to know what files are exactly delivered
with each RPMs; staring at wild-card doesn't give much information.
* Put bsc#xxx at previous line of each SUSE patch at my best, some
are still missing.

==== m4 ====

- Fix de-registration of the info files.

==== milou5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== oxygen5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== oxygen5-icon-theme ====
Version update (5.30.0 -> 5.31.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== pcre ====
Version update (8.39 -> 8.40)
Subpackages: libpcre1 libpcre1-32bit libpcre16-0 libpcrecpp0 libpcreposix0
pcre-devel

- pcre 8.40:
* Using -o with -M in pcregrep could cause unnecessary repeated
output when the match extended over a line boundary.
* Fix register overwite in JIT when SSE2 acceleration is enabled.
* Ignore "show all captures" (/=) for DFA matching.
* Fix JIT unaligned accesses on x86
* In any wide-character mode (8-bit UTF or any 16-bit or 32-bit
mode), without PCRE_UCP set, a negative character type such as
\D in a positive class should cause all characters greater than
255 to match, whatever else is in the class. There was a bug
that caused this not to happen if a Unicode property item was
added to such a class, for example [\D\P{Nd}] or [\W\pL].
* When pcretest was outputing information from a callout, the
caret indicator for the current position in the subject line
was incorrect if it was after an escape sequence for a
character whose code point was greater than \x{ff}.
* A pattern such as (?<RA>abc)(?(R)xyz) was incorrectly compiled
such that the conditional was interpreted as a reference to
capturing group 1 instead of a test for recursion. Any group
whose name began with R was misinterpreted in this way. (The
reference interpretation should only happen if the group's name
is precisely "R".)
* A number of bugs have been mended relating to match start-up
optimizations when the first thing in a pattern is a positive
lookahead. These all applied only when PCRE_NO_START_OPTIMIZE
was *not* set:
+ A pattern such as (?=.*X)X$ was incorrectly optimized as if
it needed both an initial 'X' and a following 'X'.
+ Some patterns starting with an assertion that started with
.* were incorrectly optimized as having to match at the start
of the subject or after a newline. There are cases where this
is not true, for example, (?=.*[A-Z])(?=.{8,16})(?!.*[\s])
matches after the start in lines that start with spaces.
Starting .* in an assertion is no longer taken as an
indication of matching at the start (or after a newline).
- Explicitly package %{_docdir}/%{name} to fix build with RPM 4.13.

==== perl-Config-Crontab ====
Version update (1.42 -> 1.43)

- updated to 1.43
see /usr/share/doc/packages/perl-Config-Crontab/Changes
Release 1.43
- ---------------------------
commit 2fedca514e2826bae41960295af20dc718db3256
Author: Scott Wiersdorf <scott@xxxxxxxxxxxx>
Date: Mon Feb 27 10:42:51 2017 -0700
fix lexical scope error introduced in PR#2; tests

==== perl-Log-Log4perl ====
Version update (1.48 -> 1.49)

- updated to 1.49
see /usr/share/doc/packages/perl-Log-Log4perl/Changes
1.49 (2017/02/20)
* (ms) Adapted to perl 5.24 which balks at syswrite/utf8:
https://github.com/mschilli/log4perl/issues/78

==== perl-Net-DNS ====
Version update (1.07 -> 1.08)

- updated to 1.08
see /usr/share/doc/packages/perl-Net-DNS/Changes

==== perl-libwww-perl ====
Version update (6.19 -> 6.21)

- updated to 6.21
see /usr/share/doc/packages/perl-libwww-perl/Changes
6.21 2017-02-21
- Ensure that LWP::Simple re-exports some HTTP::Status functions
6.20 2017-02-21
- Converted to use Dist::Zilla
- Moved several tests to xt/author

==== plasma-framework ====
Version update (5.30.0 -> 5.31.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== plasma-nm5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Don't assume initialized if there are pending dbus replies

==== plasma5-addons ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== plasma5-desktop ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* [tooltips] Limit tooltip title to one line
* Add an option to limit the number of text lines in task buttons.
* Make the hover state optional.
* Make the hover state optional.
* Fix default fixed font in fonts kcm
* Avoid capturing MenuItem instead determine checked state from toggled signal
* Set root.dragging to false during reset.
* Revert "Revert "use KPluginMetaData::readStringList""
* Revert "use KPluginMetaData::readStringList"
* Use icon center for vertical hitscan on drop.
* Don't pin during reordering by DND.
* Revert "remove get new looks button from 5.8"
* remove get new looks button from 5.8
- Remove patches, now upstream:
* 0001-Don-t-pin-during-reordering-by-DND.patch

==== plasma5-integration ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.9.3

==== plasma5-pa ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* StreamRestore: Cache values in writeChanges until receiving change from pa

==== plasma5-workspace ====
Version update (5.9.2 -> 5.9.3)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* Remove deprecated --shut-up start flag
* Fix another regression with rearranging launchers in an activities world.
* [Media Controller] Round button size for play button
* try harder to make the selected wallpaper visible
* [Logout Screen] Show suspend button only if supported
* Map StartupWMClass for Chrome apps instead of RegExp'ing the name
* [kioslave/remote] Fix broken kded module
* Port to QMultiHash.
* Only remove + announce if leader change actually occured, avoid excessive
loop.
* Fix crash.
* [Notifications] Never manually hide() the NotificationPopup
* Add comment laying out goals.
* Fix crash when switching activities.
* Tweak alphabetic (default) sort behavior.
- Remove patches, now upstream:
* 0001-Fix-another-regression-with-rearranging-launchers-in.patch
- Add patch to fix regression in Plasma 5.9:
* 0001-Fix-another-regression-with-rearranging-launchers-in.patch
- drkonqi can use konsole again, the problems there are fixed

==== polkit-kde-agent-5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== powerdevil5 ====
Version update (5.9.2 -> 5.9.3)

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== purple-bot-sentry ====
Subpackages: libpurple-plugin-bot-sentry libpurple-plugin-bot-sentry-lang

- Rename the source package to purple-bot-sentry.
- Rename the 'no' locale to 'nb_NO' only on SLE 11.
- Spec cleanup.
- Add a comment about the fact that the COPYING file in the tarball
most likely wrongfully states the program is GPL-3.0(+): the code
is GPL-2.0+ and this COPYING file seems to come from autotools
magic, and not from the author. Fix bnc#741048.
- Cleanup for Factory:
+ Rename source package from pidgin-bot-sentry to bot-sentry,
following upstream name.
+ Create a libpurple-plugin-bot-sentry binary package for the
plugin.
+ Add appropriate Provides/Obsoletes for smooth migration.
+ Do not use a patch and autoreconf call to rename a translation,
just move the files in %install.
- Build requires libtool.
- Requires pidgin.
- Build doesn't require fdupes.
- Corrected License tag
- Use full URL as a source.
- Removed check for obsolete versions of openSUSE.
- Doesn't require lang_package (recommends).
- Spec clean up.
- remove dependency on licenses, package no longer in Factory
- fix build
- Removed superfluous --libdir.
- Updated to version 1.3.0:
* smart handling of auth requests.
* partial disabling of challenge by keeping setup blank
* translation updates
* UI improvements
* better support for the latest pidgin
- Do not call (too old) autoconf in older SuSE versions.
- Use %fdupes
- Split off a -lang subpackage.

==== rpm ====
Version update (4.12.0.1 -> 4.13.0.1)
Subpackages: rpm-32bit rpm-build rpm-devel

- Tweak debugedit-comp-dir patch so that debugedit does not crash
with a NULL comp_dir [bnc#1027228]
- Fix debugedit-canon-fix.diff to handle directory table size
shrinking by 1 byte correctly.
- update to rpm-4.13.0.1
* fix several out of bounds reads in the OpenPGP parser
* fix handling of OpenPGP reserved tag (should be rejected)
* fix various crashes from malformed packages with invalid tags
* fix transfiletriggerpostun nondeterministic behavior
- update to rpm-4.13.0
* support of rich (boolean) dependencies
* support of file triggers
- new patches:
* nobfd.diff
* emptymanifest.diff
- dropped patches:
* rpm-4.12.0.1-lua-5.3.patch
* fixsizeforbigendian.diff
* repackage-nomd5.diff

==== sane-backends ====
Subpackages: sane-backends-32bit sane-backends-autoconfig sane-backends-devel

- CVE-2017-6318.patch fixes CVE-2017-6318 which is about that via
access to saned some opcodes could leak uninitialized memory
back to the requester allowing information disclosure
of memory content in saned (bsc#1027197).
In general regarding "access to saned" see
https://en.opensuse.org/SDB:CUPS_and_SANE_Firewall_settings

==== solid ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== sonnet ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== spice-gtk ====
Subpackages: libspice-client-glib-2_0-8 libspice-client-glib-helper
libspice-client-gtk-3_0-5 libspice-controller0 typelib-1_0-SpiceClientGlib-2_0
typelib-1_0-SpiceClientGtk-3_0

- Drop pkgconfig(pygtk-2.0) BuildRequires: No longer needed, nor
used as gtk2 support was dropped.
- Add spice-gtk-remove-pygtk-bindings-leftovers.patch: Remove
leftover pygtk bindings, patch from upstream git.
- Stop using sed to insert usbredirhost-0.5 into configure checks,
no longer needed: fixed upstream.

==== syntax-highlighting ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5SyntaxHighlighting5

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== systemsettings5 ====
Version update (5.9.2 -> 5.9.3)
Subpackages: systemsettings5-devel

- Update to 5.9.3
* New bugfix release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.3.php
- Changes since 5.9.2:
* None

==== threadweaver ====
Version update (5.30.0 -> 5.31.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.31.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.31.0.php

==== wayland ====
Version update (1.12.0 -> 1.13.0)
Subpackages: libwayland-client0 libwayland-client0-32bit libwayland-cursor0
libwayland-server0 libwayland-server0-32bit

- Update to new upstrea mrelease 1.13.0
* Add some API for controlling the visibility of globals.
- Drop wayland-wl_array_Set_data_to_invalid_address_after_free.patch
(no longer needed)

==== xcb-util-wm ====

- List baselibs.conf as source.
- Explicitly BuildRequire m4

==== xmlgraphics-fop ====

- Add patch to fix build with stricter javadoc in version 8:
* fix-javadoc-java8.patch (boo#1027467)
- Fix file list on SLE

==== yast2-iscsi-client ====
Version update (3.1.29 -> 3.1.30)

- Fate#318832, redesign authentication UI and online help.
- 3.1.30

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >