Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
Re: [opensuse-factory] TW 20170219 - VLC (and in consequence Kaffeine) - no video playback any more on a system with nvidia nouveau and all packman etc codecs installed.
  • From: Wolfgang Bauer <wbauer@xxxxxx>
  • Date: Wed, 22 Feb 2017 20:00:10 +0100
  • Message-id: <31016511.8xgo0jqgpZ@amiga>
Am Dienstag, 21. Februar 2017, 23:03:24 schrieb stakanov:
I actually did not have it installed. I installed it, I had picture but the
system became unresponsive in a random way. So I took it off and no picture.
Before I did not need anything, worked out of the box,
up to that update.
Well, waiting for a new snapshot I guess. Currently video is broken on vlc,
kaffeine but also on dragonviewer. Just no video but the one in the
browserwindow.

You could try to set a different video output device in VLC (other than Auto
or VDPAU).

It should also be possible to add an appropriate command line option to vlc in
Kaffeine's settings. Or use kaffeine4, which is still Xine based and available
from KDE:Extra for Tumbleweed too
.
Btw, I just noticed today that I get a similar "surface creation error" here
in 42.2.
In my case it is indeed caused by libvdpau_va_gl1, disabling it (or choosing a
different video output) "fixed" it. (libvdpau_va_gl1 worked fine when I was
still using 13.2, my video card doesn't even support hardware decoding though)
Kaffeine 1.2.2 (the Xine-based KDE4 version) still works fine here though even
with libvdpau_va_gl1.

Dragonplayer just uses Phonon, so it may help to switch to phonon-backend-
gstreamer. If that doesn't work either, you may try to uninstall gstreamer-
plugins-vaapi...

Kind Regards,
Wolfgang

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >