Mailinglist Archive: opensuse-factory (807 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170211 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170211

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
apparmor (2.10.2 -> 2.11.0)
appstream-glib (0.6.7 -> 0.6.8)
bluedevil5 (5.9.0 -> 5.9.1)
breeze (5.9.0 -> 5.9.1)
breeze-gtk (5.9.0 -> 5.9.1)
breeze4-style (5.9.0 -> 5.9.1)
cmis-client
dbus-1
efivar
ekiga
enblend-enfuse
esound
evince
geoclue2
gnome-maps
intel-gpu-tools
java-1_8_0-openjdk
kactivitymanagerd (5.9.0 -> 5.9.1)
kamera
kcm_sddm (5.9.0 -> 5.9.1)
kde-cli-tools5 (5.9.0 -> 5.9.1)
kde-gtk-config5 (5.9.0 -> 5.9.1)
kde-user-manager (5.9.0 -> 5.9.1)
kgamma5 (5.9.0 -> 5.9.1)
kgpg
khotkeys5 (5.9.0 -> 5.9.1)
kinfocenter5 (5.9.0 -> 5.9.1)
kmenuedit5 (5.9.0 -> 5.9.1)
knotes
korganizer
kscreen5 (5.9.0 -> 5.9.1)
kscreenlocker (5.9.0 -> 5.9.1)
ksshaskpass5 (5.9.0 -> 5.9.1)
ksysguard5 (5.9.0 -> 5.9.1)
kwin5 (5.9.0 -> 5.9.1)
ldb (1.1.27 -> 1.1.29)
libapparmor (2.10.2 -> 2.11.0)
libgnome-keyring
libkdecoration2 (5.9.0 -> 5.9.1)
libkipi
libkolab-qt5
libkolabxml
libkscreen2 (5.9.0 -> 5.9.1)
libksysguard5 (5.9.0 -> 5.9.1)
libktorrent
libproxy
libproxy-plugins
libssh (0.7.2 -> 0.7.4)
libvirt
libyui-qt (2.47.0 -> 2.47.1)
lynx
milou5 (5.9.0 -> 5.9.1)
oxygen5 (5.9.0 -> 5.9.1)
plasma-nm5 (5.9.0 -> 5.9.1)
plasma5-addons (5.9.0 -> 5.9.1)
plasma5-desktop (5.9.0 -> 5.9.1)
plasma5-integration (5.9.0 -> 5.9.1)
plasma5-openSUSE
plasma5-pa (5.9.0 -> 5.9.1)
plasma5-session (5.9.0 -> 5.9.1)
plasma5-workspace (5.9.0 -> 5.9.1)
polkit-default-privs
polkit-kde-agent-5 (5.9.0 -> 5.9.1)
powerdevil5 (5.9.0 -> 5.9.1)
python-pyasn1 (0.1.9 -> 0.2.2)
python-setuptools
samba
syndication
systemsettings5 (5.9.0 -> 5.9.1)
tdb (1.3.11 -> 1.3.12)
tevent (0.9.29 -> 0.9.31)
tracker
tracker-extras
vigra
virtualbox
xdm
ypbind
zsh

=== Details ===

==== apparmor ====
Version update (2.10.2 -> 2.11.0)
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-profiles apparmor-utils pam_apparmor pam_apparmor-32bit perl-apparmor
python3-apparmor

- add upstream-changes-r3616..3628.diff:
- update abstractions/base, abstractions/apache2-common and dovecot profiles
- merge ask_the_questions() of aa-logprof and aa-mergeprof
- pass LDFLAGS when building parser, libapparmor perl bindings and
pam_apparmor
- adjust deleting the cache in profiles %post to the new cache location
- silence errors when deleting the cache (boo#976914)
- split libapparmor into separate spec to get rid of build loop
involving mariadb, systemd, apparmor, libapr and mariadb again
(see the discussion in SR 448871 for details)
- update to AppArmor 2.11.0
- apparmor_parser now supports parallel compiles and loads
- add full support for dbus, ptrace and signal rules and events to the
utils
- full rewrite of the file rule handling in the utils
- lots of improvements and fixes
- see http://wiki.apparmor.net/index.php/ReleaseNotes_2_11 for the
detailed changelog
- patches:
- add sshd-profile-drop-local-include-r3615.diff to fix 'make check'
- drop aa-unconfined-fix-netstat-call-2.10r3380.diff, no longer needed
- refresh apparmor-abstractions-no-multiline.diff
- refresh apparmor-samba-include-permissions-for-shares.diff
- spec changes:
- aa-unconfined switched to using ss (from iproute2), adjust Recommends:
- move libapparmor to /usr/lib*/
- drop %if %suse_version checks for 12.x
- change several Obsoletes from %version to < 2.9. Those package names
weren't used since years, and 2.9 is still a careful choice
- include apparmor.service independent of %suse_version
- techdoc.pdf is now shipped in upstream tarball to reduce BuildRequires
- drop latex2html, texlive-* and w3m BuildRequires
- techdoc.txt and techdoc.html not included, drop them from the package
- run most of utils/ make check (some tests expect /etc/apparmor.d/ and
/sbin/apparmor_parser to exist, skip them)
- BuildRequires python3-pyflakes (utils tests) and dejagnu (libapparmor tests)
- drop sed'ing python3 into aa-* shebang (upstreamed)
- build binutils
- aa-exec is now written in C and lives in /usr/bin/, move it to the
apparmor_parser package and create a compability symlink in /usr/sbin/
- aa-exec manpage moved to section 1
- aa-enabled is a small new tool to find out if AppArmor is enabled
- package new aa_stack_profile(2) manpage

==== appstream-glib ====
Version update (0.6.7 -> 0.6.8)
Subpackages: libappstream-builder8 libappstream-glib8

- Update to version 0.6.8:
+ Do not ignore type=replace merge components.
+ Tighten a rule that classifies apps as web-apps.
+ Support reading metainfo.xml files when using
appstream-compose.
+ Read and write the <custom> tag.
+ appstream-compose: Support appdata with no desktop files.
+ AsStore: hold a ref in hash_unique_id to avoid use-after-free.
+ trivial: profile: Free mutex resources in finalize().
+ trivial: Update app ID rename list.
+ store: Fix use after free with hash table keys.
+ Add a destructor for AsRefString.
+ Make gperf a hard dep.
+ Fix the build with gperf 3.1.
+ Ignore -Wconversion and -Wsign-conversion warnings from
generated file.
+ Require name and summary for validate-relax.
+ util: Add a dummy update_contact to appdata-from-desktop.
+ trivial: Fix a crash when removing apps from the store.
+ Release version 0.6.8.
- Add gperf BuildRequires: New dependency.

==== bluedevil5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== breeze ====
Version update (5.9.0 -> 5.9.1)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* [KStyle] Don't draw focus indicator on ComboBox entries

==== breeze-gtk ====
Version update (5.9.0 -> 5.9.1)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== breeze4-style ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* [KStyle] Don't draw focus indicator on ComboBox entries

==== cmis-client ====

- Description updates
- Rename %soname to %sover to better reflect its use

==== dbus-1 ====
Subpackages: dbus-1-devel libdbus-1-3 libdbus-1-3-32bit

- A note for scripts bsc#974092 (remove sysvinit script) is already
fixed here.

==== efivar ====

- Add efivar-use-sysmacros.patch to fix the Factory/Tumbleweed
build correctly.
- Amend the spec file to specify the gcc version for SLE11SP4
- Fix building for SLE11SP4, SLE12SP2, and Tumbleweed
(fate#322108, bnc#1012765)

==== ekiga ====
Subpackages: ekiga-lang ekiga-plugins-evolution

- Use individual libboost-*-devel packages instead of boost-devel.
+ Add conditional libboost_signals-devel BuildRequires.

==== enblend-enfuse ====

- use individual libboost-*-devel packages instead of boost-devel

==== esound ====
Subpackages: libesd-devel libesd0

- Drop esound-daemon subpackage (and related binaries):
+ openSUSE builds on pulseaudio. For applications that really
still want to connect to ESD, there is pulseaudio-esound-compat
in place (as a drop-in replacement, it also provides
esound-daemon)
+ Drop esound.init and sysconfig.esound: sources were only used
to configure the daemon.

==== evince ====
Subpackages: evince-plugin-comicsdocument evince-plugin-djvudocument
evince-plugin-dvidocument evince-plugin-pdfdocument evince-plugin-psdocument
evince-plugin-tiffdocument evince-plugin-xpsdocument libevdocument3-4
libevview3-3 nautilus-evince typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0

- Workaround bgo#738370: Disable the browser-plugin (pass
- -disable-browser-plugin to configure) and evince-browser-plugin
package, make main package obsolete the browser-plugin package to
avoid update issues.

==== geoclue2 ====
Subpackages: typelib-1_0-Geoclue-2_0

- Drop convenience shortcut for rcgeoclue, as this is a dbus
activated service, there is no point in that shortcut, no human
should ever manually call it. Following this, filter warning now
produced via rpmlintrc.

==== gnome-maps ====

- Improve package description.

==== intel-gpu-tools ====

- Add u_respect_cflags.diff
- supersedes N_intel-gpu-tools_Fix_libkmod.h_include_path_1320.patch,
N_intel-gpu-tools_Fix_libkmod.h_include_path_1315.patch,
N_intel-gpu-tools_Fix_libkmod.h_include_path.patch

==== java-1_8_0-openjdk ====
Subpackages: java-1_8_0-openjdk-headless

- Don't run bootstrap build for s390, since it is broken, instead
introduce a little cycle on this platform, in order to have
working openjdk8

==== kactivitymanagerd ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Merge Plasma/5.8 into Plasma/5.9
* Backporting the fixes from master
* Sync the dbus ActivityInfo structure with the framework

==== kamera ====

- Drop wrong description and replace with text from Debian

==== kcm_sddm ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Set wallpaper type in SDDM config

==== kde-cli-tools5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Merge Plasma/5.8 into Plasma/5.9

==== kde-gtk-config5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kde-user-manager ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kgamma5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kgpg ====

- use individual libboost-*-devel packages instead of boost-devel

==== khotkeys5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: khotkeys5-devel

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kinfocenter5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kmenuedit5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== knotes ====

- use individual libboost-*-devel packages instead of boost-devel

==== korganizer ====

- use individual libboost-*-devel packages instead of boost-devel

==== kscreen5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Merge Plasma/5.8 into Plasma/5.9
* guard against nullptr-access to the OutputPtr
* apply config change after correcting invalid mode
* no use in setting modes on disabled outputs
* correct possibly invalid current mode
* Disable unify button when only one output is connected
* Increase precision of refresh rate
* Move back to runtime connection

==== kscreenlocker ====
Version update (5.9.0 -> 5.9.1)
Subpackages: libKScreenLocker5

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== ksshaskpass5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Merge Plasma/5.8 into Plasma/5.9
* Workaround for keys stored with an extra space at the end
* Fix several problems in algorithm of deriving key filename from a prompt
message supplied by ssh-add

==== ksysguard5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== kwin5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: kwin5-devel

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Call performMoveResize when we got a new geoemtry during resize
* [autotests] Add test case for resizing window manually

==== ldb ====
Version update (1.1.27 -> 1.1.29)
Subpackages: libldb1 libldb1-32bit

- Update to 1.1.29
+ add support for LDB_CONTROL_RECALCULATE_RDN_OID on ldb_modify()
+ Performance and memory consumption improvements

==== libapparmor ====
Version update (2.10.2 -> 2.11.0)
Subpackages: libapparmor-devel libapparmor1 libapparmor1-32bit

- split libapparmor into separate spec to get rid of build loop
involving mariadb, systemd, apparmor, libapr and mariadb again
(see the discussion in SR 448871 for details)
- libapparmor.spec is based on the AppArmor 2.11 apparmor.spec, but
with minimum BuildRequires

==== libgnome-keyring ====
Subpackages: libgnome-keyring-devel libgnome-keyring0
typelib-1_0-GnomeKeyring-1_0

- Drop the provides and obsoletes of gnome-keyring from
baselibs.conf: the library does not provide all the capabilities
gnome-keyring did. The package gnome-keyring-32bit still exists.

==== libkdecoration2 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== libkipi ====
Subpackages: libKF5Kipi32_0_0 libkipi-devel

- Restore the separate data package that includes the icons and
desktop-file. This would restore the SLPP for the library package

==== libkolab-qt5 ====

- use individual libboost-*-devel packages instead of boost-devel

==== libkolabxml ====

- Add missing libboost-*-devel requirements to the devel package
to fix the build of dependent packages in Tumbleweed

==== libkscreen2 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Fix type argument for get property call
* disable logging to kscreen.log by default
* allow changing an output's modelist at runtime

==== libksysguard5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== libktorrent ====
Subpackages: libktorrent-devel libktorrent6 libktorrent6-lang

- use individual libboost-*-devel packages instead of boost-devel

==== libproxy ====
Subpackages: libproxy-devel libproxy1

- Have libproxy1-config-kde require libqt5-qtpaths instead of
libqt5-qttools on openSUSE > 13.2 / openSUSE > Leap 42.x
(boo#988808).

==== libproxy-plugins ====
Subpackages: libproxy1-config-gnome3 libproxy1-config-kde
libproxy1-networkmanager libproxy1-pacrunner-webkit

- Have libproxy1-config-kde require libqt5-qtpaths instead of
libqt5-qttools on openSUSE > 13.2 / openSUSE > Leap 42.x
(boo#988808).

==== libssh ====
Version update (0.7.2 -> 0.7.4)
Subpackages: libssh-devel libssh4

- Update to version 0.7.4
* Added id_ed25519 to the default identity list
* Fixed sftp EOF packet handling
* Fixed ssh_send_banner() to confirm with RFC 4253
* Fixed some memory leaks
- Removed patch gcc5-fixes.patch

==== libvirt ====
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- SLE12 SP2 bugs merged via version updates of the Factory libvirt
package:
bsc#986718
- SLE12 SP2 FATEs merged via version updates of the Factory libvirt
package:
FATE#316228, FATE#316628, FATE#319531, FATE#319810, FATE#320490
- Replaced libxl-dom0-balloon-fix.patch with upstream patch
f86a7a83-libxl-dom0-balloon-fix.patch

==== libyui-qt ====
Version update (2.47.0 -> 2.47.1)

- Fix crash when shutting down the UI (gh#libyui-libyui-qt#41, bsc#931762)
- Fix a problem with hanging UI
- 2.47.1

==== lynx ====

- security update:
* CVE-2016-9179 [bsc#1008642]
+ lynx-CVE-2016-9179.patch

==== milou5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== oxygen5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== plasma-nm5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* elide Network Manager KCM tabs

==== plasma5-addons ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* check on current comic to be valid

==== plasma5-desktop ====
Version update (5.9.0 -> 5.9.1)

- Add patch to fix regression with security fix (allow running .desktop files
inside desktop:/, boo#1024446)
* plasma-desktop-run.patch
- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* [Solid Device Actions KCM] Encode action file name
* [Task Manager] Enable "Mark applications that play audio" option only if
plasma-pa is available
* Fix i18n extraction in Kickoff Buttons
* Add missing include in sortedactivitiesmodel to fix build with GCC 7
* Add missing include in sortedactivitiesmodel to fix build with GCC 7
* Fix i18n extraction: xgettext doesn't recognize single quotes
* Use consistent default icon in UserManager and Kicker
* Revamp (Activity) Pager wheel handling
* [Folder View] Open selection in preferred application instead of running
them
* [Folder View] show script execution prompt when clicking item
* And maybe don't undo the fix while fixing the fix ...
* Fix startup warning introduced in 3568d8e4.
* Fix clearing selection when rectangle selection contains no items.
* Fix Plasmoid.busy visualization in desktop containment.
* Call correct function and fix warning.
* Fix crash and loss of favorites model on refresh with pagination on.
* Make parts of KCM Touchpad interface translatable (Patch by Victor
<victorr2007@xxxxxxxx>)
* Clip by bounding delegate size instead of Item.clip.
* fix autotest
- Remove patches, now upstream:
* 0001-Folder-View-show-script-execution-prompt-when-clicki.patch
* 0002-Folder-View-Open-selection-in-preferred-application-.patch

==== plasma5-integration ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Update to 5.9.1

==== plasma5-pa ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Always check if context is valid when calling pa functions

==== plasma5-session ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1

==== plasma5-workspace ====
Version update (5.9.0 -> 5.9.1)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* [User Switcher] Ungrab keyboard before trying to lock the screen
* react to config change
* [System Tray Containment] Drop useless Q_INVOKABLE from .cpp file
* [System Tray Containment] Ungrab mouse before opening context menu
* [AppMenu Applet] Map from scene after mapping from global
* Fix memory leak in Appmenu when using compact menu
* [Appmenu Applet] Check whether buttonGrid has a window before calling
mapToGlobal
* [Digital Clock] Take into account timezone label width for applet size
* [KRunner] In doubt use primary screen for view position
* Drop legacy fixup rule for VirtualBox.
* fix isOutputRedundant logic
* fix isOutputRedundant logic
* When swapping Wallpapers, save the config to file, not just to propertymap
- Remove patches, now upstream:
* 0001-When-swapping-Wallpapers-save-the-config-to-file-not.patch
* 0002-fix-isOutputRedundant-logic.patch
- Add patch to fix 5.9.0 regression:
* 0001-make-services-disqualification-much-stricter.patch

==== polkit-default-privs ====

- polkit-default-privs: adding blueman actions (bsc#987141)

==== polkit-kde-agent-5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* Merge Plasma/5.8 into Plasma/5.9

==== powerdevil5 ====
Version update (5.9.0 -> 5.9.1)

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== python-pyasn1 ====
Version update (0.1.9 -> 0.2.2)

- updated to upstream release 0.2.2 with security fixes
- updated project and source URLs and list of doc files
Revision 0.2.2, released 07-02-2017
- FIX TO A SECURITY WEAKNESS: define length only decoders could have
successfully
processed indefinite length serialization.
- FIX TO A SECURITY WEAKNESS: canonical decoders (CER/DER) may have successfully
consumed non-canonical variations of (otherwise valid) serialization.
- Broken Enumerated subtyping fixed.
Revision 0.2.1, released 05-02-2017
- FIX TO A SECURITY WEAKNESS: BER decoder improperly cached long tags.
- New "native" codec implemented to transform pyasn1 types to Python built-in
types and back.
- Switched to new-style classes.
- Sphinx documentation added.
- BitString improvements:
* simple string of binary digits is now supported as initializer
* default str() yields string of binary digits (used to yield str(tuple())
* binValue and hexValue initializers added
* .asNumbers(), .asOctets() and asInteger() representation added
- Components of constructed ASN.1 types can now be populated with
uninitialized ASN.1 objects by assigning either noValue sentinel or
setupComponent() function return in addition to now-legacy None sentinel.
This should improve code readability.
- NoValue class improved to become a singleton and catch more kinds
of access to it.
- Compatibility wrappers str2octs() and oct2strs() fixed to run over
iso-8859-1 encoding.
- Integer changed to emit Real instance if division produces a float.
- True division operation now supported by Integer type.
- The __contains__(), __reverse__() methods implemented for container types
- Iterator protocol support implemented for all container types.
Warning, warning, warning: this change may potentially affect backward
compatibility when:
* user class overrides __getitem__() without overriding __iter__()
* when user code iterates over SEQUENCE object to get its components (now
keys will be yielded)
- Almost complete Python list and dict protocols added to SequenceOf/SetOf and
Sequence/Set respectively
- Fix to divmod operation implementation in Integer type.
- Fix to IntegerDecoder's precomputed value map on Python 3.
- Fix to base ASN.1 types to run in "unicode_literals" mode.
- Fix to composite constraints "+" operands ordering
(AbstractConstraintSet.__radd__)
- Fix to constraints merge in .subtype() -- on merge existing constraints are
expanded to accommodate new constraints, not the other way round. When
existing
constraints are wrapped in ConstraintsIntersection composite, additional
constraints being added on subtyping effectively further narrow the set of
allowed values, which aligns well with the notion of subtyping.
- Fix to NamedTypes methods to handle .getTagMap() returning None
- Fix to Set/Sequence.setDefaultComponents() to return self
- Copyright notice added to non-trivial source code files.
- Author's email changed, copyright extended to 2017

==== python-setuptools ====

- make sure, that setuptools-certpath.patch is applied
unconditionally (fixes traceback in setuptools/ssl_support.py)

==== samba ====
Subpackages: libdcerpc-binding0 libdcerpc-binding0-32bit libdcerpc0
libdcerpc0-32bit libndr-krb5pac0 libndr-krb5pac0-32bit libndr-nbt0
libndr-nbt0-32bit libndr-standard0 libndr-standard0-32bit libndr0 libndr0-32bit
libnetapi0 libnetapi0-32bit libsamba-credentials0 libsamba-credentials0-32bit
libsamba-errors0 libsamba-errors0-32bit libsamba-hostconfig0
libsamba-hostconfig0-32bit libsamba-passdb0 libsamba-passdb0-32bit
libsamba-util0 libsamba-util0-32bit libsamdb0 libsamdb0-32bit
libsmbclient-devel libsmbclient0 libsmbconf0 libsmbconf0-32bit libsmbldap0
libsmbldap0-32bit libtevent-util0 libtevent-util0-32bit libwbclient0
libwbclient0-32bit samba-client samba-client-32bit samba-doc samba-libs
samba-libs-32bit samba-winbind samba-winbind-32bit

- Fix vfs_ceph builds against recent Ceph versions; (bsc#1021933).
- Add base Samba dependency to samba-ceph package.

==== syndication ====

- drop boost as a runtime dependency for -devel subpackage

==== systemsettings5 ====
Version update (5.9.0 -> 5.9.1)
Subpackages: systemsettings5-devel

- Update to 5.9.1
* New feature release
* For more details please see:
* https://www.kde.org/announcements/plasma-5.9.1.php
- Changes since 5.9.0:
* None

==== tdb ====
Version update (1.3.11 -> 1.3.12)
Subpackages: libtdb1 libtdb1-32bit

- Update to version 1.3.12.
+ Fix mutexes on FreeBSD
+ Only mmap the mutex area if not already mmap'ed
+ NULL out tdb->mutexes in tdb_mutex_munmap

==== tevent ====
Version update (0.9.29 -> 0.9.31)
Subpackages: libtevent0 libtevent0-32bit

- Drop redundant PreReq for ldconfig; this is autodetected.
Set RPM group right.
- Use https urls.
- Update to version 0.9.31.
+ Add tevent_req_reset_endtime
+ Make talloc_free safe when threaded_contexts exist
+ Add tevent_update_timer
+ Factor out tevent_common_insert_timer
+ Add threaded immediate activation

==== tracker ====
Subpackages: libtracker-common-1_0 libtracker-control-1_0-0
libtracker-miner-1_0-0 libtracker-sparql-1_0-0 tracker-miner-files
typelib-1_0-Tracker-1_0 typelib-1_0-TrackerControl-1_0

- Trim filler words from description
- Remove ancient %clean section

==== tracker-extras ====
Subpackages: nautilus-extension-tracker-tags tracker-gui

- Trim filler words from description
- Remove ancient %clean section

==== vigra ====

- use individual libboost-*-devel packages instead of boost-devel

==== virtualbox ====
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- use individual libboost-*-devel packages instead of boost-devel

==== xdm ====
Subpackages: xdm-xsession

- no longer try to configure Linux console and X11 keymaps
according to setting in /etc/vconsole.conf; this needs to be done
via localectl by YaST itself now; /etc/X11/xdm/keytable removed
and no longer invoked by /usr/lib/X11/display-manager (bnc#1023211)

==== ypbind ====

- Remove wrong insserv requires and support for old init scripts

==== zsh ====

- fix broken completion for filterdiff: fix-patchutils-completion.patch
(boo#1019130)

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages