Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170125 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170125

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager-vpnc
PackageKit (1.1.4 -> 1.1.5)
abiword-docs (3.0.1 -> 3.0.2)
akonadi-calendar (16.12.0 -> 16.12.1)
akonadi-calendar-tools (16.12.0 -> 16.12.1)
akonadi-contact (16.12.0 -> 16.12.1)
akonadi-mime (16.12.0 -> 16.12.1)
akonadi-notes (16.12.0 -> 16.12.1)
akonadi-search (16.12.0 -> 16.12.1)
akonadi-server (16.12.0 -> 16.12.1)
akregator (16.12.0 -> 16.12.1)
ark (16.12.0 -> 16.12.1)
baloo5-widgets (16.12.0 -> 16.12.1)
bind (9.10.3P4 -> 9.10.4P5)
calendarsupport (16.12.0 -> 16.12.1)
ding-libs
dmidecode
dolphin (16.12.0 -> 16.12.1)
dragonplayer (16.12.0 -> 16.12.1)
eventviews (16.12.0 -> 16.12.1)
gcc-java
gnu-jaf
grantleetheme (16.12.0 -> 16.12.1)
grilo-plugins
gwenview5 (16.12.0 -> 16.12.1)
incidenceeditor (16.12.0 -> 16.12.1)
joe (4.2 -> 4.4)
kaccounts-integration (16.12.0 -> 16.12.1)
kaccounts-providers (16.12.0 -> 16.12.1)
kaddressbook (16.12.0 -> 16.12.1)
kalarmcal (16.12.0 -> 16.12.1)
kamera (16.12.0 -> 16.12.1)
kate (16.12.0 -> 16.12.1)
kcalc (16.12.0 -> 16.12.1)
kcalcore (16.12.0 -> 16.12.1)
kcalutils (16.12.0 -> 16.12.1)
kcharselect (16.12.0 -> 16.12.1)
kcolorchooser (16.12.0 -> 16.12.1)
kcontacts (16.12.0 -> 16.12.1)
kdebase4-runtime (16.12.0 -> 16.12.1)
kdelibs4 (4.14.27 -> 4.14.28)
kdenetwork4-filesharing (16.12.0 -> 16.12.1)
kdepim-addons (16.12.0 -> 16.12.1)
kdepim-apps-libs (16.12.0 -> 16.12.1)
kdepim-runtime (16.12.0 -> 16.12.1)
kdialog (16.12.0 -> 16.12.1)
kdnssd (16.12.0 -> 16.12.1)
kernel-source (4.9.4 -> 4.9.5)
kget (16.12.0 -> 16.12.1)
kgpg (16.12.0 -> 16.12.1)
khelpcenter5 (16.12.0 -> 16.12.1)
kholidays (16.12.0 -> 16.12.1)
kidentitymanagement (16.12.0 -> 16.12.1)
kimap (16.12.0 -> 16.12.1)
kio-extras5 (16.12.0 -> 16.12.1)
kio_audiocd (16.12.0 -> 16.12.1)
kldap (16.12.0 -> 16.12.1)
kleopatra (16.12.0 -> 16.12.1)
kmag (16.12.0 -> 16.12.1)
kmail (16.12.0 -> 16.12.1)
kmail-account-wizard (16.12.0 -> 16.12.1)
kmailtransport (16.12.0 -> 16.12.1)
kmbox (16.12.0 -> 16.12.1)
kmime (16.12.0 -> 16.12.1)
kmousetool (16.12.0 -> 16.12.1)
knotes (16.12.0 -> 16.12.1)
kompare (16.12.0 -> 16.12.1)
konqueror (16.12.0 -> 16.12.1)
konsole (16.12.0 -> 16.12.1)
kontact (16.12.0 -> 16.12.1)
kontactinterface (16.12.0 -> 16.12.1)
kopete (16.12.0 -> 16.12.1)
korganizer (16.12.0 -> 16.12.1)
kpimtextedit (16.12.0 -> 16.12.1)
kqtquickcharts (16.12.0 -> 16.12.1)
krb5
krdc (16.12.0 -> 16.12.1)
krfb (16.12.0 -> 16.12.1)
kruler (16.12.0 -> 16.12.1)
ktnef (16.12.0 -> 16.12.1)
ktp-accounts-kcm (16.12.0 -> 16.12.1)
ktp-approver (16.12.0 -> 16.12.1)
ktp-auth-handler (16.12.0 -> 16.12.1)
ktp-common-internals (16.12.0 -> 16.12.1)
ktp-contact-list (16.12.0 -> 16.12.1)
ktp-contact-runner (16.12.0 -> 16.12.1)
ktp-desktop-applets (16.12.0 -> 16.12.1)
ktp-filetransfer-handler (16.12.0 -> 16.12.1)
ktp-kded-module (16.12.0 -> 16.12.1)
ktp-send-file (16.12.0 -> 16.12.1)
ktp-text-ui (16.12.0 -> 16.12.1)
kwalletmanager5 (16.12.0 -> 16.12.1)
lcms2
libXi (1.7.8 -> 1.7.9)
libdb-4_5
libgcrypt (1.7.3 -> 1.7.6)
libgexiv2
libgravatar (16.12.0 -> 16.12.1)
libimobiledevice (1.2.0 -> 1.2.0+git20170122.45fda81)
libjpeg-turbo
libjpeg62-turbo
libkcddb (16.12.0 -> 16.12.1)
libkcompactdisc (16.12.0 -> 16.12.1)
libkdcraw (16.12.0 -> 16.12.1)
libkdepim (16.12.0 -> 16.12.1)
libkexiv2 (16.12.0 -> 16.12.1)
libkface (16.12.0 -> 16.12.1)
libkgeomap (16.12.0 -> 16.12.1)
libkipi (16.12.0 -> 16.12.1)
libkleo (16.12.0 -> 16.12.1)
libkomparediff2 (16.12.0 -> 16.12.1)
libksane (16.12.0 -> 16.12.1)
libksieve (16.12.0 -> 16.12.1)
mailcommon (16.12.0 -> 16.12.1)
mailimporter (16.12.0 -> 16.12.1)
marble (16.12.0 -> 16.12.1)
messagelib (16.12.0 -> 16.12.1)
mobipocket (16.12.0 -> 16.12.1)
nss_ldap
okular (16.12.0 -> 16.12.1)
openvpn (2.3.13 -> 2.3.14)
pim-storage-service-manager (16.12.0 -> 16.12.1)
pimcommon (16.12.0 -> 16.12.1)
poppler (0.50.0 -> 0.51.0)
poppler-qt5 (0.50.0 -> 0.51.0)
postfix
protobuf
pulseaudio (9.99.1 -> 10.0)
python-numpy (1.11.1 -> 1.12.0)
python3-matplotlib (1.5.3 -> 2.0.0)
rhino
signon-kwallet-extension (16.12.0 -> 16.12.1)
spectacle (16.12.0 -> 16.12.1)
sweeper (16.12.0 -> 16.12.1)
syndication (16.12.0 -> 16.12.1)
texinfo (6.1 -> 6.3)
virtualbox (5.1.12_k4.9.4_1 -> 5.1.12_k4.9.5_1)
webrtc-audio-processing
wine (2.0~rc6 -> 2.0)
wireshark (2.2.3 -> 2.2.4)
xfce4-terminal (0.8.1 -> 0.8.3)

=== Details ===

==== NetworkManager-vpnc ====
Subpackages: NetworkManager-vpnc-gnome

- Enable build for s390x: the entire dependency chain is in place.

==== PackageKit ====
Version update (1.1.4 -> 1.1.5)
Subpackages: PackageKit-backend-zypp PackageKit-gstreamer-plugin
PackageKit-gtk3-module libpackagekit-glib2-18 typelib-1_0-PackageKitGlib-1_0

- Update to version 1.1.5:
+ This release removes the hif backend which is superseded by the
new dnf backend.
+ Bugfixes:
- Fix redeclaration of polkit autocleanup functions.
- Check for a zero-length search string before passing to
backends.
- command-not-found: Ignore commands of only one character.
+ Backends: fixes for alpm, aptcc and katja.
+ Updated translations.

==== abiword-docs ====
Version update (3.0.1 -> 3.0.2)

- Update to version 3.0.2:
+ Documentation updated for abiword 3.0.2.

==== akonadi-calendar ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-calendar-tools ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-contact ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5AkonadiContact5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-mime ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5AkonadiMime5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-notes ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-search ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== akonadi-server ====
Version update (16.12.0 -> 16.12.1)
Subpackages: akonadi-server-sqlite libKF5AkonadiAgentBase5 libKF5AkonadiCore5
libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Add handle-mysql-process-crashes-gracefully.patch from upstream
- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php
- Drop upstream patch fix-connect-api.patch

==== akregator ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ark ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libkerfuffle16

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php
- Drop 0001-Stop-running-executables-when-opening-urls.patch,
merged upstream

==== baloo5-widgets ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== bind ====
Version update (9.10.3P4 -> 9.10.4P5)
Subpackages: bind-chrootenv bind-doc bind-utils idnkit libbind9-140 libidnkit1
libirs141 libisc160 libisccc140 libisccfg140 liblwres141

- Update to latest release in the 9.10.X series
* Security fixes in 9.10.4
* Duplicate EDNS COOKIE options in a response could trigger an assertion
failure.
CVE-2016-2088. [RT #41809]
* The resolver could abort with an assertion failure due to improper DNAME
handling
when parsing fetch reply messages. CVE-2016-1286. [RT #41753]
* Malformed control messages can trigger assertions in named and rndc.
CVE-2016-1285. [RT #41666]
* Certain errors that could be encountered when printing out or logging an
OPT record containing
a CLIENT-SUBNET option could be mishandled, resulting in an assertion
failure. CVE-2015-8705. [RT #41397]
* Specific APL data could trigger an INSIST. CVE-2015-8704. [RT #41396]
* Incorrect reference counting could result in an INSIST failure if a socket
error occurred while performing
a lookup. CVE-2015-8461. [RT#40945]
* Insufficient testing when parsing a message allowed records with an
incorrect class to be be accepted,
triggering a REQUIRE failure when those records were subsequently cached.
CVE-2015-8000. [RT #40987]
* For Features and other fixes in 9.10.4 see
https://kb.isc.org/article/AA-01380/0/BIND-9.10.4-Release-Notes.html
* Description of patch changes
* BIND 9.10.4-P5 addresses the security issues described in CVE-2016-9131,
CVE-2016-9147 and CVE-2016-9444. [bsc#1018699]
* BIND 9.10.4-P4 addresses the security issue described in CVE-2016-8864.
* BIND 9.10.4-P3 addresses the security issue described in CVE-2016-2776 and
addresses an interoperability issue with ECS clients.
* BIND 9.10.4-P2 addresses the security issue described in CVE-2016-2775.
* BIND 9.10.4-P1 addresses Windows installation issues, the %z modifier is
not supported under Windows and
a race condition in the rbt/rbtdb implementation resulting in named exiting
due to assertion failures being detected.
* Following patches removed, fixed upstream
* cve-2016-2776.patch
* cve-2016-8864.patch

==== calendarsupport ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5CalendarSupport5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ding-libs ====
Subpackages: libbasicobjects0 libcollection4 libdhash1 libini_config5
libpath_utils1 libref_array1

- Update to new upstream release 0.6.0
* libini now supports validators that check for well-formed INI
files.

==== dmidecode ====

- dmidecode-07-only-decode-one-dmi-table.patch: Only decode one
DMI table.
https://savannah.nongnu.org/bugs/?50022

==== dolphin ====
Version update (16.12.0 -> 16.12.1)
Subpackages: dolphin-part libdolphinvcs5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== dragonplayer ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== eventviews ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5EventViews5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== gcc-java ====
Subpackages: gcc-gij libgcj-devel

- New package split out from gcc.

==== gnu-jaf ====

- Switch from gcj to java-devel as gcj is getting deprecated

==== grantleetheme ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5GrantleeTheme5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== grilo-plugins ====
Subpackages: grilo-plugin-tracker grilo-plugin-youtube

- Add armv7hl to conditional gstreamer1(element-chromaprint)
BuildRequires: Build for armv7.

==== gwenview5 ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== incidenceeditor ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5IncidenceEditor5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== joe ====
Version update (4.2 -> 4.4)

- Update to version 4.4:
* Fix segfault due to buffer overrun. This happens if a line
with many backslashes appears in the status line context display.
* Fix jmacs: ^X ^F and ^X ^B were not working
* Build fixes for Solaris
* Improve php highlighter: allow numbers in substitution variable names
* Unicode tweak: treat private use characters (Co) as printable
* Dockerfile highlighter: Add Docker new commands from 1.12,
mark bad strings in arrays
* Fix loading external charmaps
- Changes for version 4.3:
* Improve memory usage by shrinking buffer header size and
highlighter state size.
* Improve performance of status line context display (which shows
the first line of the function that the cursor is currently in).
This feature was making JOE very slow on extremely large files with
auto indent enabled (typically JSON or XML data files). Now
the syntax highlighter computes the context display (using a new
syntax named context.jsf).
* Add a mode 'title' to enable or disable the status line context
display (previously autoindent mode was overloaded to do this).
* Disable syntax highlighting and context display in very large
files
* Force more appropriate modes when we enter hex dump display:
enable overtype, disable autoindent, wordwrap, ansi, picture.
* Handle middle mouse button in "joe -mouse" mode (before it did
nothing). It's treated as paste (copy region to mouse) as
expected. (patch from Petr Olsak).
* Do not kill region highlighting during incremental search (patch
from Petr Olsak).
* Negative numbers were not being recognized in blocks
* PgUp/PgDn would try to scroll menu if the window above is a menu
(it should do this only for completion menus associated with
prompts)
* Use 'LC_ALL=C sed' to get JOE to compile in OS X.
* Forward direction delimiter matching where the delimiters do
not begin with special characters (for example in Verilog
"begin" / "end") was not working.
* Get mouse to work in menus: this broke in 4.1
* Character classes with ranges were not working for UTF-8 (as in \\[a-z])
* Apply spec highlighting to .spec files
* Gracefully handle short terminals: fix segfaults which occur when
trying to shrink terminal while many windows are on the screen or
while turning on help with a short terminal. Fix similar bugs
involving the skiptop option. JOE now works even if the terminal
height is only one line.
- Refresh patches
- Small spec file cleanup

==== kaccounts-integration ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libkaccounts1

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kaccounts-providers ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kaddressbook ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kalarmcal ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5AlarmCalendar5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kamera ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kate ====
Version update (16.12.0 -> 16.12.1)
Subpackages: kate-plugins kwrite

- Add upstream patch to fix build with plasma-framework >= 5.30
* remove-popupapplet-servicetype.patch
- Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcalc ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcalcore ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcalutils ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5CalendarUtils5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcharselect ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcolorchooser ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kcontacts ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdebase4-runtime ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdelibs4 ====
Version update (4.14.27 -> 4.14.28)
Subpackages: kdelibs4-core libkde4 libkdecore4 libksuseinstall1

- Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdenetwork4-filesharing ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdepim-addons ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdepim-apps-libs ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdepim-runtime ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php
- Drop fix-data-loss-bug-in-ical.patch due to upstream inclusion

==== kdialog ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdnssd ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kernel-source ====
Version update (4.9.4 -> 4.9.5)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.9.5 (bnc#1003623 bnc#1012628).
- Delete
patches.fixes/revert-tty-serial-8250-add-CON_CONSDEV-to-flags.patch.
- commit 699d1c6
- Refresh
patches.fixes/revert-tty-serial-8250-add-CON_CONSDEV-to-flags.patch.
Update upstream status.
- commit d26480f
- Update config files.
- Refresh patches.suse/stack-unwind-disable-kasan.patch.
- Delete

patches.suse/revert-x86-remove-warning-and-warning_symbol-from-struct-stacktrace_ops.
Update and enable the DWARF unwinder.
- commit d7228f4

==== kget ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kgpg ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php
- Drop 0001-fix-crash-when-GnuPG-does-not-output-curve-fields-fo.patch,
included in this release

==== khelpcenter5 ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kholidays ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kidentitymanagement ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kimap ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kio-extras5 ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kio_audiocd ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kldap ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Ldap5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kleopatra ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmag ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmail ====
Version update (16.12.0 -> 16.12.1)
Subpackages: kmail-application-icons ktnef

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmail-account-wizard ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmailtransport ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmbox ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmime ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmousetool ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== knotes ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kompare ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== konqueror ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Konq6 libkonq-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== konsole ====
Version update (16.12.0 -> 16.12.1)
Subpackages: konsole-part

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kontact ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kontactinterface ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kopete ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== korganizer ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kpimtextedit ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kqtquickcharts ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== krb5 ====
Subpackages: krb5-32bit krb5-client krb5-devel

- Introduce patch
krb5-1.15-fix_kdb_free_principal_e_data.patch
to fix freeing of e_data in the kdb principal

==== krdc ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== krfb ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kruler ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktnef ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-accounts-kcm ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libktpaccountskcminternal9

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-approver ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-auth-handler ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-common-internals ====
Version update (16.12.0 -> 16.12.1)
Subpackages: ktp-icons

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-contact-list ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-contact-runner ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-desktop-applets ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-filetransfer-handler ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-kded-module ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-send-file ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ktp-text-ui ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kwalletmanager5 ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== lcms2 ====
Subpackages: liblcms2-2 liblcms2-2-32bit liblcms2-devel

- Added 0001-Added-an-extra-check-to-MLU-bounds.patch
* fixes https://bugzilla.suse.com/show_bug.cgi?id=1021364

==== libXi ====
Version update (1.7.8 -> 1.7.9)
Subpackages: libXi6 libXi6-32bit

- Update to version 1.7.9:
* Plug a memory leak
* Check that allocating a buffer succeeded
* Fix possible free of uninitialized pointer

==== libdb-4_5 ====
Subpackages: db45-utils

- Add reproducible.patch to allow for reproducible builds

==== libgcrypt ====
Version update (1.7.3 -> 1.7.6)
Subpackages: libgcrypt-devel libgcrypt20 libgcrypt20-32bit

- libgcrypt 1.7.6:
* Fix counter operand from read-only to read/write
* Fix too large jump alignment in mpih-rshift
- libgcrypt 1.7.5:
* Fix regression in mlock detection introduced with 1.7.4
- libgcrypt 1.7.4:
* ARMv8/AArch32 performance improvements for AES, GCM, SHA-256,
and SHA-1.
* Add ARMv8/AArch32 assembly implementation for Twofish and
Camellia.
* Add bulk processing implementation for ARMv8/AArch32.
* Add Stribog OIDs.
* Improve the DRBG performance and sync the code with the Linux
version.
* When secure memory is requested by the MPI functions or by
gcry_xmalloc_secure, they do not anymore lead to a fatal error
if the secure memory pool is used up. Instead new pools are
allocated as needed. These new pools are not protected against
being swapped out (mlock can't be used). Mitigation for
minor confidentiality issues is encryption swap space.
* Fix GOST 28147 CryptoPro-B S-box.
* Fix error code handling of mlock calls.

==== libgexiv2 ====

- Add get_orientation-Fix-abort-on-Minolta-meta-data.patch: Fix
abort on Minolta meta-data (bgo#776233).

==== libgravatar ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Gravatar5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libimobiledevice ====
Version update (1.2.0 -> 1.2.0+git20170122.45fda81)
Subpackages: libimobiledevice-devel libimobiledevice6

- update version 1.2.0+git20170122.45fda81
* m4: use python-config if available to fix python3 support
on newer distros
* lockdown: remove unneeded plist_free() calls since entire dict
is freed later
* lockdown: add more error codes
* add new lockdownd_pair_with_options() function
* fix installation_proxy when using GnuTLS instead of OpenSSL
* tools: fix inverted abort condition in idevicecrashreport
* tools: idevicecrashreport: propertly initialize buffer used
to check for ping message
* tools: idevicecrashreport: fix missing 0-term when creating local
filename
* make sure sockets only listen locally
* idevicebackup: fix some timestamps that are relative to the Mac
epoch instead of Unix one
* avoid potential NULL pointer dereference (leading to segfault) if
functions are called w/ null arguments
* add new functions to get the underlying file descriptor of an
idevice connection
* idevicedebug: show error if container info not found
* diagnostics_relay: plug small memory leak
* file_relay: plug small memory leak
* update GnuTLS certificate callback to new API
* fix SSL version negotiation with newer versions of OpenSSL
* lockdown: remove unnecessary check for pair record file during
pairing
* userpref: remove obsoleted function userpref_has_pair_record()
* idevice: update GnuTLS code to support iOS 10
* lockdown: return LOCKDOWN_E_INVALID_HOST_ID when missing pair record
* idevicebackup2: fix removal of snapshot dir during backup w iOS 10+
* idevicebackup2: add installed application info to Info.plist
during backup
* idevicebackup2: fix assertion occuring when copying non-present MEID
* idevicebackup2: suppress repeated printing of global status when
100% is reached
* idevicebackup2: use remove_file() wrapper instead of remove()
* idevicebackup2: don't report an error when file to remove doesn't
exist
* idevicebackup2: fix heap buffer out-of-bounds write caused by
wrong buffer size
* userpref: [GnuTLS]fix pairing record generation and improve
error handling
* idevicebackup2: plug some small memory leaks
* misagent: add new misagent_copy_all() function (introduced in iOS 9.3)
* ideviceprovision: use newer API to get list of profiles on iOS 9.3+
* ideviceprovision: check output directory parameter for 'copy'
command and return exit code on error
* ideviceprovision: allow copying single profiles instead of all
* ideviceprovision: add new remove-all command to remove all installed
profiles at once
* idevicebackup2: fix logical bug when checking for success of backup
operation
* ideviceprovision: fix ASN1 parsing for large provisioning profiles
* property_list_service: remove packet length check when receiving
plist data
- drop libimobiledevice-CVE-2016-5104.patch, upstreamed
- drop libimobiledevice-nosslv3.patch, upstream changed default
method from SSLv3_method to TLSv1_method.

==== libjpeg-turbo ====
Subpackages: libjpeg8 libjpeg8-32bit libturbojpeg0

- set build date to enable reproducible builds

==== libjpeg62-turbo ====
Subpackages: libjpeg62 libjpeg62-devel

- set build date to enable reproducible builds

==== libkcddb ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkcompactdisc ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkdcraw ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkdepim ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Libkdepim5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkexiv2 ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkface ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5KFace10_0_0 libkface-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkgeomap ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5KGeoMap10_0_0 libkgeomap-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkipi ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Kipi32_0_0 libkipi-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkleo ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Libkleo5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libkomparediff2 ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libksane ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5Sane5 libksane-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libksieve ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== mailcommon ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5MailCommon5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== mailimporter ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5MailImporter5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== marble ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libastro1 libmarblewidget-qt5-26 marble-devel

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== messagelib ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== mobipocket ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== nss_ldap ====
Subpackages: nss_ldap-32bit

- Add reproducible.patch to allow for reproducible builds

==== okular ====
Version update (16.12.0 -> 16.12.1)

- Cleanup/update build requirements
- Add necessary dependencies to the devel package (boo#1020735)
- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== openvpn ====
Version update (2.3.13 -> 2.3.14)

- silence warning about %{_rundir}/openvpn
- for non systemd case: just package the %{_rundir}/openvpn in
the package
- for systemd case: call systemd-tmpfiles and own the dir as
%ghost in the filelist
- refreshed patches to apply cleanly again
openvpn-2.3-plugin-man.dif
openvpn-fips140-2.3.2.patch
- update to 2.3.14
- update year in copyright message
- Document the --auth-token option
- Repair topology subnet on FreeBSD 11
- Repair topology subnet on OpenBSD
- Drop recursively routed packets
- Support --block-outside-dns on multiple tunnels
- When parsing '--setenv opt xx ..' make sure a third parameter
is present
- Map restart signals from event loop to SIGTERM during
exit-notification wait
- Correctly state the default dhcp server address in man page
- Clean up format_hex_ex()
- enabled pkcs11 support

==== pim-storage-service-manager ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== pimcommon ====
Version update (16.12.0 -> 16.12.1)
Subpackages: libKF5PimCommon5

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== poppler ====
Version update (0.50.0 -> 0.51.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 libpoppler66
poppler-tools

- Update to version 0.51.0:
+ core:
- Check for error from NSS in SignatureHandler construct
(fdo#99363).
- Add Form[Field|Widget]::setPartialName
- Fix memory leak in PDFDoc::markAnnotations.
+ qt5:
- Implement digital signature support. Bug #94378
- Add Poppler::FormField::setName
- Fix segfault/assert if LinkDestination is constructed with
invalid input string (fdo#99357).
+ utils: pdfunite: add fields to AcroForm dict (fdo#99141).

==== poppler-qt5 ====
Version update (0.50.0 -> 0.51.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.51.0:
+ core:
- Check for error from NSS in SignatureHandler construct
(fdo#99363).
- Add Form[Field|Widget]::setPartialName
- Fix memory leak in PDFDoc::markAnnotations.
+ qt5:
- Implement digital signature support. Bug #94378
- Add Poppler::FormField::setName
- Fix segfault/assert if LinkDestination is constructed with
invalid input string (fdo#99357).
+ utils: pdfunite: add fields to AcroForm dict (fdo#99141).

==== postfix ====
Subpackages: postfix-doc

- update postfix-mysql
* update mysql_*.cf files
* update postfix-mysql.sql (INNODB, utf8)
- update postfix-main.cf.patch
* uncomment smtpd_sasl_path, smtpd_sasl_type
can be changed via POSTFIX_SMTP_AUTH_SERVICE=(cyrus,dovecot)
* add option for smtp_tls_policy_maps (commented)
- update postfix-master.cf.patch
* fix indentation of submission, smtps options for correct
enabling via config.postfix
- update config.postfix
* fix sync of CA certificates
* fix master.cf generation for submission, smtps
- rebase postfix-vda-v14-3.0.3.patch

==== protobuf ====

- Fix an issue with setup.py where some files are built on the
first invocation, but only copied on the second. This resulted
in an incomplete protobuf-python package.

==== pulseaudio ====
Version update (9.99.1 -> 10.0)
Subpackages: libpulse-devel libpulse-mainloop-glib0 libpulse0 libpulse0-32bit
pulseaudio-bash-completion pulseaudio-esound-compat pulseaudio-module-bluetooth
pulseaudio-module-gconf pulseaudio-module-jack pulseaudio-module-lirc
pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils
pulseaudio-utils-32bit

- Update to 10.0
* Fixed hotplugging support for USB surround sound cards
* Clarified qpaeq license
* https://www.freedesktop.org/wiki/Software/PulseAudio/Notes/10.0/

==== python-numpy ====
Version update (1.11.1 -> 1.12.0)

- update to version 1.12.0:
* Highlights
+ Order of operations in np.einsum can now be optimized for large
speed improvements.
+ New signature argument to np.vectorize for vectorizing with core
dimensions.
+ The keepdims argument was added to many functions.
+ New context manager for testing warnings
+ Support for BLIS in numpy.distutils
+ Much improved support for PyPy (not yet finished)
* full changelog at:
https://github.com/numpy/numpy/blob/master/doc/release/1.12.0-notes.rst
- changes from version 1.11.3:
* #8341: BUG: Fix ndarray.tofile large file corruption in append
mode.
* #8346: TST: Fix tests in PR #8341 for NumPy 1.11.x
- update to version 1.11.2:
* #7736 BUG: Many functions silently drop 'keepdims' kwarg.
* #7738 ENH: Add extra kwargs and update doc of many MA methods.
* #7778 DOC: Update Numpy 1.11.1 release notes.
* #7793 BUG: MaskedArray.count treats negative axes incorrectly.
* #7816 BUG: Fix array too big error for wide dtypes.
* #7821 BUG: Make sure npy_mul_with_overflow_<type> detects
overflow.
* #7824 MAINT: Allocate fewer bytes for empty arrays.
* #7847 MAINT,DOC: Fix some imp module uses and update f2py.compile
docstring.
* #7849 MAINT: Fix remaining uses of deprecated Python imp module.
* #7851 BLD: Fix ATLAS version detection.
* #7896 BUG: Construct ma.array from np.array which contains
padding.
* #7904 BUG: Fix float16 type not being called due to wrong
ordering.
* #7917 BUG: Production install of numpy should not require nose.
* #7919 BLD: Fixed MKL detection for recent versions of this
library.
* #7920 BUG: Fix for issue #7835 (ma.median of 1d).
* #7932 BUG: Monkey-patch _msvccompile.gen_lib_option like other
compilers.
* #7939 BUG: Check for HAVE_LDOUBLE_DOUBLE_DOUBLE_LE in
npy_math_complex.
* #7953 BUG: Guard against buggy comparisons in generic quicksort.
* #7954 BUG: Use keyword arguments to initialize Extension base
class.
* #7955 BUG: Make sure numpy globals keep identity after reload.
* #7972 BUG: MSVCCompiler grows 'lib' & 'include' env strings
exponentially.
* #8005 BLD: Remove __NUMPY_SETUP__ from builtins at end of
setup.py.
* #8010 MAINT: Remove leftover imp module imports.
* #8020 BUG: Fix return of np.ma.count if keepdims is True and axis
is None.
* #8024 BUG: Fix numpy.ma.median.
* #8031 BUG: Fix np.ma.median with only one non-masked value.
* #8044 BUG: Fix bug in NpyIter buffering with discontinuous arrays.
- update copyright year
- changed from tar.gz to zip on pypi
- Remove long-unused atlas support.
- Use preferrered pypi.io download url.
- Add openBLAS support.
This can improve performance in many situations.
- Remove numpy-1.10.4-cblas.patch since openblas handles this.

==== python3-matplotlib ====
Version update (1.5.3 -> 2.0.0)
Subpackages: python3-matplotlib-cairo python3-matplotlib-gtk3

- update to version 2.0.0
+ Highlights include:
* 'viridis' is default color map instead of jet.
* Modernized the default color cycle.
* Many more functions respect the color cycle.
* Line dash patterns scale with linewidth.
* Change default font to DejaVu, now supports most Western alphabets
(including Greek, Cyrillic and Latin with diacritics), math symbols and emoji
out of the box.
* Faster text rendering.
* Improved auto-limits.
* Ticks out and only on the right and bottom spines by default.
* Improved auto-ticking, particularly for log scales and dates.
* Improved image support (imshow respects scales and eliminated a class of
artifacts).

==== rhino ====

- Build with java not gcj as it gets deprecated

==== signon-kwallet-extension ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== spectacle ====
Version update (16.12.0 -> 16.12.1)

- Add patch to support Plasma 5.9 feature of images in notifications:
* set-screenshot-URL-for-notification.patch
- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== sweeper ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== syndication ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== texinfo ====
Version update (6.1 -> 6.3)
Subpackages: info makeinfo

- Update to version 6.3:
* Language:
+ The commands `@setcontentsaftertitlepage' and
`@setshortcontentsaftertitlepage' have been removed.
+ @-commands are no longer supported within `@errormsg'.
* texinfo.tex:
+ For a couple of characters (opening and closing braces), use glyphs
from the standard TeX math fonts instead of using EC fonts which are
less likely to be installed.
+ Use of user-defined macros in the text of an index entry is more
reliable when the text contains Texinfo @-commands.
+ @synindex and @syncodeindex have been fixed (broken in the last
release).
+ Support added for native UTF-8 support with XeTeX and LuaTeX.
+ Support of PDF output with XeTeX improved.
+ You can use a new file doc/texinfo-ja.tex for Texinfo documents in
Japanese. doc/short-sample-ja.tex is a sample document. New
support file doc/txi-ja.tex for Japanese.
+ texi2any:
+ Fix handling of compiler options when building Perl extension modules.
* texi2dvi:
+ Can now process files whose absolute paths contain space characters,
as long a relative path to the file is given. Better support of
files with unusual characters in their names.
+ No longer exits prematurely in some circumstances (due to the script
running under "set -e").
+ Bug fixed which made the `--command' and `--tidy' options
incompatible.
* info:
+ Handling of "invalid" value in infokey file fixed.

==== virtualbox ====
Version update (5.1.12_k4.9.4_1 -> 5.1.12_k4.9.5_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- The printing of the warning about the insecurity in USB passthru had been
lost. As most people are likely to want that feature,
the logic has been inverted. Now, the required udev commands to allow
passthru are included. The first time that VB is started,
the user will get a screen that points to the bug entry discussing the
problem and states what they should do to block the
insecure usage. In any case, that screen will only be printed once. File
"virtualbox-60-vboxdrv.rules" has been added
These changes address the issues in bnc #1018340.

==== webrtc-audio-processing ====

- Add baselibs.conf for gstreamer-plugins-bad-32bit

==== wine ====
Version update (2.0~rc6 -> 2.0)
Subpackages: wine-32bit

- Updated to 2.0 final release

==== wireshark ====
Version update (2.2.3 -> 2.2.4)
Subpackages: libwireshark8 libwiretap6 libwscodecs1 libwsutil7 wireshark-ui-qt

- Wireshark 2.2.4:
This release fixes two minor vulnerabilities that could be use to
cause Wireshark to go into a large or infinite loop by sending
specially crafted packages over the network or into a capture file
(bsc#1021739)
* The ASTERIX dissector could go into an infinite loop
wnpa-sec-2017-01
* The DHCPv6 dissector could go into a large loop.
wnpa-sec-2017-02
* Further bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-2.2.4.html

==== xfce4-terminal ====
Version update (0.8.1 -> 0.8.3)
Subpackages: xfce4-terminal-lang

- Update to 0.8.3.
* Fix incorrect initial position of a drop-down window under
Unity.
* min-height/width CSS properties not available in old GTK
versions.
* Remove redundant set_window_geometry_hints() call.
* Add Help button to Set Title dialog.
* GtkColorButton show-editor property only available starting
with GTK 3.20.
* Watch for screen size changes to update drop-down window size
or position accordingly. Size change signal is emitted when
monitor resolution is changed or another monitor is connected.
* Make slim tabs even more slim.
* Translation updates: Chinese (China), Lithuanian, Thai.
- Changes in 0.8.2.
* Add hidden option MiscSlimTabs to override huge gtk3 tabs
style.
* Temporarily show menubar with F10 even if it's hidden.
* Add "Run custom command instead of shell" feature.
* Fix segfault on dragging last window tab to another window.
* Add option for ambigouos-width characters (narrow/wide).
* Don't show palette when editing palette colors in preferences.
* Fix move dropdown window to monitor with pointer behavior.
* When un-closing a tab, set it active if it was active when it
got closed.
* Set locale as vte encoding in case encoding is not set in prefs
(support for running 'LANG=charset xfce4-terminal').
* Allow to specify text selection background color.
* Allow to select system-wide monospace font in preferences.
* Fix Alt+n shortcuts when starting with several tabs.
* Add option to automatically copy selection to the clipboard.
* Support background image transparency.
* Fix deprecation warnings.
* Support setting drop-down status bar icon with --icon option.
* Fix terminal geometry hints for GTK < 3.19.5.
* Translation updates: Arabic, Bulgarian, Catalan, Chinese
(China), Chinese (Taiwan), Croatian, Czech, Danish, Deutsch,
Dutch, French, Hebrew, Italian, Japanese, Kazakh, Korean,
Lithuanian, Malay, Norwegian Bokmål, Polish, Portuguese,
Portuguese (Brazil), Russian, Slovak, Spanish, Swedish,
Ukrainian.

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages