Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170123 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170123

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
Mesa
dtv-scan-tables (20150208 -> 20161227)
evolution (3.22.3 -> 3.22.4)
evolution-data-server (3.22.3 -> 3.22.4)
evolution-ews (3.22.3 -> 3.22.4)
gdk-pixbuf (2.36.3 -> 2.36.4)
glib2
gnome-software (3.22.4 -> 3.22.5)
gtk3 (3.22.6 -> 3.22.7)
kcachegrind (16.12.0 -> 16.12.1)
kdbg (2.5.6 -> 2.9.0)
kde-l10n (16.12.0 -> 16.12.1)
kernel-firmware (20161130 -> 20170113)
kgoldrunner (16.12.0 -> 16.12.1)
kmouth (16.12.0 -> 16.12.1)
kolf (16.12.0 -> 16.12.1)
konquest (16.12.0 -> 16.12.1)
kreversi (16.12.0 -> 16.12.1)
ksirk (16.12.0 -> 16.12.1)
kspaceduel (16.12.0 -> 16.12.1)
ksudoku (16.12.0 -> 16.12.1)
kubrick (16.12.0 -> 16.12.1)
libgtop (2.34.1 -> 2.34.2)
libinput (1.5.3 -> 1.6.0)
llvm3_9
lskat (16.12.0 -> 16.12.1)
obs-service-tar_scm (0.7.0.1481203567.804351a -> 0.7.0.1484082405.7671be8)
pavucontrol
poxml (16.12.0 -> 16.12.1)
python-SecretStorage
python-atspi (2.20.2 -> 2.20.3)
python-keyring (10.0.2 -> 10.2)
python3-atspi (2.20.2 -> 2.20.3)
python3-numpy (1.11.2 -> 1.12.0)
python3-setuptools (32.3.1 -> 33.1.1)
step (16.12.0 -> 16.12.1)
umbrello (16.12.0 -> 16.12.1)
webkit2gtk3 (2.14.2 -> 2.14.3)
wine (2.0~rc5 -> 2.0~rc6)
xf86-input-evdev (2.10.4 -> 2.10.5)
xf86-video-intel (2.99.917.703_b45dbdb -> 2.99.917.747_g028c946)
xf86-video-nv (2.1.20 -> 2.1.21)
xf86-video-r128 (6.10.1 -> 6.10.2)
yast2 (3.2.11 -> 3.2.12)
yast2-installation (3.2.13 -> 3.2.15)
yast2-network (3.2.17 -> 3.2.18)
yast2-packager (3.2.10 -> 3.2.11)

=== Details ===

==== Mesa ====
Subpackages: Mesa-dri-devel Mesa-dri-nouveau Mesa-libEGL-devel Mesa-libEGL1
Mesa-libEGL1-32bit Mesa-libGL-devel Mesa-libGL1 Mesa-libGLESv2-2 Mesa-libglapi0
Mesa-libglapi0-32bit Mesa-libva libOSMesa9 libOSMesa9-32bit libgbm1
libgbm1-32bit libvdpau_nouveau libvdpau_r300 libvdpau_r600 libvdpau_radeonsi
libvulkan_intel libwayland-egl1 libxatracker2

- Updated baselibs.conf to reflect libvulkan_radeon
- Enabled RADV vulkan driver for AMD GPU cards

==== dtv-scan-tables ====
Version update (20150208 -> 20161227)

- Update to version 20161227:
* Add scan file for fi-kaisa
* dvb-t/es-Asturias: whitespace fixes
* Create pl-Krosno_Sucha_Góra
* Create pl-Warszawa
* UPC ?eská republika - value adjustment for FEC
* Rename pl-Krosno_Sucha_Gora with only ASCII characters
* renaming NTSC file because it doesnt actually use 8VSV, updating channel
listings, add channel numbers
* ca-ON-Toronto: adding scan file for Toronto, Canada, added channel numbers
* DVB-T2 for ug-All, Kampala
* DVB-T2 channels with Russia channel range and Vladivostok
- Update _service file to generate changelog as well
- Small spec file cleanup
- Send to Leap (boo#1018436)

==== evolution ====
Version update (3.22.3 -> 3.22.4)
Subpackages: evolution-plugin-bogofilter evolution-plugin-pst-import
evolution-plugin-spamassassin

- Update to version 3.22.4:
+ Fix a crash when deleting a meeting without DTEND.
+ Fix a use-after-free after editor's WebKitWebProcess crash.
+ Attached meeting invitations not shown properly.
+ Crash on paste of a vCard into a message composer body.
+ "Insert text file" sensitive to HTML-significant characters.
+ EWeekView could write out of rows_per_day array.
+ Replace deprecated icalproperty_remove_parameter() with
icalproperty_remove_parameter_by_kind().
+ Replace deprecated icaltime_from_timet() with
icaltime_from_timet_with_zone().
+ Fix few memory leaks.
+ Avoid a (rather rare) crash under message-list.c::build_tree().
+ Bugs fixed: bgo#776224, bgo#776584, bgo#489466, bgo#776813,
bgo#776969, bgo#776958, bgo#776415, bgo#777071.
+ Updated translations.

==== evolution-data-server ====
Version update (3.22.3 -> 3.22.4)
Subpackages: libcamel-1_2-59 libebackend-1_2-10 libebook-1_2-16
libebook-contacts-1_2-2 libecal-1_2-19 libedata-book-1_2-25 libedata-cal-1_2-28
libedataserver-1_2-22 libedataserverui-1_2-1

- Update to version 3.22.4:
+ Correct new module detection when installed by file rename.
+ camel-stream-process: Avoid call of g_debug() in the fork
process.
+ Replace deprecated icalproperty_remove_parameter() with
icalproperty_remove_parameter_by_kind().
+ Replace deprecated icaltime_from_timet() with
icaltime_from_timet_with_zone().
+ [IMAPx] Fix a memory leak.
+ Bugs fixed: bgo#776152, bgo#774304, bgo#777085.

==== evolution-ews ====
Version update (3.22.3 -> 3.22.4)
Subpackages: evolution-ews-lang libeews-1_2-0 libewsutils0

- Update to version 3.22.4:
+ Fix few memory leaks.
+ Bugs fixed: bgo#775951, bgo#775649.

==== gdk-pixbuf ====
Version update (2.36.3 -> 2.36.4)
Subpackages: gdk-pixbuf-devel gdk-pixbuf-query-loaders
gdk-pixbuf-query-loaders-32bit libgdk_pixbuf-2_0-0 libgdk_pixbuf-2_0-0-32bit
typelib-1_0-GdkPixbuf-2_0

- Update to version 2.36.4:
+ Add a fastpath for no-op scales.
+ Documentation improvements (bgo#442452).
+ Fix some coverity warnings (bgo#776945, bgo#768062).
+ Updated translations.

==== glib2 ====
Subpackages: glib2-devel glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Replace dbus-1-x11 Requires of libgio-2_0-0 to dbus-launch:
openSUSE provides two implementations of dbus-launch (with and
without X interaction). For glib, it does not matter which one is
being used (boo#1020651).

==== gnome-software ====
Version update (3.22.4 -> 3.22.5)

- Update to version 3.22.5:
+ Fix local package installation.
+ Fix codec and printer driver installation for packages without
appdata.
+ Fix update notes to show up on the Updates page.
+ Add support for "+" operator at the end of SPDX license
identifiers.
+ Only show the scary firmware warning for removable devices.
+ Various fixes for flatpak support.
+ Fix several potential crashers.
+ Updated translations.

==== gtk3 ====
Version update (3.22.6 -> 3.22.7)
Subpackages: gtk3-data gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-tools
libgtk-3-0 typelib-1_0-Gtk-3_0

- Update to version 3.22.7:
+ Bugs fixed: bgo#165385, bgo#769214, bgo#769835, bgo#774726,
bgo#775846, bgo#776031, bgo#776225, bgo#776485, bgo#776807,
bgo#777031, bgo#777176.
+ Updated translations.
- Drop gtk3-wayland-handle-subsurface-popup-parent.patch: Fixed
upstream.

==== kcachegrind ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kdbg ====
Version update (2.5.6 -> 2.9.0)
Subpackages: kdbg-doc kdbg-lang

- Update to 2.9.0:
* Enhancements
- A brand new application icon.
- There is now a command to detach from a program being debugged.
Thanks to Daniel Black.
- Pointing on a variable shows a value in a popup in more cases.
Thanks to Max Tomilov.
- C++11 keywords are highlighted. Thanks to Michael Hansen.
* Bug fixes
- Line breaks of status bar messages produced by GDB are now trimmed
to avoid that the text is only visible partially. Fix by Gilles Allard.
- (Action and application) icons are installed in an application neutral
location because the launcher menu of modern KDE desktops does not show
the icon otherwise.
- Fixed a typo in the pretty-printer of std::vector<>.
- Drop susepatches.diff, applied upstream
- Revert kde4_runtime_requires change

==== kde-l10n ====
Version update (16.12.0 -> 16.12.1)
Subpackages: kde-l10n-cs kde-l10n-da kde-l10n-da-data kde-l10n-da-doc
kde-l10n-de kde-l10n-de-data kde-l10n-de-doc kde-l10n-el kde-l10n-en_GB
kde-l10n-en_GB-data kde-l10n-en_GB-doc kde-l10n-es kde-l10n-es-data
kde-l10n-es-doc kde-l10n-fr kde-l10n-fr-data kde-l10n-hu kde-l10n-it
kde-l10n-it-data kde-l10n-it-doc kde-l10n-ja kde-l10n-pl kde-l10n-pl-data
kde-l10n-pt kde-l10n-pt_BR kde-l10n-pt_BR-data kde-l10n-ru kde-l10n-ru-data
kde-l10n-zh_CN kde-l10n-zh_TW

- Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kernel-firmware ====
Version update (20161130 -> 20170113)
Subpackages: ucode-amd

- Update to version 20170113:
* WHENCE: Add new amdgpu firmware
* WHENCE: Add new snd_intel_sst_core
* LICENCE.siano: Add copyright years
* linux-firmware: update firmware file for atusb
* Update Intel OPA hfi1 firmware
* cxgb4: Update firmware to revision 1.16.26.0.
* linux-firmware: intel: Update Skylake audio firmware
* linux-firmware: intel: Update Broxton audio firmware
* linux-firmware: Fix DDC file format for Intel Bluetooth 8260/8265
* brcm: add firmware for the BCM4356 SDIO device
* brcm: add firmware for the BCM4358 PCIe device.
* wl127x/wl128x: update firmwares
* atusb: Document that dfu-util needs to be run before device enters runtime
mode
* Fix permissions on ti-connectivity firmware from 05e9fe59

==== kgoldrunner ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kmouth ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kolf ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== konquest ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kreversi ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ksirk ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kspaceduel ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== ksudoku ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== kubrick ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== libgtop ====
Version update (2.34.1 -> 2.34.2)

- Add libgtop-bsc1020294-cpu-buffer.patch: dynamically allocate
memory for buffer when reading /proc/cpuinfo (bsc#1020294
bgo#323354).
- Update to version 2.34.2:
+ Linux: fill last_processor member.
+ Added more gettext options.
+ Updated translations.
- Add url to upstream developer page, silence rpmlint.

==== libinput ====
Version update (1.5.3 -> 1.6.0)
Subpackages: libinput-udev libinput10

- Update to new upstream release 1.6.0
* New touchpad acceleration. This better reflects finger motion,
but can also go a lot faster than before, alleviating some
concerns that the touchpad is too slow.
* The tap parameters have also been changed to provide for a more
responsive cursor.
* The Asus X555LAB now has a smaller middle software button.

==== llvm3_9 ====

- Require LLVMgold and libLTO in llvm-devel, otherwise we get in CMake:
The imported target "LLVMgold" references the file
"/usr/lib64/LLVMgold.so" but this file does not exist.
This happens when requiring llvm3_9-devel directly, not llvm-devel.

==== lskat ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== obs-service-tar_scm ====
Version update (0.7.0.1481203567.804351a -> 0.7.0.1484082405.7671be8)

- Update to version 0.7.0.1484082405.7671be8:
* fix problems with generatechanges when ~/.obs/tar_scm exists

==== pavucontrol ====
Subpackages: pavucontrol-lang

- Add pavucontrol-use-C++11-for-building.patch: Use C++11 for
building, patch from upstream git.
- Following the above add libtool BuildRequires and pass autoreconf
as the patch touches the buildsystem.
- Drop obsolete clean section and conditionals for obsolete
versions of openSUSE.

==== poxml ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== python-SecretStorage ====

- fix building outside OBS

==== python-atspi ====
Version update (2.20.2 -> 2.20.3)

- Update to version 2.20.3:
+ Rename enum module and Enum class not to conflict with stdlib
(needed for python 3.6).

==== python-keyring ====
Version update (10.0.2 -> 10.2)

- update copyright year
- update to 10.2 (requires python-setuptools_scm>=1.15.0)
10.2
----
* #259: Allow to set a custom application attribute for
SecretService backend.
10.1
----
* #253: Backends now expose a '.name' attribute suitable
for identifying each backend to users.

==== python3-atspi ====
Version update (2.20.2 -> 2.20.3)

- Update to version 2.20.3:
+ Rename enum module and Enum class not to conflict with stdlib
(needed for python 3.6).

==== python3-numpy ====
Version update (1.11.2 -> 1.12.0)

- Remove long-unused atlas support.
- Use preferrered pypi.io download url.
- Use conditional build for openblas.
- specfile:
* update copyright year
* changed from tar.gz to zip on pypi
- update to version 1.12.0:
* Highlights
+ Order of operations in np.einsum can now be optimized for large
speed improvements.
+ New signature argument to np.vectorize for vectorizing with core
dimensions.
+ The keepdims argument was added to many functions.
+ New context manager for testing warnings
+ Support for BLIS in numpy.distutils
+ Much improved support for PyPy (not yet finished)
* full changelog at:
https://github.com/numpy/numpy/blob/master/doc/release/1.12.0-notes.rst
- changes from version 1.11.3:
* #8341: BUG: Fix ndarray.tofile large file corruption in append
mode.
* #8346: TST: Fix tests in PR #8341 for NumPy 1.11.x

==== python3-setuptools ====
Version update (32.3.1 -> 33.1.1)

- update to version 33.1.1:
* #921: Correct issue where certifi fallback not being reached on
Windows.
- update to version 33.1.0:
* Installation via pip, as indicated in the Python Packaging User's
Guide, is the officially-supported mechanism for installing
Setuptools, and this recommendation is now explicit in the much
more concise README.
* Other edits and tweaks were made to the documentation. The
codebase is unchanged.
- changes from version 33.0.0:
* #619: Removed support for the tag_svn_revision distribution
option. If Subversion tagging support is still desired, consider
adding the functionality to setuptools_svn in setuptools_svn #2.

==== step ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== umbrello ====
Version update (16.12.0 -> 16.12.1)

- - Update to KDE Applications 16.12.1
* KDE Applications 16.12.1
* https://www.kde.org/announcements/announce-applications-16.12.1.php

==== webkit2gtk3 ====
Version update (2.14.2 -> 2.14.3)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.14.3:
+ Create GLX OpenGL contexts using version 3.2 (core profile)
when available to reduce the memory consumption on Mesa based
drivers.
+ Improve memory pressure handler to reduce the CPU usage on
memory pressure situations.
+ Fix a regression in WebKitWebView title notify signal emission
that caused the signal to be emitted multiple times.
+ Fix high CPU usage in the web process loading hyphenation
dictionaries.
+ More user agent string improvements to improve compatibility
with several websites.
+ Fix web process crash when closing the web view in X11.
+ Fix the build with OpenGL ES2 enabled.
+ Fix several crashes and rendering issues.
+ Security fixes: CVE-2016-7656, CVE-2016-7635, CVE-2016-7654,
CVE-2016-7639, CVE-2016-7645, CVE-2016-7652, CVE-2016-7641,
CVE-2016-7632, CVE-2016-7599, CVE-2016-7592, CVE-2016-7589,
CVE-2016-7623, CVE-2016-7586.
+ Updated translations.

==== wine ====
Version update (2.0~rc5 -> 2.0~rc6)
Subpackages: wine-32bit

- Updated to 2.0-rc6 development snapshot
- Bug fixes only, we are in code freeze.
- updated winetricks

==== xf86-input-evdev ====
Version update (2.10.4 -> 2.10.5)

- update to version 2.10.5
* Two fixes, one new feature for the evdev driver. The new
feature is the ability to change the emulated middle button
number (e.g. useful on devices with physical middle button
as well).

==== xf86-video-intel ====
Version update (2.99.917.703_b45dbdb -> 2.99.917.747_g028c946)

- Update to 2.99.917.703_b45dbdb:
including SNA cursor pointer bug fixes (bsc#1020081)

==== xf86-video-nv ====
Version update (2.1.20 -> 2.1.21)

- Update to version 2.1.21:
* Remove mibstore.h
* Adapt Block/WakeupHandler signature for ABI 23
* init: Initialize VGA IOBase before using it
* Include xf86Modes.h to use functions from hw/xfree86/modes/xf86Modes.c.
* Fix shadow framebuffer implementation.
- supersedes U_Adapt-Block-WakeupHandler-signature-for-ABI-23.patch,
U_Include-xf86Modes.h-to-use-functions-from-hw-xfree86.patch,
U_Remove-mibstore.h.patch,
U_init-Initialize-VGA-IOBase-before-using-it.patch

==== xf86-video-r128 ====
Version update (6.10.1 -> 6.10.2)

- Update to version 6.10.2
* Adapt Block/WakeupHandler signature for ABI 23
* Remove gatos advertisement
* xextproto 7.1 support update to the source code
- supersedes U_Adapt-Block-WakeupHandler-signature-for-ABI-23.patch

==== yast2 ====
Version update (3.2.11 -> 3.2.12)

- Added a CWM::ReplacePoint widget
- 3.2.12
- CWM: when skipping storing of widget values, skip also its
validation (FATE#322328)

==== yast2-installation ====
Version update (3.2.13 -> 3.2.15)

- Do not retry to download release notes if a previous attempt
failed (bsc#1015794)
- 3.2.15
- add ability to roles to enable list of services when selected
(FATE#321754)
- fate#321739
- Made user's interaction possible in case of error in read-only
proposal.
- 3.2.14

==== yast2-network ====
Version update (3.2.17 -> 3.2.18)

- Fixed the assignment of udev rules to Lan Items when a previous
one does not exist (bsc#996879).
- 3.2.18

==== yast2-packager ====
Version update (3.2.10 -> 3.2.11)

- Adjust /etc/zypp/zypp.conf in the installed system when
software/minimalistic_libzypp_config is enabled in the control
file (FATE#321764)
- 3.2.11

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages