Mailinglist Archive: opensuse-factory (562 mails)

< Previous Next >
[opensuse-factory] TW 20170118: ghc-yaml <-> ghc-resourcet dependency conflict
Hi all,

did anyone notice this conflict:

---
Computing distribution upgrade...
2 Problems:
Problem: ghc-yaml-0.8.21.1-1.1.x86_64 requires
libHSresourcet-1.1.8.1-1XWaZ7RmVde330DM5PRI3Z-ghc8.0.1.so()(64bit),
but this requirement cannot be provided
Problem: ghc-xml-hamlet-0.4.0.12-1.10.x86_64 requires
libHSunordered-containers-0.2.7.1-3e8xjAL62g93O6bFkYb1wF-ghc8.0.1.so()(64bit),
but this requirement canno
t be provided

Problem: ghc-yaml-0.8.21.1-1.1.x86_64 requires
libHSresourcet-1.1.8.1-1XWaZ7RmVde330DM5PRI3Z-ghc8.0.1.so()(64bit),
but this requirement cannot be provided
deleted providers: ghc-resourcet-1.1.8.1-1.3.x86_64
Solution 1: Following actions will be done:
deinstallation of ghc-yaml-0.8.21.1-1.1.x86_64
deinstallation of ghc-xml-conduit-1.3.5-2.21.x86_64
deinstallation of ghc-conduit-extra-1.1.15-1.1.x86_64
deinstallation of ghc-DAV-1.3.1-1.12.x86_64
Solution 2: keep obsolete ghc-resourcet-1.1.8.1-1.3.x86_64
Solution 3: break ghc-yaml-0.8.21.1-1.1.x86_64 by ignoring some of its
dependencies

Choose from above solutions by number or skip, retry or cancel
[1/2/3/s/r/c] (c):
---

René
--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups