Mailinglist Archive: opensuse-factory (297 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20170104 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20170104

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
MozillaThunderbird (45.5.1 -> 45.6.0)
akonadi-server
alsa (1.1.2 -> 1.1.3)
alsa-tools
alsa-utils (1.1.2 -> 1.1.3)
atftp
bluedevil5 (5.8.4 -> 5.8.5)
breeze (5.8.4 -> 5.8.5)
breeze-gtk (5.8.4 -> 5.8.5)
breeze4-style (5.8.4 -> 5.8.5)
elfutils
gnutls (3.4.15 -> 3.5.7)
gpg2 (2.1.16 -> 2.1.17)
ibus (1.5.13 -> 1.5.14)
installation-images (14.285 -> 14.288)
iproute2 (4.8 -> 4.9)
kactivitymanagerd (5.8.4 -> 5.8.5)
kcm_sddm (5.8.4 -> 5.8.5)
kde-cli-tools5 (5.8.4 -> 5.8.5)
kde-gtk-config5 (5.8.4 -> 5.8.5)
kde-user-manager (5.8.4 -> 5.8.5)
kdeconnect-kde (1.0.1 -> 1.0.3)
kdepim-runtime
kgamma5 (5.8.4 -> 5.8.5)
khotkeys5 (5.8.4 -> 5.8.5)
kinfocenter5 (5.8.4 -> 5.8.5)
kmail
kmenuedit5 (5.8.4 -> 5.8.5)
kscreen5 (5.8.4 -> 5.8.5)
kscreenlocker (5.8.4 -> 5.8.5)
ksshaskpass5 (5.8.4 -> 5.8.5)
ksysguard5 (5.8.4 -> 5.8.5)
kwin5 (5.8.4 -> 5.8.5)
libkdecoration2 (5.8.4 -> 5.8.5)
libkscreen2 (5.8.4 -> 5.8.5)
libksysguard5 (5.8.4 -> 5.8.5)
libunistring
libvirt-python (2.4.0 -> 2.5.0)
logrotate (3.10.0 -> 3.11.0)
milou5 (5.8.4 -> 5.8.5)
mozilla-kde4-integration
nano (2.7.2 -> 2.7.3)
ncurses
notmuch (0.23.3 -> 0.23.4)
osc (0.155.1 -> 0.156.0)
oxygen5 (5.8.4 -> 5.8.5)
pidgin-openfetion
plasma-nm5 (5.8.4 -> 5.8.5)
plasma5-addons (5.8.4 -> 5.8.5)
plasma5-desktop (5.8.4 -> 5.8.5)
plasma5-integration (5.8.4 -> 5.8.5)
plasma5-openSUSE
plasma5-pa (5.8.4 -> 5.8.5)
plasma5-session (5.8.4 -> 5.8.5)
plasma5-workspace (5.8.4 -> 5.8.5)
polkit-kde-agent-5 (5.8.4 -> 5.8.5)
powerdevil5 (5.8.4 -> 5.8.5)
protobuf
samba (4.5.0 -> 4.5.3)
shim-leap
smb4k (1.2.1 -> 1.2.2)
spec-cleaner (0.9.0 -> 0.9.1)
systemsettings5 (5.8.4 -> 5.8.5)
valgrind (3.11.0 -> 3.12.0)
wireshark (2.2.2 -> 2.2.3)
xf86-video-dummy (0.3.7 -> 0.3.8)
xfce4-settings (4.12.0 -> 4.12.1)
yast2-country (3.2.5 -> 3.2.6)

=== Details ===

==== MozillaThunderbird ====
Version update (45.5.1 -> 45.6.0)
Subpackages: MozillaThunderbird-translations-common

- update to Thunderbird 45.6.0 (boo#1015422)
* The system integration dialog was shown every time when starting
Thunderbird
* MFSA 2016-96
CVE-2016-9899: Use-after-free while manipulating DOM events and
audio elements (bmo#1317409)
CVE-2016-9895: CSP bypass using marquee tag (bmo#1312272)
CVE-2016-9897: Memory corruption in libGLES (bmo#1301381)
CVE-2016-9898: Use-after-free in Editor while manipulating DOM
subtrees (bmo#1314442)
CVE-2016-9900: Restricted external resources can be loaded by
SVG images through data URLs (bmo#1319122)
CVE-2016-9904: Cross-origin information leak in shared atoms
(bmo#1317936)
CVE-2016-9905: Crash in EnumerateSubDocuments (bmo#1293985)
CVE-2016-9893: Memory safety bugs fixed in Thunderbird 45.6

==== akonadi-server ====
Subpackages: akonadi-server-sqlite libKF5AkonadiAgentBase5 libKF5AkonadiCore5
libKF5AkonadiPrivate5 libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Add upstream patch fix-connect-api.patch in order to fix the
subscribe/unsubscribe IMAP folders

==== alsa ====
Version update (1.1.2 -> 1.1.3)
Subpackages: alsa-devel libasound2 libasound2-32bit

- Really bump the version number to 1.1.3 (sorry, forgot to change
in Version tag).
- Update to alsa-lib 1.1.3 release;
just including all previous fixes
- Drop obsoleted patches:
0001-ucm-Add-ucm-files-for-DB410c-board.patch
0002-mixer-Fix-rounding-mode-documentation.patch
0003-pcm-Fix-shm-initialization-race-condition.patch
0004-pcm-Better-understandable-locking-code.patch
0005-ucm-fix-crash-when-calling-snd_use_case_geti-with-no.patch
0006-ucm-docs-typeset-lists-of-identifiers-explicitly.patch
0007-Update-include-sound-tlv.h-from-4.9-pre-kernel-uapi.patch
0008-test-use-actual-information-for-TLV-operation.patch
0009-ctl-improve-API-documentation-for-TLV-operation.patch
0010-ctl-improve-documentation-about-TLV-related-APIs.patch
0011-ctl-correct-documentation-about-TLV-feature.patch
0012-conf-ucm-skylake-add-skylake-rt286-conf-files.patch
0013-pcm_plug-Clear-plugins-on-all-error-conditions.patch
0014-mixer-Don-t-install-smixer-modules-unless-python-is-.patch
0015-pcm_dshare-Do-not-discard-slave-reported-delay-in-st.patch
0016-pcm-direct-Protect-from-freeing-semaphore-when-alrea.patch
0017-pcm-dshare-Fix-endless-playback-of-buffer.patch
0018-pcm-Add-the-PCM-state-checks-to-plugins.patch
0019-pcm-dmix-Do-not-discard-slave-reported-delay-in-stat.patch

==== alsa-tools ====

- Really bump the version number to 1.1.3 (sorry, forgot to change
in Version tag).
- Update to alsa-tools-1.1.3:
just including the previous gcc6 fix.
- Dropped patch: 0001-gcc6-narrowing-error.patch

==== alsa-utils ====
Version update (1.1.2 -> 1.1.3)

- Really bump the version number to 1.1.3 (sorry, forgot to change
in Version tag).
- Update to alsa-utils 1.1.3:
* a couple of amidi fixes
* a few alsabat extensions
* alsaloop cpu hog fix,
* a fix for suspend/resume with aplay
* fix chmap selection in speaker-test WAV mode
* alsaucm man pages,
* fix potential NULL dereferences in alsactl daemon mode
- Add python-docutils to build dependency (for rst2man)
- Fix missing alsaucm man page file in the 1.1.3 tarball

==== atftp ====

- honor --user and --group options in non-daemon mode (bsc#1013565)
* add atftp-drop_privileges_non-daemon.patch

==== bluedevil5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== breeze ====
Version update (5.8.4 -> 5.8.5)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== breeze-gtk ====
Version update (5.8.4 -> 5.8.5)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== breeze4-style ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== elfutils ====
Subpackages: libasm1 libdw1 libelf1

- Add 0001-Add-GCC7-Wimplicit-fallthrough-support-fixes.patch: fix
new warning introduced in GCC 7.
- Add 0001-ar-Fix-GCC7-Wformat-length-issues.patch: fix -Wformat-length
warning introduced in GCC 7.

==== gnutls ====
Version update (3.4.15 -> 3.5.7)
Subpackages: libgnutls-dane0 libgnutls-devel libgnutls-openssl27 libgnutls30

- GnuTLS 3.5.7, the next stable branch, with the following
highlights:
* SHA3 as a certificate signature algorithm
* X25519 (formerly curve25519) for ephemeral EC diffie-hellman
key exchange
* TLS false start
* New APIs to access the Shawe-Taylor-based provable RSA and DSA
parameter generation
* Prevent the change of identity on rehandshakes by default
- GnuTLS 3.4.17:
* libgnutls: Introduced time and constraints checks in the end
certificate in the gnutls_x509_crt_verify_data2() and
gnutls_pkcs7_verify_direct() functions.
* libgnutls: Set limits on the maximum number of alerts handled.
That is, applications using gnutls could be tricked into an
busy loop if the peer sends continuously alert messages.
Applications which set a maximum handshake time (via
gnutls_handshake_set_timeout) will eventually recover but
others may remain in a busy loops indefinitely. This is related
but not identical to CVE-2016-8610, due to the difference in
alert handling of the libraries (gnutls delegates that handling
to applications). boo#1005879
* libgnutls: Enhanced the PKCS#7 parser to allow decoding old
(pre-rfc5652) structures with arbitrary encapsulated content.
* libgnutls: Backported cipher priorities order from 3.5.x branch
That adds CHACHA20-POLY1305 ciphersuite to SECURE priority
strings.
* certtool: When exporting a CRQ in DER format ensure no text data
are intermixed.
* API and ABI modifications:
gnutls_pkcs7_get_embedded_data_oid: Added
- includes changes from 3.4.16:
* libgnutls: Ensure proper cleanups on
gnutls_certificate_set_*key() failures due to key mismatch.
This prevents leaks or double freeing on such failures.
* libgnutls: Increased the maximum size of the handshake message
hash. This will allow the library to cope better with larger
packets, as the ones offered by current TLS 1.3 drafts.
* libgnutls: Allow to use client certificates despite them
containing disallowed algorithms for a session. That allows for
example a client to use DSA-SHA1 due to his old DSA
certificate, without requiring him to enable DSA-SHA1 (and thus
make it acceptable for the server's certificate).
* guile: Backported all improvements from 3.5.x branch.
* guile: Update code to the I/O port API of Guile >= 2.1.4
This makes sure the GnuTLS bindings will work with the
forthcoming 2.2 stable series of Guile, of which 2.1 is a
preview.

==== gpg2 ====
Version update (2.1.16 -> 2.1.17)

- GnuPG 2.1.17:
* gpg: By default new keys expire after 2 years.
* gpg: New command --quick-set-expire to conveniently change the
expiration date of keys.
* gpg: Option and command names have been changed for easier
comprehension. The old names are still available as aliases.
* gpg: Improved the TOFU trust model.
* gpg: New option --default-new-key-algo.
* scd: Support OpenPGP card V3 for RSA.
* dirmngr: Support for the ADNS library has been removed. Now using
bundled libdns, enabling Tor support on all platforms.
New option --standard-resolver can be used to disable this code
at runtime.
* dirmngr: Lazily launch ldap reaper thread.
* tools: New options --check and --status-fd for gpg-wks-client.
* The UTF-8 byte order mark is now skipped when reading conf files.
* Fixed many bugs and regressions.
* Major improvements to the test suite. For example it is possible
to run the external test suite of GPGME.

==== ibus ====
Version update (1.5.13 -> 1.5.14)
Subpackages: ibus-branding-openSUSE-KDE ibus-gtk ibus-gtk3 libibus-1_0-5
python-ibus typelib-1_0-IBus-1_0

- Disable emoji dict build.
- Update to 1.5.14
* Don't warn if DISPLAY is not set.
* Install a DBus service file
* configure: don't hardcode pkg-config
* conf/gconf: Fix SEGV in ibus_config_gconf_get_values
* client/gtk2: Fix SEGV with Wayland display
* ui/gtk3: Fix panel CSS format for GTK 3.20
* engine: Implement Emoji typing with XKB engines
* engine: Add emoji-list.html
* engine: Use annotations/en.xml from unocode.org but not
emoji-list.html
* Fix typo in configure.ac
* tests/ibus-engine-switch: Don't try to remove non-existing GSource
* Fix make dist
* Fix Croatian language code in simple.xml
* Replace deprecated GSimpleAsyncResult with GTask since GLib 2.46

==== installation-images ====
Version update (14.285 -> 14.288)

- fix typo in initrd.file_list
- 14.288
- add uuencode to initrd
- 14.287
- documentation update
- caveats on make's linuxrc env variable
- deleted whitespaces
- some more precise instructions
- added a tree to explicitly show how the directories look like
- added a section link
- added troubleshooting section
- typos fix and wording changes
- deleted images.md because obsolete, instead Anatomy of the images
- 14.286
- test %with_storage_ng flag so we can build against the new yast storage code
directly

==== iproute2 ====
Version update (4.8 -> 4.9)

- Update to new upstream release 4.9
* bridge: vlan: add support to display per-vlan statistics
* tipc: add the ability to get UDP bearer options
* tc: flower: Introduce vlan support
* ss: output TCP BBR diag information
* iptnl: add support for collect_md flag in IPv4 and IPv6 tunnels
* ss: Support displaying and filtering on socket marks.
* tc: fq: display unthrottle latency
* ip link: Add support to configure SR-IOV VF to vlan protocol
802.1ad (VST QinQ)
* ip rule: add selector support
* bridge: add support for the multicast flood flag
* ip: update link types to show 6lowpan and ieee802.15.4 monitor
* ss: Add support for SCTP protocol
* iproute2: macvlan: add "source" mode

==== kactivitymanagerd ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kcm_sddm ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kde-cli-tools5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kde-gtk-config5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kde-user-manager ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kdeconnect-kde ====
Version update (1.0.1 -> 1.0.3)

- Update to 1.0.3
- Update to 1.0.2

==== kdepim-runtime ====

- Add fix-data-loss-bug-in-ical.patch to prevent an critical
data loss. The ical resource failed to create std.ics if it
didn't exists.

==== kgamma5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== khotkeys5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: khotkeys5-devel

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kinfocenter5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kmail ====
Subpackages: kmail-application-icons ktnef

- Recommend akonadi-import-wizard (instead of
akonadi-import-wizards), that's how the package is called

==== kmenuedit5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kscreen5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kscreenlocker ====
Version update (5.8.4 -> 5.8.5)
Subpackages: libKScreenLocker5

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== ksshaskpass5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== ksysguard5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== kwin5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: kwin5-devel

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== libkdecoration2 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== libkscreen2 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== libksysguard5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== libunistring ====

- Add baselibs.conf to generate -32bit packages

==== libvirt-python ====
Version update (2.4.0 -> 2.5.0)

- Update to 2.5.0
- Add all new APIs and constants in libvirt 2.5.0

==== logrotate ====
Version update (3.10.0 -> 3.11.0)

- Remove all patches merged upstream:
* logrotate-addextension.patch
* logrotate-autoext.patch
* logrotate-conf.patch
* logrotate-fix-test62_with_bash-4.4.patch
* logrotate-manpage_config_clarification.patch
* logrotate-var-lib-misc.patch
* logrotate-3.7.8-suse.patch

==== milou5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== mozilla-kde4-integration ====

- Revert kde4_runtime_requires change

==== nano ====
Version update (2.7.2 -> 2.7.3)
Subpackages: nano-lang

- GNU nano 2.7.3:
* now able to handle filenames that contain newlines
* avoid a brief flash of color when switching between buffers
that are governed by different syntaxes
* make the Shift+Ctrl+Arrow keys select text again on a Linux
console
* more resistant against malformations in the positionlog file
* do not crash when ^C is typed on systems where it produces the
code KEY_CANCEL
* no longer mistakenly warn about editing an unlocked file just
after saving a new one

==== ncurses ====
Subpackages: libncurses5 libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base

- Add ncurses patch 20161217
+ add tput-colorcube demo script.
+ add -r and -s options to tput-initc demo, to match usage in xterm.
+ flush the standard output in _nc_flush for the case where SP is zero,
e.g., when called via putp. This fixes a scenario where "tput flash"
did not work after changes in 20130112.
- Add ncurses patch 20161210
+ add configure script option --disable-wattr-macros for use in cases
where one wants to use the same headers for ncurses5/ncurses6
development, by suppressing the wattr* macros which differ due to
the introduction of extended colors (prompted by comments in
Debian #230990, Redhat #1270534).
+ add test/tput-initc to demonstrate tput used to initialize palette
from a data file.
+ modify test/xterm*.dat to use the newer color4/color12 values.
- Add ncurses patch 20161203
+ improve discussion of field validation in form_driver.3x manual page.
+ update curs_trace.3x manual page.

==== notmuch ====
Version update (0.23.3 -> 0.23.4)

- version 0.23.4
- Improve error handling in notmuch insert
- Restore autoload cookie for notmuch-search

==== osc ====
Version update (0.155.1 -> 0.156.0)

- 0.156.0
- highlight scheduled jobs with dispatch problems (due to constraints)
- allow to specify a log message in lock command
- Add '--wipe' option to osc chroot for deleting buildroots
- Add '--vm-memory' option to osc build
- add --multibuild to results command for showing all packages
of a multibuild config
- add --multibuild-package option to results command for showing
only one package of the multibuild config

==== oxygen5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== pidgin-openfetion ====
Subpackages: libpurple-plugin-openfetion libpurple-plugin-openfetion-lang

- Rename the pidgin-openfetion package to pidgin-plugin-openfetion.
- Require pidgin of the same or greater version.
- Make pidgin-plugin-openfetion noarch.
- Own Pidgin pixmap directories.
- Use the %cmake macro.
- Spec cleanup.

==== plasma-nm5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== plasma5-addons ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== plasma5-desktop ====
Version update (5.8.4 -> 5.8.5)

- Add Dont-clear-hover-state-while-a-child-dialog-is-open.patch to
fix a regression in 5.8.5 that prevents one from browsing
subfolders on the desktop/folderview, the popups would close
immediately when moving the mouse over them (kde#374291)
- Drop unneeded 0001-Require-xorg-evdev-2.8.99.1.patch
- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php
- Recommend xf86-input-synaptics, otherwise libinput is used
for touchpads, which isn't that configurable with the kcm

==== plasma5-integration ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== plasma5-openSUSE ====
Subpackages: plasma5-defaults-openSUSE plasma5-theme-openSUSE
plasma5-workspace-branding-openSUSE sddm-theme-openSUSE

- Increase contrast on splash/images/bulb.png to get rid of
noise and visible edges
- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php
- Only keep metadata.json, remove breeze's metadata.desktop

==== plasma5-pa ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== plasma5-session ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== plasma5-workspace ====
Version update (5.8.4 -> 5.8.5)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== polkit-kde-agent-5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== powerdevil5 ====
Version update (5.8.4 -> 5.8.5)

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== protobuf ====

- Use py_sitedir for library installation with setup.py install
- Drop protobuf-libs as it is just workaround for rpmlint issue
- Cleanup specfile:
* remove any conditionals for versions predating SLES 12/Leap 42.x
* add Provides: protobuf-libs to fix rpmlint warning

==== samba ====
Version update (4.5.0 -> 4.5.3)
Subpackages: libdcerpc-binding0 libdcerpc0 libndr-krb5pac0 libndr-nbt0
libndr-standard0 libndr0 libnetapi0 libsamba-credentials0 libsamba-errors0
libsamba-hostconfig0 libsamba-passdb0 libsamba-util0 libsamdb0
libsmbclient-devel libsmbclient0 libsmbconf0 libsmbldap0 libtevent-util0
libwbclient0 samba-client samba-doc samba-libs samba-winbind

- Update to 4.5.3
+ Heap-based Buffer Overflow Remote Code Execution Vulnerability;
CVE-2016-2123; (bso#12409); (bsc#1014437).
+ Don't send delegated credentials to all servers; CVE-2016-2125;
(bso#12445); (bsc#1014441).
+ denial of service due to a client triggered crash in the winbindd
parent process; CVE-2016-2126; (bso#12446); (bsc#1014442).
- 4.5.1 and 4.5.2 updates
+ various streams vfs fixes
+ various printing fixes
+ ntlm_auth: do not map explicitly empty domain
+ various stability fixes in smbd
+ match file compression ReFS behavior

==== shim-leap ====

- Update shim to 0.9-13.1
+ Update shim-install to support "--no-nvram" and improve
removable media and fallback mode handling (bsc#985568,
bsc#999818) (Fix from mchang@xxxxxxxx)

==== smb4k ====
Version update (1.2.1 -> 1.2.2)
Subpackages: smb4k-doc smb4k-lang

- Update to 1.2.2:
* Improved error message handling in the scanner. Mostly
backported changes from master.
* Accept the drop events (QEvent::accept()) in the shares views.
* Added remarks regarding the regression introduced
by the security fixes released on April 12, 2016 to the handbook.
Changed URL of the bug tracker to the KDE Bugtracking System.
Bumped version number (and modification date) of the handbook.
* Now that Smb4K is on bugs.kde.org, remove the custom bug report address.

==== spec-cleaner ====
Version update (0.9.0 -> 0.9.1)

- Version update to 0.9.1:
* Switch from regexp macro detection to full-blown parser to avoid
bugs

==== systemsettings5 ====
Version update (5.8.4 -> 5.8.5)
Subpackages: systemsettings5-devel

- Update to 5.8.5
* New bugfix release
* For more details please see:
https://www.kde.org/announcements/plasma-5.8.5.php

==== valgrind ====
Version update (3.11.0 -> 3.12.0)

- update to 3.12.0
* 3.12.0 is a feature release with many improvements and the usual
collection of bug fixes. The full changelog can be found at
http://valgrind.org/docs/manual/dist.news.html
or
/usr/share/doc/packages/valgrind/NEWS
- droped patches which are part of the release:
gcc5.patch, r15702.diff, r15792.diff, r15802.diff, svn-r15766.patch,
vex-r3197.diff, vex-r3210.diff, vex-r3213.diff

==== wireshark ====
Version update (2.2.2 -> 2.2.3)

- Wireshark 2.2.3:
* fix export related bugs
* fix UI bugs
* bugfix and corrections updates for dissectors
* updated protocol support for BGP, BOOTP/DHCP, BTLE, DICOM,
DOF, Echo, GTP, ICMP, Radiotap, RLC, RPC over RDMA, RTCP, SMB,
TCP, UFTP4, and VXLAN

==== xf86-video-dummy ====
Version update (0.3.7 -> 0.3.8)

- Update to version 0.3.8
* This new release of the dummy Xorg video driver adds a few
cleanups and compatibility with xorg-server 1.19.

==== xfce4-settings ====
Version update (4.12.0 -> 4.12.1)
Subpackages: xfce4-settings-lang

- update to version 4.12.1:
- fix color scheme preview on low bit depth displays
- fix: Segfault in convert_xfce_output_info
- fix: /Xft/Hinting is never set
- fix memory leak in xfce4-appearance-settings
- fix: xfsettingsd resets TV mode to NULL on power cycle
- translation updates

==== yast2-country ====
Version update (3.2.5 -> 3.2.6)
Subpackages: yast2-country-data

- Read keyboard and console fonts from different files depending
on the product (bsc#1016004)
- 3.2.6

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages