Mailinglist Archive: opensuse-factory (682 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161120 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161120

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
dasher
mozilla-nspr
perl-DBD-SQLite (1.50 -> 1.52)
perl-Log-Log4perl (1.47 -> 1.48)
perl-XML-XPath (1.39 -> 1.40)
polari (3.22.1 -> 3.22.2)
rubygem-gem2rpm

=== Details ===

==== dasher ====
Subpackages: dasher-data-extras dasher-data-recommended dasher-lang

- Fix some typos in the language code mapping.
- Upgrade .spec.in file to produce the correct spec file.

==== mozilla-nspr ====

- Properly run testsuite

==== perl-DBD-SQLite ====
Version update (1.50 -> 1.52)

- updated to 1.52
see /usr/share/doc/packages/perl-DBD-SQLite/Changes
1.52 2016-11-15
- Switched to a production version.
1.51_07 2016-10-16
- Downgraded SQLite to 3.13.0 (RT#118395)
1.51_06 2016-10-15
- Updated SQLite to 3.15.0
1.51_05 2016-06-23
- Updated SQLite to 3.13.0
- Resolved #115465: column_info doesn't parse sizes with spaces
(ilmari++)
- Added two missing function declarations (rurban++)
1.51_04 2016-03-07
- Updated SQLite to 3.11.1, which fixed an FTS5 index
corruption issue
1.51_03 2016-02-20
- No code change
- Resolved #112220: t/62_regexp_multibyte_char_class.t fails
for perl >= 5.22.0 and non-utf8 locale (SREZIC++)
1.51_02 2016-02-20
- No code change; fixed a newly added test that only passed
under recent perls (>= 5.18)
1.51_01 2016-02-20
* ** CHANGES THAT MAY POSSIBLY BREAK YOUR OLD APPLICATIONS ***
- Updated to SQLite 3.11.0.
As upstream disabled two-arg fts3_tokenizer() for security concern,
DBD::SQLite also stopped enabling it by default. If you do need
perl tokenizer, compile/install with SQLITE_ENABLE_FTS3_TOKENIZER
environmental variable.
- Applied a doc patch by Salvatore Bonaccorso
- Enabled (experimental) FTS5
- Fixed REGEXP function to work under sqlite_unicode correctly
(András Farkas++)

==== perl-Log-Log4perl ====
Version update (1.47 -> 1.48)

- updated to 1.48
see /usr/share/doc/packages/perl-Log-Log4perl/Changes
1.48 (2016/11/14)
* (ms) [rt.cpan.org #117377] Moved PatternLayout's documentation of
DateFormat features to DateFormat.pm to avoid duplication
and keep the two parts consistent, as suggested by Max Carey.
* (ms) [rt.cpan.org #114822] Split two lines with CVS-sensitive
$Log.. variables into two parts.
* (ms) Semaphore issue fixed in Synchronized (reported by
Siarhei Kuchynski and Martin Köhler):
https://github.com/mschilli/log4perl/issues/72
* (ms) header_text now works with syswrite (reported by Tom Metro):
https://github.com/mschilli/log4perl/issues/73

==== perl-XML-XPath ====
Version update (1.39 -> 1.40)

- updated to 1.40
see /usr/share/doc/packages/perl-XML-XPath/Changes
1.40 2016-11-13 MANWAR
- Proposed fix for RT #118726.

==== polari ====
Version update (3.22.1 -> 3.22.2)
Subpackages: typelib-1_0-Polari-1_0

- Update to version 3.22.2:
+ Fix glitch when opening user list.
+ Fix launching through mission control.
+ Updated translations.
- Drop polari-run-as-background-service.patch: fixed upstream.

==== rubygem-gem2rpm ====

- fix gem2rpm --fetch: prefer https for accessing rubygems.org
(bnc #963710)
adds 0026-use-https-instead-of-http-for-rubygems.org.patch
- added support for 2.4.0
- dropped all patches and replaced them with git format-patch
series:
- modified:
0001-use-the-ID-from-os-release-to-use-the-proper-templat.patch
0002-added-basic-config-file-support-to-gem2rpm-in-yaml-f.patch
0003-new-opensuse-templates.-they-require-the-config-file.patch
0004-added-example-gem2rpm.yml.patch
0005-properly-shorten-description-and-summary.patch
0006-Preserve-the-license-header-found-in-the-output-file.patch
0007-fixes-for-the-opensuse-template.patch
0008-do-not-use-not-.-not-supported-on-1.8-e.g.patch
0009-No-longer-require-the-ruby-version-inside-the-subpac.patch
0010-Try-to-load-rbconfigpackagingsupport-and-fail-gracef.patch
0011-Add-support-for-scripts-pre-post-for-subpackages.patch
0012-typo-in-gem2rpm.yml.documentation-custom_pkgs-instea.patch
0013-Also-tag-LICENSE-MIT-as-docfile.patch
0014-Refactor-into-multiple-lines.patch
0015-Add-licence-to-the-list-of-license-files-as-well.patch
0016-add-two-more-ways-to-express-changes.patch
- dropped:
0017-touch-unpacked-sources.patch
0001-Also-tag-APACHE-LICENSE-2.0-as-docfile.patch
- newly added:
0017-.markdown-is-also-seen-in-the-wild.patch
0018-Only-use-the-extensions-doc-dir-on-MRI-2.1.x.patch
0019-Cleaner-solution-for-the-extensions-doc-dir.patch
0020-Ruby-1.8-insists-on-the-for-the-parameter.patch
0021-Fix-company-name-in-copyright-header.patch
0022-add-the-touch-for-build-compare-to-the-template.patch
0023-Also-tag-APACHE-LICENSE-2.0-as-docfile.patch
0024-add-ability-to-provide-alternative-main-Source.patch
0025-allow-running-commands-after-patching.patch
- added :post_patch hook to run commands before we rebuild the gem
used by libv8

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages