Mailinglist Archive: opensuse-factory (682 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161112 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161112

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
akonadi-calendar (16.08.2 -> 16.08.3)
akonadi-contact (16.08.2 -> 16.08.3)
akonadi-mime (16.08.2 -> 16.08.3)
akonadi-notes (16.08.2 -> 16.08.3)
akonadi-search (16.08.2 -> 16.08.3)
akonadi-server (16.08.2 -> 16.08.3)
ark (16.08.2 -> 16.08.3)
autoyast2 (3.1.152 -> 3.2.0)
baloo5-widgets (16.08.2 -> 16.08.3)
calendarsupport (16.08.2 -> 16.08.3)
dolphin (16.08.2 -> 16.08.3)
dracut
dragonplayer (16.08.2 -> 16.08.3)
eventviews (16.08.2 -> 16.08.3)
file-roller (3.22.1 -> 3.22.2)
gnome-calculator (3.22.1 -> 3.22.2)
gnome-disk-utility (3.22.0 -> 3.22.1)
gnome-mines (3.22.1 -> 3.22.2)
gnome-music (3.22.1 -> 3.22.2)
gnome-shell (3.22.1 -> 3.22.2)
gnome-system-monitor (3.22.0 -> 3.22.2)
gpgmepp5 (16.08.2 -> 16.08.3)
grantleetheme (16.08.2 -> 16.08.3)
grisbi (1.0.0 -> 1.0.1)
gwenview5 (16.08.2 -> 16.08.3)
hwinfo (21.34 -> 21.35)
incidenceeditor (16.08.2 -> 16.08.3)
kaccounts-integration (16.08.2 -> 16.08.3)
kaccounts-providers (16.08.2 -> 16.08.3)
kalarmcal (16.08.2 -> 16.08.3)
kamera (16.08.2 -> 16.08.3)
kate (16.08.2 -> 16.08.3)
kcalc (16.08.2 -> 16.08.3)
kcalcore (16.08.2 -> 16.08.3)
kcalutils (16.08.2 -> 16.08.3)
kcharselect (16.08.2 -> 16.08.3)
kcolorchooser (16.08.2 -> 16.08.3)
kcontacts (16.08.2 -> 16.08.3)
kdebase4 (16.08.2 -> 16.08.3)
kdebase4-runtime (16.08.2 -> 16.08.3)
kdelibs4 (4.14.25 -> 4.14.26)
kdenetwork4-filesharing (16.08.2 -> 16.08.3)
kdepim (16.08.2 -> 16.08.3)
kdepim-addons (16.08.2 -> 16.08.3)
kdepim-apps-libs (16.08.2 -> 16.08.3)
kdepim-runtime (16.08.2 -> 16.08.3)
kdgantt2 (16.08.2 -> 16.08.3)
kdnssd (16.08.2 -> 16.08.3)
kget (16.08.2 -> 16.08.3)
kgpg (16.08.2 -> 16.08.3)
khelpcenter5 (16.08.2 -> 16.08.3)
kholidays (16.08.2 -> 16.08.3)
kidentitymanagement (16.08.2 -> 16.08.3)
kimap (16.08.2 -> 16.08.3)
kio-extras5 (16.08.2 -> 16.08.3)
kio_audiocd (16.08.2 -> 16.08.3)
kldap (16.08.2 -> 16.08.3)
kleopatra5 (16.08.2 -> 16.08.3)
kmag (16.08.2 -> 16.08.3)
kmailtransport (16.08.2 -> 16.08.3)
kmbox (16.08.2 -> 16.08.3)
kmime (16.08.2 -> 16.08.3)
kmousetool (16.08.2 -> 16.08.3)
kompare (16.08.2 -> 16.08.3)
konsole (16.08.2 -> 16.08.3)
kontactinterface (16.08.2 -> 16.08.3)
kopete (16.08.2 -> 16.08.3)
kpimtextedit (16.08.2 -> 16.08.3)
kqtquickcharts (16.08.2 -> 16.08.3)
krdc (16.08.2 -> 16.08.3)
krfb (16.08.2 -> 16.08.3)
kruler (16.08.2 -> 16.08.3)
ktnef (16.08.2 -> 16.08.3)
ktp-accounts-kcm (16.08.2 -> 16.08.3)
ktp-approver (16.08.2 -> 16.08.3)
ktp-auth-handler (16.08.2 -> 16.08.3)
ktp-common-internals (16.08.2 -> 16.08.3)
ktp-contact-list (16.08.2 -> 16.08.3)
ktp-contact-runner (16.08.2 -> 16.08.3)
ktp-desktop-applets (16.08.2 -> 16.08.3)
ktp-filetransfer-handler (16.08.2 -> 16.08.3)
ktp-kded-module (16.08.2 -> 16.08.3)
ktp-send-file (16.08.2 -> 16.08.3)
ktp-text-ui (16.08.2 -> 16.08.3)
kwalletmanager5 (16.08.2 -> 16.08.3)
libgravatar (16.08.2 -> 16.08.3)
libkcddb4 (16.08.2 -> 16.08.3)
libkcompactdisc4 (16.08.1 -> 16.08.3)
libkdcraw (16.08.2 -> 16.08.3)
libkdepim (16.08.2 -> 16.08.3)
libkexiv2 (16.08.2 -> 16.08.3)
libkface (16.08.2 -> 16.08.3)
libkgeomap (16.08.2 -> 16.08.3)
libkipi (16.08.2 -> 16.08.3)
libkleo (16.08.2 -> 16.08.3)
libkomparediff2 (16.08.2 -> 16.08.3)
libksane (16.08.2 -> 16.08.3)
libksieve (16.08.2 -> 16.08.3)
lightsoff (3.22.0 -> 3.22.2)
mailcommon (16.08.2 -> 16.08.3)
mailimporter (16.08.2 -> 16.08.3)
marble (16.08.2 -> 16.08.3)
messagelib (16.08.2 -> 16.08.3)
mobipocket (16.08.2 -> 16.08.3)
mutter (3.22.1 -> 3.22.2)
okular (16.08.2 -> 16.08.3)
orca (3.22.1 -> 3.22.2)
pimcommon (16.08.2 -> 16.08.3)
signon-kwallet-extension (16.08.2 -> 16.08.3)
spectacle (16.08.2 -> 16.08.3)
sweeper (16.08.2 -> 16.08.3)
swell-foop (3.22.0 -> 3.22.2)
syndication (16.08.2 -> 16.08.3)
virtualbox (5.1.6_k4.8.6_2 -> 5.1.8_k4.8.6_2)
webkit2gtk3
yast2-installation (3.2.6 -> 3.2.7)
yast2-trans (84.87.20161026.cec15e5 -> 84.87.20161108.95adeff)

=== Details ===

==== akonadi-calendar ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== akonadi-contact ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5AkonadiContact5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== akonadi-mime ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5AkonadiMime5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== akonadi-notes ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== akonadi-search ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5AkonadiSearch

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== akonadi-server ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5AkonadiAgentBase5 libKF5AkonadiCore5 libKF5AkonadiPrivate5
libKF5AkonadiWidgets5 libKF5AkonadiXml5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ark ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libkerfuffle16

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== autoyast2 ====
Version update (3.1.152 -> 3.2.0)
Subpackages: autoyast2-installation

- Add support to enable copy-on-write for Btrfs subvolumes
(FATE#320342)
- Add support to omit the Btrfs default subvolume name
(FATE#317775)
- 3.2.0

==== baloo5-widgets ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== calendarsupport ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5CalendarSupport5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== dolphin ====
Version update (16.08.2 -> 16.08.3)
Subpackages: dolphin-part libdolphinvcs5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== dracut ====

- systemd-initrd: Add initrd-root-device.target. Cherry-pick to get
systemd v230 into factory (bsc1009089)
* add 0451-systemd-initrd-add-initrd-root-device.target.patch
- Bash cannot handle binary strigns with embedded NULs. This used
to work by accident, it no longer does starting from bash 4.4.
Strip NULs during all comparison operations as a workaround.
Addresses bsc989218.
* add 0450-Strip-NUL-bytes-in-stream-before-push-in-string.patch
- Do not create initramfs with world-readable permissions if
early microcode update is used bsc#1008340 CVE-2016-8637
0503-dracut.sh-create-the-initramfs-non-world-readable-al.patch

==== dragonplayer ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== eventviews ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5EventViews5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== file-roller ====
Version update (3.22.1 -> 3.22.2)

- Update to version 3.22.2:
+ file-roller does not respect sort order for folders
(bgo#630543).
+ Updated translations.

==== gnome-calculator ====
Version update (3.22.1 -> 3.22.2)
Subpackages: gnome-shell-search-provider-gnome-calculator

- Update to version 3.22.2:
+ Fixed conversion unit switch.
+ Fixed first expression with parentheses.
+ Fixed possible errors on currency conversion.
+ Ctrl+Backspace should only delete last number.
+ Fixed reusing results from the history stack.

==== gnome-disk-utility ====
Version update (3.22.0 -> 3.22.1)

- Update to version 3.22.1:
+ Updated translations.

==== gnome-mines ====
Version update (3.22.1 -> 3.22.2)

- Update to version 3.22.2:
+ Updated translations.

==== gnome-music ====
Version update (3.22.1 -> 3.22.2)

- Update to version 3.22.2:
+ Updated translations.

==== gnome-shell ====
Version update (3.22.1 -> 3.22.2)
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar

- Update to version 3.22.2:
+ Fix OSD popup glitches (bgo#772723, bgo#772287).
+ Request periodic scans while WiFi list is open (bgo#767918).
+ Always show primary network icon when connected (bgo#773890).
+ Misc. bug fixes: bgo#773875, bgo#740043, bgo#773893.
+ Updated translations.

==== gnome-system-monitor ====
Version update (3.22.0 -> 3.22.2)

- Update to version 3.22.2:
+ Updated translations.

==== gpgmepp5 ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5QGpgme5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== grantleetheme ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5GrantleeTheme5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== grisbi ====
Version update (1.0.0 -> 1.0.1)
Subpackages: grisbi-lang

- Update to version 1.0.1:
+ Fix major crash with gtk-2.24.30.
+ Fix many other bugs.
+ Fix many memory leaks.
+ Initialization of the financial year when creating a new
archive.
+ Allow editing the 'voucher field' of the child transaction.
+ Homogenization of code to categories and budgetary allocations.

==== gwenview5 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== hwinfo ====
Version update (21.34 -> 21.35)
Subpackages: hwinfo-devel

- ensure network devices have a bus_id (bsc#1007172)
- 21.35

==== incidenceeditor ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5IncidenceEditor5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kaccounts-integration ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libkaccounts1

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kaccounts-providers ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kalarmcal ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kamera ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kate ====
Version update (16.08.2 -> 16.08.3)
Subpackages: kate-plugins kwrite

- Remove unnecessary build requirements
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcalc ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcalcore ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcalutils ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5CalendarUtils5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcharselect ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcolorchooser ====
Version update (16.08.2 -> 16.08.3)

- Remove unused kwidgetsaddons-devel build requirement
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kcontacts ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdebase4 ====
Version update (16.08.2 -> 16.08.3)
Subpackages: kdebase4-libkonq kdebase4-nsplugin kdepasswd kdialog
keditbookmarks konqueror konqueror-plugins libkonq5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdebase4-runtime ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdelibs4 ====
Version update (4.14.25 -> 4.14.26)
Subpackages: kdelibs4-core libkde4 libkdecore4 libksuseinstall1

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdenetwork4-filesharing ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdepim ====
Version update (16.08.2 -> 16.08.3)
Subpackages: akonadi_resources akregator5 kaddressbook5 kalarm5 kmail5 knotes5
kontact5 korganizer5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdepim-addons ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdepim-apps-libs ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdepim-runtime ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdgantt2 ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5KDGantt2-5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kdnssd ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kget ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kgpg ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== khelpcenter5 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kholidays ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kidentitymanagement ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kimap ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kio-extras5 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kio_audiocd ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kldap ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Ldap5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kleopatra5 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kmag ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kmailtransport ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kmbox ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kmime ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kmousetool ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kompare ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== konsole ====
Version update (16.08.2 -> 16.08.3)
Subpackages: konsole-part

- Update build requirements
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kontactinterface ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kopete ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kpimtextedit ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kqtquickcharts ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== krdc ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== krfb ====
Version update (16.08.2 -> 16.08.3)

- Update build requirements
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kruler ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktnef ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-accounts-kcm ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libktpaccountskcminternal9

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-approver ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-auth-handler ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-common-internals ====
Version update (16.08.2 -> 16.08.3)
Subpackages: ktp-icons

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-contact-list ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-contact-runner ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-desktop-applets ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-filetransfer-handler ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-kded-module ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-send-file ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== ktp-text-ui ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== kwalletmanager5 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libgravatar ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Gravatar5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkcddb4 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkcompactdisc4 ====
Version update (16.08.1 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkdcraw ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5KDcraw5 libkdcraw-devel

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkdepim ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Libkdepim5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkexiv2 ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5KExiv2-15_0_0 libkexiv2-devel

- Remove unnecessary (build) requirements
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkface ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5KFace10_0_0 libkface-devel

- Remove unnecessary build requirements
- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkgeomap ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5KGeoMap10_0_0 libkgeomap-devel

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkipi ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Kipi31_0_0 libkipi-data libkipi-devel

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkleo ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Libkleo5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libkomparediff2 ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libksane ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5Sane5 libksane-devel

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== libksieve ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== lightsoff ====
Version update (3.22.0 -> 3.22.2)

- Update to version 3.22.2:
+ Updated translations.

==== mailcommon ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5MailCommon5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== mailimporter ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5MailImporter5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== marble ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libastro1 libmarblewidget-qt5-25 marble-devel

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== messagelib ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== mobipocket ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== mutter ====
Version update (3.22.1 -> 3.22.2)
Subpackages: libmutter0 mutter-data

- Update to version 3.22.2:
+ Really fix framebuffer capture origin offset (bgo#771502).
+ Fix session going into idle mode immediately on startup
(bgo#772839).
+ Fix mirror mode with stage views (bgo#773115).
+ Improve pointer constraints support (bgo#771859).
+ Stack docks below other windows on fullscreen monitors
(bgo#772937).
+ Fix switching between two finger- and edge scrolling on wayland
(bgo#771744).
+ Fix popup grabs blocking screen lock on wayland (bgo#771235).
+ Fix various crashes on wayland (bgo#771646, bgo#771858).
+ Fix various placement issues on wayland (bgo#768039,
bgo#771841, bgo#773141, bgo#772729).
+ Misc. bug fixes: bgo#771019, bgo#773116, bgo#772914,
bgo#773210.
+ Updated translations.
- Drop upstream fixed patches:
+ mutter-screeenshot-coords.patch
+ mutter-scale-positioner-coordinates.patch

==== okular ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== orca ====
Version update (3.22.1 -> 3.22.2)

- Update to version 3.22.2:
+ Improve support for Icedove.
+ Work around broken accessibility trees causing flat review to
fail.
+ Work around missing state-changed events for LibreOffice toggle
buttons.
+ Updated translations.

==== pimcommon ====
Version update (16.08.2 -> 16.08.3)
Subpackages: libKF5PimCommon5

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== signon-kwallet-extension ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== spectacle ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== sweeper ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== swell-foop ====
Version update (3.22.0 -> 3.22.2)

- Update to version 3.22.2:
+ Updated translations.

==== syndication ====
Version update (16.08.2 -> 16.08.3)

- Update to KDE Applications 16.08.3
* KDE Applications 16.08.3
* https://www.kde.org/announcements/announce-applications-16.08.3.php

==== virtualbox ====
Version update (5.1.6_k4.8.6_2 -> 5.1.8_k4.8.6_2)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Remove all references to libreadline. I misinterpreted a previous error
message.
- Fixes for VUL-0:
CVE-2016-5501,CVE-2016-5538,CVE-2016-5605,CVE-2016-5608,CVE-2016-5610,CVE-2016-5611,CVE-2016-561313
boo #1005621.
- Replaced libreadline6 with libreadline7.
- Found and fixed another API change for kernel 4.9. In addition, the
libreadline6 package is now needed.
- Fix typo in "vbox_fix_4.9_api_changes.patch".
- Make another 4.9 API change.
- Fix build on kernel 4.9 using patch "vbox_fix_4.9_api_changes.patch".
- Fixes for VUL-0:
CVE-2016-5501,CVE-2016-5538,CVE-2016-5605,CVE-2016-5608,CVE-2016-5610,CVE-2016-5611,CVE-2016-561313
boo #1005621.
- Add patch file "vbox_remove_smp_mflags.patch" to limit number of simultaneous
make jobs.
- Version bump to 5.1.8 (released 2016-10-18 by Oracle)
This is a maintenance release. The following items were fixed and/or added:
GUI: fixed keyboard shortcut handling regressions (Mac OS X hosts only;
bugs #15937 and #15938)
GUI: fixed keyboard handling regression for separate UI (Windows hosts
only; bugs #15928)
NAT: don't exceed the maximum number of "search" suffixes. Patch from bug
#15948.
NAT: fixed parsing of port-forwarding rules with a name which contains a
slash (bug #16002)
NAT Network: when the host has only loopback nameserver that cannot be
mapped to the guests (e.g. dnsmasq running on 127.0.1.1), make DHCP supply NAT
Network DNS proxy as nameserver.
Bridged Network: prevent flooding syslog with packet allocation error
messages (bug #15569)
Audio: now using Audio Queues on Mac OS X hosts
Audio: fixed recording with the PulseAudio backend (5.1 regression)
Audio: various bugfixes
Snapshots: fixed regression in 5.1.4 for deleting snapshots with several
disks (bug #15831)
Snapshots: crash fix and better error reporting when snapshot deletion
failed
Storage: some fixes for the NVMe emulation with Windows guests
API: fixed initialization of SAS controllers (bug #15972)
Build system: make it possible to build VBox on systems which default to
Python 3
Windows Additions / VGA: if the guest's power management turns a virtual
screen off, blank the corresponding VM window rather than hide the window
Windows Additions: fixed a generic bug which could lead to freezing shared
folders (bug #15662)
Linux hosts / guests: fix for kernels with CONFIG_CPUMASK_OFFSTACK set (bug
#16020)
Linux Additions: don't require all virtual consoles be in text mode. This
should fix cases when the guest is booted with a graphical boot screen (bug
#15683)
Linux Additions: added depmod overrides for the vboxguest and vboxsf kernel
modules to fix conflicts with modules shipped by certain Linux distributions
X11 Additions: disable 3D on the guest if the host does not provide enough
capabilities (bug #15860)
- Requesting 14000 MB is too much. Reduce the request to 12000 MB.
- Some builds still run out of memory and fail. Increase to 14000 MB.
- Builds keep running out of memory when building the web server part of the
package.
To help the memory pressure, I have forced make to run with "-j2", rather
than use
the number of processors. Such a change will slow the build, but will result
in a
higher rate of success.
- Increase memory allowed in build to 10000 MB.

==== webkit2gtk3 ====
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Do not recommend the -lang package with a version: it has close
to no effect anyway, as the solver could simply ignore it to
find a solution.

==== yast2-installation ====
Version update (3.2.6 -> 3.2.7)

- Do not crash if importing ssh config from system which
/etc/os-release does not contain pretty name (bsc#1009492)
- 3.2.7

==== yast2-trans ====
Version update (84.87.20161026.cec15e5 -> 84.87.20161108.95adeff)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en_GB yast2-trans-en_US
yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi yast2-trans-fr
yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr yast2-trans-hu
yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv yast2-trans-ka
yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt yast2-trans-mk
yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa yast2-trans-pl
yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru yast2-trans-si
yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Update to version 84.87.20161108.95adeff:
* Translated using Weblate (Arabic)
* Translated using Weblate (German)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Russian)
* Translated using Weblate (Swedish)
- Update to version 84.87.20161107.51657f4:
* New POT for text domain 'add-on'.
* New POT for text domain 'autoinst'.
* New POT for text domain 'base'.
* New POT for text domain 'bootloader'.
* New POT for text domain 'control'.
* New POT for text domain 'country'.
* New POT for text domain 'fonts'.
* New POT for text domain 'ftp-server'.
* New POT for text domain 'gtk'.
* New POT for text domain 'gtk-pkg'.
* New POT for text domain 'http-server'.
* New POT for text domain 'installation'.
* New POT for text domain 'kdump'.
* New POT for text domain 'network'.
* New POT for text domain 'registration'.
* New POT for text domain 'storage'.
* Translated using Weblate (Arabic)
* Translated using Weblate (Catalan)
* Translated using Weblate (Chinese (Taiwan))
* Translated using Weblate (Czech)
* Translated using Weblate (Danish)
* Translated using Weblate (Dutch)
* Translated using Weblate (French)
* Translated using Weblate (German)
* Translated using Weblate (Greek)
* Translated using Weblate (Indonesian)
* Translated using Weblate (Japanese)
* Translated using Weblate (Lithuanian)
* Translated using Weblate (Persian)
* Translated using Weblate (Portuguese (Brazil))
* Translated using Weblate (Russian)
* Translated using Weblate (Slovak)
* Translated using Weblate (Spanish)
* Translated using Weblate (Ukrainian)

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages