Mailinglist Archive: opensuse-factory (678 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161026 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161026

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
NetworkManager-openvpn (1.2.4 -> 1.2.6)
bash (4.3 -> 4.4)
build (20160809 -> 20161025)
desktop-translations
drbd (9.0.2+git.14d2eea -> 9.0.5+git.8d53d3e)
eog-plugins (3.16.4 -> 3.16.5)
epiphany (3.22.0 -> 3.22.1)
gnome-backgrounds (3.22.0 -> 3.22.1)
gnome-mines (3.22.0 -> 3.22.1)
grub2
iproute2 (4.6 -> 4.8)
libgnome-games-support (1.2.0 -> 1.2.1)
libyui-qt-pkg (2.45.9 -> 2.45.10)
skype4pidgin (1.2.1 -> 1.2.2)
sound-juicer (3.22.0 -> 3.22.1)
spice-gtk (0.31 -> 0.33)
wine (1.9.20 -> 1.9.21)
xfce4-terminal (0.6.92 -> 0.8.0)
yast2-packager (3.2.4 -> 3.2.5)

=== Details ===

==== NetworkManager-openvpn ====
Version update (1.2.4 -> 1.2.6)
Subpackages: NetworkManager-openvpn-gnome

- Update to version 1.2.6:
+ Restore previous behavior for handling empty "comp-lzo"
(bgo#769177).
+ Support verify-x509-name (bgo#770922).
+ Support max-routes (bgo#720097).
+ Fix invalid free when parsing remote option.
+ Various cleanups.
+ Updated translations.
- Drop NetworkManager-openvpn-dl-linking.patch: Fixed upstream.
Following this: Drop libtool BuildRequires and stop passing
autoreconf, we no longer carry any patches.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.

==== bash ====
Version update (4.3 -> 4.4)
Subpackages: bash-doc readline-devel readline-doc

- no-null-warning.patch: Don't warn about null bytes in command
substitution
- Avoid confusing library path
- Update bash 4.4 final
* Latest bug fixes since 4.4 rc2
- Update readline 7.0 final
* Latest bug fixes since 7.0 rc2
* New application-callable function: rl_pending_signal(): returns the signal
number of any signal readline has caught but not yet handled.
* New application-settable variable: rl_persistent_signal_handlers: if set
to a non-zero value, readline will enable the readline-6.2 signal handler
behavior in callback mode: handlers are installed when
rl_callback_handler_install is called and removed removed when a complete
line has been read.
- Drop patch bash-4.3-async-bnc971410.dif as this one is part of 4.4
- Drop patch bash-3.2-longjmp.dif as now long time be fixed
- Drop patch bash-4.3-headers.dif as loadables now simply work
- Drop readline-6.1-wrap.patch as this seems to be fixed
- Disable patch bash-4.0-async-bnc523667.dif for now as it seems to be fixed
in an other way
- Update bash 4.4 rc2 -- Bugfixes
- Update readline 7.0 rc2 -- Bugfixes

==== build ====
Version update (20160809 -> 20161025)
Subpackages: build-mkbaselibs build-mkdrpms

- Add clang binaries to ccache symlinking
- Fix a probable tabs to spaces bug
- Kiwi: allow to specify ExclusiveArch and ExcludeArch
- build-vm-kvm: use virtio-rng-device also on aarch64
- Add support for LXC as libvirt driver
- support multiple image builds for multiple profiles
- Add optional whitelisting for allowed buildroots and parameters
- build-vm-xen: use xvd devices for disks and hvc0 for console for recent xen
- build-vm-kvm: fix vm_enable_console also for kvm_serial_console case
- sl13.3.conf: Prepare for bash 4.4, using libreadline7
- Add and clarify licenses

==== desktop-translations ====

- Remove Cyrillic strings from the Swedish (sv) translations.
- Update translations from SVN.

==== drbd ====
Version update (9.0.2+git.14d2eea -> 9.0.5+git.8d53d3e)

- bsc#1006176, compat with kernel 4.8 with 9.0.5
- Upgrade 9.0.2 to 9.0.5
- Remove patch compat-4.7-9902af79-i_mutex.patch
Remove patch compat-4.7-fe8fb75e-blk_queue_write_cache.patch
Remove patch compat-4.7-50225243-kill-nla_put_u64.patch
Remove patch compat-4.7-1dee3f59-align-nla-u64.patch
Remove patch drbd-buildcompare.patch
Remove patch kernel-4.5-compat.patch
Remove patch temp.patch

==== eog-plugins ====
Version update (3.16.4 -> 3.16.5)
Subpackages: eog-plugins-lang

- Update to version 3.16.5:
+ Map: map plugin:
- Use default marker (bgo#771945).
- Slowly move to selected image (bgo#771948).
- Initial zoom level wrong (bgo#771976).
+ Updated translations.

==== epiphany ====
Version update (3.22.0 -> 3.22.1)
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Updated to version 3.22.1:
+ Remember decision to allow or deny notifications (bgo#748339).
+ Do not copy cookies when creating web app (bgo#771540).
+ Fix dock to right button in web inspector.
+ Improve overview layout in small windows.
+ Escape URL for markup in new web app dialog.
+ Updated translations.

==== gnome-backgrounds ====
Version update (3.22.0 -> 3.22.1)
Subpackages: gnome-backgrounds-lang

- Update to version 3.22.1:
+ Noise ('fireflies') removal on adwaita-day.
- Remove old and currently unneeded workaround for latin locale.

==== gnome-mines ====
Version update (3.22.0 -> 3.22.1)

- Update to version 3.22.1:
+ Updated translations.

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- From Juergen Gross <jgross@xxxxxxxx>: grub-xen: support booting huge
pv-domains (bsc#1004398) (bsc#899465)
* 0001-xen-make-xen-loader-callable-multiple-times.patch
* 0002-xen-avoid-memleaks-on-error.patch
* 0003-xen-reduce-number-of-global-variables-in-xen-loader.patch
* 0004-xen-add-elfnote.h-to-avoid-using-numbers-instead-of-.patch
* 0005-xen-synchronize-xen-header.patch
* 0006-xen-factor-out-p2m-list-allocation-into-separate-fun.patch
* 0007-xen-factor-out-allocation-of-special-pages-into-sepa.patch
* 0008-xen-factor-out-allocation-of-page-tables-into-separa.patch
* 0009-xen-add-capability-to-load-initrd-outside-of-initial.patch
* 0010-xen-modify-page-table-construction.patch
* 0011-xen-add-capability-to-load-p2m-list-outside-of-kerne.patch

==== iproute2 ====
Version update (4.6 -> 4.8)

- Update to new upstream release 4.7
* add support for VXLAN-GPE
* ss: add SK_MEMINFO_DROPS display
* devlink: implement shared buffer support
* devlink: implement shared buffer occupancy control
* ip, token: add del command
* fq_codel: add per queue memory limit
* ip: add MACsec support
* ipaddress: Allow listing addresses by type
* ip rule: Add support for l3mdev rules
* ss: Add support to filter on device
* ip link/addr/route: Add support for vrf keyword
* bridge: add json support for bridge fdb/vlan show
- Update to new upstream release 4.8
* ip: report IFLA_GSO_MAX_SIZE and IFLA_GSO_MAX_SEGS
* tc: Add support for the matchall traffic classifier.
* iptuntap: show processes using tuntap interface

==== libgnome-games-support ====
Version update (1.2.0 -> 1.2.1)

- Update to version 1.2.1:
+ Do not iterate global main context when running scores dialog.
+ Updated translations.

==== libyui-qt-pkg ====
Version update (2.45.9 -> 2.45.10)

- install qt-pkg if graphical control center and yast2-packager is
used to prevent crash (bsc#999031)
- 2.45.10

==== skype4pidgin ====
Version update (1.2.1 -> 1.2.2)
Subpackages: libpurple-plugin-skype libpurple-plugin-skypeweb
pidgin-plugin-skype pidgin-plugin-skypeweb

- Update to version 1.2.2:
* Fix Logins for non-Outlook usernames (i.e. if you don't have an
"@" in your username).
* Don't remember/use the refresh-token for auth if the user have
marked the account to always require the password ? this will
make sure the user can't just use any password to login.

==== sound-juicer ====
Version update (3.22.0 -> 3.22.1)
Subpackages: sound-juicer-lang

- Update to version 3.22.1:
+ Fix a memory leak.
+ Updated translations.

==== spice-gtk ====
Version update (0.31 -> 0.33)
Subpackages: libspice-client-glib-2_0-8 libspice-client-glib-helper
libspice-controller0 typelib-1_0-SpiceClientGlib-2_0
typelib-1_0-SpiceClientGtk-3_0

- Update to version 0.33:
+ lz4 compression of USB channel.
+ Keyboard: pause key fixes, set keypress-delay to 0 on local
socket.
+ Mouse: fix pointer grabbing in server mode.
+ Clipboard: fix copying text from old application without
UTF8_STRING target (motif).
+ File-xfer changes: grouping all transferred files per
operation.
+ New
spice_file_transfer_task_get_{total_bytes,transferred_bytes}
API and associated properties.
+ New SpiceChannel:socket property.
+ Fix rendering issues with CSD on Windows.
+ Fix gettext support, some translations updates.
+ Fix display refresh issue on f25 after resize (init egl only
when required).
+ Many leaks and races fixes, new tests.
- Changes from version 0.32:
+ Libspice-client-gtk API/ABI break: library soname/version has
been bumped, and deprecated symbols have been removed. In
practice, most of the API (in particular for language bindings)
should be unchanged.
+ Drop gtk+ 2.0 support.
+ Require gtk+ >= 3.12 and glib >= 2.36.
+ Add GStreamer as a backend for mjpeg, vp8 & h264 decoding. This
allows the upcoming Spice server release to send video regions
with better codecs.
+ A number of spice-gtk structures are now private.
+ Spice-gtk widget is no longer a GtkDrawingArea but an opaque
type with only guarantee to be a GtkWidget.
+ Virgl:
- Use GtkGlArea if possible (on wayland only atm).
- Various fixes (multiple display, resize, canvas-less
support).
+ Win-usbredir: use UsbDk backend when available and various
improvements.
+ Ensure that dnd file copy get cancelled.
+ Some JP and KR keyboard handling fixes on Windows.
+ Fix SASL GSSAPI.
+ Fix ipv6 proxy address handling.
+ Allow smaller widget with scaling enabled.
+ Add spice_main_request_mouse_mode() to request mouse mode.
+ Add SpiceGtkSession:sync-modifiers to change modifiers sync
behaviour.
+ Various video decoding improvements.
+ Use GTask instead of GSimpleAsyncResult.
+ Misc bindings, leaks, warnings, and spelling fixes.
- Add gstreamer-plugins-bad, gstreamer-plugins-good,
pkgconfig(gstreamer-1.0), pkgconfig(gstreamer-app-1.0),
pkgconfig(gstreamer-audio-1.0), pkgconfig(gstreamer-base-1.0) and
pkgconfig(opus) BuildRequires: New dependencies.
- Add disabled pkgconfig(libphodav-2.0) BuildRequires: New optional
dependency, not yet available in openSUSE.
- Drop pkgconfig(gtk+-2.0) BuildRequires: No longer needed as
upstream dropped gtk2 support.
- Remove all buildhandling of gtk2.
- Changes to subpackages following upstream changes:
+ Bump sover for libspice-client-gtk-3.
+ Drop libspice-client-gtk-2,python-SpiceClientGtk and
typelib-1_0-SpiceClientGtk-2_0 no longer built.

==== wine ====
Version update (1.9.20 -> 1.9.21)
Subpackages: wine-32bit

- Updated to 1.9.21 development snapshot
- Initial version of the HID minidriver.
- Support for lists in the RichEdit control.
- System tray improvements.
- Various bug fixes.
- updated winetricks

==== xfce4-terminal ====
Version update (0.6.92 -> 0.8.0)
Subpackages: xfce4-terminal-lang

- Update to 0.8.0.
* Move context menu zoom actions to a sub-menu.
* Fix some build-time deprecation warnings.
* Fix hiding of dropdown terminal.
* Fix setting focus to dropdown window.
* Fix "Always keep window on top" setting that was ignored.
* Show missing action icons in dropdown mode.
* Add rewrap on resize control option to Preferences.
* Add --show/hide-scrollbar command line options.
* Implement background image support; add BackgroundImageShading
setting for background image mode.
* Remove "Scrolling single line" option as the functionality is
implemented by vte.
* Add mouse-wheel binding for zoom: Shift + Ctrl + wheel up/down
controlled by a hidden option MiscMouseWheelZoom - ON by
default.
* Do not set DISPLAY variable in non-X11 environments (e.g.
Wayland).
* Fix memory leak when showing preferences dialog.
* Fix menubar text not visible with some themes.
* Fix vte "resize-window" signal handler.
* Fix notebook widget transparency seen under Unity.
* Make vte transparency work in Gnome under both X11 and Wayland.
* Show warning and disable Opacity control in Preferences if
window manager does not support compositing.
* Fix tab activity indication.
* Fix geometry positioning when a negative offset is used.
* Quote all file names/URIs drag-and-dropped to the terminal.
* Fix cursor focus.
* Translation updates: Bulgarian, Chinese (Taiwan), Croatian,
Czech, Dutch, English (Australia), French, German, Hebrew,
Japanese, Korean, Lithuanian, Malay, Polish, Portuguese,
Portuguese (Brazil), Russian, Slovak, Spanish, Swedish, Thai,
Ukrainian.

==== yast2-packager ====
Version update (3.2.4 -> 3.2.5)

- Faking /etc/mtab on target system for post RPM installation
actions which depend on it, e.g. checking if there is a /home
directory. (bnc#995299)
- 3.2.5

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages