Mailinglist Archive: opensuse-factory (678 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161020 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161020

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
bridge-utils (1.5 -> 1.6)
glibc
glibc
gpgme (1.7.0 -> 1.7.1)
ibus-libzhuyin (1.7.6 -> 1.7.8)
kde-l10n (16.08.1 -> 16.08.2)
kernel-firmware (20160913 -> 20161005)
kernel-source (4.7.6 -> 4.8.3)
kscd (16.08.1 -> 16.08.2)
libwps (0.4.3 -> 0.4.4)
libzhuyin (1.1.0 -> 1.1.1)
lightdm (1.19.5 -> 1.20.0)
logrotate (3.9.1 -> 3.10.0)
ncurses
perl-Bootloader (0.915 -> 0.916)
quagga
shotwell (0.24.0 -> 0.24.1)
yast2 (3.2.1 -> 3.2.2)
yast2-bootloader (3.2.3 -> 3.2.4)
yast2-dhcp-server (3.2.0 -> 3.2.1)
yast2-network (3.2.4 -> 3.2.7)
yast2-ntp-client (3.1.28 -> 3.2.0)

=== Details ===

==== bridge-utils ====
Version update (1.5 -> 1.6)

- Version update to 1.6:
* Various tiny fixes, nothing ground breaking
- Refresh patch bridge-utils-1.5-ip6.patch (fuzz)

==== glibc ====
Subpackages: glibc-32bit glibc-locale-32bit

- cpuid-assertion.patch: Don't assert on older Intel CPUs (BZ #20647)
- glibc-2.3.3-nscd-db-path.diff: Move persistent nscd databases to
/var/lib/nscd
- glibc-2.3.90-langpackdir.diff: simplify

==== glibc ====
Subpackages: glibc-devel glibc-extra glibc-info glibc-locale nscd

- cpuid-assertion.patch: Don't assert on older Intel CPUs (BZ #20647)
- glibc-2.3.3-nscd-db-path.diff: Move persistent nscd databases to
/var/lib/nscd
- glibc-2.3.90-langpackdir.diff: simplify

==== gpgme ====
Version update (1.7.0 -> 1.7.1)
Subpackages: libgpgme-devel libgpgme11

- Trim and update descriptions
- New upstream release 1.7.1
* Fixed problems with the new language bindings.
* New helper function gpgme_addrspec_from_uid.
* Use option --exit-on-status-write-error with newer gpg versions.
* qt: Missed API from the Qt Binding inclusion has
been added again.
* qt: abstractimportjob.h is now installed to that
ImportJobs can be used again.
* qt: Fixed spelling error in API (startReceive).
* Interface changes relative to the 1.7.0 release:
gpgme_addrspec_from_uid NEW.
qt: WksPublishJob::startRecieve RENAMED to ::startReceive.
qt: MultiDeleteJob NEW.
qt: AbstractImportJob NEW.
qt: SpecialJob NEW.
cpp: Signature::key(bool, bool) NEW.
cpp: UserID::addrSpecFromString(const char*) NEW.
cpp: UserID::addrSpec() NEW.
- Drop conflict (handled on kdepimlibs4 side)
- Drop upstreamed patches:
* gpgme-1.7.0-nonvoid-returns.patch
* gpgme-1.7.0-cpp-qt-Include-config.h.patch
* gpgme-1.7.0-python-Include-config.h.patch

==== ibus-libzhuyin ====
Version update (1.7.6 -> 1.7.8)

- Update to 1.7.8
* fixes leak
* Fixes FallbackEditor
* fixes full punctuation in English mode
* use Shift-Space to toggle full English mode
* update class ZhuyinProperties
* update class ZhuyinConfig
* update main.py
* update setup UI
* combine two full/width modes into one mode
* fixes compile

==== kde-l10n ====
Version update (16.08.1 -> 16.08.2)
Subpackages: kde-l10n-cs kde-l10n-da kde-l10n-da-data kde-l10n-da-doc
kde-l10n-de kde-l10n-de-data kde-l10n-de-doc kde-l10n-el kde-l10n-en_GB
kde-l10n-en_GB-data kde-l10n-en_GB-doc kde-l10n-es kde-l10n-es-data
kde-l10n-es-doc kde-l10n-fr kde-l10n-fr-data kde-l10n-hu kde-l10n-it
kde-l10n-it-data kde-l10n-it-doc kde-l10n-ja kde-l10n-pl kde-l10n-pl-data
kde-l10n-pt kde-l10n-pt_BR kde-l10n-pt_BR-data kde-l10n-ru kde-l10n-ru-data
kde-l10n-zh_CN kde-l10n-zh_TW

- KDE Applications 16.08.2
https://www.kde.org/announcements/announce-applications-16.08.2.php

==== kernel-firmware ====
Version update (20160913 -> 20161005)
Subpackages: ucode-amd

- Update to version 20161005:
* Remove unused 'LICENCE.mwl8335'
* WHENCE: Adjust some licence file references to satisfy check_whence.py
* WHENCE: Fix metadata for snd-soc-skl firmware
* WHENCE: List new radeon CI and SI smc firmware
* WHENCE: List symlink 'qat_mmp.bin'
* WHENCE: Add reference to 'qca/NOTICE.txt'
* README: Say that files must be listed in WHENCE, and how to check it
* radeon: update SMC firmware for SI parts
* radeon: update SMC firmware for CI parts
* amdgpu: update SMC firmware for VI parts
- Add Provides for brcmfmac43430-sdio.bin formerly in bcm43xx-firmware
- Package new GPL-2 file

==== kernel-source ====
Version update (4.7.6 -> 4.8.3)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Update patches.kernel.org/patch-4.8.2-3 (bnc#1004418
CVE-2016-5195).
- commit 94eb9fb
- Linux 4.8.3 (: :).
- commit db38c1f
- Revert "tty: serial: 8250: add CON_CONSDEV to flags"
(bnc#1003623).
- commit b029ac4
- config: disable NET_DSA on non-ARM
- commit 17e3f19
- drm: virtio: reinstate drm_virtio_set_busid() (bnc#1003623).
- commit 7574477
- Linux 4.8.2 (: :).
- commit b46d583
- config: armv7hl: Enable MMC_SDHCI_IPROC for lpae (boo#1005019)
Needed for Raspberry Pi 2, and default flavor already has it.
- commit 81ca578
- time: Avoid undefined behaviour in ktime_add_safe() (syzkaller
testing).
- commit 28732f2
- fix get_builtin_firmware compilation with gcc 7 (bnc#1004626).
- commit c8f15f0
- Input: ALPS - set DualPoint flag for 74 03 28 devices
(bsc#987703).
- Input: ALPS - allow touchsticks to report pressure (bsc#987703).
- Input: ALPS - handle 0-pressure 1F events (bsc#987703).
- Input: ALPS - add touchstick support for SS5 hardware
(bsc#987703).
- Input: ALPS - set DualPoint flag for 74 03 28 devices
(bsc#987703).
- Input: ALPS - allow touchsticks to report pressure (bsc#987703).
- Input: ALPS - handle 0-pressure 1F events (bsc#987703).
- Input: ALPS - add touchstick support for SS5 hardware
(bsc#987703).
- commit 5e4310e
- net: add recursion limit to GRO (CVE-2016-7039 bsc#1001486).
- commit c6408a6
- Linux 4.8.1 (: :).
- commit 4861355
- Update blacklisting documentation to contain path-blacklisting
- README.blacklist:
- blacklist.conf:
- commit 57a57d3
- apparmor: fix change_hat not finding hat after policy
replacement (bsc#1000287).
- commit b49afc4
- Update AppArmor network mediation patchset.
- AppArmor: basic networking rules (FATE#300516).
- apparmor: Fix quieting of audit messages for network mediation
(FATE#300516).
- Delete
patches.apparmor/apparmor-compatibility-patch-for-v5-network-control.
- commit a586694
- net: add recursion limit to GRO (CVE-2016-7039 bsc#1001486).
- commit 0a6dcd2
- Document the process to blacklist upstream commit-ids
- README.blacklist:
- blacklist.conf:
- commit ff3ff42
- Update to 4.8-final.
- commit bbbf852
- rpm/kernel-binary.spec.in: Simplify debug info switch
Any CONFIG_DEBUG_INFO sub-options are answered in the configs nowadays.
- commit d404ac5

==== kscd ====
Version update (16.08.1 -> 16.08.2)

- KDE Applications 16.08.2
https://www.kde.org/announcements/announce-applications-16.08.2.php

==== libwps ====
Version update (0.4.3 -> 0.4.4)

- Version update to 0.4.4:
* Few lotus fixes

==== libzhuyin ====
Version update (1.1.0 -> 1.1.1)
Subpackages: libzhuyin-data libzhuyin7

- Update to 1.1.1
* simplify ZhuyinDaChenCP26Parser2

==== lightdm ====
Version update (1.19.5 -> 1.20.0)
Subpackages: liblightdm-gobject-1-0 lightdm-lang

- Update to version 1.20.0:
* No changelog available.

==== logrotate ====
Version update (3.9.1 -> 3.10.0)

- Version update to 3.10.0:
* Update url to point to github
- Remove upstreamed patch:
* logrotate-3.7.8-mess_err.patch
- Rebase patches:
* logrotate-3.7.8-suse.patch
* logrotate-addextension.patch
* logrotate-autoext.patch
* logrotate-fix-test62_with_bash-4.4.patch
- Add logrotate-fix-test62_with_bash-4.4.patch: Fix the test suite
when running with bash 4.4 (gh#logrotate/logrotate#66).

==== ncurses ====
Subpackages: libncurses5 libncurses6 libncurses6-32bit ncurses-devel
ncurses-utils tack terminfo terminfo-base

- Add ncurses patch 20161001
+ add -W option to tic/infocmp to force long strings to wrap. This is
in addition to the -w option which attempts to fit capabilities into
a given line-length.
+ add linux-m1 minitel entries (patch by Alexandre Montaron).
+ correct rs2 string for vt100-nam -TD
- Re-enable block cursor on virtual console

==== perl-Bootloader ====
Version update (0.915 -> 0.916)

- run shim-install only if secure boot is set to yes (bsc#985567)
- 0.916

==== quagga ====

- Add quagga-CVE-2016-1245-stack-overrun-in-IPv6-RA-receive.patch:
Fix for a zebra stack overrun in IPv6 RA receive code.
(CVE-2016-1245, bsc#1005258)

==== shotwell ====
Version update (0.24.0 -> 0.24.1)
Subpackages: shotwell-lang

- Update to version 0.24.1:
+ Add debug output when shifting day of event.
+ Add debug output of Shotwell's current timezone.
+ Fix Vala generic handling with recent Vala compiler.
+ Fix focus handling when in fullscreen (bgo#771969).
+ Remove obsolete CSS style.
+ Prevent a critical in Piwigo uploader.
+ Fix issue with accessability in recent Vala compiler.
+ Fix album creation with Piwigo uploader (bgo#772648).
+ Add option to enable SQL debugging without recompilation.
+ Updated translations.

==== yast2 ====
Version update (3.2.1 -> 3.2.2)

- Add-on module: Do not escape characters like ":" in the path
string (bnc#966413).
- 3.2.2

==== yast2-bootloader ====
Version update (3.2.3 -> 3.2.4)

- Do not require syslinux on target system during installation
(bsc#1004229)
- fix installation on dm raids to not use mapper device and instead
use underlaying device (bsc#1004921)
- 3.2.4

==== yast2-dhcp-server ====
Version update (3.2.0 -> 3.2.1)

- allow empty string in primary name server field for dynamic DNS
option to allow what is suggested in documentation for local DNS
servers (bsc#736496)
- 3.2.1

==== yast2-network ====
Version update (3.2.4 -> 3.2.7)

- Bridge handling has been improved (bsc#962824).
- "NONE" is shown instead of 0.0.0.0 for old bridge configuration
- The bridge master is shown in the enslaved interface.
- The interfaces overview is updated after a bridge is modified
- The interfaces enlsaved are not lost when save in a different
tab.
- 3.2.7
- fix crash when dummy ip is not needed
(found during testing of bsc#877047)
- 3.2.6
- optimize loading /etc/hosts if there is a lot of entries
(bsc#877047)
- 3.2.5

==== yast2-ntp-client ====
Version update (3.1.28 -> 3.2.0)

- properly report that test failed if server without running ntp is
checked as ntp server (bsc#972842)
- 3.2.0

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups