Mailinglist Archive: opensuse-factory (678 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20161010 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20161010

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
accountsservice (0.6.42 -> 0.6.43)
apache2-mod_perl
armagetron
bluez (5.41 -> 5.42)
brltty (5.3.1 -> 5.4)
double-conversion
file-roller
freetype2 (2.6.5 -> 2.7)
ft2demos (2.6.5 -> 2.7)
gd (2.1.1 -> 2.2.3)
gnome-control-center
gnome-settings-daemon
gnutls (3.4.14 -> 3.4.15)
grub2
gtk3 (3.22.0 -> 3.22.1)
gwenview5
hdf5
irssi
kio
kwallet
libXrandr (1.5.0 -> 1.5.1)
libkgapi (5.1.0 -> 5.3.1)
libnl3 (3.2.27 -> 3.2.28)
libproxy
libproxy-plugins
libvirt (2.2.0 -> 2.3.0)
lightdm-gtk-greeter (2.0.1 -> 2.0.2)
llvm3_8
multipath-tools (0.6.2+suse20160919.a385ea7 -> 0.6.2+suse20160928.8939fb6)
nmap (7.12 -> 7.30)
obs-service-format_spec_file (20160406 -> 20160929)
okular
openssh
openssl
perl-DBD-mysql (4.036 -> 4.037)
perl-Sub-Name (0.19 -> 0.21)
postgresql-init (9.4 -> 9.6)
postgresql94 (9.4.8 -> 9.4.9)
postgresql94-libs (9.4.8 -> 9.4.9)
postgresql95-libs (9.4.8 -> 9.5.4)
powertop
python-Pillow
python3-numpy (1.11.1 -> 1.11.2)
python3-setuptools (28.0.0 -> 28.2.0)
timezone (2016f -> 2016g)
timezone-java (2016f -> 2016g)
tracker
tracker-extras
vlc
webkit2gtk3 (2.13.92 -> 2.14.0)
wireshark (2.2.0 -> 2.2.1)
xf86-input-libinput (0.19.1 -> 0.20.0)
yast2 (3.1.207 -> 3.1.208)
yast2-bootloader (3.1.203 -> 3.2.3)
yast2-dhcp-server (3.1.11 -> 3.2.0)
yast2-installation (3.1.217 -> 3.2.0)
yast2-packager (3.1.117 -> 3.2.1)
yast2-pkg-bindings (3.1.34 -> 3.2.0)
yast2-storage (3.1.103 -> 3.1.104)
yast2-theme (3.1.40 -> 3.1.42)
yast2-trans (84.87.20160929.17a3ba9 -> 84.87.20161005.d47da02)
yast2-update (3.1.42 -> 3.1.43)

=== Details ===

==== accountsservice ====
Version update (0.6.42 -> 0.6.43)
Subpackages: libaccountsservice0 typelib-1_0-AccountsService-1_0

- Update to version 0.6.43:
+ Fix logout times in login-history.
+ Increase performance in large deployments.
+ Memory leak fix.
+ Exclude nologin users from user list.

==== apache2-mod_perl ====

- Remove unused icon and shorten the description a bit 1-2 migration
is quite irelevant in these days
- Move tests to %check phase
- Use proper group for devel subpackage

==== armagetron ====

- Some cleanup:
* removed BuildRequires: kdelibs3-devel (fixes build for
openSUSE Leap 42.1 and Leap 42.2).
* added some BuildRequires.

==== bluez ====
Version update (5.41 -> 5.42)
Subpackages: bluez-cups bluez-devel libbluetooth3

- update to version 5.42:
The major API change with this release is that the GATT D-Bus API
is no longer marked as experimental.This should hopefully
encourage the creation of more applications using it. Feature-
wise, btmon received support for decoding full mgmt message
traces - a feature that is available in the bluetooth-next kernel
tree, i.e. on its way to the 4.9 kernel release. In addition to
these changes, this release contains also fixes in areas such as
PBAP, transport selection (BR/EDR vs LE), ATT and A2DP.

==== brltty ====
Version update (5.3.1 -> 5.4)
Subpackages: brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-espeak
brltty-driver-speech-dispatcher brltty-driver-xwindow libbrlapi0_6
python3-brlapi xbrlapi

- Update to version 5.4
+ Too many changes; please read ChangeLog :
- Drop b40-1.patch, brltty-polkit.patch, and
brltty-5.3.1-udev-systemd.patch: fixed upstream.
- Add brltty-5.4-latex-tables-executable.patch: LaTeX tables
should be executable.
- API version is now 0.6.5
- Install rules file into %{_udevdir}/rules.d
- Install systemd files via the Makefile
- Make polkit a conditional.
- Install polkit file (bsc#930242).
- Add brltty-5.3.1-udev-systemd.patch: fix udev rules to work with
systemd. From upstream.

==== double-conversion ====

- Add baselibs.conf: Build 32-bit support (boo#1002561).

==== file-roller ====

- Add file-roller-revertfix-fr_application_local.patch: Allow
multiple windows of file-roller (bgo#772148).

==== freetype2 ====
Version update (2.6.5 -> 2.7)
Subpackages: freetype2-devel libfreetype6 libfreetype6-32bit

- update to version 2.7:
* IMPORTANT CHANGES
+ As announced earlier, the 2.7.x series now uses the new subpixel
hinting mode as the default, emulating a modern version of
ClearType.
This change inevitably leads to different rendering results, and
you might change the `TT_CONFIG_OPTION_SUBPIXEL_HINTING'
configuration option to adapt it to your taste (or use the new
`FREETYPE_PROPERTIES' environment variable). See the
corresponding entry below for version 2.6.4, which gives more
information.
- A new option `FT_CONFIG_OPTION_ENVIRONMENT_PROPERTIES' has been
introduced. If set (which is the default), an environment
variable `FREETYPE_PROPERTIES' can be used to control driver
properties. Example:
FREETYPE_PROPERTIES=truetype:interpreter-version=35 \
cff:no-stem-darkening=1 \
autofitter:warping=1
This allows to select, say, the subpixel hinting mode at runtime
for a given application. See file `ftoption.h' for more.
* IMPORTANT BUG FIXES
+ After loading a named instance of a GX variation font, the
`face_index' value in the returned `FT_Face' structure now
correctly holds the named instance index in the upper 16bits as
documented.
* MISCELLANEOUS
+ A new macro `FT_IS_NAMED_INSTANCE' to test whether a given face
is a named instance.
+ More fixes to GX font handling.
+ Apple's `GETVARIATION' bytecode operator (needed for GX
variation font support) has been implemented.
+ Another round of fuzzer fixes, mainly to reject invalid fonts
faster.
+ Handling of raw CID fonts was broken (bug introduced in version
2.6.4).
+ The smooth rasterizer has been streamlined to make it faster by
approx. 20%.
+ The `ftgrid' demo program now understands command line option
`-d' to give start-up design coordinates.
+ The `ftdump' demo program has a new command line option `-p' to
dump TrueType bytecode instructions.
- removed freetype2-subpixel.patch in favor of above
FREETYPE_PROPERTIES environment variable

==== ft2demos ====
Version update (2.6.5 -> 2.7)

- update to version 2.7:
+ Sync with freetype 2.7

==== gd ====
Version update (2.1.1 -> 2.2.3)
Subpackages: libgd3 libgd3-32bit

- Update to version 2.2.3:
+ Security fixes:
- Php bug#72339, Integer Overflow in _gd2GetHeader
(CVE-2016-5766)
- Issue gh/libgd/libgd#247: A read out-of-bands was found in
the parsing of TGA files (CVE-2016-6132)
- Issue gh/libgd/libgd#247: Buffer over-read issue when
parsing crafted TGA file (CVE-2016-6214)
- Issue gh/libgd/libgd#248: fix Out-Of-Bounds Read in
read_image_tga
- Integer overflow error within _gdContributionsAlloc()
(CVE-2016-6207)
- Fix php bug#72494, invalid color index not handled, can lead
to crash (CVE-2016-6128)
+ Improve color check for CropThreshold
+ gdImageCopyResampled has been improved. Better handling of
images with alpha channel, also brings libgd in sync with
php's bundled gd.
- Drop patches:
+ gd-CVE-2016-5116.patch: upstreamed
+ gd-CVE-2016-6132.patch: upstreamed
+ gd-CVE-2016-6214.patch: upstreamed
+ gd-CVE-2016-6905.patch: upstreamed
+ gd-libvpx.patch: vpx support dropped.
- Add BuildRequires for automake and autoconf since
gd-disable-freetype27-failed-tests.patch touches makefiles.
- Drop getver.pl from source: included in upstream tarball.
- Add "-msse -mfpmath=sse" to CFLAGS to fix tests on ix86
architectures.
- Add "-ffp-contract=off" to CFLAGS for non-ix86 arch (ppc, arm)
to fix a test: see gh#libgd/libgd#278.
- Add gd-test-unintialized-var.patch to fix an uninitialised
variable in tests/gd2/gd2_read.c to prevent it from compiling
with -Werror (only causes problems in no ix86 arch
surprisingly); patch sent upstream.
- Rebase gd-disable-freetype27-failed-tests.patch for updated
version.
- Update URL and Source to project's new github URL's.
- Add gd-disable-freetype27-failed-tests.patch: Disable for now
tests failing against freetype >= 2.7 for being too exact
(gh#libgd/libgd#302). The failures have been understood by
upstream to be due to minor differences between test images and
those generated when freeetype >= 2.7 is used to build gd.

==== gnome-control-center ====
Subpackages: gnome-control-center-color gnome-control-center-goa
gnome-control-center-user-faces

- Add gnome-control-center-printers-fix-compilation-warning.patch:
Adapt to changes in cups.
- Add
gnome-control-center-display-fix-possible-crash-on-startup.patch:
Display: Fix possible crash on startup (bgo#771875).
- Stop passing V=1 to make, we do debugging locally.

==== gnome-settings-daemon ====

- Add iio-sensor-proxy Recommends for openSUSE.

==== gnutls ====
Version update (3.4.14 -> 3.4.15)
Subpackages: libgnutls-dane0 libgnutls-devel libgnutls-openssl27 libgnutls30
libgnutls30-32bit

- GnuTLS 3.4.15:
* libgnutls: Corrected the comparison of the serial size in OCSP
response. Previously the OCSP certificate check wouldn't verify
the serial length and could succeed in cases it shouldn't
(GNUTLS-SA-2016-3).
* libgnutls: Fixes in gnutls_x509_crt_list_import2, which was
ignoring flags if all certificates in the list fit within the
initially allocated memory.
* libgnutls: Corrected issue which made
gnutls_certificate_get_x509_crt() to return invalid pointers
when returned more than a single certificate.
* libgnutls: Fix gnutls_pkcs12_simple_parse to always extract the
complete chain.
* libgnutls: Added support for decrypting PKCS#8 files which use
the HMAC-SHA256 as PRF.
* libgnutls: Addressed issue with PKCS#11 signature generation on
ECDSA keys. The signature is now written as unsigned integers
into the DSASignatureValue structure. Previously signed
integers could be written depending on what the underlying
module would produce. Addresses #122.
- fix build error for 13.2, 42.1 and 42.2

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- use $PRETTY_NAME instead of $NAME $VERSION for $GRUB_DISTRIBUTOR
in openSUSE Tumbleweed (bsc#995549)
* modified grub2-default-distributor.patch
- grub2.spec: add http module to grub.efi (fate#320129)

==== gtk3 ====
Version update (3.22.0 -> 3.22.1)
Subpackages: gtk3-data gtk3-devel gtk3-immodule-amharic gtk3-immodule-inuktitut
gtk3-immodule-thai gtk3-immodule-vietnamese gtk3-immodule-xim gtk3-tools
libgtk-3-0 typelib-1_0-Gtk-3_0

- Update to version 3.22.1:
+ Reduce runtime warnings.
+ Bugs fixed: bgo#765649, bgo#769500, bgo#769554, bgo#770388,
bgo#771516, bgo#771553, bgo#771666, bgo#771812, bgo#771826,
bgo#771915, bgo#771959, bgo#771963, bgo#772057, bgo#772215.
+ Updated translations.
- Drop patches fixed upstream:
+ gtk3-widget-warn-consistency-check-only.patch.
+ gtk3-add-missing-annotations.patch.
+ gtk3-wayland-always-sync-state.patch.
+ gtk3-wayland-avoid-negative-size-constraints.patch.
- Add gtk3-wayland-avoid-negative-size-constraints.patch: Fix
totem window misplaced after a state change (bgo#771915).
- Add gtk3-wayland-always-sync-state.patch: wayland: always sync
state after a frame is painted. Fix black areas in webkit based
apps (bgo#771553).
- Add gtk3-add-missing-annotations.patch: Add some missing
(nullable) annotations (bgo#771826).
- Rebase settings.ini, set Adwaita as gtk-fallback-icon-theme.

==== gwenview5 ====

- Added a require for kdelibs4support since that package provides
qimageioplugins services for jpeg, png, gif and other image formats
and gwenview5 can't be used without it (boo#1001276).
- Added QUrl::AssumeLocalFile to fix-multiple-arguments.diff to
mimic the patch accepted upstream
- Add fix-multiple-arguments.diff to fix handling of multiple local
file arguments in the command line (boo#1001276)

==== hdf5 ====
Subpackages: libhdf5-100 libhdf5_hl100

- Fix baselibs.conf so numbers.
Fixes bnc#1002569

==== irssi ====

- irssi-0.8.20-buf.pl.patch: Fixed a information disclosure in buf.pl
(CVE-2016-7553 bsc#1001215)

==== kio ====
Subpackages: kio-core kio-devel

- Add 0001-Fix-kio-using-only-tls1.0.patch
- Added Fix-launching-terminal-desktop-files-with-konsole.patch
(kde#368949, boo#1003125)

==== kwallet ====
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Add fix-isOpen-crash-when-wallet-disabled.patch to fix a crash in
drkonqi (and maybe other applications) if kwallet is disabled
(kde#358260)

==== libXrandr ====
Version update (1.5.0 -> 1.5.1)
Subpackages: libXrandr-devel libXrandr2 libXrandr2-32bit

- Update to version 1.5.1
* Avoid out of boundary accesses on illegal responses
* fix: doGetScreenResources() info: redundant null check on
calling free()
* fix: redundant null check on calling free()

==== libkgapi ====
Version update (5.1.0 -> 5.3.1)
Subpackages: libKF5GAPICalendar5 libKF5GAPIContacts5 libKF5GAPICore5
libKF5GAPITasks5

- Update to 5.3.1
* No changelog provided
- Update to 5.3.0
* No changelog provided

==== libnl3 ====
Version update (3.2.27 -> 3.2.28)
Subpackages: libnl-config libnl3-200 libnl3-200-32bit

- Update to new upstream release 3.2.28
* route/link: IFLA_VLAN_PROTOCOL added to vlan_put_attrs
* route/vrf: add VRF support
* route/link: add macvtap support
* sit: add 6RD support
* lib/route: add macsec support

==== libproxy ====
Subpackages: libproxy-devel libproxy1

- Add libproxy-FindMono-4.6.patch: Fall back to mcs if gmcs cannot
be found. Fixes issues with mono 4.6, which no longer ships the
wrapper by default.

==== libproxy-plugins ====
Subpackages: libproxy1-config-gnome3 libproxy1-config-kde
libproxy1-networkmanager libproxy1-pacrunner-webkit

- Add libproxy-FindMono-4.6.patch: Fall back to mcs if gmcs cannot
be found. Fixes issues with mono 4.6, which no longer ships the
wrapper by default.

==== libvirt ====
Version update (2.2.0 -> 2.3.0)
Subpackages: libvirt-client libvirt-daemon libvirt-daemon-config-network
libvirt-daemon-config-nwfilter libvirt-daemon-driver-interface
libvirt-daemon-driver-libxl libvirt-daemon-driver-lxc
libvirt-daemon-driver-network libvirt-daemon-driver-nodedev
libvirt-daemon-driver-nwfilter libvirt-daemon-driver-qemu
libvirt-daemon-driver-secret libvirt-daemon-driver-storage
libvirt-daemon-driver-uml libvirt-daemon-driver-vbox libvirt-daemon-lxc
libvirt-daemon-qemu libvirt-daemon-xen libvirt-libs

- Update to libvirt 2.3.0
- Many incremental improvements and bug fixes, see
http://libvirt.org/news.html
- Dropped patches:
pci-use-driver-override-sysfs.patch,
virHostdevFindUSBDevice-privsyms.patch, libxl-usb-vendor.patch,
apparmor-qemu-bridge-helper.patch

==== lightdm-gtk-greeter ====
Version update (2.0.1 -> 2.0.2)
Subpackages: lightdm-gtk-greeter-lang

- Update to version 2.0.2:
* Add support for lightdm 1.19.2+.
* Include a badge for Budgie desktop (lp#1568494).
* Fix solid colour instead of background image for some themes
(lp#1458330).
* Restore user background after changing display setup.
* Correct login box blinking on login.
* Replace a number of build-breaking deprecations.
* Update translations.
- Remove lightdm-gtk-greeter-fix-fail-return-value.patch,
lightdm-gtk-greeter-lightdm-1.19.2-api.patch: fixed upstream.

==== llvm3_8 ====
Subpackages: libLLVM3_8 libLLVM3_8-32bit

- Fix python-clang dependency.
- Change update-alternatives to use %postun instead of %preun,
which is now what Factory maintainers are requesting.
- Use the minor version to set the update-alternatives priority so
the most recent version of the LLVM, Clang, and LLDB are used by
default.
- Add LLVM rpm macros so downstream packages can have some idea how
LLVM was built.
- Rename libomp to make it possible to have multiple versions available.
- Split the old llvm package into this version-specific package
and a wrapper package.
- Implement update-alternatives to allow parallel installation
of many of the subpackages.
- Rename subpackages that can be parallel-installed to a
version-specific name based on the associated shared library's
current .so number.
- Various fixes to support the above changes.

==== multipath-tools ====
Version update (0.6.2+suse20160919.a385ea7 -> 0.6.2+suse20160928.8939fb6)
Subpackages: kpartx

- Update to version 0.6.2+suse20160928.8939fb6
- Implement support for 'multipath=off' and 'nompath'
kernel commandline options (bsc#1001691)
- multipath: avoid crash when using modified configuration
(bsc#1000914)

==== nmap ====
Version update (7.12 -> 7.30)

- Nmap 7.30:
* Many added NSE scripts, OS fingerprints, service proes
* Improved output filtering
* Using Lua 5.3
* Many bug fixes, improvements and performance enhancements

==== obs-service-format_spec_file ====
Version update (20160406 -> 20160929)

- Handle needssslcertforbuild directive
- Handle empty output directory
- Improve the license and group comments handling

==== okular ====

- Add mimeinfo17.patch to fix opening CBR files with
shared-mime-info 1.7 (kde#369078)

==== openssh ====
Subpackages: openssh-helpers

- remaining patches that were still missing
since the update to 7.2p2 (FATE#319675):
- allow X forwarding over IPv4 when IPv6 sockets is not available
[openssh-7.2p2-X_forward_with_disabled_ipv6.patch]
- do not write PID file when not daemonizing
[openssh-7.2p2-no_fork-no_pid_file.patch]
- use correct options when invoking login
[openssh-7.2p2-login_options.patch]
- helper application for retrieving users' public keys from
an LDAP server
[openssh-7.2p2-ldap.patch]
- allow forcing permissions over sftp
[openssh-7.2p2-sftp_force_permissions.patch]
- do not perform run-time checks for OpenSSL API/ABI change
[openssh-7.2p2-disable_openssl_abi_check.patch]
- suggest commands for cleaning known hosts file
[openssh-7.2p2-host_ident.patch]
- sftp home chroot patch
[openssh-7.2p2-sftp_homechroot.patch]
- ssh sessions auditing
[openssh-7.2p2-audit.patch]
- enable seccomp sandbox on additional architectures
[openssh-7.2p2-additional_seccomp_archs.patch]
- fix forwarding with IPv6 addresses in DISPLAY (bnc#847710)
[openssh-7.2p2-IPv6_X_forwarding.patch]
- ignore PAM environment when using login
(bsc#975865, CVE-2015-8325)
[openssh-7.2p2-ignore_PAM_with_UseLogin.patch]
- limit accepted password length (prevents possible DoS)
(bsc#992533, CVE-2016-6515)
[openssh-7.2p2-limit_password_length.patch]
- Prevent user enumeration through the timing of password
processing (bsc#989363, CVE-2016-6210)
[openssh-7.2p2-prevent_timing_user_enumeration.patch]
- Add auditing for PRNG re-seeding
[openssh-7.2p2-audit_seed_prng.patch]

==== openssl ====
Subpackages: libopenssl-devel libopenssl1_0_0 libopenssl1_0_0-32bit

- resume reading from /dev/urandom when interrupted by a signal
(bsc#995075)
* add openssl-randfile_fread_interrupt.patch
- add FIPS changes from SP2:
- fix problems with locking in FIPS mode (bsc#992120)
* duplicates: bsc#991877, bsc#991193, bsc#990392, bsc#990428
and bsc#990207
* bring back openssl-fipslocking.patch
- drop openssl-fips_RSA_compute_d_with_lcm.patch (upstream)
(bsc#984323)
- don't check for /etc/system-fips (bsc#982268)
* add openssl-fips-dont_run_FIPS_module_installed.patch
- refresh openssl-fips-rsagen-d-bits.patch

==== perl-DBD-mysql ====
Version update (4.036 -> 4.037)

- updated to 4.037
see /usr/share/doc/packages/perl-DBD-mysql/Changes
2016-10-03 Patrick Galbraith, Michiel Beijen, DBI/DBD community (4.037)
* Security release to patch possible buffer overflow in prepared
statements. Reported and fixed by Pali Rohár. This vulnerability
is present in all releases at least back to versions 3.0 of the
driver, which were released in 2005.
The CVE identifier for this vulnerability is CVE-2016-1246.

==== perl-Sub-Name ====
Version update (0.19 -> 0.21)

- updated to 0.21
see /usr/share/doc/packages/perl-Sub-Name/Changes
0.21 2016-10-02 05:00:12Z
- no change since 0.20
0.20 2016-09-11 00:33:10Z (TRIAL RELEASE)
- fix occasional segmentation fault on OpenBSD when malloc randomization
causes nameptr to be at the beginning of the page (RT#117072, Alexander
Bluhm)

==== postgresql-init ====
Version update (9.4 -> 9.6)

- fix building on 13.1 by removing the BuildRequires on systemd
we will get it via systemd mini and the systemd_requires macro
- bump to 9.6 so we can also build for the latest version

==== postgresql94 ====
Version update (9.4.8 -> 9.4.9)
Subpackages: postgresql94-contrib postgresql94-docs postgresql94-server

- Update to version 9.4.9:
* Fix possible mis-evaluation of nested CASE-WHEN expressions
(CVE-2016-5423)
* Fix client programs' handling of special characters in database
and role names (CVE-2016-5424)
* Fix corner-case misbehaviors for IS NULL/IS NOT NULL applied
to nested composite values
* Make the inet and cidr data types properly reject IPv6
addresses with too many colon-separated fields
* Prevent crash in close_ps() (the point ## lseg operator) for
NaN input coordinates
* Fix several one-byte buffer over-reads in to_number()
* Avoid unsafe intermediate state during expensive paths through
heap_update()
* For the other bug fixes, see the release notes:
https://www.postgresql.org/docs/9.4/static/release-9-4-9.html
- The libs are now built in 9.5, so disable them here and remove
baselibs.conf.

==== postgresql94-libs ====
Version update (9.4.8 -> 9.4.9)

- Update to version 9.4.9:
* Fix possible mis-evaluation of nested CASE-WHEN expressions
(CVE-2016-5423)
* Fix client programs' handling of special characters in database
and role names (CVE-2016-5424)
* Fix corner-case misbehaviors for IS NULL/IS NOT NULL applied
to nested composite values
* Make the inet and cidr data types properly reject IPv6
addresses with too many colon-separated fields
* Prevent crash in close_ps() (the point ## lseg operator) for
NaN input coordinates
* Fix several one-byte buffer over-reads in to_number()
* Avoid unsafe intermediate state during expensive paths through
heap_update()
* For the other bug fixes, see the release notes:
https://www.postgresql.org/docs/9.4/static/release-9-4-9.html
- The libs are now built in 9.5, so disable them here and remove
baselibs.conf.

==== postgresql95-libs ====
Version update (9.4.8 -> 9.5.4)
Subpackages: libecpg6 libpq5 libpq5-32bit

- Update to version 9.5.4:
* Fix possible mis-evaluation of nested CASE-WHEN expressions
(CVE-2016-5423, bsc#993454)
* Fix client programs' handling of special characters in database
and role names (CVE-2016-5424, bsc#993453)
* Fix corner-case misbehaviors for IS NULL/IS NOT NULL applied
to nested composite values
* Fix "unrecognized node type" error for INSERT ... ON CONFLICT
within a recursive CTE (a WITH item)
* Fix INSERT ... ON CONFLICT to successfully match index
expressions or index predicates that are simplified during the
planner's expression preprocessing phase
* Correctly handle violations of exclusion constraints that apply
to the target table of an INSERT ... ON CONFLICT command, but
are not one of the selected arbiter indexes
* For the other bug fixes, see the release notes:
https://www.postgresql.org/docs/9.5/static/release-9-5-4.html

==== powertop ====
Subpackages: powertop-lang

- Add powertop-2.8-potential-segfaults.patch: Fix potential
segfaults.
- Drop Environment="TERM=xterm" from the systemd service file, it
is not needed.
- Following the above: Remove xterm/xterm-bin Requires.

==== python-Pillow ====
Subpackages: python-Pillow-tk

- Add python-Pillow-tests-update-epsilon-for-freetype27.patch: Fix
buildfailures against freetype 2.7 by increasing the epsilon
(gh#python-pillow/Pillow#2116); this seems to be the recommended
solution by upstream.
- ignore make check errors on all bigendian archs
(adding ppc s390 s390x)
- add LICENSE
- ignore make check errors ppc64 architecture as upstream issue
https://github.com/python-pillow/Pillow/issues/1204
- update to version 3.1.1 with security fixes:
* Fixed an integer overflow in Resample.c causing writes in the Python heap.
* Fixed a buffer overflow in PcdDecode.c causing a segfault when opening
PhotoCD files. CVE-2016-TBD
* Fixed a buffer overflow in FliDecode.c causing a segfault when opening
FLI files. CVE-2016-0775 (fixes bsc#965582)
* Fixed a buffer overflow in TiffDecode.c causing an arbitrary amount of
memory to be overwritten when opening a specially crafted invalid TIFF
file. CVE-2016-0740 (fixes bsc#965579)
- update to version 3.1.0:
* Fixing test failures on Python 2.6/Windows #1633 [wiredfool]
* Limit metadata tags when writing using libtiff #1620 [wiredfool]
* Rolling back exif support to pre-3.0 format #1627 [wiredfool]
* Fix Divide by zero in Exif, add IFDRational class #1531
[wiredfool]
* Catch the IFD error near the source #1622 [wiredfool]
* Added release notes for 3.1.0 #1623 [radarhere]
* Updated spacing to be consistent between multiline methods #1624
[radarhere]
* Let EditorConfig take care of some basic formatting #1489 [hugovk]
* Restore gpsexif data to the v1 form [wiredfool]
* Add /usr/local include and library directories for freebsd #1613
[leforestier]
* Updated installation docs for new versions of dependencies #1611
[radarhere]
* Removed unrunnable test file #1610 [radarhere]
* Changed register calls to use format property #1608 [radarhere]
* Added field type constants to TiffTags #1596 [radarhere]
* Allow saving RowsPerStrip with libtiff #1594 [wiredfool]
* Enabled conversion to numpy array for HSV images #1578 [cartisan]
* Changed some urls in the docs to use https #1580 [hugovk]
* Removed logger.exception from ImageFile.py #1590 [radarhere]
* Removed warnings module check #1587 [radarhere]
* Changed arcs, chords and pie slices to use floats #1577
[radarhere]
* Update unit test asserts #1584, #1598 [radarhere]
* Fix command to invoke ghostscript for eps files #1478 [baumatron,
radarhere]
* Consistent multiline text spacing #1574 [wiredfool, hugovk]
* Removed unused lines in BDFFontFile #1530 [radarhere]
* Changed ImageQt import of Image #1560 [radarhere, ericfrederich]
* Throw TypeError if no cursors were found in .cur file #1556
[radarhere]
* Fix crash in ImageTk.PhotoImage on win-amd64 #1553 [cgohlke]
* ExtraSamples tag should be a SHORT, not a BYTE #1555 [Nexuapex]
* Docs and code health fixes #1565 #1566 #1581 #1586 #1591 #1621
[radarhere]
* Updated freetype to 2.6.2 #1564 [radarhere]
* Updated WebP to 0.5.0 for Travis #1515 #1609 [radarhere]
* Fix missing 'version' key value in __array_interface__ #1519
[mattip]
* Replaced os.popen with subprocess.Popen to pilprint script #1523
[radarhere]
* Catch OverflowError in SpiderImagePlugin #1545 [radarhere,
MrShark]
* Fix the definition of icc_profile in TiffTags #1539 [wiredfool]
* Remove old _imagingtiff.c and pilplus stuff #1499 [hugovk]
* Fix Exception when requiring jpeg #1501 [hansmosh]
* Dependency scripts for Debian and Ubuntu #1486 [wiredfool]
* Added Usage message to painter script #1482 [radarhere]
* Add tag info for iccprofile, fixes #1462. #1465 [wiredfool]
* Added some requirements for make release-test #1451 [wiredfool]
* Flatten tiff metadata value SAMPLEFORMAT to initial value, fixes
[#1466] [wiredfool]
* Fix handling of pathlib in Image.save. Fixes #1460 [wiredfool]
* Make tests more robust #1469 [hugovk]
* Use correctly sized pointers for windows handle types. #1458 [nu744]
- fix wrong macro name in %post - it's %{py_ver}, not %{py-ver}
- specfile:
* added new binary files as update alternatives
* cleaned up update alternatives
* removed build command, since it will be rebuild during install anyway
(taken from python3 spec file)
- update to version 3.0.0:
* Check flush method existence for file-like object #1398 [mrTable,
radarhere]
* Added PDF multipage saving #1445 [radarhere]
* Removed deprecated code, Image.tostring, Image.fromstring,
Image.offset, ImageDraw.setink, ImageDraw.setfill, ImageFileIO,
ImageFont.FreeTypeFont and ImageFont.truetype file kwarg,
ImagePalette private _make functions, ImageWin.fromstring and
ImageWin.tostring #1343 [radarhere]
* Load more broken images #1428 [homm]
* Require zlib and libjpeg #1439 [wiredfool]
* Preserve alpha when converting from a QImage to a Pillow Image by
using png instead of ppm #1429 [ericfrederich]
* Qt needs 32 bit aligned image data #1430 [ericfrederich]
* Tiff ImageFileDirectory rewrite #1419 [anntzer, wiredfool, homm]
* Removed spammy debug logging #1423 [wiredfool]
* Save as GiF89a with support for animation parameters #1384
[radarhere]
* Correct convert matrix docs #1426 [wiredfool]
* Catch TypeError in _getexif #1414 [radarhere, wiredfool]
* Fix for UnicodeDecodeError in TiffImagePlugin #1416 [bogdan199,
wiredfool]
* Dedup code in image.open #1415 [wiredfool]
* Skip any number extraneous chars at the end of JPEG chunks #1337
[homm]
* Single threaded build for pypy3, refactor #1413 [wiredfool]
* Fix loading of truncated images with LOAD_TRUNCATED_IMAGES enabled
[#1366] [homm]
* Documentation update for concepts: bands [merriam]
* Add Solaris/SmartOS include and library directories #1356
[njones11]
* Improved handling of getink color #1387 [radarhere]
* Disable compiler optimizations for topalette and tobilevel
functions for all msvc versions, fixes #1357 [cgohlke]
* Skip ImageFont_bitmap test if _imagingft C module is not installed
[#1409] [homm]
* Add param documentation to ImagePalette #1381 [bwrsandman]
* Corrected scripts path #1407 [radarhere]
* Updated libtiff to 4.0.6 #1405, #1421 [radarhere]
* Updated Platform Support for Yosemite #1403 [radarhere]
* Fixed infinite loop on truncated file #1401 [radarhere]
* Check that images are L mode in ImageMorph methods #1400
[radarhere]
* In tutorial of pasting images, add to mask text #1389 [merriam]
* Style/health fixes #1391, #1397, #1417, #1418 [radarhere]
* Test on Python 3.5 dev and 3.6 nightly #1361 [hugovk]
* Fix fast rotate operations #1373 [radarhere]
* Added support for pathlib Path objects to open and save #1372
[radarhere]
* Changed register calls to use format property #1333 [radarhere]
* Added support for ImageGrab.grab to OS X #1367, #1443 [radarhere,
hugovk]
* Fixed PSDraw stdout Python 3 compatibility #1365 [radarhere]
* Added Python 3.3 to AppVeyor #1363 [radarhere]
* Treat MPO with unknown header as base JPEG file #1350 [hugovk,
radarhere]
* Added various tests #1330, #1344 [radarhere]
* More ImageFont tests #1327 [hugovk]
* Use logging instead of print #1207 [anntzer]
- Update to 2.9.0:
* Added test for GimpPaletteFile #1324
* Fixed ValueError in Python 2.6 #1315 #1316
* Fixed tox test script path #1308
* Added width and height properties #1304
* Update tiff and tk tcl 8.5 versions #1303
* Add functions to convert: Image <-> QImage; Image <-> QPixmap #1217
* Remove duplicate code in gifmaker script #1294
* Multiline text in ImageDraw #1177
* Automated Windows CI/build support #1278
* Removed support for Tk versions earlier than 8.4 #1288
* Fixed polygon edge drawing #1255 (fixes #1252)
* Check prefix length in _accept methods #1267
* Register MIME type for BMP #1277
* Adjusted ImageQt use of unicode() for 2/3 compatibility #1218
* Identify XBM file created with filename including underscore #1230 (fixes
#1229)
* Copy image when saving in GifImagePlugin #1231 (fixes #718)
* Removed support for FreeType 2.0 #1247
* Added background saving to GifImagePlugin #1273
* Provide n_frames attribute to multi-frame formats #1261
* Add duration and loop set to GifImagePlugin #1172, #1269
* Ico files are little endian #1232
* Upgrade olefile from 0.30 to 0.42b #1226
* Setting transparency value to 0 when the tRNS contains only null byte(s)
#1239
* Separated out feature checking from selftest #1233
* Style/health fixes
* Update WebP from 0.4.1 to 0.4.3 #1235
* Release GIL during image load (decode) #1224
* Added icns save #1185
* Fix putdata memory leak #1196
* Keep user-specified ordering of icon sizes #1193
* Tiff: allow writing floating point tag values #1113
- Update to 2.8.2:
* Bug fix: Fixed Tiff handling of bad EXIF data
- Remove 0001-Ico-files-are-little-endian-ref-1204.patch: merged upstream
- Remove fix-textsize-equal.patch: merged upstream
- fix build and dependencies for RHEL/CentOS 7
- add 0001-Ico-files-are-little-endian-ref-1204.patch: fix for s390x
- Update to 2.8.1:
- Bug fix: Catch struct.error on invalid JPEG, fixes #1163
- Fix 32-bit BMP loading (RGBA or RGBX)
- Fix UnboundLocalError in ImageFile #1131
- Re-enable test image caching
- Fix: Cannot identify EPS images, fixes #1104
- Configure setuptools to run nosetests, fixes #729
- Style/health fixes
- Add support for HTTP response objects to Image.open()
- Improve reference docs for PIL.ImageDraw.Draw.pieslice() #1145
- Added copy method font_variant() and accessible properties to truetype()
#1123
- Fix ImagingEffectNoise #1128
- Remove unreachable code
- Let Python do the endian stuff + tests #1121
- Fix webp decode memory leak #1114
- Fast path for opaque pixels in RGBa unpacker #1088
- Enable basic support for 'RGBa' raw encoding/decoding #1096
- Remove Pillow-fixtests.patch, merged upstream
- Add fix-textsize-equal.patch. Fixes testsuite on SLE11SP3
- fix test for lossy webp alpha deviation of earlier lib versions
* Add Pillow-fixtests.patch
- update to version 2.7.0:
- Look for OSX and Linux fonts in common places. #1054
- Fix potential PNG decompression DOS #1060
- Use underscores, not spaces, in TIFF tag kwargs. #1044, #1058
- Update PSDraw for Python3, add tests. #1055
- Use Bicubic filtering by default for thumbnails. Don't use Jpeg Draft mode
for thumbnails. #1029
- Fix MSVC compiler error: Use Py_ssize_t instead of ssize_t #1051
- Fix compiler error: MSVC needs varaibles defined at the start of the block
#1048
- The GIF Palette optimization algorithm is only applicable to mode='P' or
'L' #993
- Use PySide as an alernative to PyQt4/5.
- Replace affine-based im.resize implementation with convolution-based
im.stretch #997
- Replace Gaussian Blur implementation with iterated fast box blur. #961
Note: Radius parameter is interpreted differently than before.
- Better docs explaining import _imaging failure #1016, build #1017, mode
#1018, PyAccess, PixelAccess objects #1019 Image.quantize #1020 and Image.save
#1021
- Fix for saving TIFF image into an io.BytesIO buffer #1011
- Fix antialias compilation on debug versions of Python #1010
- Fix for Image.putdata segfault #1009
- Ico save, additional tests #1007
- Use PyQt4 if it has already been imported, otherwise prefer PyQt5. #1003
- Speedup resample implementation up to 2.5 times. #977
- Speed up rotation by using cache aware loops, added transpose to rotations.
#994
- Fix Bicubic interpolation #970
- Support for 4-bit greyscale TIFF images #980
- Updated manifest #957
- Fix PyPy 2.4 regression #952
- Webp Metadata Skip Test comments #954
- Fixes for things rpmlint complains about #942
- update to version 2.6.2:
- Fix potential PNG decompression DOS #1060
- Fix Regression in PyPy 2.4 in streamio #958
- Update to 2.6.1
- Fix SciPy regression for in Image.resize
- Fix manifest to include all test files
- Update to 2.6.0
- Relax precision of ImageDraw tests for x86, GimpGradient for PPC
- Use redistributable image for testing
- Use redistributable ICC profiles for testing, skip if not available
- Additional documentation for JPEG info and save options
- Fix JPEG Encoding memory leak when exif or qtables were specified
- Image.tobytes() and Image.tostring() documentation update
- On Windows, do not execute convert.exe without specifying path
- Fix msvc build error
- Fix for handling P + transparency -> RGBA conversions
- Retain alpha in ImageEnhance operations
- Jpeg2k Decode/encode memory leak fix
- EpsFilePlugin Speed improvements
- Don't resize if already the right size
- Fix for reading multipage TIFFs
- Correctly handle saving gray and CMYK JPEGs with quality=keep
- Correct duplicate Tiff Metadata and Exif tag values
- Windows fixes
- Fix TGA files with image ID field
- Fixed wrong P-mode of small, unoptimized L-mode GIF
- Fixed CVE-2014-3598, a DOS in the Jpeg2KImagePlugin
- Fixed CVE-2014-3589, a DOS in the IcnsImagePlugin
- setup.py: Close open file handle before deleting
- Return Profile with Transformed Images
- Changed docstring to refer to the correct function
- Adding coverage support for C code tests
- PyPy performance improvements
- Added support for reading MPO files
- Added support for encoding and decoding iTXt chunks
- HSV Support
- Removed unusable ImagePalette.new()
- Fix Scrambled XPM
- Doc cleanup
- Fix `ImageStat` docs
- Added docs for ExifTags
- More tests for CurImagePlugin, DcxImagePlugin, Effects.c, GimpGradientFile,
ImageFont, ImageMath, ImagePalette, IptcImagePlugin, SpiderImagePlugin,
SgiImagePlugin, XpmImagePlugin and _util
- Fix return value of FreeTypeFont.textsize() does not include font offsets
- Fix dispose calculations for animated GIFs
- Added class checking to Image __eq__ function
- Test PalmImagePlugin and method to skip known bad tests
- Update to 2.5.3
- Fixed CVE-2014-3598, a DOS in the Jpeg2KImagePlugin (backport)
- Update to 2.5.2
- Fixed CVE-2014-3589, a DOS in the IcnsImagePlugin (backport)
- Use versioned provides and conflicts to fix installation on SLE11
- enable build time testing, but not for i586 as it's broken there due to some
rounding error (see https://github.com/python-pillow/Pillow/issues/819)
- Update to 2.5.1:
* 2.5.1 (2014-07-10)
Fixed install issue if Multiprocessing.Pool is not available [wiredfool]
32bit mult overflow fix #782 [wiredfool]
* 2.5.0 (2014-07-01)
Imagedraw rewrite [terseus, wiredfool]
Add support for multithreaded test execution [wiredfool]
Prevent shell injection #748 [mbrown1413, wiredfool]
Support for Resolution in BMP files #734 [gcq]
Fix error in setup.py for Python 3 [matthew-brett]
Pyroma fix and add Python 3.4 to setup metadata #742 [wirefool]
Top level flake8 fixes #741 [aclark]
Remove obsolete Animated Raster Graphics (ARG) support [hugovk]
Fix test_imagedraw failures #727 [cgohlke]
Fix AttributeError: class Image has no attribute 'DEBUG' #726 [cgohlke]
Fix msvc warning: 'inline' : macro redefinition #725 [cgohlke]
Cleanup #654 [dvska, hugovk, wiredfool]
16-bit monochrome support for JPEG2000 [videan42]
Fixed ImagePalette.save [brightpisces]
Support JPEG qtables [csinchok]
Add binary morphology addon [dov, wiredfool]
Decompression bomb protection [hugovk]
Put images in a single directory [hugovk]
Support OpenJpeg 2.1 [al45tair]
Remove unistd.h #include for all platforms [wiredfool]
Use unittest for tests [hugovk]
ImageCms fixes [hugovk]
Added more ImageDraw tests [hugovk]
Added tests for Spider files [hugovk]
Use libtiff to write any compressed tiff files [wiredfool]
Support for pickling Image objects [hugovk]
Fixed resolution handling for EPS thumbnails [eliempje]
Fixed rendering of some binary EPS files (Issue #302) [eliempje]
Rename variables not to use built-in function names [hugovk]
Ignore junk JPEG markers [hugovk]
Change default interpolation for Image.thumbnail to Image.ANTIALIAS [hugovk]
Add tests and fixes for saving PDFs [hugovk]
Remove transparency resource after P->RGBA conversion [hugovk]
Clean up preprocessor cruft for Windows [CounterPillow]
Adjust Homebrew freetype detection logic [jacknagel]
Added Image.close, context manager support. [wiredfool]
Added support for 16 bit PGM files. [wiredfool]
Updated OleFileIO to version 0.30 from upstream [hugovk]
Added support for additional TIFF floating point format [Hijackal]
Have the tempfile use a suffix with a dot [wiredfool]
Fix variable name used for transparency manipulations [nijel]
- adjusted testsuite execution
- Add missing PIL.pth installation (bnc#889973)
- Fixing conflicting provides/conflicts that prevent installation
of the tk subpackage.
- Adjust openjpeg2 dependency for older distributions
- New upstream release 2.4.0. For details see
https://pypi.python.org/pypi/Pillow/2.4.0
- New dependency: openjpeg2 for JPEG 2000 support
- provide python-imaging in order to act as a drop in replacement
for it.
- Fix build for older distributions which do not include lcms2
- symlink alternatives files, as requested from Coolo, in order to
get rid of suse version conditional
- also exclude 12.2 from ghost etc/alternatives/* as this results in
failed builds with: Explicit file attributes required in spec for:
$BUILDROOT/etc/alternatives/pil*
- New upstream release 2.3.0. For details see
https://pypi.python.org/pypi/Pillow/2.3.0
- Drop use-recommended-freetype-include.patch: merged on upstream
- Build with liblcms2 instead of liblcms due to upstream switching
library.
- Added use-recommended-freetype-include.patch -- Freetype upstream
recommends using their macros together with ft2build include.
Positive sideeffect is that this patch makes it build with both
freetype2 2.5.1, and older version
- Move away from pkgconfig-style buildrequires to support SLE
- Implement update-alternatives
- License update: HPND
- Add split-provides inside tk sub-package to get rid of python-imaging-tk
- Initial version

==== python3-numpy ====
Version update (1.11.1 -> 1.11.2)

- update to version 1.11.2:
* #7736 BUG: Many functions silently drop 'keepdims' kwarg.
* #7738 ENH: Add extra kwargs and update doc of many MA methods.
* #7778 DOC: Update Numpy 1.11.1 release notes.
* #7793 BUG: MaskedArray.count treats negative axes incorrectly.
* #7816 BUG: Fix array too big error for wide dtypes.
* #7821 BUG: Make sure npy_mul_with_overflow_<type> detects
overflow.
* #7824 MAINT: Allocate fewer bytes for empty arrays.
* #7847 MAINT,DOC: Fix some imp module uses and update f2py.compile
docstring.
* #7849 MAINT: Fix remaining uses of deprecated Python imp module.
* #7851 BLD: Fix ATLAS version detection.
* #7896 BUG: Construct ma.array from np.array which contains
padding.
* #7904 BUG: Fix float16 type not being called due to wrong
ordering.
* #7917 BUG: Production install of numpy should not require nose.
* #7919 BLD: Fixed MKL detection for recent versions of this
library.
* #7920 BUG: Fix for issue #7835 (ma.median of 1d).
* #7932 BUG: Monkey-patch _msvccompile.gen_lib_option like other
compilers.
* #7939 BUG: Check for HAVE_LDOUBLE_DOUBLE_DOUBLE_LE in
npy_math_complex.
* #7953 BUG: Guard against buggy comparisons in generic quicksort.
* #7954 BUG: Use keyword arguments to initialize Extension base
class.
* #7955 BUG: Make sure numpy globals keep identity after reload.
* #7972 BUG: MSVCCompiler grows 'lib' & 'include' env strings
exponentially.
* #8005 BLD: Remove __NUMPY_SETUP__ from builtins at end of
setup.py.
* #8010 MAINT: Remove leftover imp module imports.
* #8020 BUG: Fix return of np.ma.count if keepdims is True and axis
is None.
* #8024 BUG: Fix numpy.ma.median.
* #8031 BUG: Fix np.ma.median with only one non-masked value.
* #8044 BUG: Fix bug in NpyIter buffering with discontinuous arrays.

==== python3-setuptools ====
Version update (28.0.0 -> 28.2.0)

- update to version 28.2.0:
* #805: Disable -nspkg.pth behavior on Python 3.3+ where PEP-420
functionality is adequate. Fixes pip #1924.
- changes from version 28.1.0:
* #803: Bump certifi to 2016.9.26.

==== timezone ====
Version update (2016f -> 2016g)

- timezone update 2016g:
* Turkey will remain on UTC+03 after 2016-10-30 bsc#997830
* New leap second 2016-12-31 23:59:60 UTC
Remove 0001-Positive-leap-second-on-2016-12-31.patch
* Corrections for past DST transitions
* Antarcica and nautical time zones now use numeric time zone
abbreviations instead of obsolete alphanumeric ones
* Renamed Asia/Rangoon to Asia/Yangon
* The following change was previously patched in the package
and is now upstream:
+ If the installed localtime and/or posixrules files are
symbolic links, zic now keeps them symbolic links when
updating them, for compatibility with platforms like
openSUSE where other programs configure these files as
symlinks.
+ zic now avoids hard linking to symbolic links, avoids
some unnecessary mkdir and stat system calls, and uses
shorter file names internally.
+ Drop the patches:
tzcode-link.diff
tzcode-revert-01-8c9cb9580.patch
tzcode-revert-02-301f794f3.patch
tzcode-revert-03-39fd078a6.patch
tzcode-symlink.patch
tzcode-zic.diff
tzcode-fromname.patch
+ Upstream changes did not account for TZDEFAULT being an
absolute path. Prevent broken symlinks (bsc#1003324),
add timezone-2016g-absolute-TZDEFAULT.patch
* zdump has a new -i option to generate transitions in a
more-compact but still human-readable format. (experimental)

==== timezone-java ====
Version update (2016f -> 2016g)

- timezone update 2016g:
* Turkey will remain on UTC+03 after 2016-10-30 bsc#997830
* New leap second 2016-12-31 23:59:60 UTC
Remove 0001-Positive-leap-second-on-2016-12-31.patch
* Corrections for past DST transitions
* Antarcica and nautical time zones now use numeric time zone
abbreviations instead of obsolete alphanumeric ones
* Renamed Asia/Rangoon to Asia/Yangon
* The following change was previously patched in the package
and is now upstream:
+ If the installed localtime and/or posixrules files are
symbolic links, zic now keeps them symbolic links when
updating them, for compatibility with platforms like
openSUSE where other programs configure these files as
symlinks.
+ zic now avoids hard linking to symbolic links, avoids
some unnecessary mkdir and stat system calls, and uses
shorter file names internally.
+ Drop the patches:
tzcode-link.diff
tzcode-revert-01-8c9cb9580.patch
tzcode-revert-02-301f794f3.patch
tzcode-revert-03-39fd078a6.patch
tzcode-symlink.patch
tzcode-zic.diff
tzcode-fromname.patch
+ Upstream changes did not account for TZDEFAULT being an
absolute path. Prevent broken symlinks (bsc#1003324),
add timezone-2016g-absolute-TZDEFAULT.patch
* zdump has a new -i option to generate transitions in a
more-compact but still human-readable format. (experimental)

==== tracker ====
Subpackages: libtracker-common-1_0 libtracker-control-1_0-0
libtracker-miner-1_0-0 libtracker-sparql-1_0-0 tracker-devel
tracker-miner-files typelib-1_0-Tracker-1_0 typelib-1_0-TrackerControl-1_0
typelib-1_0-TrackerMiner-1_0

- Only suggest instead of recommend tracker by the various library
packages. They work fine without tracker being present and
actually doings its work.

==== tracker-extras ====
Subpackages: nautilus-extension-tracker-tags tracker-gui

- Only suggest instead of recommend tracker by the various library
packages. They work fine without tracker being present and
actually doings its work.

==== vlc ====
Subpackages: libvlc5 libvlccore8 vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt

- Require libavcodec<ABI>(unrestricted) (<ABI> is automatically
discovered during build based on what libavcodec.so links to)
from vlc-codecs. This ensures that users installing vlc-codecs
will get a prompt to replace the distro-provided libavcodec
package - which is restricted in its formats. This requires the
user to accept a vendor change.

==== webkit2gtk3 ====
Version update (2.13.92 -> 2.14.0)
Subpackages: libjavascriptcoregtk-4_0-18 libwebkit2gtk-4_0-37
typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
webkit2gtk-4_0-injected-bundles

- Update to version 2.14.0:
+ Use gdk_cairo_draw_from_gl() when possible in Wayland to render
directly using the GPU in the UI process.
+ Ensure we don't send an empty referrer header after session
restore.
+ Fix a web process crash in pages using filter animations.
+ Fix main frame scrolling jumps when scrolling acclerated
subframes.
+ Fix the size of the cairo surface created in the UI process on
Wayland.
+ Fix memory leak in JavaScriptCore.
+ Fix the build when '.' is not in @INC by default in perl.
+ Updated translations.
- Rebase webkitgtk-disable-gcc-version-checks.patch.

==== wireshark ====
Version update (2.2.0 -> 2.2.1)
Subpackages: wireshark-ui-gtk

- Wireshark 2.2.1:
This release fixes a number of issues that made it possible to
make Wireshark crash by injecting a malformed packet onto the
wire or by convincing someone to read a malformed packet trace
file. (bsc#1002981)
* wnpa-sec-2016-56: The Bluetooth L2CAP dissector could crash
* wnpa-sec-2016-57: The NCP dissector could crash
* Further bug fixes and updated protocol support as listed in:
* Bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-2.2.1.html

==== xf86-input-libinput ====
Version update (0.19.1 -> 0.20.0)

- Update to version 0.20.0:
+ Most important fix is the use of input_lock() instead of the
old SIGIO stuff to handle the input thread in server 1.19.
+ This version now supports tablet pads and exposes properties
for changing the tap button mapping and the rotation.
- Rebase n_enable-tapping.patch.
- Pass --with-xorg-conf-dir to configure and modify spec following
upstream changes.

==== yast2 ====
Version update (3.1.207 -> 3.1.208)

- save_y2logs: use canonical path (bsc#1001454)
- 3.1.208

==== yast2-bootloader ====
Version update (3.1.203 -> 3.2.3)

- Warn user if the packages needed for booting are deselected
(bsc#885496)
- 3.2.3
- allow user to repropose configuration if unknown udev link found
(bnc#931291)
- 3.2.2
- Do not crash when the user tries to enable serial console with
blank arguments (bsc#1000629)
- 3.2.1
- show popup when unsupported bootloader used on system, allowing
user to exit yast2-bootloader or propose supported bootloader
there (bnc#923458)
- Version bumped to 3.2.X to ease coordination of Tumbleweed,
Leap 42.2 and SLE-12-SP2 development.
- 3.2.0

==== yast2-dhcp-server ====
Version update (3.1.11 -> 3.2.0)

- prevent adding "pool" to global scope as it is allowed only in
network scope (bsc#737492)
- 3.2.0

==== yast2-installation ====
Version update (3.1.217 -> 3.2.0)

- AutoYaST upgrade: Do not override the Report module settings in
the AutoYaST upgrade mode, keep the previous settings
(bnc#999895).
- 3.2.3
- Translate description of Snapper snapshots (bsc#988700)
- 3.2.2

==== yast2-packager ====
Version update (3.1.117 -> 3.2.1)

- Disable autorefresh for newly added local repositories ("cd",
"dvd", "dir", "hd" (including USB flash), "iso" and "file" URL
protocols) (bsc#948982)
- 3.2.1
- remove workaround that creates fake mtab to prevent collision
with real one (bsc#1002978)
- 3.2.0
- prevent double URL encoding for ISO (bsc#954813)
- 3.1.118

==== yast2-pkg-bindings ====
Version update (3.1.34 -> 3.2.0)

- Added Pkg.UrlSchemeIs*() methods for classifying the URL scheme
to avoid duplication of the libzypp code in YaST (bsc#948982)
- 3.2.0

==== yast2-storage ====
Version update (3.1.103 -> 3.1.104)

- removed displaying /var/log/messages (bsc#933517)
- 3.1.104

==== yast2-theme ====
Version update (3.1.40 -> 3.1.42)

- unify back -SLE subpackage to main yast2-theme. This is done by
separated build results on opensuse and SLE ( as there is
colliding files, like icewm configuration ). (bsc#996498)
- 3.1.42
- Added back the style and assets for the left pane global
progress, it is still used by the firstboot module (bsc#963034)
[by Fabian Vogt]
- 3.1.41

==== yast2-trans ====
Version update (84.87.20160929.17a3ba9 -> 84.87.20161005.d47da02)
Subpackages: yast2-trans-af yast2-trans-ar yast2-trans-bg yast2-trans-bn
yast2-trans-bs yast2-trans-ca yast2-trans-cs yast2-trans-cy yast2-trans-da
yast2-trans-de yast2-trans-el yast2-trans-en_GB yast2-trans-en_US
yast2-trans-es yast2-trans-et yast2-trans-fa yast2-trans-fi yast2-trans-fr
yast2-trans-gl yast2-trans-gu yast2-trans-hi yast2-trans-hr yast2-trans-hu
yast2-trans-id yast2-trans-it yast2-trans-ja yast2-trans-jv yast2-trans-ka
yast2-trans-km yast2-trans-ko yast2-trans-lo yast2-trans-lt yast2-trans-mk
yast2-trans-mr yast2-trans-nb yast2-trans-nl yast2-trans-pa yast2-trans-pl
yast2-trans-pt yast2-trans-pt_BR yast2-trans-ro yast2-trans-ru yast2-trans-si
yast2-trans-sk yast2-trans-sl yast2-trans-sr yast2-trans-sv yast2-trans-ta
yast2-trans-th yast2-trans-tr yast2-trans-uk yast2-trans-vi yast2-trans-wa
yast2-trans-xh yast2-trans-zh_CN yast2-trans-zh_TW yast2-trans-zu

- Fix names of installed mo files (boo#1003165).
- Update to version 84.87.20161005.d47da02:
* Translated using Weblate (Slovak)
* Translated using Weblate (Turkish)
* Add scripts for mass import of suggestions
* Translated using Weblate (German)
* journalctl: Reimport of old translations
* journalctl: Add missing community translations
* Translated using Weblate (Indonesian)
* alternatives: Add ca.po
* Translated using Weblate (Portuguese (Brazil))
* Automatic update of auth-client.
* Automatic update of bootloader.
* Automatic update of installation.
* Automatic update of kdump.
* Automatic update of packager.
* Automatic update of registration.
* Automatic update of storage.
* Automatic update of update.
* Automatic update of users.
* Automatic update of vpn.
* Translated using Weblate (French)
* Translated using Weblate (French)
* Translated using Weblate (Ukrainian)
* Translated using Weblate (Polish)
* Translated using Weblate (Dutch)
* Translated using Weblate (Chinese (China))

==== yast2-update ====
Version update (3.1.42 -> 3.1.43)

- Translate description of Snapper pre-update snapshot
(bsc#988700)
- 3.1.43

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages