Mailinglist Archive: opensuse-factory (624 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160920 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160920

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
autoyast2 (3.1.149 -> 3.1.151)
btrfsprogs (4.7.1 -> 4.7.2)
hugin (2016.0.0 -> 2016.2.0)
kernel-source (4.7.3 -> 4.7.4)
kiwi-config-openSUSE
php5 (5.6.25 -> 5.6.26)
texlive
virtualbox (5.1.4_k4.7.3_1 -> 5.1.6_k4.7.4_1)
vte2
vym (2.5.21 -> 2.6.0)
xf86-video-amdgpu (1.1.0 -> 1.1.2)
yast2-fonts (3.1.16 -> 3.1.17)
yast2-ruby-bindings (3.1.50 -> 3.1.51)

=== Details ===

==== autoyast2 ====
Version update (3.1.149 -> 3.1.151)
Subpackages: autoyast2-installation

- Adding an missing PREP partition for PPC, BUT not for
Power8 system (powerNV). PowerNV do not have PREP partitions
and do not need any because they do not call grub2-install
(bnc#989392).
- 3.1.151
- Fix IP detection in AutoYaST installation rules
in order to find the correct profile when "ip route"
mentions "metric" (bnc#997548).
- 3.1.150

==== btrfsprogs ====
Version update (4.7.1 -> 4.7.2)
Subpackages: btrfsprogs-udev-rules libbtrfs0

- removed btrfsprogs-only-install-udev-rules-for-udev-190.patch: fix build
- update to 4.7.2
* check:
* urgent fix: false report of backref mismatches; do not --repair
last unaffected version 4.6.1 (code reverted to that state)
* fuzzing and fixes
* added more sanity checks for various structures
* testing images added
* build: udev compatibility: do not install .rules on version < 190
* other:
* dump-super: do not crash on garbage value in csum_type
* minor improvements in messages and help strings
* documentation:
* filesystem features

==== hugin ====
Version update (2016.0.0 -> 2016.2.0)

- Updated to version 2016.2.0
* Allow reading of image positions from Papywizard XML files: First add the
image to a new project and then select File, Import settings from Papywizard
XML file... This will read the lens settings, the image positions and also, if
applicable, the bracket settings. After this, the usual workflow is to run
cpfind with --prealigned switch and then geocpset to connect orphanded images.
* The internal blender and verdandi got the possibility to blend seams as
alternative to current hard seam: For each seam the color of second image is
adapted to the match the color of the first seam. For this blender, the blender
order changes according to the overlap. The blending starts with the exposure
anchor and blends then all overlapping images. This blending mode is not suited
if there are bigger misalignments or bigger parallax errors.
* The display of the control point error (after optimizing and in fast
preview window) and the control point list window can now limited to take only
control points in active images into account (menu Edit, Optimize only active
images, connected with the setting on the optimizer tab).
* Improvements to mask tab in Hugin (edit crop of all images of the same lens
at once) and find panorama dialog in PTBatcherGUI (remove images from found
panoramas, split found panorama into two).
* Fixes several issues with fast preview window which could result in random
crashes (uninitialized variables, memory leaks).

==== kernel-source ====
Version update (4.7.3 -> 4.7.4)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.7.4.
- commit b93c795
- drm/i915: Ignore OpRegion panel type except on select machines (bsc#993996).
- commit 6a5bbb1
- mm, oom: prevent premature OOM killer invocation for high
order request (bnc#994066).
- commit d2c8eb9

==== kiwi-config-openSUSE ====

- start-install.sh: disable the YaST self-update feature
(FATE#319716) in the Live installer, it works only in
the installation inst-sys (bsc#997829)

==== php5 ====
Version update (5.6.25 -> 5.6.26)
Subpackages: apache2-mod_php5 php5-bcmath php5-bz2 php5-calendar php5-ctype
php5-curl php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear
php5-pear-Archive_Tar php5-pgsql php5-shmop php5-snmp php5-sockets php5-sqlite
php5-suhosin php5-sysvsem php5-sysvshm php5-tidy php5-tokenizer php5-wddx
php5-xmlreader php5-xmlwriter php5-xsl php5-zip php5-zlib

- updated to 5.6.26: Several security bugs were fixed in this
release.

==== texlive ====

- perl-biber requires perl(Class::Accessor) and perl(Data::Uniqid)
at runtime (boo#995076)

==== virtualbox ====
Version update (5.1.4_k4.7.3_1 -> 5.1.6_k4.7.4_1)
Subpackages: virtualbox-guest-kmp-default virtualbox-guest-tools
virtualbox-guest-x11

- Remove file "fix_removal_of_DEFINE_PCI_DEVICE_TABLE" - fixed upstream.
- Version bump to 5.1.6 (released 2016-09-12 by Oracle)
This is a maintenance release. The following items were fixed and/or added:
GUI: fixed issue with opening '.vbox' files and it's aliases
GUI: keyboard grabbing fixes (bugs #15771 and #15745)
GUI: fix for passing through Ctrl + mouse-click (Mac OS X hosts only; bug
#15714)
GUI: fixed automatic deletion of extension pack files (bugs #11352 and
#14742)
USB: fixed showing unknown device instead of the manufacturer or product
description under certain circumstances (5.1.0 regression; bug #15764)
XHCI: another fix for a hanging guest under certain conditions as result of
the fix for bug #15747, this time for Windows 7 guests
Serial: fixed high CPU usage with certain USB to serial converters on Linux
hosts (bug #7796)
Storage: fixed attaching stream optimized VMDK images (bug #14764)
Storage: reject image variants which are unsupported by the backend (bug
#7227)
Storage: fixed loading saved states created with VirtualBox 5.0.10 and
older when using a SCSI controller (bug #15865)
Storage: fixed broken NVMe emulation if the host I/O cache setting is
enabled
Storage: fixed using multiple NVMe controllers if ICH9 is used
NVMe: fixed a crash during reset which could happen under certain
circumstances
Audio: fixed microphone input (5.1.2 regression; bugs #14386 and #15802)
Audio: fixed crashes under certain conditions (5.1.0 regression; bug #15887
and others)
Audio: fixed recording with the ALSA backend (5.1 regression)
Audio: fixed stream access mode with OSS backend (5.1 regression, thanks to
Jung-uk Kim)
E1000: do also return masked bits when reading the ICR register, this fixes
booting from iPXE (5.1.2 regression; bug #15846)
BIOS: fixed 4bpp scanline calculation (bug #15787)
API: relax the check for the version attribute in OVF/OVA appliances (bug
#15856)
Windows hosts: fixed crashes when terminating the VM selector or other VBox
COM clients (bug #15726 and others)
Linux Installer: fixed path to the documentation in .rpm packages (5.1.0
regression)
Linux Installer: fixed the vboxdrv.sh script to prevent an SELinux
complaint (bug #15816)
Linux hosts: don't use 32-bit legacy capabilities
Linux Additions: Linux 4.8 fix for the kernel display driver (bugs #15890
and #15896)
Linux Additions: don't load the kernel modules provided by the Linux
distribution but load the kernel modules from the official Guest Additions
package instead (bug #15324)
Linux Additions: fix dynamic resizing problems in recent Linux guests (bug
#15875)
User Manual: fixed error in the VBoxManage chapter for the getextradata
enumerate example (bug #15862)

==== vte2 ====
Subpackages: libvte9 vte2-lang

- add vte-0.28.2-paste-fix.patch: fixes adding extra characters
when pasting to terminal (rh#1114301 bgo#729533 deb#734571).

==== vym ====
Version update (2.5.21 -> 2.6.0)

- Update to upstream 2.6.0 (bugfix and languages added)

==== xf86-video-amdgpu ====
Version update (1.1.0 -> 1.1.2)

- Update to version 1.1.2:
The only change in this release is a fix for issues with the configure option
- -with-xorg-conf-dir which slipped into the 1.1.1 release.
- Packaging changes:
+ Check the signature for the driver release, as other drivers already do.
- Update to version 1.1.1:
+ Use --with-xorg-conf-dir=$prefix/share/X11/xorg.conf.d by
default.
+ Fix cursor size for SI.
+ Add SI PCI IDs.
+ Add missing Kaveri PCI ID (1318).
+ Add Mullins PCI IDs (fdo#97472).
+ DRI2: Fix amdgpu_dri2_exchange_buffers width/height
copy'n'paste error.
+ DRI2: Add interpolated_vblanks in amdgpu_dri2_get_crtc_msc.
+ Only use RandR APIs if RandR is enabled (deb#827984).
+ Destroy all dedicated scanout buffers during CloseScreen.
+ glamor: Reallocate linear pixmap BO if necessary for DRI2
PRIME.
+ Move DRI2's local fixup_glamor helper to
amdgpu_glamor_set_pixmap_bo v2 so it can be used outside of the
DRI2 code.
+ Consolidate get_drawable_pixmap helper.
+ Add amdgpu_pixmap_get_tiling_info.
+ Remove amdgpu_share_pixmap_backing.
+ glamor: Fix amdgpu_glamor_share_pixmap_backing for priv->bo ==
NULL.
+ Add missing Bonaire PCI ID.
+ Add more Polaris 10 and 11 PCI IDs.
+ Fix amdgpu_mode_hotplug crash on multi GPU platform.
+ Handle Zaphod mode correctly in amdgpu_mode_hotplug
(fdo#93415).
+ Add Strato PCI ID.
+ Remove RR_Capability_SinkOutput for GPU without CRTC.
- Set amdgpu.ids as a config file to fix rpmlint warning.

==== yast2-fonts ====
Version update (3.1.16 -> 3.1.17)

- comma and the rest of family string is ignored [bsc#998300]
- 3.1.17

==== yast2-ruby-bindings ====
Version update (3.1.50 -> 3.1.51)

- Rescue "invalid byte sequence in UTF-8", with a custom message
(bsc#992821).
- 3.1.51

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages