Mailinglist Archive: opensuse-factory (586 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160825 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160825

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ModemManager (1.4.14 -> 1.6.0)
MozillaFirefox (48.0 -> 48.0.1)
bash
boost
build (20160629 -> 20160809)
dbus-1 (1.10.8 -> 1.10.10)
dbus-1-x11 (1.10.8 -> 1.10.10)
dconf
efibootmgr
eog (3.20.3 -> 3.20.4)
gdm
glib2 (2.48.1 -> 2.48.2)
gnome-calculator
gnome-documents
gnome-keyring
gnome-shell (3.20.3 -> 3.20.4)
gnome-sudoku (3.20.4 -> 3.20.5)
goffice (0.10.31 -> 0.10.32)
kernel-source (4.7.1 -> 4.7.2)
kiwi-config-openSUSE
libbs2b
libgexiv2 (0.10.3 -> 0.10.4)
libgtop (2.34.0 -> 2.34.1)
libksba (1.3.4 -> 1.3.5)
libtasn1 (4.8 -> 4.9)
linux-glibc-devel (4.6 -> 4.7)
ncurses
nfs-utils
parted
php5 (5.6.24 -> 5.6.25)
polari (3.20.2 -> 3.20.3)
pragha
python3-requests (2.10.0 -> 2.11.1)
rsibreak (0.12 -> 0.12.3)
screen (4.3.1 -> 4.4.0)
thin-provisioning-tools (0.6.2 -> 0.6.3)
timezone
timezone-java
util-linux (2.28 -> 2.28.1)
util-linux-systemd (2.28 -> 2.28.1)
virt-manager
virt-viewer
vm-install (0.8.55 -> 0.8.56)
yast2-country (3.1.29 -> 3.1.30)
yast2-firstboot (3.1.16 -> 3.1.17)
yast2-network (3.1.166 -> 3.1.167)
yast2-storage (3.1.100 -> 3.1.101)
yp-tools

=== Details ===

==== ModemManager ====
Version update (1.4.14 -> 1.6.0)
Subpackages: ModemManager-devel libmm-glib0 typelib-1_0-ModemManager-1_0

- Add ModemManager-core-use-MM-specific-logging-methods.patch:core:
use MM-specific logging methods always instead of the generic
GLib ones. Patch from upstream stable git.
- Update to version 1.6.0 (boo#975211):
+ New features:
- Core:
. Implemented support for suspend/resume detection, currently
working when systemd is in use. Whenever the system is
suspended, we'll flag the modems as invalid so that they
are re-probed from scratch when the system is resumed.
. Added cancellation support for the probing operations.
. Reworked and simplified the serial port response
processing.
- Location interface:
. Added A-GPS support, currently available only for QMI based
modems with PDS service.
. Added support for updating the default GPS refresh time.
- Time interface: New default implementation for all AT-based
modems.
- Voice interface: New DBus interface to allow the management
of voice calls, which currently assumes that the audio
channel is setup out of ModemManager.
- Bearer: New support for reporting statistics of the ongoing
connection with a new 'Stats' property, currently available
for QMI and MBIM based modems.
- QMI:
. Implemented support for devices which only work in "raw IP"
mode, like the Sierra MC7455.
. Implemented support for SIM related operations using the
UIM service, as newer modems with multi-SIM capabilities
don't support the legacy DMS UIM operations.
. Implemented support for detecting network-initiated
disconnections.
- MBIM: If online mode fails, try to use the 'DMS Set FCC
Authentication' QMI
- udev: Added new supported 'ID_MM_PORT_IGNORE' tag to allow
fully ignoring ports specified by the user.
- mmcli:
. Added command completion.
. Added new operations to use the Voice interface.
- Build: Added code coverage support.
- Plugins:
. haier: new plugin to support the Haier CE81B.
. thuraya: new plugin for Thuraya satellite modems.
. sierra-legacy,sierra: the implementation for Sierra modems
is now split into two different plugins: a 'legacy' one for
the old PPP and DirectIP based modems and the standard one
for the newer QMI and MBIM based ones.
. dell: new plugin for Dell rebranded devices from Novatel,
Sierra or Ericsson.
. gobi: removed the plugin. All non-vendor specific QMI
devices should now be managed by the generic plugin.
. mbm: dynamically load the list of supported modes.
. mbm: fixed several connection/disconnection issues.
. simtech: support QMI devices.
. huawei: implemented Voice call management support.
. huawei: use static IP addressing in NDISDUP capable devices
if the AT^DHCP response provides the IP details.
+ Existing features backported to 1.4.x releases also present in
in ModemManager 1.6.0:
- MBIM:
. The mbim-proxy is used by default.
. Implemented support for disconnection status notification
while connected.
. Disabled CDMA capabilities, until properly supported.
- QMI:
. The qmi-proxy is used by default.
. If online mode fails, use 'DMS Set FCC Authentication',
required by some rebranded Sierra modems (e.g. Dell branded
ones).
. Implemented support for loading SIM operator id and name.
. Implemented power-cycle reset functionality.
- Plugins:
. telit:
. added support for new devices, like HE910, UE910 and
. implemented dynamic port identification.
. implemented unlock retries loading.
. implemented supported/current bands management.
. implemented supported/current modes management.
. implemented modem reset and power down.
. mbm: implemented GPS support for Ericsson HS2350 and
H5321gw modems.
- Drop upstream fixed patches:
+ ModemManager-cinterion_drop_unused_constants.patch.
+ ModemManager-novatel_remove_unused_custom_AT_probe_array.patch.
+ ModemManager-wmc_fix_typo.patch.
+ ModemManager-fix-whitespaces.patch.
- Added nmcli-bash-completion package.
- Need last version of polkit-default-priv (bsc#976945).
- build '--with-suspend-resume=systemd' argument.

==== MozillaFirefox ====
Version update (48.0 -> 48.0.1)
Subpackages: MozillaFirefox-translations-common

- Mozilla Firefox 48.0.1:
* Fix an audio regression impacting some major websites
(bmo#1295296)
* Fix a top crash in the JavaScript engine (bmo#1290469)
* Fix a startup crash issue caused by Websense (bmo#1291738)
* Fix a different behavior with e10s / non-e10s on <select> and
mouse events (bmo#1291078)
* Fix a top crash caused by plugin issues (bmo#1264530)
* Fix a shutdown issue (bmo#1276920)
* Fix a crash in WebRTC
- added upstream patch so system plugins/extensions are correctly
loaded again on x86-64 (bmo#1282843)
(mozilla-old_configure-bmo1282843.patch)

==== bash ====
Subpackages: bash-doc libreadline6 readline-devel readline-doc

- Make clear that the files /etc/profile as well as /etc/bash.bashrc
may source other files as well even if the bash does not.
Therefore modify patch bash-4.1-bash.bashrc.dif (bsc#959755)

==== boost ====
Subpackages: boost-license1_61_0 boost_1_61-devel libboost_atomic1_61_0
libboost_chrono1_61_0 libboost_container1_61_0 libboost_context1_61_0
libboost_coroutine1_61_0 libboost_date_time1_61_0 libboost_filesystem1_61_0
libboost_graph1_61_0 libboost_graph_parallel1_61_0 libboost_iostreams1_61_0
libboost_locale1_61_0 libboost_log1_61_0 libboost_math1_61_0 libboost_mpi1_61_0
libboost_program_options1_61_0 libboost_python1_61_0 libboost_python3-1_61_0
libboost_random1_61_0 libboost_regex1_61_0 libboost_serialization1_61_0
libboost_signals1_61_0 libboost_system1_61_0 libboost_test1_61_0
libboost_thread1_61_0 libboost_timer1_61_0 libboost_wave1_61_0

- Fix boo#994378, boo#994381, boo#994382 boo#994383:
Fix build issues when optional_fwd.hpp is used before
including boost/config.hpp
- Add boost-fix_include_config.patch from
gh#boostorg/optional#19

==== build ====
Version update (20160629 -> 20160809)
Subpackages: build-mkbaselibs build-mkdrpms

- calculate leap version for default config
- first version of Leap 42.2 configuration
- provide loop devices in docker VM
- support lxc 2.0
- Add architecture-specific sources extract for Arch Linux
- snapcraft improvements

==== dbus-1 ====
Version update (1.10.8 -> 1.10.10)
Subpackages: dbus-1-devel libdbus-1-3 libdbus-1-3-32bit

- Update to 1.10.10
* Fixes:
+ On Linux, when dbus-daemon is run with reduced susceptibility
to the OOM killer (typically via systemd), do not let child
processes inherit that setting (fdo#32851;
Kimmo Hämäläinen, WaLyong Cho)
+ Output valid shell syntax in ~/.dbus/session-bus/ if the bus
address contains a semicolon (fdo#94746, Thiago Macieira)
+ Fix memory leaks and thread safety in subprocess starting on
Windows (fdo#95191, Ralf Habacker)
+ Do not require systemd to have a service file if using it for
activation (fdo#93194; Simon McVittie; backport from 1.11.0)
+ Stop test-dbus-daemon incorrectly failing on platforms that
cannot discover the process ID of clients (fdo#96653,
?????? ?????????)
+ In tests that exercise correct handling of crashing D-Bus
services, suppress Windows crash handler (fdo#95155;
Yiyang Fei, Ralf Habacker)
+ Explicitly check for stdint.h (Ioan-Adrian Ratiu)
+ update-activation-environment: produce better diagnostics on
error (fdo#96653, Simon McVittie)
+ Don't fail the build with an unused const variable warning
under gcc 6 (fdo#97282; Thomas Zimmermann, Simon McVittie)
+ Merge dbus-1.10-ci branch, containing backports from 1.11.0
in build/test code to support continuous integration
(fdo#93194, Simon McVittie)
- Avoid -Wunused-label when compiling with libselinux but no
libaudit
- In development builds, allow OOM tests to be disabled as
documented
- Accept and ignore the --tap argument in all "embedded
tests", and run all automated tests with that argument for
better diagnostics
- Fix the systemd activation test under CMake by installing
the required files
- In Automake, fix shell syntax for installcheck-local with
no DESTDIR
- In Automake, don't try to run manual tests in installcheck
- In CMake, don't run manual-tcp test as an automated test
- Add travis-ci.org build machinery

==== dbus-1-x11 ====
Version update (1.10.8 -> 1.10.10)
Subpackages: dbus-1

- Update to 1.10.10
* Fixes:
+ On Linux, when dbus-daemon is run with reduced susceptibility
to the OOM killer (typically via systemd), do not let child
processes inherit that setting (fdo#32851;
Kimmo Hämäläinen, WaLyong Cho)
+ Output valid shell syntax in ~/.dbus/session-bus/ if the bus
address contains a semicolon (fdo#94746, Thiago Macieira)
+ Fix memory leaks and thread safety in subprocess starting on
Windows (fdo#95191, Ralf Habacker)
+ Do not require systemd to have a service file if using it for
activation (fdo#93194; Simon McVittie; backport from 1.11.0)
+ Stop test-dbus-daemon incorrectly failing on platforms that
cannot discover the process ID of clients (fdo#96653,
?????? ?????????)
+ In tests that exercise correct handling of crashing D-Bus
services, suppress Windows crash handler (fdo#95155;
Yiyang Fei, Ralf Habacker)
+ Explicitly check for stdint.h (Ioan-Adrian Ratiu)
+ update-activation-environment: produce better diagnostics on
error (fdo#96653, Simon McVittie)
+ Don't fail the build with an unused const variable warning
under gcc 6 (fdo#97282; Thomas Zimmermann, Simon McVittie)
+ Merge dbus-1.10-ci branch, containing backports from 1.11.0
in build/test code to support continuous integration
(fdo#93194, Simon McVittie)
- Avoid -Wunused-label when compiling with libselinux but no
libaudit
- In development builds, allow OOM tests to be disabled as
documented
- Accept and ignore the --tap argument in all "embedded
tests", and run all automated tests with that argument for
better diagnostics
- Fix the systemd activation test under CMake by installing
the required files
- In Automake, fix shell syntax for installcheck-local with
no DESTDIR
- In Automake, don't try to run manual tests in installcheck
- In CMake, don't run manual-tcp test as an automated test
- Add travis-ci.org build machinery

==== dconf ====
Subpackages: gsettings-backend-dconf libdconf1

- Add 0001-gvdb-Restore-permissions-on-changed-files.patch:
'dconf update' writes new contents into temporary file and
renames it to the original one, resulting permission
inconsistencies if umask has been changed before that. The patch
restores the changed permissions (bsc#971074, bgo#758066).

==== efibootmgr ====

- add efibootmgr-fix-usage-of-efi_loadopt_path-again.patch - fix
efibootmgr -v with new efivar (boo#993458)

==== eog ====
Version update (3.20.3 -> 3.20.4)

- Update to version 3.20.4 (boo#994819):
+ Out-of-bounds fix (bgo#770143, CVE-2016-6855).
+ eog leaks error message if loading an SVG fails (bgo#770197).
+ Updated translations.

==== gdm ====
Subpackages: gdmflexiserver libgdm1 typelib-1_0-Gdm-1_0

- Add gdm-fails-to-restart-gnome-shell.patch: Gdm should stop after
a few times fails (bgo#769969, bsc#981976).

==== glib2 ====
Version update (2.48.1 -> 2.48.2)
Subpackages: glib2-devel glib2-tools libgio-2_0-0 libgio-2_0-0-32bit
libglib-2_0-0 libglib-2_0-0-32bit libgmodule-2_0-0 libgmodule-2_0-0-32bit
libgobject-2_0-0 libgobject-2_0-0-32bit libgthread-2_0-0 libgthread-2_0-0-32bit

- Update to version 2.48.2:
+ Bugs fixed: bgo#547200, bgo#673101, bgo#700756, bgo#725902,
bgo#728207, bgo#730187, bgo#746685, bgo#750257, bgo#753231,
bgo#755439, bgo#760115, bgo#760423, bgo#761810, bgo#766211,
bgo#766899, bgo#766933, bgo#767172, bgo#767218, bgo#767824,
bgo#767949, bgo#768453, bgo#768504, bgo#768551, bgo#768560,
bgo#768806, bgo#769027.
+ Updated translations.

==== gnome-calculator ====
Subpackages: gnome-shell-search-provider-gnome-calculator

- Add history-entry.ui and history-view.ui as sources: they were
missing in the tarball.

==== gnome-documents ====
Subpackages: gnome-documents_books-common gnome-shell-search-provider-documents

- Drop pdf-converter-modify.patch.
Drop unoconv or libreoffice recommends:
Upstream uses LOKDocView instead of unoconv to handle ODF, OOXML,
etc now, see bgo#753686 for more details (bnc#902922).

==== gnome-keyring ====
Subpackages: gnome-keyring-32bit gnome-keyring-pam gnome-keyring-pam-32bit
libgck-modules-gnome-keyring

- Merge

bnc#903966-SEGV-in-gnome-keyring-daemon-caused-by-calling-free-on-static-string.patch
into gnome-keyring-896818-reduce-head-msg-length.patch:
bsc#903966 is just a regression caused by bsc#896818 anyway
(bsc#896818, bsc#903966, bgo#770170).
- Rebase gnome-keyring-bsc932232-use-non-fips-md5.patch for
version 3.20.0 (bsc#932232, bsc#966229, bsc#966225).
- Drop gnome-keyring-bsc961271-secmem-mismatch.patch (fixed
upstream).

==== gnome-shell ====
Version update (3.20.3 -> 3.20.4)
Subpackages: gnome-shell-browser-plugin gnome-shell-calendar

- Update to version 3.20.4:
+ Free old backgrounds immediately (bgo#766353).
+ Adjust to flatpak PermissionStore API changes (bgo#766598).
+ calendar: Only hide dismissed occurrence of recurring event
(bgo#748226).
+ Updated translations.
- Drop gnome-shell-background-free-MetaBackground.patch: Fixed
upstream.
- Add gnome-shell-fix-missing-return.patch: Fix build, add missing
return value in gnome-calendar.

==== gnome-sudoku ====
Version update (3.20.4 -> 3.20.5)

- Update to version 3.20.5:
+ Properly hide game field during pause and show after resume.

==== goffice ====
Version update (0.10.31 -> 0.10.32)
Subpackages: goffice-lang libgoffice-0_10-10

- Update to version 0.10.32:
+ Avoid gnome-common dpendency.
+ Plug leak.
- Conditionally apply translations-update-upstream BuildRequires
and macro for non-openSUSE only.

==== kernel-source ====
Version update (4.7.1 -> 4.7.2)
Subpackages: kernel-default kernel-default-devel kernel-devel kernel-docs
kernel-macros kernel-syms

- Linux 4.7.2.
- Refresh patches.fixes/block-copy-bi_vcnt-in-_bio_clone_fast.
- commit 34ba8d6

==== kiwi-config-openSUSE ====

- Improve start-install.sh:
- Prevent simultaneous calls
- Same look everywhere:
- Display accelerators on KDE
- Same accelerators and font everywhere

==== libbs2b ====

- Add baselibs.conf to build 32-bit support. Also add to sources.

==== libgexiv2 ====
Version update (0.10.3 -> 0.10.4)

- Use %_smp_mflags for parallel building; re-set RPM groups.
- Add libgexiv2-fix-typelib-vapi-install.patch: Fix install
location dir of typelib and always install vapi file. Taken from
upstream git.
- Following the the above patch, pass autoreconf as it touches the
buildsystem.
- Update Url to new home.
- Update to version 0.10.4:
+ Additions to get_comment based on MWG guidelines (bgo#746424).
+ Fix builddir != srcdir.
+ Fix leaks in GPS coordinate handling (bgo#754241).
+ Update build instructions (bgo#749800).
+ Copyright transfer to SFC.
+ Use M4 macros for GObject introspection (bgo#765827).
+ Clean-up some introspection warnings.
+ Catch exception by reference (CID:112500).
+ Generate the VAPI file from GIR.
+ Mark _free() functions as deprecated.
+ Fix several g-i-scanner warnings.
+ Fix build issue introduced by VAPI changes (bgo#768896).
+ Use AX_COMPILER_FLAGS and fix issues risen by that.
+ Remove linker flags from CXXFLAGS.
+ Enable maintainer mode and silent rules.
+ Fix lookup of XMP tags (bgo#768906).
+ Enable compiling without GObject Introspection.
+ Bugs fixed: bgo#746424, bgo#749800, bgo#754241, bgo#765827,
bgo#768896, bgo#768906.
- Add pkgconfig(vapigen) BuildRequires: New depenency.

==== libgtop ====
Version update (2.34.0 -> 2.34.1)
Subpackages: libgtop-2_0-10 libgtop-devel typelib-1_0-GTop-2_0

- Update to version 2.34.1:
+ Rename --with-libgtop-examples to --with-examples.
+ Use gettext instead of intltool/glib-gettext.
+ Added Language headers to the translations.
- Drop intltool BuildRequires following upstream changes.
- Remove obsolete clean section, and conditionals for long gone
versions of openSUSE.
- Make translation-update-upstream conditional, only apply on
non-openSUSE.
- Update to GNOME 3.20 Fate#318572
- Drop extending-max-cpu-number.patch: fixed upstream.
(bnc#885202).

==== libksba ====
Version update (1.3.4 -> 1.3.5)

- libksba 1.3.5:
* Limit the allowed size of complex ASN.1 objects (e.g.
certificates) to 16MiB.
* Avoid read access to unitialized memory.
* Improve detection of invalid RDNs.
* Encode the OCSP nonce value as an octet string as described by
RFC-6960.

==== libtasn1 ====
Version update (4.8 -> 4.9)
Subpackages: libtasn1-6 libtasn1-6-32bit libtasn1-devel

- update to 4.9:
* Fix OID encoding of OIDs which have elements which exceed 2^32
- Do not treat i586 warning as error, adding upstream
0001-configure-don-t-add-Werror-to-build-flags.patch

==== linux-glibc-devel ====
Version update (4.6 -> 4.7)

- Update to kernel headers 4.7

==== ncurses ====
Subpackages: libncurses5 libncurses6 ncurses-devel ncurses-utils tack terminfo
terminfo-base

- Add ncurses patch 20160813
+ add a dependency upon generated-sources in Ada95/src/Makefile.in to
handle a case of "configure && make install".
+ trim trailing blanks from include/Caps*, to work around a problem
in sed (Debian #818067).
- Add ncurses patch 20160806
+ improve CF_GNU_SOURCE configure macro to optionally define
_DEFAULT_SOURCE work around a nuisance in recent glibc releases.
+ move the terminfo-specific parts of tput's "reset" function into
the shared reset_cmd.c, making the two forms of reset use the same
strings.
+ split-out the terminal initialization functions from tset as
progs/reset_cmd.c, as part of changes to merge the reset-feature
with tput.
- Add ncurses patch 20160730
+ change tset's initialization to allow it to get settings from the
standard input as well as /dev/tty, to be more effective when
output or error are redirected.
+ improve discussion of history and portability for tset/reset/tput
manual pages.
- Add ncurses patch 20160723
+ improve error message from tset/reset when both stderr/stdout are
redirected to a file or pipe.
+ improve organization of curs_attr.3x, curs_color.3x
- Add ncurses patch 20160709
+ work around Debian's antique/unmaintained version of mawk when
building link_test.
+ improve test/list_keys.c, showing ncurses's convention of modifiers
for special keys, based on xterm.

==== nfs-utils ====
Subpackages: nfs-client nfs-doc nfs-kernel-server

- 0001-Make-location-of-nfs-utils_env.sh-configurable.patch
1.3.4 moved the config script location to somewhere
that doesn't exist on openSUSE. Move it somewhere
better and install it there.
(bsc#990356)

==== parted ====
Subpackages: libparted0

- Sync with SLES-12 SP2 for bsc#979275
- amend: libparted-open-the-device-RO-and-lazily-switch-to-RW.patch
- Correctly flush caches before reading from the device
(bsc#989751)
- amend: libparted-open-the-device-RO-and-lazily-switch-to-RW.patch
- refresh: libparted-Add-support-for-NVMe-devices.patch

==== php5 ====
Version update (5.6.24 -> 5.6.25)
Subpackages: apache2-mod_php5 php5-bcmath php5-bz2 php5-calendar php5-ctype
php5-curl php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear
php5-pear-Archive_Tar php5-pgsql php5-shmop php5-snmp php5-sockets php5-sqlite
php5-suhosin php5-sysvsem php5-sysvshm php5-tidy php5-tokenizer php5-wddx
php5-xmlreader php5-xmlwriter php5-xsl php5-zip php5-zlib

- updated to 5.6.25: Several security bugs were fixed in this
release.

==== polari ====
Version update (3.20.2 -> 3.20.3)
Subpackages: typelib-1_0-Polari-1_0

- Update to version 3.20.3:
+ Fix auto-scrolling to bottom (bgo#765129).
+ Fix rooms in sidebar not updating their read/unread style
(bgo#768909).
+ Fix connection issues with predefined networks (bgo#766935).
+ Updated translations.

==== pragha ====
Subpackages: pragha-lang pragha-plugins

- Do not use grilo BuildRequires for Leap 42.2, as it has grilo
v0.13.

==== python3-requests ====
Version update (2.10.0 -> 2.11.1)

- update to version 2.11.1:
* Fixed a bug when using iter_content with decode_unicode=True for
streamed bodies would raise AttributeError. This bug was
introduced in 2.11.
* Strip Content-Type and Transfer-Encoding headers from the header
block when following a redirect that transforms the verb from
POST/PUT to GET.
- update to version 2.11.0:
* Improvements
+ Added support for the ALL_PROXY environment variable.
+ Reject header values that contain leading whitespace or newline
characters to reduce risk of header smuggling.
* Bugfixes
+ Fixed occasional TypeError when attempting to decode a JSON
response that occurred in an error case. Now correctly returns a
ValueError.
+ Requests would incorrectly ignore a non-CIDR IP address in the
NO_PROXY environment variables: Requests now treats it as a
specific IP.
+ Fixed a bug when sending JSON data that could cause us to
encounter obscure OpenSSL errors in certain network conditions
(yes, really).
+ Added type checks to ensure that iter_content only accepts
integers and None for chunk sizes.
+ Fixed issue where responses whose body had not been fully
consumed would have the underlying connection closed but not
returned to the connection pool, which could cause Requests to
hang in situations where the HTTPAdapter had been configured to
use a blocking connection pool.
* Miscellaneous
+ Updated bundled urllib3 to 1.16.
+ Some previous releases accidentally accepted non-strings as
acceptable header values. This release does not.

==== rsibreak ====
Version update (0.12 -> 0.12.3)
Subpackages: rsibreak-lang

- Update to 0.12.3:
* ChangeLog not available.
- Added build requirements kcrash-devel, pkgconfig(Qt5Core),
pkgconfig(Qt5Gui) and pkgconfig(Qt5Widgets).
- Removed build requirement pkgconfig(Qt5X11Extras).
- Merged doc and lang subpackages since doc holds the translated
helpfiles. Moved english help file to main package. Obsolete the
doc subpackage.

==== screen ====
Version update (4.3.1 -> 4.4.0)

- Remove %postun - it tried to delete "screen.info.gz" file
second time.
- GNU screen 4.4.0:
* Support up to 24 function keys
* 'logfile' command, starts logging into new file upon changing
* Fix runtime issues

==== thin-provisioning-tools ====
Version update (0.6.2 -> 0.6.3)

- Update to version 0.6.3:
* Update documentation

==== timezone ====

- A positive leap second will be added at the end of 2016-12-31
(bsc#988184) 0001-Positive-leap-second-on-2016-12-31.patch
- add new signing key which is now available. Next release will
revert to previous key.

==== timezone-java ====

- A positive leap second will be added at the end of 2016-12-31
(bsc#988184) 0001-Positive-leap-second-on-2016-12-31.patch
- add new signing key which is now available. Next release will
revert to previous key.

==== util-linux ====
Version update (2.28 -> 2.28.1)
Subpackages: libblkid-devel libblkid1 libblkid1-32bit libfdisk1 libmount1
libmount1-32bit libsmartcols1 libuuid-devel libuuid1 libuuid1-32bit

- Update to version 2.28.1, bugfix release, see
ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.1-ReleaseNotes
- Remove util-linux-libblkid-wipe-offset.patch (upstream)
- use the new configure option --enable-libuuid-force-uuidd
instead of sed'ing configure.ac
- Install klogconsole with read permissions (bnc#990837)

==== util-linux-systemd ====
Version update (2.28 -> 2.28.1)

- Update to version 2.28.1, bugfix release, see
ftp://ftp.kernel.org/pub/linux/utils/util-linux/v2.28/v2.28.1-ReleaseNotes
- Remove util-linux-libblkid-wipe-offset.patch (upstream)
- use the new configure option --enable-libuuid-force-uuidd
instead of sed'ing configure.ac
- Install klogconsole with read permissions (bnc#990837)

==== virt-manager ====
Subpackages: virt-install virt-manager-common

- bsc#994394 - virt-manager does not show up in SLE Classic
"Applications" menu
virtman-desktop.patch
- bsc#989639 - xen cdrom device pass-through fails to start FV
guest
virtinst-use-qemu-for-cdrom-device.patch

==== virt-viewer ====

- bsc#983689 - virt-viewer shows Domain-0 on list of virtual
machines
virtview-dont-show-Domain-0.patch
- Upstream bug fix
813c775c-fix-filename-leak-on-transfer-dialog.patch

==== vm-install ====
Version update (0.8.55 -> 0.8.56)

- bsc#984189 - vm-install: add updated language files
- Version 0.8.56

==== yast2-country ====
Version update (3.1.29 -> 3.1.30)
Subpackages: yast2-country-data

- Fixed downloading language extensions in the installation
(bsc#994577)
- 3.1.30

==== yast2-firstboot ====
Version update (3.1.16 -> 3.1.17)

- fix not showing errors as popup in firstboot (bnc#994892)
- 3.1.17

==== yast2-network ====
Version update (3.1.166 -> 3.1.167)

- bnc#991382
- init and store IFPLUGD_PRIORITY properly
- 3.1.167

==== yast2-storage ====
Version update (3.1.100 -> 3.1.101)

- added /var/lib/machines to the list of subvolumes (bsc#992573)
- 3.1.101

==== yp-tools ====

- Re-add ypdomainname and nisdomainname for SLE12 and Leap 42.x
[bsc#994532]

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages