Mailinglist Archive: opensuse-factory (586 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160818 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160818

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
WindowMaker-applets
autoyast2 (3.1.140 -> 3.1.147)
baloo
bundle-lang-common
bundle-lang-gnome
bundle-lang-kde
cmake
colord (1.3.2 -> 1.3.3)
gnome-weather (3.20.1 -> 3.20.2)
gpsd
grub2
kernel-firmware (20160712 -> 20160804)
lftp (4.7.1 -> 4.7.3)
libreoffice
libstorage (2.26.4 -> 2.26.6)
nfs-utils (1.3.3 -> 1.3.4)
pciutils-ids (20160701 -> 20160731)
pesign
procps (3.3.11 -> 3.3.12)
skanlite (1.1git -> 2.0)
snapper
tigervnc
tnftp (20141104 -> 20151004)
vaapi-intel-driver
vm-install (0.8.54 -> 0.8.55)
wicked (0.6.36 -> 0.6.37)
yast2 (3.1.196 -> 3.1.203)
yast2-add-on (3.1.16 -> 3.1.17)
yast2-country (3.1.27 -> 3.1.29)
yast2-installation (3.1.202 -> 3.1.208)
yast2-kdump (3.1.39 -> 3.1.40)
yast2-network (3.1.163 -> 3.1.165)
yast2-ntp-client (3.1.27 -> 3.1.28)
yast2-packager (3.1.109 -> 3.1.114)
yast2-storage (3.1.96 -> 3.1.100)
yast2-update (3.1.40 -> 3.1.41)
yast2-users (3.1.53 -> 3.1.55)

=== Details ===

==== WindowMaker-applets ====

- Fix boo#707539: Adapt parameter change of ImageMagick convert
tool. And also remove not used and deprecated requre ctime.pl.
- Add wmgrabimage-0.70-boo-707539-fix-GrabImage.patch

==== autoyast2 ====
Version update (3.1.140 -> 3.1.147)
Subpackages: autoyast2-installation

- Improved logging for broken script descriptions.
Still a part of bnc#986049.
- 3.1.147
- Cloning devices: Devices which are not needed for the
installation will be ignored explicitly in the "skip_list".
(bnc#989392)
- 3.1.146
- Added "confirm_base_product_license" to rnc file.
(bnc#992535)
- 3.1.145
- Reintroduced autoyast=usb as a valid URL to AutoYaST profile
(bsc#987858)
- 3.1.144
- Added missed flag "install_recommended" in software section.
(bnc#990494)
- 3.1.143
- Added new [Stop] button for <ask> dialogs with timeout. The
button shows the current time in seconds till the automatic
timeout (bsc#990114).
- More possible user actions can now stop the execution to prevent
from timeout (bsc#990114).
- 3.1.142
- Check if AutoYaST "script" elements are hashes.
Other entries will be ignored. (bnc#986049)
- 3.1.141

==== baloo ====
Subpackages: baloo-core baloo-kioslaves libbaloofiles4 libbalooqueryparser4

- Drop the explicit require on libxapian22

==== bundle-lang-common ====
Subpackages: bundle-lang-common-cs bundle-lang-common-da bundle-lang-common-de
bundle-lang-common-el bundle-lang-common-en bundle-lang-common-es
bundle-lang-common-fr bundle-lang-common-hu bundle-lang-common-it
bundle-lang-common-ja bundle-lang-common-pl bundle-lang-common-pt
bundle-lang-common-ru bundle-lang-common-zh

- Update package list.

==== bundle-lang-gnome ====
Subpackages: bundle-lang-gnome-cs bundle-lang-gnome-da bundle-lang-gnome-de
bundle-lang-gnome-el bundle-lang-gnome-en bundle-lang-gnome-es
bundle-lang-gnome-fr bundle-lang-gnome-hu bundle-lang-gnome-it
bundle-lang-gnome-ja bundle-lang-gnome-pl bundle-lang-gnome-pt
bundle-lang-gnome-ru bundle-lang-gnome-zh

- Update package list.

==== bundle-lang-kde ====
Subpackages: bundle-lang-kde-cs bundle-lang-kde-da bundle-lang-kde-de
bundle-lang-kde-el bundle-lang-kde-en bundle-lang-kde-es bundle-lang-kde-fr
bundle-lang-kde-hu bundle-lang-kde-it bundle-lang-kde-ja bundle-lang-kde-pl
bundle-lang-kde-pt bundle-lang-kde-ru bundle-lang-kde-zh

- Update package list.

==== cmake ====

- Add cmake-hdf5-detection.patch to fix detection of hdf5 with
cmake >= 3.6
(https://gitlab.kitware.com/cmake/cmake/issues/16225).

==== colord ====
Version update (1.3.2 -> 1.3.3)
Subpackages: colord-lang libcolord2 libcolorhug2

- Update to version 1.3.3:
+ Check polkit version before defining g_autoptr macros.
+ Fix an assert failure when connecting to sensors.
+ Fix gtk-doc build when srcdir != builddir.
+ Increase timeout to 60s for argyll spotread sampling.
+ Use the USB path to match the ArgyllCMS port.
- Update to GNOME 3.20 Fate#318572

==== gnome-weather ====
Version update (3.20.1 -> 3.20.2)
Subpackages: gnome-shell-search-provider-gnome-weather

- Update to version 3.20.2:
+ Minor bug fixes.
+ Updated translations.

==== gpsd ====
Subpackages: gpsd-devel libQgpsmm22 libgps22 python-gpsd

- use pkgconfig(udev) to always allow using udev-mini
- add pps-tools-devel as BuildRequires to enable kernel PPS

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Workaround default entry in snapshot menu (bsc#956046)
* grub2-btrfs-08-workaround-snapshot-menu-default-entry.patch
- grub2.spec: Add true command to grub.efi (bsc#993274)

==== kernel-firmware ====
Version update (20160712 -> 20160804)
Subpackages: ucode-amd

- Update to version 20160804:
* usbdux: usbduxsigma: created matching binary of the firmware
* linux-firmware: rockchip: update dptx firmware to v2.6
* amdgpu: update stoney UVD firmware
* linux-firmware: intel: Update Skylake audio firmware

==== lftp ====
Version update (4.7.1 -> 4.7.3)

- lftp 4.7.3:
* mirror: don't add source directory base name to the target if
the source ends with a slash.
* mirror: fixed transfer count tracking in --scan-all-first mode.
* new setting file:use-fallocate.
* fixed "kill all" to remove queued commands.
* fixed xfer:log-file setting to a writable file in a protected
directory.
* fixed xfer:clobber to allow output to non-plain files.
* fixed mirror --Move to really keep source dir if it ends with a
slash.
From 4.7.2:
* ftp: fixed loss of 17th file from MLSD listing.
* new setting xfer:timeout.
* ssl: improved ssl performance for small read sizes.
* pget: allocate all needed disk space at once.
* http: new settings http:use-range and hftp:use-range.
* http: fixed setting http:authorization.
* http: resolve redirections when getting files information.
* http: include X-OC-MTime header in PUT requests for OwnCloud.
* mirror: changed --Move option to keep source dir if it ends
with a slash.
* mirror: fixed timestamp mirroring when the source site sends
redirections.
* mirror: don't report errors when the target does not support
chmod.
* torrent: discard cached data after validating.
* torrent: fixed a coredump on a file read error.
* torrent: fixed closing oldest cached FD.
* torrent/DHT: fixed our external IP voting.
* torrent/DHT: black-list nodes which change node_id often.
* torrent/DHT: black-list nodes which report many bad nodes.
* torrent/DHT: ignore nodes with our own ID.
* torrent/DHT: made node search more robust.
* torrent/DHT: mark new nodes as questionable.
* translations updated (zh_TW, ru).
- Added new build requirements libexpat-devel, libidn-devel and
zlib-devel.
- Fixes for update-alternatives usage.
- Rebased lftp-wrapper+edit+compat-modify.patch to apply cleanly.

==== libreoffice ====
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions
libreoffice-draw libreoffice-filters-optional libreoffice-gnome
libreoffice-gtk3 libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions libreofficekit

- Build KDE integration on openSUSE 13.2 as well
- Update _constraints file: set the 25GB HDD / 4GB RAM limit as
general requirement (global) which only aarch64 overrides at the
moment. Prior, there was no 'default' limit set and all archs
were exceptions.

==== libstorage ====
Version update (2.26.4 -> 2.26.6)
Subpackages: libstorage-ruby libstorage7

- added partition id string for GPT BIOS (bsc#991252)
- 2.26.6
- fixed removing volume groups with encrypted physical volumes
(bsc#989750)
- 2.26.5

==== nfs-utils ====
Version update (1.3.3 -> 1.3.4)
Subpackages: nfs-client nfs-doc nfs-kernel-server

- nfs-utils-1.3.4.tar.xz
New upstream release. Lots of bugfixes, no significant
functionality changes
- delete 0001-Fix-protocol-minor-version-fall-back.patch
delete 0001-close-the-syslog-fd-in-daemon_init.patch
delete 0001-mount-run-START_STATD-fully-as-root.patch
delete 0001-mount.nfs-hide-EBUSY-errors.patch
delete 0001-mount.nfs-trust-the-exit-status-of-start_statd.patch
delete 0001-systemd-Decouple-the-starting-and-stopping-of-rpcbin.patch
delete 0002-systemd-unit-files-fix-up-dependencies-on-rpcbind.patch
delete nfs-utils-no-svcgss.service
delete nfs-utils-uninit-mem.patch
All patches are included in 1.3.4
- nfs-utils_env.sh
Fix some problems with version_params.
Various misspellings and remove the possiblity
that V4 is both disabled and enabled.
(bsc#990356)
- Drop OMC svcinfo file, nowdays useless
- Sort a bit with spec-cleaner to get uptodate spec
- Convert deps from regular devels to pkgconfig style

==== pciutils-ids ====
Version update (20160701 -> 20160731)

- Update to 20160731

==== pesign ====

- Add pesign-fix-argument-list.patch to fix the argument list
parsing

==== procps ====
Version update (3.3.11 -> 3.3.12)

- Avoid fillup and insserv on modern systems (bsc#992845)
- Use test suite but avoid the w command due dummy utmp
* This requires dejagnu for the runtest command
* This requires screen to be able to provide a tty
- Add patch procps-ng-3.3.12-strtod.patch to fix missed extern
declaration of strtod_nol_or_err()
- Update to procps-ng-3.3.12
* libprocps API 6:0:0
* build: formerly optional --enable-oomem unconditional
* free: man document rewritten for shared Debian #755233
* free: interpret intervals in non-locale way Debian #692113
* kill: report error if cannot kill process Debian #733172
* library: refine calculation of 'cached' memory
* library: find tty quicker Debian #770215
* library: eliminate threads display inconsistencies Redhat #1284091
* pidof: check cmd if space found in argv0
* pmap: fixed detail parsing on long mapping lines
* pmap: fix occasional incorrect memory usage values Redhat #1262864
* ps: sort by cgroup Debian #692279
* ps: display control group name with -o cgname
* ps: fallback to attr/current for context Debian #786956
* ps: enabled broken 'thcount' option Redhat #1174313
* tests: conditionally add prctl Debian #816237
* top: displays the 3 new linux-4.5 RES memory fields
* top: man page memory fields corrected + new narrative
* top: added display of CGNAME (control group name)
* top: is now more responsive to cpus brought online
* top: namespace cols use suppressible zero
* top: zero suppress ('0') includes out-of-memory & nice
* top: better 'i' toggle management when scrolled
* top: the '=' key now includes active locate requests
* vmstat: devices exceeding 15 chars now displayed Redhat #586078
* watch: hostname added to header
* watch: better handling ANSI including esc[m Debian #830313
* watch: use locale-independent float Debian #692113

==== skanlite ====
Version update (1.1git -> 2.0)

- Update to version 2.0:
* Port to Kf5.
- Added lang subpackage.
- Merged doc subpackage with the main package in order to have the
english help files in the main package. Obsolete the doc
subpackage.
- Added build requirements pkgconfig(Qt5Gui) and
pkgconfig(Qt5Widgets).
- Added a patch "fix_translations_install.patch" to fix the
installation of translation (mo) files.

==== snapper ====
Subpackages: libsnapper3 snapper-zypp-plugin

- merged patch to fix order of object destruction on shutdown
(gh#openSUSE/snapper#258)
- better messages for some btrfs quota errors
(gh#openSUSE/snapper#257)

==== tigervnc ====

- Adding a generic 'windowmanager' requires which will be
satisfied by any package providing 'windowmanager':
Requires: windowmanager
(boo#981663).

==== tnftp ====
Version update (20141104 -> 20151004)

- Update to version 20151004:
* Implement '-x xferbufsize' to set xferbuf size.
* Add Server Name Indication (SNI) support for https.
* Increase buffer limit used for response handling.
- Removed post/pre requirement coreutils (not needed).
- Fixes for update-alternatives usage.

==== vaapi-intel-driver ====

- Remove useless --with-pic, there are no static libs being built.

==== vm-install ====
Version update (0.8.54 -> 0.8.55)

- bsc#992780 - Upgrade of SLES11SP4 PV guest => SLES12SP1 does not
work with qcow2 disk device
- Version 0.8.55

==== wicked ====
Version update (0.6.36 -> 0.6.37)
Subpackages: libwicked-0-6 wicked-service

- version 0.6.37
- auto6: do not apply rdnss/dnssl if autoconf=0 (bsc#984088)
- addrconf: utility to parse string with update flags
- leasefile: added an lease file exists utility
- ifstatus: show IPv6 privacy addresses as autoconf
- updater: adjusted system settings update debug info
- updater: no remove before install on granted lease
- updater: no backup/restore for netconfig, unused
- updater: no warning on unset optional backup/restore
- man: added DHCLIENT_REQUEST_OPTION to ifcfg-dhcp
- leaseinfo: dump other/unknown dhcp options
- dhcp4: initial support to request custom options (bsc#916948,bsc#988954)
- lease: store and load other/unknown dhcp options
- utils: fixed last byte formating in ni_format_hex
- dbus: handle unparsed dhcp options in leases
- dhcp4: store unparsed options in the lease
- addrconf: add generic dhcp options to lease
- dhcp: move specific dhcp.h to dhcp4.h and dhcp6.h
- ovs: use generic ovs type until we can query ovs (bsc#982231)
- dhcp4: send hostname in discover (bsc#985894)
- ifconfig: fixed to apply address preferred_lft 0
- address: apply suse ifcfg IP_OPTIONS (bsc#984088)
- config: add a global LINK_REQUIRED ifcfg default
- client: apply global LINK_REQUIRED setting if any

==== yast2 ====
Version update (3.1.196 -> 3.1.203)

- Popup.Error will escape the text when message is too long and
richtext is used (bsc#992506)
- 3.1.203
- Fixed handling of cd:/ and dvd:/ URLs (bsc#991935)
- 3.1.202
- Declare textdomain to fix untranslated texts (bsc#992084).
- 3.1.201
- show release notes during package installation even if slide
show is not available (bsc#978700)
- 3.1.200
- Fixed ArgumentError in Popup.AnyTimedMessage (bsc#988739).
- 3.1.199
- Fixed Yast::NetworkInterfaces.FilterNOT regexp matching
(bsc#990482) added in previous release.
- 3.1.198
- Clean up of NetworkInterfaces Read method to make it more
readable (bsc#982850)
- 3.1.197

==== yast2-add-on ====
Version update (3.1.16 -> 3.1.17)

- Added "confirm_license" to the RNC file.
(bnc#992535)
- 3.1.17

==== yast2-country ====
Version update (3.1.27 -> 3.1.29)
Subpackages: yast2-country-data

- Added check for correct <language /> coming from an AutoYast
profile. When erroneous language is detected, then it's reported
and corrected to the default 'en_US' (bnc#991001).
- 3.1.29
- Added support for Asturian variant of Spanish keyboard
(bsc#981008)
- Asturian variant is now the default layout for Asturian language
- 3.1.28
- Use the eurlatg font for all languages with latin alphabet
and simplify language<->font mapping (bsc#942899, bsc#942896).

==== yast2-installation ====
Version update (3.1.202 -> 3.1.208)

- SSH Importer: Width fix to avoid cut of CheckBoxFrame Label
(fate##319624)
- 3.1.209
- Fixed testsuite for inst_complex_welcome after implementing lazy
loading in ProductLicense in yast2-packager (bsc#993285)
- 3.1.208
- Fix the registration screen initialization when SCC server
is used during self-update (FATE#319716)
- 3.1.207
- Retrieve the self-update URL from the registration
server (SCC/SMT) (FATE#319716)
- 3.1.206
- UI, UX and internal handling for the Welcome screen optimized to
prevent from not showing that the license needs to be accepted
(bsc#980374).
- 3.1.205
- If the user has skipped multipath activation, don't ask again
after installer self-update (bsc#989770)
- 3.1.204
- Don't halt the installation if installer updates server
cannot be reached when using AutoYaST (bsc#988949)
- 3.1.203

==== yast2-kdump ====
Version update (3.1.39 -> 3.1.40)

- Reading kernel_param: Filtering out empty entries. (bnc#991140)
- 3.1.40

==== yast2-network ====
Version update (3.1.163 -> 3.1.165)

- bnc#985905
- do not limit number of bonding slaves to 10
- 3.1.165
- bnc#988786
- Create bridge when proposing configuration for VM host.
- 3.1.164

==== yast2-ntp-client ====
Version update (3.1.27 -> 3.1.28)

- Error while using <type>__clock</type> in AutoYaST.
Fixed typo.
(bnc#992854)
- 3.1.28

==== yast2-packager ====
Version update (3.1.109 -> 3.1.114)

- Remove the icon from the add-on selection popup (bsc#875201)
- 3.1.114
- Added lazy loading of licenses into AcceptanceNeeded in case of
base product in the initial installation to fix a problem when
explicit acceptance of the product license was always required
(bnc#993285)
- 3.1.113
- Fixed parameter error while logging errors. It belongs to
bnc#991935.
- 3.1.112
- Fix automatic add-on handling when using CD/DVD medias as source
(bsc#991935)
- 3.1.111
- List addons below base product in Software proposal during
installation. (bsc#992304)
- 3.1.110

==== yast2-storage ====
Version update (3.1.96 -> 3.1.100)

- Fixed message suggesting to add PReP partition (bsc#988783)
- 3.1.100
- Do not ignore suggestion made by partitioning proposal of turning
an EFI partition into bios_grub (bsc#991252)
- 3.1.99
- Fixed installer proposed size of /boot partition for aarch64
systems using UEFI (bsc#984874)
- 3.1.98
- If the user has skipped LUKS activation, don't ask again after
installer self-update (bsc#989770)
- 3.1.97

==== yast2-update ====
Version update (3.1.40 -> 3.1.41)

- Remember selected target/partitions after an installer update.
(bsc#988287)
- 3.1.41

==== yast2-users ====
Version update (3.1.53 -> 3.1.55)

- The YaST client using the user creation dialog can now know
which action was selected by the user (needed to fix bsc#992245)
- 3.1.55
- Fixed the installation dialog for user creation so it works
also in YaST Firstboot (needed to fix bsc#992245)
- 3.1.54

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups