Mailinglist Archive: opensuse-factory (586 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160805 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160805

When you reply to report some issues, make sure to change the subject.
It is not helpful to keep the release announcement subject in a thread
while discussing a specific problem.

Packages changed:
ImageMagick (6.9.4.7 -> 6.9.5.4)
NetworkManager-gnome
armagetron
bluez (5.40 -> 5.41)
clamav
coreutils
dejavu-fonts (2.35 -> 2.37)
dracut
drbd-utils
epiphany
expat
fftw3 (3.3.4 -> 3.3.5)
five-or-more (3.20.0 -> 3.20.1)
gegl-unstable (0.3.6 -> 0.3.8)
gimp (2.8.16 -> 2.8.18)
gmime
gnome-disk-utility
gnome-maps (3.20.1 -> 3.20.2)
gpsd
krb5 (1.14.2 -> 1.14.3)
libcdr
libisoburn (1.4.2 -> 1.4.4)
libpsl (0.13.0 -> 0.14.0)
libreoffice (5.2.0.3 -> 5.2.0.4)
lightdm
lxmusic (0.4.6 -> 0.4.7)
meld (3.16.1 -> 3.16.2)
mercurial (3.8.3 -> 3.9)
mozc
nano (2.6.1 -> 2.6.2)
nautilus (3.20.1 -> 3.20.2)
obs-service-tar_scm (0.6.0.1467889501.49c9462 -> 0.6.0.1469628830.67456b7)
patterns-openSUSE
perl-DBD-mysql (4.033 -> 4.035)
php5 (5.6.23 -> 5.6.24)
pidgin-openfetion
qscintilla (2.9.2 -> 2.9.3)
sqlite3
texinfo
wireshark (2.0.4 -> 2.0.5)
xine-lib
yast2-dns-server (3.1.21 -> 3.1.24)
yast2-drbd (3.1.23 -> 3.1.24)

=== Details ===

==== ImageMagick ====
Version update (6.9.4.7 -> 6.9.5.4)
Subpackages: ImageMagick-devel ImageMagick-extra libMagick++-6_Q16-6
libMagickCore-6_Q16-2 libMagickWand-6_Q16-2 perl-PerlMagick

- updated to 6.9.5-4
* Prevent buffer overflow
- updated to 6.9.5-3:
* Fix MVG stroke-opacity (reference
https://github.com/ImageMagick/ImageMagick/issues/229).
* Prevent possible buffer overflow when reading TIFF images (bug report from
Shi Pu of MS509 Team).
* To comply with the SVG standard, use stroke-opacity for transparent strokes.
* The histogram coder now returns the correct extent.
* Use CopyMagickString() rather than CopyMagickMemory() for strings.
* Correct for numerical instability (reference
https://github.com/ImageMagick/ImageMagick/issues/218).

==== NetworkManager-gnome ====
Subpackages: NetworkManager-connection-editor libnm-gtk0 typelib-1_0-NMGtk-1_0

- Add nm-applet-fix-missing-translation.patch: Fix missing
translation in ce-page-team.ui (bsc#988533).

==== armagetron ====

- bypass boo#927268 for PowerPC clang failing if fstack-protector

==== bluez ====
Version update (5.40 -> 5.41)
Subpackages: bluez-cups bluez-devel libbluetooth3

- Update descriptions a bit. Adjust RPM groups for what is used
in openSUSE normally. Drop archaic %clean section.
Drop --with-pic which is only for (unbuilt) static libs.
- update to version 5.41:
BlueZ 5.41 is purely a bug-fix release targeting areas such as
GATT, AVRCP, OBEX and device discovery filters. The GATT D-Bus
API is now starting to be stable enough that this will likely be
the last release where it is flagged as experimental.
- fix build with older distributions that don't have %_userunitdir
ins systemd-rpm-macros

==== clamav ====

- boo#991812: Remove obsolete dependency on latex2html-pngicons.
- Trim useless words from description and fix spellos.
Test for user/group existence before adding and always show
errors when they occur.

==== coreutils ====

- coreutils-maint-fix-dependency-of-man-arch.1.patch: Add Upstream
patch to fix the build dependency between src/arch -> man/arch.1
which lead to spurious build failures.
- coreutils-df-hash-in-filter.patch: Refresh with -p0.
- Add coreutils-df-hash-in-filter.patch that speeds up df.

==== dejavu-fonts ====
Version update (2.35 -> 2.37)

- Update to 2.37
* Changes from 2.36 to 2.37
* Fix issue with empty glyphs in condensed typefaces in the released source
files.
* Changes from 2.35 to 2.36
* Math: added DejaVu Math Tex Gyre by B. Jackowski, P. Strzelczyk and P.
Pianowski (on behalf of TeX users groups)
* Sans: removed dot of U+06BA in all forms
* Sans: fixed position of three dots of U+06BD in init and medi forms (by
Denis Jacquerye)
* Sans: corrected direction of contours in U+05E7 (by Lior Halphon]])
* Sans: added U+1F643 (by Olleg Samoylov)
* Serif: moved up U+0360-0361 (by Gee Fung Sit ???]])
* Serif: increased spacing of Roman numerals U+2161-2163, U+2165-2168,
U+216A-216B (by Gee Fung Sit ???)
* Serif: fixed anchor position of U+00E6 (by Gee Fung Sit ???)
* Sans: fixed vertical position of U+20BA (by Gee Fung Sit ???)
* Sans, Serif: fixed glyph height of Block Elements (by Gee Fung Sit ???)
* Sans, Serif: added U+A698-A699 (by Gee Fung Sit ???)
* Sans, Mono, Serif: added U+037F (by Gee Fung Sit ???)
* Mono: added U+0376-0377, U+037B-037D (by Gee Fung Sit ???)
* Serif: removed duplicate point from U+1D05 (by Gee Fung Sit ???)
* Mono: added U+20BA, U+20BD (by Gee Fung Sit ???)
* Sans: Added moon symbols U+1F311-1F318 (by Ben Laenen)

==== dracut ====

- Fix DASD SSID handling (bsc#989313)
* Add 0501-dasd_fix_ssid_bigger_zero.patch
- Advise user of fs recovery options when we fail to mount (fate#320443)
* Add 0404-dracut-emergency-optionally-print-fs-help.patch

==== drbd-utils ====

- bsc#990834, remove the warning with experimental.
- Add warning when using multiple nodes.

==== epiphany ====
Subpackages: epiphany-lang gnome-shell-search-provider-epiphany

- Add epiphany-embed-Check-for-NULL-SoupURI.patch: Fixes crashes
when accessing soup_uri memory (bgo#768250).

==== expat ====
Subpackages: libexpat-devel libexpat1 libexpat1-32bit

- Remove pointless --with-pic (for static only)

==== fftw3 ====
Version update (3.3.4 -> 3.3.5)
Subpackages: fftw3-devel libfftw3-3 libfftw3_threads3

- update to version 3.3.5
* New SIMD support:
- Power8 VSX instructions in single and double precision.
To use, add --enable-vsx to configure.
- Support for AVX2 (256-bit FMA instructions).
To use, add --enable-avx2 to configure.
- Experimental support for AVX512 and KCVI. (--enable-avx512, --enable-kcvi)
This code is expected to work but the FFTW maintainers do not have
hardware to test it.
- Support for AVX128/FMA (for some AMD machines) (--enable-avx128-fma)
- Double precision Neon SIMD for aarch64.
This code is expected to work but the FFTW maintainers do not have
hardware to test it.
- generic SIMD support using gcc vector intrinsics
* Add fftw_make_planner_thread_safe() API
* fix #18 (disable float128 for CUDACC)
* fix #19: missing Fortran interface for fftwq_alloc_real
* fix #21 (don't use float128 on Portland compilers, which pretend to be gcc)
* fix: Avoid segfaults due to double free in MPI transpose

==== five-or-more ====
Version update (3.20.0 -> 3.20.1)
Subpackages: five-or-more-lang

- Update to version 3.20.1:
+ Fix Quit menu item and keyboard shortcut.
+ Fix window size growing out of control with GTK+ 3.20.
+ Updated translations.

==== gegl-unstable ====
Version update (0.3.6 -> 0.3.8)
Subpackages: gegl-0_3 libgegl-0_3-0

- Update to version 0.3.8:
+ buffer:
- Add box filtering downsampling paths to linear and cubic
resamplers to improve default results.
- Clear hot tile when removing a tile from the cache.
+ operations:
- Added: vhsfix (workshop), gegl-gegl (commandline syntax).
- exr-save: port from deprecated chanting system.
- ff-save: increase max output packet size from 200kb to 1mb.
- gegl-path: add ability to compute y coordinate for a given x.
- transform: treat infinite and empty rectangles correctly.
- webp: port webp-save to GIO for URI handling.
+ ops progress:
- add gegl_operation_progress function to report processing
progress.
- use the new function in cartoon and distance-transform ops.
+ ops metadata:
- remove custom multiline paramspec.
- set multiline ui_meta on more ops.
- add reference meta and use it in various ops.
+ gegl-binary:
- add simple video filtering.
- encode audio with video.
- permit dragging and zooming in more ui states.
- deal correctly with integers in ui.
- show prop editor for operation if op chain passed at
commmandline.
+ gegl-chain:
- implement keyframing of strings.
- suggest possible ops in warninge/errors.
+ gegl-node: relay property change notifies from operation to
node.
+ gegl-serialize:
- improve error handling for parsing of properties.
- start handling relative coordinates.
- use path instead of curve.
+ json: misc improvements and fixes.
+ opencl: fix RGB luminance constants.
+ docs: fixes, update some info in directory overview.
+ handlers:
- allow registration of operations by MIME type.
- register MIME types for loaders.
- guess file types by sniffing content.
+ build: fix luajit detection.
+ Updated translations.
- No longer rm tester dirs, they are removed upstream.

==== gimp ====
Version update (2.8.16 -> 2.8.18)
Subpackages: gimp-help-browser gimp-lang gimp-plugin-aa gimp-plugins-python
libgimp-2_0-0 libgimpui-2_0-0

- update to 2.8.18
- Drop gimp-Multiple-Use-After-Free.patch - upstreamed
+Core:
- Initialize fontconfig cache in separate thread to keep GUI
responsive on first startup
- Properly recognize layer masks as deactivated, e.g. for moving layers
- Create $XDG_DATA_HOME if it doesn't exist
- (CVE-2016-4994) Multiple Use-After-Free when parsing XCF channel
and layer properties
- Fix progress access to prevent crash on rapid sequence of commands
- Fix crash in gimp-gradient-segment-range-move
+GUI:
- Disable color picker buttons on OS X to prevent a GUI lockup
- Disable "new-style" full-screen mode on OS X to prevent a crash
- Pulsing progress bar in splash screen to indicate unknown durations
- Fix gamut warning color for lcms display filter
- Fix unbolding of bold font on edit
- Prevent accidental renaming of wrong adjacent item
+Installer:
- Change compression settings to decrease size by 20%
- Add Catalan, Danish, French, Dutch
+Plug-ins:
- Fix crash on sRGB JPEG image drag & drop
- Fix ambiguous octal-escaped output of c-source
- Fix KISS CEL export
- Fix progress bar for file-compressor
- Make Script-Fu regex match return proper character indexes for
Unicode characters
- Fix Script-Fu modulo for large numbers
+General:
- Documentation updates
- Bug fixes
- Translation updates

==== gmime ====

- Update to GNOME 3.20.2 Fate#318572

==== gnome-disk-utility ====

- Update to GNOME 3.20.2 Fate#318572

==== gnome-maps ====
Version update (3.20.1 -> 3.20.2)

- Update to version 3.20.2:
+ Change tile URIs to use Mapbox, through proxy.
+ Fix escaping of tel: URIs.
+ Adapt colors of instuction when printing routes.
+ Updated translations.

==== gpsd ====
Subpackages: gpsd-devel libQgpsmm22 libgps22 python-gpsd

- use pkg-config to figure out udevdir. Fixes bootstrapping with
udev-mini

==== krb5 ====
Version update (1.14.2 -> 1.14.3)
Subpackages: krb5-32bit krb5-client krb5-devel

- Upgrade from 1.14.2 to 1.14.3:
* Improve some error messages
* Improve documentation
* Allow a principal with nonexistent policy to bypass the minimum
password lifetime check, consistent with other aspects of
nonexistent policies
* Fix a rare KDC denial of service vulnerability when anonymous client
principals are restricted to obtaining TGTs only [CVE-2016-3120]

==== libcdr ====

- Disable silent rules
- Remove sle11 support code

==== libisoburn ====
Version update (1.4.2 -> 1.4.4)
Subpackages: libisoburn1 xorriso

- Update to 1.4.4:
* Bug fix: -as mkisofs did not unescape "\=" in the source part
of pathspecs
* Bug fix: -boot_image "any" "system_area=/dev/zero" did not
zeroize loaded data
* Bug fix: -pathspecs "on" did not properly handle "\\="
* Bug fix: HFS+ production could cause MBR partition of type 0xEE
without GPT
* Bug fix: HFS+ directories could announce more children than
they actually have
* Bug fix: The HFS+ filesystem was not marked by in GPT of GRUB2
hybrid layout
* Bug fix: When reading an ISO filesystem, the presence of
- -protective-msdos-label was not recognized if a partition is
appended
* Bug fix: xorrisofs option --protective-msdos-label did not work
if no system area data were given by option -G or alike
* Bug fix: -modesty_on_drive properties timeout_sec, min_usec,
max_usec read wrong numbers from the parameter text
* Letting -as mkisofs --norock revoke the special effect of -r
* Letting -blank on overwritable media invalidate UDF extended
descriptors
* New -pathspecs mode "as_mkisofs"
* New -boot_image setting mbr_force_bootable=, -as mkisofs
- -mbr-force-bootable
* New -boot_image bootspecs appended_part_as=apm,
part_like_isohybrid=on
* New -as mkisofs options -appended_part_as_apm,
- part_like_isohybrid
* New command -scsi_dev_family, new -as cdrecord option
drive_scsi_dev_family=

==== libpsl ====
Version update (0.13.0 -> 0.14.0)

- libpsl 0.14.0:
* Remove unneeded libraries from tools/psl link step
* Use https instead of http where possible
* Add man page for tools/psl
* Add header magic to DAFSA files
* Rename make_dafsa.py to psl-make-dafsa
* Add man page for psl-make-dafsa

==== libreoffice ====
Version update (5.2.0.3 -> 5.2.0.4)
Subpackages: libreoffice-base libreoffice-base-drivers-mysql
libreoffice-branding-upstream libreoffice-calc libreoffice-calc-extensions
libreoffice-draw libreoffice-filters-optional libreoffice-gnome
libreoffice-gtk3 libreoffice-icon-theme-breeze libreoffice-icon-theme-galaxy
libreoffice-icon-theme-hicontrast libreoffice-icon-theme-oxygen
libreoffice-icon-theme-sifr libreoffice-icon-theme-tango libreoffice-impress
libreoffice-kde4 libreoffice-l10n-cs libreoffice-l10n-da libreoffice-l10n-de
libreoffice-l10n-el libreoffice-l10n-en libreoffice-l10n-es libreoffice-l10n-fr
libreoffice-l10n-hu libreoffice-l10n-it libreoffice-l10n-ja libreoffice-l10n-pl
libreoffice-l10n-ru libreoffice-mailmerge libreoffice-math libreoffice-pyuno
libreoffice-writer libreoffice-writer-extensions libreofficekit

- Version update to 5.2.0.4:
* Fixes contained in rc4 of 5.2.0 release

==== lightdm ====
Subpackages: liblightdm-gobject-1-0 lightdm-lang

- Add code to %post to migrate users of no longer maintained
'lxdm' display manager over to 'lightdm'.
- Obsolete lxdm up to version 0.5 (we never carried 0.5 in any
openSUSE product).

==== lxmusic ====
Version update (0.4.6 -> 0.4.7)
Subpackages: lxmusic-lang

- Update to 0.4.7:
* Update translations
* Add option to compile with GTK3
- Add xmms2-plugin-restricted as recommended package (boo#980920)
- Add bcond to build with or without GTK3 (not used by default)

==== meld ====
Version update (3.16.1 -> 3.16.2)
Subpackages: meld-lang

- Update to version 3.16.2:
+ Fix performance regression in text filtering.
+ Fix regression in respecting custom text encoding.
+ Updated translations.

==== mercurial ====
Version update (3.8.3 -> 3.9)
Subpackages: mercurial-lang

- Mercurial v3.9
+ Features
* ui.textwidth can now be set to define width of help text
* separate() template function added
* ui.rollback can be set to false to disable the hg rollback command
* fail-<command> hooks now run when a command fails
* experimental.graphstyle.* config options to control styling of graphs in
console
* experimental.histedit.autoverb allows histedit lines beginning with
"verb!" to be interpreted as histedit actions
* [hostsecurity] config section for defining advanced per-host security
settings
* ability to define the SHA-256 and SHA-512 hashes of pinned server
certificates
* ability to define CA certificates on a per-host basis
* ability to define the minimum TLS protocol version on a global or
per-host basis
* sort() revset can now perform topological sorts using the topo option
* hgweb can now render JSON for filelog, filerevision, summary, and search
web commands
* [paths] entries can now define a pushrev sub-option to control which
revisions to push by default
* The experimental 'journal' extension was added, allowing users to view
the previous positions of bookmarks and the working copy
+ Improvements
This release includes many improvements, including (but not limited to):
* performance of `hg diff` has been improved
* chg now detects more changes to the configuration and execution
environment
* SSL/TLS code has been significantly refactored and now is consistent
across all consumers (HTTPS, SMTPS)
* performance improvements to server communication (particularly for the
largefiles and remotefilelog extensions)
* connections to servers whose certificate authority (CA) is unknown are
now refused even if no CA certificates are available (see SecureConnections
for details)
* fingerprints of server certificates are now printed using SHA-256
instead of SHA-1
* reads and writes to certain files is now robust and avoids more race
conditions and edge cases (see ExactCacheValidationPlan)
* performance improvements to certain revsets
* cloning will no longer prompt for a password multiple times when cloning
from a server that requires a password
* annotate view in hgweb now groups lines into blocks depending on their
revision and highlights lines for the current revision
* hgweb now displays extra information and also navigation links in popups
for each line in annotate view

==== mozc ====
Subpackages: fcitx-mozc ibus-mozc ibus-mozc-candidate-window mozc-gui-tools

- fix unnecessary "BuildRequires: protobuf-devel"
- remove ExcludeArch as related failure caused by workaround
- remove workaround https://llvm.org/bugs/show_bug.cgi?id=22248
in spec as now using gcc not clang.
remove mozc-stack-protector.patch

==== nano ====
Version update (2.6.1 -> 2.6.2)
Subpackages: nano-lang

- Update to version 2.6.2:
* The keystrokes Ctrl+Up and Ctrl+Down for jumping between blocks
of text, and the option 'wordchars' for specifying which
characters (beside alphanumeric ones) should be considered
word-forming.
* Provides feedback during Unicode input (M-V followed by a
six-digit hexadecimal number which must start with 0 or 10).
* Avoids a crash when resizing the window during Verbatim input.
* Doesn't drop a keystroke after having been suspended.
* Replaces the beginning-of-line anchor (^) just once per line.
* Several tiny improvements in screen rendering and key handling.
- Removed build time references fix (not needed anymore).

==== nautilus ====
Version update (3.20.1 -> 3.20.2)
Subpackages: gnome-shell-search-provider-nautilus libnautilus-extension1

- Update to version 3.20.2:
+ Fix white desktop background after changing themes.
+ Improve double click detection.
+ Fix path bar menu on wayland appearing on random places.
+ Only save zoom level if the level has changed.
+ Fix date difference calculation for attributes like Modified
Date.
+ Hide floating bar on hover.
+ Fix detection of remote systems for not thumbnailing.
+ Fix sorting on Japanese locale.
+ Fix gnome shell search provider not being recursive.
+ Fix copy operation lags.
+ Avoid unresponsiveness when file chooser is opened.
+ Fix renaming duplicated logic on search and recent.
+ Fix trash handling to delete files if disk is full.
- Drop nautilus-adjust-style-priority.patch and
nautilus-bsc979947.patch: Fixed upstream.

==== obs-service-tar_scm ====
Version update (0.6.0.1467889501.49c9462 -> 0.6.0.1469628830.67456b7)

- fix mtime handling
- Update to version 0.6.0.1469628830.67456b7:
* pep8 fixes/workarounds
* make yaml dependency optional for travis
* Add an option 'master' to submodules to fetch the latest mater branch.
* do not set files back to 1970...
* transfer mtime via obsinfo
* create needed sub directories for cache handling

==== patterns-openSUSE ====
Subpackages: patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt
patterns-openSUSE-base patterns-openSUSE-books patterns-openSUSE-console
patterns-openSUSE-devel_C_C++ patterns-openSUSE-devel_basis
patterns-openSUSE-devel_gnome patterns-openSUSE-devel_ide
patterns-openSUSE-devel_java patterns-openSUSE-devel_kde
patterns-openSUSE-devel_kde_frameworks patterns-openSUSE-devel_kernel
patterns-openSUSE-devel_osc_build patterns-openSUSE-devel_perl
patterns-openSUSE-devel_python patterns-openSUSE-devel_qt4
patterns-openSUSE-devel_qt5 patterns-openSUSE-devel_rpm_build
patterns-openSUSE-devel_ruby patterns-openSUSE-devel_web
patterns-openSUSE-dhcp_dns_server patterns-openSUSE-directory_server
patterns-openSUSE-enhanced_base patterns-openSUSE-enhanced_base_opt
patterns-openSUSE-file_server patterns-openSUSE-fonts
patterns-openSUSE-fonts_opt patterns-openSUSE-games
patterns-openSUSE-gateway_server patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis patterns
-openSUSE-gnome_basis_opt patterns-openSUSE-gnome_games
patterns-openSUSE-gnome_ide patterns-openSUSE-gnome_imaging
patterns-openSUSE-gnome_imaging_opt patterns-openSUSE-gnome_internet
patterns-openSUSE-gnome_laptop patterns-openSUSE-gnome_multimedia
patterns-openSUSE-gnome_multimedia_opt patterns-openSUSE-gnome_office
patterns-openSUSE-gnome_office_opt patterns-openSUSE-gnome_utilities
patterns-openSUSE-gnome_yast patterns-openSUSE-imaging
patterns-openSUSE-imaging_opt patterns-openSUSE-kde
patterns-openSUSE-kde_edutainment patterns-openSUSE-kde_games
patterns-openSUSE-kde_ide patterns-openSUSE-kde_imaging
patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma
patterns-openSUSE-kde_telepathy patterns-openSUSE-kde_utilities
patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast
patterns-openSUSE-kvm_server patterns-openSUSE-lamp_server
patterns-openSUSE-laptop patterns-openSUSE-lxde patterns-openSUSE-lxde_lap
top patterns-openSUSE-lxde_office patterns-openSUSE-mail_server
patterns-openSUSE-minimal_base patterns-openSUSE-minimal_base-conflicts
patterns-openSUSE-misc_server patterns-openSUSE-multimedia
patterns-openSUSE-multimedia_opt patterns-openSUSE-network_admin
patterns-openSUSE-non_oss patterns-openSUSE-non_oss_opt
patterns-openSUSE-office patterns-openSUSE-office_opt
patterns-openSUSE-print_server patterns-openSUSE-remote_desktop
patterns-openSUSE-rest_dvd patterns-openSUSE-sw_management
patterns-openSUSE-sw_management_gnome patterns-openSUSE-sw_management_kde
patterns-openSUSE-tabletpc patterns-openSUSE-technical_writing
patterns-openSUSE-x11 patterns-openSUSE-x11_opt patterns-openSUSE-x11_yast
patterns-openSUSE-xen_server patterns-openSUSE-xfce
patterns-openSUSE-xfce_basis patterns-openSUSE-xfce_laptop
patterns-openSUSE-xfce_office patterns-openSUSE-yast2_basis
patterns-openSUSE-yast2_install_wf

- Use lightdm instead of lxdm for LXDE.

==== perl-DBD-mysql ====
Version update (4.033 -> 4.035)

- updated to 4.035
see /usr/share/doc/packages/perl-DBD-mysql/Changes
2016-07-09 Patrick Galbraith, Michiel Beijen, DBI/DBD community (4.035)
* Add DBI back to configure_requires, fix by miyagawa.
- updated to 4.034
see /usr/share/doc/packages/perl-DBD-mysql/Changes

==== php5 ====
Version update (5.6.23 -> 5.6.24)
Subpackages: apache2-mod_php5 php5-bcmath php5-bz2 php5-calendar php5-ctype
php5-curl php5-dba php5-devel php5-dom php5-exif php5-fastcgi php5-ftp php5-gd
php5-gettext php5-gmp php5-iconv php5-imap php5-json php5-ldap php5-mbstring
php5-mcrypt php5-mysql php5-odbc php5-openssl php5-pdo php5-pear
php5-pear-Archive_Tar php5-pgsql php5-shmop php5-snmp php5-sockets php5-sqlite
php5-suhosin php5-sysvsem php5-sysvshm php5-tidy php5-tokenizer php5-wddx
php5-xmlreader php5-xmlwriter php5-xsl php5-zip php5-zlib

- updated to 5.6.24: Several security bugs were fixed in this
release.

==== pidgin-openfetion ====
Subpackages: libpurple-plugin-openfetion libpurple-plugin-openfetion-lang

- Own dir due to changes in libpurple.

==== qscintilla ====
Version update (2.9.2 -> 2.9.3)
Subpackages: libqscintilla-devel libqscintilla2-12

- Update to 2.9.3
- Bug fixes

==== sqlite3 ====
Subpackages: libsqlite3-0 libsqlite3-0-32bit sqlite3-devel sqlite3-doc

- Fix SLE 11 for previous change: noarch subpackages not supported
- Reduce the conditions a bit and sort with spec-cleaner
- Remove condition for old sle10 ppc machines

==== texinfo ====
Subpackages: info makeinfo

- Remove libpth-devel; texinfo doesn't depend on it

==== wireshark ====
Version update (2.0.4 -> 2.0.5)

- Wireshark 2.0.5:
This release fixes a number issues in protocol dissectors that
could have allowed a remote attacker to crash Wireshark or cause
excessive CPU usage through specially crafted packages inserted
into the network or a capture file.
* PacketBB crash
wnpa-sec-2016-41 bsc#991013 CVE-2016-6505
* WSP infinite loop
wnpa-sec-2016-42 bsc#991015 CVE-2016-6505
* RLC long loop
wnpa-sec-2016-44 bsc#991017 CVE-2016-6508
* LDSS dissector crash
wnpa-sec-2016-45 bsc#991018 CVE-2016-6509
* RLC dissector crash
wnpa-sec-2016-46 bsc#991019 CVE-2016-6510
* OpenFlow long loop
wnpa-sec-2016-47 bsc#991020 CVE-2016-6511
* MMSE, WAP, WBXML, and WSP infinite loop
wnpa-sec-2016-48 bsc#991021 CVE-2016-6512
* WBXML crash
wnpa-sec-2016-49 bsc#991022 CVE-2016-6513
* Further bug fixes and updated protocol support as listed in:
https://www.wireshark.org/docs/relnotes/wireshark-2.0.5.html
- Drop external wireshark.appdata.xml file, use the upstream
bundled one instead.
- Use the bundled appdata file as a template to generate the
proper appdata files for both the GTK and QT GUI applications;
install separate appdata for both apps.

==== xine-lib ====
Subpackages: libxine-devel libxine2 libxine2-pulse

- Fixed build in Leap:42.2 by building with gcc5.
- Removed conditinals for old openSUSE versions from spec file.
- Modified pre checkin script to enable build with the ffmpeg libs
that are in the distribution.
- Added xine-lib-crippled-ffmpeg3.0.patch to enable leap and above
to build with ffmpeg3.
- Removed unused build flags.

==== yast2-dns-server ====
Version update (3.1.21 -> 3.1.24)

- Prevent failures with dejagnu-1.6 (bsc#992333).
- 3.1.24
- Fix an Internal Error 'undefined method DnsSequence' in case
bind.rpm is not installed (bsc#990453)
- 3.1.23
- Stop generating autodocs (fate#320356)
- 3.1.22

==== yast2-drbd ====
Version update (3.1.23 -> 3.1.24)

- Syntax change: support resync-rate in disk section, fix bsc#991253
- bsc#992066, replace panic of on-io-error handler to local-io-error
- Version 3.1.24

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages