Mailinglist Archive: opensuse-factory (491 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160715 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160715

Packages changed:
attica-qt5 (5.23.0 -> 5.24.0)
baloo5 (5.23.0 -> 5.24.0)
bluedevil5 (5.6.4 -> 5.7.0)
bluez-qt (5.23.0 -> 5.24.0)
breeze (5.6.4 -> 5.7.0)
breeze-gtk (5.6.4 -> 5.7.0)
breeze4-style (5.6.4 -> 5.7.0)
breeze5-icons (5.23.0 -> 5.24.0)
extra-cmake-modules (5.23.0 -> 5.24.0)
frameworkintegration (5.23.0 -> 5.24.0)
kaccounts-integration (16.04.2 -> 16.04.3)
kaccounts-providers (16.04.2 -> 16.04.3)
kactivities5 (5.23.0 -> 5.24.0)
kactivitymanagerd (5.6.4 -> 5.7.0)
karchive (5.23.0 -> 5.24.0)
kauth (5.23.0 -> 5.24.0)
kbookmarks (5.23.0 -> 5.24.0)
kcm_sddm (5.6.4 -> 5.7.0)
kcmutils (5.23.0 -> 5.24.0)
kcodecs (5.23.0 -> 5.24.0)
kcompletion (5.23.0 -> 5.24.0)
kconfig (5.23.0 -> 5.24.0)
kconfigwidgets (5.23.0 -> 5.24.0)
kcoreaddons (5.23.0 -> 5.24.0)
kcrash (5.23.0 -> 5.24.0)
kdbusaddons (5.23.0 -> 5.24.0)
kde-cli-tools5 (5.6.4 -> 5.7.0)
kde-gtk-config5 (5.6.4 -> 5.7.0)
kde-user-manager (5.6.4 -> 5.7.0)
kdeclarative (5.23.0 -> 5.24.0)
kded (5.23.0 -> 5.24.0)
kdelibs4support (5.23.0 -> 5.24.0)
kdesignerplugin (5.23.0 -> 5.24.0)
kdesu (5.23.0 -> 5.24.0)
kdewebkit (5.23.0 -> 5.24.0)
kdnssd-framework (5.23.0 -> 5.24.0)
kdoctools (5.23.0 -> 5.24.0)
kemoticons (5.23.0 -> 5.24.0)
kfilemetadata5 (5.23.0 -> 5.24.0)
kglobalaccel (5.23.0 -> 5.24.0)
kguiaddons (5.23.0 -> 5.24.0)
khotkeys5 (5.6.4 -> 5.7.0)
khtml (5.23.0 -> 5.24.0)
ki18n (5.23.0 -> 5.24.0)
kiconthemes (5.23.0 -> 5.24.0)
kidletime (5.23.0 -> 5.24.0)
kimageformats (5.23.0 -> 5.24.0)
kinfocenter5 (5.6.4 -> 5.7.0)
kinit (5.23.0 -> 5.24.0)
kio (5.23.0 -> 5.24.0)
kitemmodels (5.23.0 -> 5.24.0)
kitemviews (5.23.0 -> 5.24.0)
kjobwidgets (5.23.0 -> 5.24.0)
kjs (5.23.0 -> 5.24.0)
kjsembed (5.23.0 -> 5.24.0)
kmediaplayer (5.23.0 -> 5.24.0)
kmenuedit5 (5.6.4 -> 5.7.0)
knewstuff (5.23.0 -> 5.24.0)
knotifications (5.23.0 -> 5.24.0)
knotifyconfig (5.23.0 -> 5.24.0)
kpackage (5.23.0 -> 5.24.0)
kparts (5.23.0 -> 5.24.0)
kpeople5 (5.23.0 -> 5.24.0)
kplotting (5.23.0 -> 5.24.0)
kpty (5.23.0 -> 5.24.0)
kross (5.23.0 -> 5.24.0)
krunner (5.23.0 -> 5.24.0)
kscreen5 (5.6.4 -> 5.7.0)
kscreenlocker (5.6.4 -> 5.7.0)
kservice (5.23.0 -> 5.24.0)
ksshaskpass5 (5.6.4 -> 5.7.0)
ksysguard5 (5.6.4 -> 5.7.0)
ktexteditor (5.23.0 -> 5.24.0)
ktextwidgets (5.23.0 -> 5.24.0)
ktp-accounts-kcm (16.04.2 -> 16.04.3)
ktp-approver (16.04.2 -> 16.04.3)
ktp-auth-handler (16.04.2 -> 16.04.3)
ktp-common-internals (16.04.2 -> 16.04.3)
ktp-contact-list (16.04.2 -> 16.04.3)
ktp-contact-runner (16.04.2 -> 16.04.3)
ktp-desktop-applets (16.04.2 -> 16.04.3)
ktp-filetransfer-handler (16.04.2 -> 16.04.3)
ktp-kded-module (16.04.2 -> 16.04.3)
ktp-send-file (16.04.2 -> 16.04.3)
ktp-text-ui (16.04.2 -> 16.04.3)
kunitconversion (5.23.0 -> 5.24.0)
kwallet (5.23.0 -> 5.24.0)
kwayland (5.23.0 -> 5.24.0)
kwidgetsaddons (5.23.0 -> 5.24.0)
kwin5 (5.6.4 -> 5.7.0)
kwindowsystem (5.23.0 -> 5.24.0)
kxmlgui (5.23.0 -> 5.24.0)
kxmlrpcclient5 (5.23.0 -> 5.24.0)
libKF5ModemManagerQt (5.23.0 -> 5.24.0)
libKF5NetworkManagerQt (5.23.0 -> 5.24.0)
libgphoto2
libkdecoration2 (5.6.4 -> 5.7.0)
libkscreen2 (5.6.4 -> 5.7.0)
libksysguard5 (5.6.4 -> 5.7.0)
libzypp-plugin-appdata
milou5 (5.6.4 -> 5.7.0)
open-vm-tools
oxygen5 (5.6.4 -> 5.7.0)
oxygen5-icon-theme (5.18.0 -> 5.24.0)
plasma-framework (5.23.0 -> 5.24.0)
plasma-nm5 (5.6.4 -> 5.7.0)
plasma5-addons (5.6.4 -> 5.7.0)
plasma5-desktop (5.6.4 -> 5.7.0)
plasma5-integration (5.6.4 -> 5.7.0)
plasma5-openSUSE
plasma5-pa (5.6.4 -> 5.7.0)
plasma5-session (5.6.4 -> 5.7.0)
plasma5-workspace (5.6.4 -> 5.7.0)
polkit-kde-agent-5 (5.6.4 -> 5.7.0)
powerdevil5 (5.6.4 -> 5.7.0)
signon-kwallet-extension (16.04.2 -> 16.04.3)
solid (5.23.0 -> 5.24.0)
sonnet (5.23.0 -> 5.24.0)
systemsettings5 (5.6.4 -> 5.7.0)
threadweaver (5.23.0 -> 5.24.0)

=== Details ===

==== attica-qt5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: attica-qt5-devel libKF5Attica5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== baloo5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: baloo5-devel baloo5-file baloo5-imports baloo5-kioslaves
baloo5-tools libKF5Baloo5 libKF5BalooEngine5

- Update to 5.24.0
* DocumentUrlDB::del Only assert when children of dir
actually exist
* Ignore malformed Queries which have a binary operator
without first argument
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php
- Use the new %kf5_find_lang macro to create the file list for the
lang package
- Remove rpmlintrc file, it is not needed any more now

==== bluedevil5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== bluez-qt ====
Version update (5.23.0 -> 5.24.0)
Subpackages: bluez-qt-devel bluez-qt-imports bluez-qt-udev libKF5BluezQt6

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== breeze ====
Version update (5.6.4 -> 5.7.0)
Subpackages: breeze5-cursors breeze5-decoration breeze5-style breeze5-wallpapers

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== breeze-gtk ====
Version update (5.6.4 -> 5.7.0)
Subpackages: gtk2-metatheme-breeze gtk3-metatheme-breeze metatheme-breeze-common

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php
- Update to 5.6.90~g4fcde88
* Support GTK 3.20.x
- Add Install-GTK3-theme-version-depending-on-present-libg.patch
- Add gtk3-devel buildrequires, needed for above patch

==== breeze4-style ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== breeze5-icons ====
Version update (5.23.0 -> 5.24.0)

- Update to 5.24.0
* Many new or improved icons
* fix kde#364931 user-idle icon was not visible
* Add a program to convert symbolically linked files
to qrc aliases
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== extra-cmake-modules ====
Version update (5.23.0 -> 5.24.0)
Subpackages: extra-cmake-modules-doc

- Update to 5.24.0
* Integrate relative library paths to APK
* Use "/data" for DATAROOTDIR on Windows
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== frameworkintegration ====
Version update (5.23.0 -> 5.24.0)
Subpackages: frameworkintegration-devel frameworkintegration-plugin libKF5Style5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kaccounts-integration ====
Version update (16.04.2 -> 16.04.3)
Subpackages: libkaccounts1

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== kaccounts-providers ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== kactivities5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kactivities5-devel kactivities5-imports libKF5Activities5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kactivitymanagerd ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== karchive ====
Version update (5.23.0 -> 5.24.0)
Subpackages: karchive-devel libKF5Archive5

- Update to 5.24.0
* Ensure extracting an archive does not install files outside
the extraction folder, for security reasons. Instead, extract
such files to the root of the extraction folder.
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kauth ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kauth-devel libKF5Auth5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kbookmarks ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kbookmarks-devel libKF5Bookmarks5

- Update to 5.24.0
* Cleanup KBookmarkManagerList before qApp exits,
to avoid deadlocks with the DBus thread
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kcm_sddm ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kcmutils ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kcmutils-devel libKF5KCMUtils5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kcodecs ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kcodecs-devel libKF5Codecs5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kcompletion ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kcompletion-devel libKF5Completion5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kconfig ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kconf_update5 kconfig-devel libKF5ConfigCore5 libKF5ConfigGui5

- Update to 5.24.0
* Deprecate authorizeKAction() in favor of authorizeAction()
* Fix reproducibility in builds by ensuring utf-8 encoding
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kconfigwidgets ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kconfigwidgets-devel libKF5ConfigWidgets5

- Update to 5.24.0
* KStandardAction::showStatusbar: Return the intended action
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kcoreaddons ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kcoreaddons-devel libKF5CoreAddons5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kcrash ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kcrash-devel libKF5Crash5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdbusaddons ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdbusaddons-devel kdbusaddons-tools libKF5DBusAddons5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kde-cli-tools5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kde-gtk-config5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kde-user-manager ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kdeclarative ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdeclarative-components kdeclarative-devel libKF5CalendarEvents5
libKF5Declarative5 libKF5QuickAddons5

- Update to 5.24.0
* Make epoxy optional
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kded ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kded-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdelibs4support ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdelibs4support-devel libKF5KDELibs4Support5

- Update to 5.24.0
* Remove KDETranslator class, there's no kdeqt.po anymore
* Document the replacement for use12Clock()
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdesignerplugin ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdesignerplugin-devel kdesignerplugin-lang

- Update to 5.24.0
* Add support for KNewPasswordWidget
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdesu ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdesu-devel libKF5Su5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdewebkit ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdewebkit-devel libKF5WebKit5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdnssd-framework ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdnssd-framework-devel libKF5DNSSD5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kdoctools ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kdoctools-devel kdoctools-lang

- Update to 5.24.0
* Allow KDocTools to always locate at least its own installed stuff
* Use CMAKE_INSTALL_DATAROOTDIR to look for docbook instead of share
* Update qt5options manpage docbook to qt 5.4
* Update kf5options manpage docbook
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kemoticons ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kemoticons-devel libKF5Emoticons5

- Update to 5.24.0
* Move glass theme to kde-look
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kfilemetadata5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kfilemetadata5-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php
- Use the new %kf5_find_lang macro to create the file list for the
lang package
- Remove rpmlintrc file, it is not needed any more now

==== kglobalaccel ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kglobalaccel-devel kglobalaccel5 libKF5GlobalAccel5
libKF5GlobalAccelPrivate5

- Update to 5.24.0
* Use QGuiApplication instead of QApplication
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kguiaddons ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kguiaddons-devel libKF5GuiAddons5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== khotkeys5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: khotkeys5-devel

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== khtml ====
Version update (5.23.0 -> 5.24.0)
Subpackages: khtml-devel libKF5KHtml5

- Update to 5.24.0
* Fix applying inherit value for outline shorthand property
* Handle initial and inherit for border radius
* Discard property if we caught an invalid length|percent
as background-size
* cssText must output comma separated values for those properties
* Fix parsing background-clip in shorthand
* Implement background-size parsing in shorthand
* Mark properties as set when repeating patterns
* Fix background properties inheritance
* Fix applying Initial and Inherit for background-size property
* Deploy the khtml kxmlgui file in a Qt resource file
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== ki18n ====
Version update (5.23.0 -> 5.24.0)
Subpackages: ki18n-devel libKF5I18n5

- Update to 5.24.0
* Also search catalogs for stripped variants of values in
env var LANGUAGE
* Fix parsing of env var values WRT modifier and codeset,
done in wrong order
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kiconthemes ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kiconthemes-devel libKF5IconThemes5

- Update to 5.24.0
* Add support for loading and using an icontheme
in a RCC file automatically
* Document icon theme deployment on MacOS and Windows,
see https://api.kde.org/frameworks/kiconthemes/html/index.html
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kidletime ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kidletime-devel libKF5IdleTime5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kimageformats ====
Version update (5.23.0 -> 5.24.0)

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kinfocenter5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kinit ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kinit-devel

- Update to 5.24.0
* Allow timeout in reset_oom_protection while waiting for SIGUSR1
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php
- Drop more_verbose.patch

==== kio ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kio-core kio-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kitemmodels ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kitemmodels-devel libKF5ItemModels5

- Update to 5.24.0
* Add KExtraColumnsProxyModel::removeExtraColumn,
will be needed by StatisticsProxyModel
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kitemviews ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kitemviews-devel libKF5ItemViews5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kjobwidgets ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kjobwidgets-devel libKF5JobWidgets5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kjs ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kjs-devel libKF5JS5 libKF5JSApi5

- Update to 5.24.0
* kjs/ConfigureChecks.cmake - set HAVE_SYS_PARAM_H properly
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kjsembed ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kjsembed-devel libKF5JsEmbed5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kmediaplayer ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kmediaplayer-devel libKF5MediaPlayer5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kmenuedit5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== knewstuff ====
Version update (5.23.0 -> 5.24.0)
Subpackages: knewstuff-devel libKF5NewStuff5

- Update to 5.24.0
* Make sure we have a size to offer (kde#364896)
* Fix "Download dialog fails when all categories missing"
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== knotifications ====
Version update (5.23.0 -> 5.24.0)
Subpackages: knotifications-devel libKF5Notifications5

- Update to 5.24.0
* Fix notify by taskbar
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== knotifyconfig ====
Version update (5.23.0 -> 5.24.0)
Subpackages: knotifyconfig-devel libKF5NotifyConfig5

- Update to 5.24.0
* KNotifyConfigWidget: add disableAllSounds() method (kde#157272)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kpackage ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kpackage-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kparts ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kparts-devel libKF5Parts5

- Update to 5.24.0
* Add switch to disable KParts' handling of window titles
* Add donate menu item to help menu of our apps
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kpeople5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kpeople5-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kplotting ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kplotting-devel libKF5Plotting5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kpty ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kpty-devel libKF5Pty5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kross ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kross-devel

- Update to 5.24.0
* Fix name of QDialogButtonBox's enumerator "StandardButtons"
* Remove the first attempt to load library because we will
try libraryPaths anyway
* Fix crash when a method exposed to Kross returns QVariant
with non-relocatable data
* Do not use C-style casts into void* (kde#325055)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== krunner ====
Version update (5.23.0 -> 5.24.0)
Subpackages: krunner-devel libKF5Runner5

- Update to 5.24.0
* [QueryMatch] Add iconName
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kscreen5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kscreenlocker ====
Version update (5.6.4 -> 5.7.0)
Subpackages: libKScreenLocker5

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kservice ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kservice-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== ksshaskpass5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== ksysguard5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== ktexteditor ====
Version update (5.23.0 -> 5.24.0)
Subpackages: ktexteditor-devel

- Update to 5.24.0
* Show Scrollbar Text Preview after a delay of 250ms
* Hide preview and stuff on view content scrolling
* Set parent + toolview, I think this is needed to avoid task
switcher entry in Win10
* Remove "KDE-Standard" from encoding box
* Folding preview on per default
* Avoid dashed underline for preview & avoid poisoning of
line layout cache
* Always enable "Show preview of folded text" option
* TextPreview: Adjust the grooveRect-height when
scrollPastEnd is enabled
* Scrollbar preview: use groove rect if scrollbar does
not use full height
* Add KTE::MovingRange::numberOfLines() just like KTE::Range has
* Code folding preview: set popup height so that
all hidden lines fit
* Add option to disable preview of folded text
* Add modeline 'folding-preview' of type bool
* View ConfigInterface: support 'folding-preview' of type bool
* Add bool KateViewConfig::foldingPreview() and
setFoldingPreview(bool)
* Feature: Show text preview when hovering over folded code block
* KateTextPreview: add setShowFoldedLines() and showFoldedLines()
* Add modelines 'scrollbar-minimap' [bool], and
'scrollbar-preview' [bool]
* Enable mini-map scrollbar by default
* New feature: Show text preview when hovering over the scrollbar
* KateUndoGroup::editEnd(): pass KTE::Range by const ref
* Fix vim-mode shortcut handling,
after behaviour changes in Qt 5.5 (kde#353332)
* Autobrace: don't insert ' character in text
* ConfigInterface: add scrollbar-minimap config key to
enable/disable scrollbar mini map
* Fix KTE::View::cursorToCoordinate() when top message widget
is visible
* Refactoring of the Emulated Command Bar
* Fix drawing artifacts when scrolling while notifications
are visible (kde#363220)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== ktextwidgets ====
Version update (5.23.0 -> 5.24.0)
Subpackages: ktextwidgets-devel libKF5TextWidgets5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== ktp-accounts-kcm ====
Version update (16.04.2 -> 16.04.3)
Subpackages: libktpaccountskcminternal9

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-approver ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-auth-handler ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-common-internals ====
Version update (16.04.2 -> 16.04.3)
Subpackages: ktp-icons

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-contact-list ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-contact-runner ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-desktop-applets ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-filetransfer-handler ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-kded-module ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-send-file ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== ktp-text-ui ====
Version update (16.04.2 -> 16.04.3)

- Fix copying of oxygen icons
- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== kunitconversion ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kunitconversion-devel libKF5UnitConversion5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kwallet ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kwallet-devel kwallet-tools kwalletd5 libKF5Wallet5
libkwalletbackend5-5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kwayland ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kwayland-devel

- Update to 5.24.0
* Add a parent_window event to Plasma Window interface
* Properly handle destroying a Pointer/Keyboard/Touch resource
* [server] Delete dead code: KeyboardInterface::Private::sendKeymap
* [server] Add support for setting the clipboard selection
DataDeviceInterface manually
* [server] Ensure that Resource::Private::get returns nullptr
if passed a nullptr
* [server] Add resource check in QtExtendedSurfaceInterface::close
* [server] Unset SurfaceInterface pointer in referenced objects
when being destroyed
* [server] Fix error message in QtSurfaceExtension Interface
* [server] Introduce a Resource::unbound signal emitted from
unbind handler
* [server] Don't assert when destroying a still
referenced BufferInterface
* Add destructor request to org_kde_kwin_shadow and
org_kde_kwin_shadow_manager
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kwidgetsaddons ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kwidgetsaddons-devel libKF5WidgetsAddons5

- Update to 5.24.0
* Fix reading Unihan data
* Fix minimum size of KNewPasswordDialog (kde#342523)
* Fix ambiguous contructor on MSVC 2015
* Fix an alignment issue under the OS X native "macintosh" style
(kde#296810)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kwin5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: kwin5-devel

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== kwindowsystem ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kwindowsystem-devel libKF5WindowSystem5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kxmlgui ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kxmlgui-devel libKF5XmlGui5

- Update to 5.24.0
* KXMLGui: Fix merge indices when removing xmlgui clients with
actions in groups (kde#64754)
* Don't warn about "file found in compat location" if it wasn't
found at all
* Add donate menu item to help menu of our apps
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== kxmlrpcclient5 ====
Version update (5.23.0 -> 5.24.0)
Subpackages: kxmlrpcclient5-devel libKF5XmlRpcClient5

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== libKF5ModemManagerQt ====
Version update (5.23.0 -> 5.24.0)
Subpackages: libKF5ModemManagerQt-devel libKF5ModemManagerQt6

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== libKF5NetworkManagerQt ====
Version update (5.23.0 -> 5.24.0)
Subpackages: libKF5NetworkManagerQt-devel libKF5NetworkManagerQt6

- Update to 5.24.0
* Do not set peap label based on peap version
* Make network manager version checks in runtime
(to avoid compile vs. run-time (kde#362736))
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== libgphoto2 ====
Subpackages: libgphoto2-6 libgphoto2-6-32bit libgphoto2-devel

- Fix Group tag.

==== libkdecoration2 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: libkdecoration2-devel libkdecorations2-5 libkdecorations2private5

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== libkscreen2 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: libKF5Screen7 libkscreen2-devel libkscreen2-plugin

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== libksysguard5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: libksysguard5-devel libksysguard5-helper

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== libzypp-plugin-appdata ====

- InstallAppdata.sh: do not stumble over the presence of the
appdata-failed.xml.gz file: this is for debug purpose and does
not contain valid applications (boo#989031).
- Add awk Requires, as the latest modification relies on awk to
find the right filenames.

==== milou5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== open-vm-tools ====
Subpackages: libvmtools0 open-vm-tools-desktop

- Fix vmtoolsd init script to run vmtoolsd in background. (bsc#971031)
+ fix originally done in SLE-11-SP4 code base by tcech@xxxxxxx

==== oxygen5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: oxygen5-cursors oxygen5-decoration oxygen5-devel oxygen5-lang
oxygen5-sounds oxygen5-style

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== oxygen5-icon-theme ====
Version update (5.18.0 -> 5.24.0)
Subpackages: oxygen5-icon-theme-large

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php
- Update to 5.23.0
* Sync weather icons with breeze
* Add update icons
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.23.0.php
- Update to 5.22.0 (boo#980066)
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.22.0.php
- Update to 5.21.0 (boo#974793)
* Install index.theme to same directory it always was in
* Install into oxygen/base/ so icons move from apps don't clash
with version installed by those apps
* Replicate symlinks from breeze-icons
* Add new emblem-added and emblem-remove icons for sync with breeze
* Upgrade Qt version requirement to 5.4.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.21.0.php
- Update to 5.19.0 (boo#967668)
* Remove broken linked files
* Add app icons from the kde applications
* Add breeze places icons into oxygen
* Sync oxygen mimetype icons with breeze mimetype icons
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.19.0.php

==== plasma-framework ====
Version update (5.23.0 -> 5.24.0)
Subpackages: plasma-framework-components plasma-framework-devel
plasma-framework-private

- Update to 5.24.0
* [Calendar] Flip arrow buttons on right-to-left languages
* Plasma::Service::operationDescription() should return a QVariantMap
* Don't include embedded contrainers in containmentAt(pos)
(kde#361777)
* Fix the color theming for the restart system icon (login screen)
(kde#364454)
* Disable taskbar thumbnails with llvmpipe (kde#363371)
* Guard against invalid applets (kde#364281)
* PluginLoader::loadApplet: restore compatibility for
misinstalled applets
* Correct folder for PLASMA_PLASMOIDS_PLUGINDIR
* PluginLoader: improve error message about
plugin version compatibility
* Fix check to keep QMenu on screen for multiscreen layouts
* New containment type for the systray
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== plasma-nm5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: plasma-nm5-openconnect plasma-nm5-openvpn plasma-nm5-pptp
plasma-nm5-vpnc

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== plasma5-addons ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== plasma5-desktop ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php
- Drop upstreamed patches:
100-fix-compile-with-gcc6.diff, fix-opening-recent-docs.patch and
Cleanup-and-fixup-KConfig-handling-for-componentchooser.patch
- Add missing Requires: in branding subpackage (boo#968427)

==== plasma5-integration ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== plasma5-openSUSE ====
Subpackages: plasma5-desktop-branding-openSUSE
plasma5-workspace-branding-openSUSE

- Add sleep(100) in plasma-change-defaults.diff to workaround
kde#365606
- Bump Plasma (Build)Requires to 5.7.0
- Add icons/start.svgz (based on
/usr/share/icons/oxygen/scalable/places/start-here-branding.svgz)
to the openSUSE themes to have the openSUSE logo as icon for the
application menus (boo#985937)
- Various dependency fixes (boo#968427):
- Remove duplicate Requires:
- Do not obsolete itself
- Add missing Provides:

==== plasma5-pa ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== plasma5-session ====
Version update (5.6.4 -> 5.7.0)

- Bump to 5.7.0

==== plasma5-workspace ====
Version update (5.6.4 -> 5.7.0)
Subpackages: drkonqi5 plasma5-workspace-devel plasma5-workspace-libs

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php
- Drop create_kdehome.patch and fix-breeze-sddm-theme-with-many-users.patch
- Add require-qt56.diff: we know our Qt package has the right patch,
so we don't need to depend on 5.6.1

==== polkit-kde-agent-5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== powerdevil5 ====
Version update (5.6.4 -> 5.7.0)

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== signon-kwallet-extension ====
Version update (16.04.2 -> 16.04.3)

- Update to KDE Applications 16.04.3
* KDE Applications 16.04.3
* https://www.kde.org/announcements/announce-applications-16.04.3.php

==== solid ====
Version update (5.23.0 -> 5.24.0)
Subpackages: libKF5Solid5 solid-devel solid-imports solid-tools

- Update to 5.24.0
* Fix check that CPU is valid
* Handle reading /proc/cpuinfo for Arm processors
* Find CPUs by subsystem rather than driver
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== sonnet ====
Version update (5.23.0 -> 5.24.0)
Subpackages: libKF5SonnetCore5 libKF5SonnetUi5 sonnet-devel

- Update to 5.24.0
* Mark helper exe as non-gui app
* Allow nsspellcheck to be compiled on mac per default
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

==== systemsettings5 ====
Version update (5.6.4 -> 5.7.0)
Subpackages: systemsettings5-devel

- Update to 5.7.0
* New feature release
* For more details please see:
https://www.kde.org/announcements/plasma-5.7.0.php

==== threadweaver ====
Version update (5.23.0 -> 5.24.0)
Subpackages: libKF5ThreadWeaver5 threadweaver-devel

- Update to 5.24.0
* For more details please see:
https://www.kde.org/announcements/kde-frameworks-5.24.0.php

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages