Mailinglist Archive: opensuse-factory (673 mails)

< Previous Next >
Re: [opensuse-factory] New Tumbleweed snapshot 20160625 released!
  • From: Robby Engelmann <robby.engelmann@xxxxxxxxxx>
  • Date: Mon, 27 Jun 2016 13:17:03 +0200
  • Message-id: <4489415.HjVpUNtD2R@linux-8pvh>
Which packages does actually need libqt5-qtwebengine? It is not installed here
and thus it seems not to be pulled in by default. What if you try to remove
that package prior to zypper dup?

I think 5.6.1 is not installed alongside the other Qt 5.6.1 packages because
libqt5-qtwebengine is not a ring package and will go a different staging
process (adi).

Cheers.

On Montag, 27. Juni 2016 10:23:33 CEST René Krell wrote:
2016-06-27 4:43 GMT+02:00 C. Brouerius van Nidek <constant@xxxxxxxxxxx>:
...
After running zypper dup it stops with:
-------------
Computing upgrade...
4 Problems:
Problem: libqt5-qtwebengine-5.6.0-1.1.x86_64 requires libQt5Core.so.
5(Qt_5.6.0_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: libqt5-qtwebengine-5.6.0-1.1.x86_64 requires libQt5Quick.so.
5(Qt_5.6.0_PRIVATE_API)(64bit), but this requirement cannot be provided
Problem: nothing provides libQt5Core.so.5(Qt_5.6.0_PRIVATE_API) needed by
libqt5-qtwebengine-32bit-5.6.0-1.1.x86_64
Problem: nothing provides libQt5Core.so.5(Qt_5.6.0_PRIVATE_API) needed by
libqt5-qtwebengine-32bit-5.6.0-1.1.x86_64
-------------

I tried the three basic solutions

Solution 1: keep obsolete
Solution 2: deinstallation
Solution 3: break by ignoring some of its dependencies

I was overwhelmed with the resulting solutions. Deleting things which I
thought I need, installing some 30 new (versions of ?) files etc.

Think I wait my turn this update until the problem has been solved.

The same here.

PS. Used the zypper up command and had no problems with the update.

"zypper up" skips quite a big part of the packages, probably due to
the above conflicts.
---
The following 90 package updates will NOT be installed:
akonadi-server 16.04.2-1.3
bluez-qt-imports 5.22.0-1.3
cmake 3.5.2-245.3
gettext-runtime 0.19.7-3.7
gettext-tools 0.19.7-3.7
kimageformats 5.22.0-1.3
kwayland 5.22.0-1.3
kwin5 5.6.4-1.3
libKF5Archive5 5.22.0-1.3
libKF5Attica5 5.22.0-1.3
libKF5Codecs5 5.22.0-1.3
libKF5ConfigCore5 5.22.0-1.3
libKF5ConfigGui5 5.22.0-1.3
libKF5CoreAddons5 5.22.0-1.3
libKF5DBusAddons5 5.22.0-1.3
libKF5DNSSD5 5.22.0-1.3
libKF5Declarative5 5.22.0-1.3
libKF5GlobalAccel5 5.22.0-1.3
libKF5GuiAddons5 5.22.0-1.3
libKF5I18n5 5.22.0-1.3
libKF5IdleTime5 5.22.0-1.3
libKF5ItemModels5 5.22.0-1.3
libKF5ItemViews5 5.22.0-1.3
libKF5Plotting5 5.22.0-1.3
libKF5Solid5 5.22.0-2.3
libKF5SonnetCore5 5.22.0-1.3
libKF5SonnetUi5 5.22.0-1.3
libKF5ThreadWeaver5 5.22.0-1.3
libKF5WidgetsAddons5 5.22.0-1.3
libKF5WindowSystem5 5.22.0-1.3
libQt5CLucene5 5.6.1-1.1
libQt5Concurrent5 5.6.1-1.1
libQt5Core5 5.6.1-1.1
libQt5DBus5 5.6.1-1.1
libQt5Designer5 5.6.1-1.1
libQt5DesignerComponents5 5.6.1-1.1
libQt5Gui5 5.6.1-1.1
libQt5Help5 5.6.1-1.1
libQt5Multimedia5 5.6.1-1.1
libQt5Network5 5.6.1-1.1
libQt5OpenGL5 5.6.1-1.1
libQt5Positioning5 5.6.1-1.1
libQt5PrintSupport5 5.6.1-1.1
libQt5Script5 5.6.1-1.1
libQt5Sensors5 5.6.1-1.1
libQt5Sensors5-imports 5.6.1-1.1
libQt5Sql5 5.6.1-1.1
libQt5Sql5-mysql 5.6.1-1.1
libQt5Sql5-sqlite 5.6.1-1.1
libQt5Svg5 5.6.1-1.1
libQt5Test5 5.6.1-1.1
libQt5WebChannel5 5.6.1-1.1
libQt5WebChannel5-imports 5.6.1-1.1
libQt5WebKit5 5.6.1-1.1
libQt5WebKit5-imports 5.6.1-1.1
libQt5WebKitWidgets5 5.6.1-1.1
libQt5WebSockets5 5.6.1-1.1
libQt5WebSockets5-imports 5.6.1-1.1
libQt5Widgets5 5.6.1-1.1
libQt5X11Extras5 5.6.1-1.1
libQt5Xdg1 1.3.0-1.5
libQt5Xml5 5.6.1-1.1
libQt5XmlPatterns5 5.6.1-1.1
libQtQuick5 5.6.1-1.1
libdca0 0.0.5.90-6.13
libdvdread4 5.0.3-35.5
libltdl7 2.4.6-5.6
libltdl7-32bit 2.4.6-5.6
libmad0 0.15.1b-9.24
libmpeg2-0 0.5.1-8.16
libprotobuf-lite9 2.6.1-56.7
libqt5-linguist 5.6.1-1.1
libqt5-qtgraphicaleffects 5.6.1-1.1
libqt5-qtimageformats 5.6.1-1.1
libqt5-qtquickcontrols 5.6.1-1.1
libqt5-qttools 5.6.1-1.1
librtmp1 2.4+git20150115-4.4
libvlc5 3.0.0-2016053002.12
libvlccore8 3.0.0-2016053002.12
plasma5-integration-plugin 5.6.4-1.3
plasma5-workspace 5.6.4-2.3
plasma5-workspace-libs 5.6.4-2.3
qtcurve-qt5 1.8.19~git20150303-2.3
site-config 0.2-25.2
solid-imports 5.22.0-2.3
vlc 2.2.4-211.2
vlc-codecs 2.2.4-211.2
vlc-noX 2.2.4-211.2
vlc-noX-lang 2.2.4-211.2
vlc-qt 2.2.4-211.2
---

Doesn't look like a way around.

René

< Previous Next >