Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
[opensuse-factory] New Tumbleweed snapshot 20160525 released!

Please note that this mail was generated by a script.
The described changes are computed based on the x86_64 DVD.
The full online repo contains too many changes to be listed here.

Please check the known defects of this snapshot before upgrading:
https://openqa.opensuse.org/tests/overview?distri=opensuse&groupid=1&version=Tumbleweed&build=20160525

Packages changed:
apparmor
grub2
gstreamer-0_10-plugins-bad
kiwi-config-openSUSE
libndp (1.4 -> 1.6)
libxml2
libxslt
libxslt-python
luit
mdadm
ocaml-facile
perl-B-Hooks-EndOfScope (0.15 -> 0.19)
perl-Config-General (2.60 -> 2.61)
perl-DateTime (1.26 -> 1.28)
perl-DateTime-TimeZone (1.97 -> 1.98)
perl-Log-Dispatch (2.54 -> 2.56)
perl-Moose (2.1605 -> 2.1801)
perl-Params-Validate (1.23 -> 1.24)
perl-namespace-clean (0.26 -> 0.27)
poppler (0.43.0 -> 0.44.0)
poppler-qt (0.43.0 -> 0.44.0)
poppler-qt5 (0.43.0 -> 0.44.0)
python-Pillow
python3-pyxdg
star
sudo
vm-install (0.8.52 -> 0.8.53)

=== Details ===

==== apparmor ====
Subpackages: apparmor-abstractions apparmor-docs apparmor-parser
apparmor-profiles apparmor-utils libapparmor-devel libapparmor1
libapparmor1-32bit pam_apparmor pam_apparmor-32bit perl-apparmor
python3-apparmor

- add profiles-ping-inet6-r3449.diff - latest ping also does IPv6 (boo#980596)

==== grub2 ====
Subpackages: grub2-i386-pc grub2-snapper-plugin grub2-systemd-sleep-plugin
grub2-x86_64-efi grub2-x86_64-xen

- Make sure all systemd unit files are passed to %service_ macros.

==== gstreamer-0_10-plugins-bad ====
Subpackages: gstreamer-0_10-plugins-bad-lang libgstbasecamerabinsrc-0_10-23
libgstbasevideo-0_10-23 libgstcodecparsers-0_10-23 libgstphotography-0_10-23
libgstsignalprocessor-0_10-23 libgstvdp-0_10-23

- Drop libmusicbrainz-devel BuildRequires: gstreamer 0.10 only
supports libmusicbrainz2 API. The current version 5 is not
supported.

==== kiwi-config-openSUSE ====

- Do not apply the live-installer patch anymore:
yast2-live-installer has been dropped.

==== libndp ====
Version update (1.4 -> 1.6)

- Update to version 1.6:
* libndp: reject redirect and router advertisements from
non-link-local
* libndp: validate the IPv6 hop limit
- Changes for version 1.5:
* ndptool: validate the IPv6 hop limit
- Small spec file adjustement:
* Used spec-cleaner
* Make building more verbose
* Update describtion of subpackages
* Use correct cathegory for subpackage

==== libxml2 ====
Subpackages: libxml2-2 libxml2-2-32bit libxml2-devel libxml2-tools

- add libxml2-2.9.3-bogus_UTF-8_encoding_error.patch to fix XML
push parser that fails with bogus UTF-8 encoding error when
multi-byte character in large CDATA section is split across
buffer [bnc#962796]

==== libxslt ====
Subpackages: libxslt-devel libxslt-tools libxslt1 libxslt1-32bit

- add libxslt-1.1.28-type_confusion_preprocess_attr.patch to fix
type confusion in preprocessing attributes [bnc#952474],
[CVE-2015-7995]

==== libxslt-python ====

- add libxslt-1.1.28-type_confusion_preprocess_attr.patch to fix
type confusion in preprocessing attributes [bnc#952474],
[CVE-2015-7995]

==== luit ====

- removed u_luit-Set-up-terminal-before-fork.diff; upstream author
and maintainer Thomas Dickey can't reproduce the issue and
downstream, i.e. me, doesn't know how to reproduce it either ...

==== mdadm ====

- Do not list XXX@.service files for anything but service_del_preun.
They cannot be restarted by systemctl as they are
just templates. They don't need to be restarted
at reinstall anyway.
(bsc#979749)

==== ocaml-facile ====

- Apply ocaml4 patch unconditionally for d:l:o

==== perl-B-Hooks-EndOfScope ====
Version update (0.15 -> 0.19)

- updated to 0.19
see /usr/share/doc/packages/perl-B-Hooks-EndOfScope/Changes
0.19 2016-05-03 00:49:01Z
- bundled an updated ExtUtils::HasCompiler, to support building with a
noexec $TMPDIR.
0.18 2016-04-21 15:22:10Z (TRIAL RELEASE)
- fixed unnecessary inlining of ExtUtils::HasCompiler dependencies
(RT#113685)
0.17 2016-04-21 11:25:35Z (TRIAL RELEASE)
- Makefile.PL now checks for a working compiler using ExtUtils::HasCompiler
(inlined into the build) rather than ExtUtils::CBuilder (RT#113685)
0.16 2015-09-19 19:01:04Z (TRIAL RELEASE)
- more Makefile.PL updates - these contain slight functionality changes,
hence the trial release

==== perl-Config-General ====
Version update (2.60 -> 2.61)

- updated to 2.61
see /usr/share/doc/packages/perl-Config-General/Changelog
2.61 - fix rt.cpan.org#113671: ignore utf BOM, if any and turn on
UTF8 support if not yet enabled.

==== perl-DateTime ====
Version update (1.26 -> 1.28)

- updated to 1.28
see /usr/share/doc/packages/perl-DateTime/Changes
1.28 2016-05-21
- Fixed handling of some floating point epochs. Because DateTime treated the
epoch like a string instead of a number, certain epochs with a non-integer
value ended up treated like integers (Perl is weird). Patch by Christian
Hansen. GitHub #15. This also addresses the problem that GitHub #6 brought
up.
1.27 2016-05-13
- Added an environment variable PERL_DATETIME_DEFAULT_TZ to globally set the
default time zone. Using this is very dangerous! Be careful!. Patch by
Ovid. GitHub #14.

==== perl-DateTime-TimeZone ====
Version update (1.97 -> 1.98)

- updated to 1.98
see /usr/share/doc/packages/perl-DateTime-TimeZone/Changes
1.98 2016-04-18
- This release is based on version 2016d of the Olson database. This release
includes contemporary changes for Russia and Venezuela.

==== perl-Log-Dispatch ====
Version update (2.54 -> 2.56)

- updated to 2.56
see /usr/share/doc/packages/perl-Log-Dispatch/Changes
2.56 2016-05-06
- Cleaned up some cruft in Pod. Some sections ended up in there twice.
2.55 2016-05-06
- The values of $@, $!, and $? are protected in various cases where they could
end up being changed by logging code. Patch by Salvador Fandiño. GitHub #18.
- Treat MSYS2 like Cygwin in tests. Fix by Graham Ollis. GitHub #19.

==== perl-Moose ====
Version update (2.1605 -> 2.1801)

- updated to 2.1801
see /usr/share/doc/packages/perl-Moose/Changes
2.1801 2016-05-02
[OTHER]
- bundled an updated ExtUtils::HasCompiler, to support building with a
noexec $TMPDIR.
2.1800 2016-04-30
[OTHER]
- an increased Data::OptList version has been added to recommended prereqs,
for greater speed. (Olivier Mengué, PR#123)
2.1705 2016-04-21 (TRIAL RELEASE)
[OTHER]
- build-time compiler sanity checking is now done with ExtUtils::HasCompiler
instead of ExtUtils::CBuilder.
2.1704 2016-04-13 (TRIAL RELEASE)
[BUG FIXES]
- Fixed method cache regeneration when a class contains a blessed sub
(RT#113704, Graham Knop, PR#122)
[TESTS]
- restore test on perl 5.8.x when Class::C3::XS is not installed (RT#113704)
2.1703 2016-04-12 (TRIAL RELEASE)
[TESTS]
- skip dysfunctional test on perl 5.8.x when Class::C3::XS is not installed
(RT#113704)
2.1702 2016-04-08 (TRIAL RELEASE)
[DOCUMENTATION]
- Moose::Meta::Attribute::Native::Trait::Array now documents the return
value for 'first_index' when there is no match (-1).
[OTHER]
- Moose::Exception's message attribute can now be any defined value, so as
to allow for objects with a stringification overload in place of a string.
2.1701 2016-04-07 (TRIAL RELEASE)
[OTHER]
- Fixed the last remaining use of List::MoreUtils (RT#113587)
2.1700 2016-04-06 (TRIAL RELEASE)
[OTHER]
- Moose::Exception now has a boolean overload. (Graham Knop, PR#119)
- All uses of List::MoreUtils have been removed, replaced by inlined forms
or equivalents in List::Util. (Graham Knop, PR#120)

==== perl-Params-Validate ====
Version update (1.23 -> 1.24)

- updated to 1.24
see /usr/share/doc/packages/perl-Params-Validate/Changes
1.24 2016-05-08
- Author tests are no longer in t/. This makes running tests for non-authors
faster. Requested by Karen Etheridge. RT #113063.

==== perl-namespace-clean ====
Version update (0.26 -> 0.27)

- updated to 0.27
see /usr/share/doc/packages/perl-namespace-clean/Changes
0.27 2016-05-18 02:24 (UTC)
- Allow packages to be cleaned multiple times
- Ensure the debugger workarounds are applied only when
DB::sub is actively used (they are superfluous otherwise)
- Work around P5#72210, resulting in fails on 5.8.8 -Duselongdouble
- Fix incorrect name in META (RT#107813)

==== poppler ====
Version update (0.43.0 -> 0.44.0)
Subpackages: libpoppler-cpp0 libpoppler-devel libpoppler-glib8 poppler-tools

- Update to version 0.44.0:
+ core:
- Fix Compile in 32bit linux (fdo#95492).
- Splash: type 3 chars. restore the current position also in
output device (fdo#95344).
- Splash: Improve rendering of some dotted lines (fdo#84693).
- Refactor GooString::Set() (fdo#94201).
- Fix typo in GfxPatchMeshShading::parse.
- Fix memory leak in PSOutputDev::filterPSLabel.
- Fix memory leak in
SignatureHandler::getDefaultFirefoxCertDB_Linux.
- Fix potential crash in SplashOutputDev::doUpdateFont.
- Fix potential crash in TextPage::coalesce.
- Remove call that does nothing.
+ utils: pdftocairo: add -antialias option (fdo#94977).
- Bump soname following upstream changes.
- Add poppler-Fix-mem-leak-SplashgouraudTriangleShadedFill.patch:
Fix memory leak in Splash::gouraudTriangleShadedFill, patch from
upstream git.

==== poppler-qt ====
Version update (0.43.0 -> 0.44.0)

- Update to version 0.44.0:
+ core:
- Fix Compile in 32bit linux (fdo#95492).
- Splash: type 3 chars. restore the current position also in
output device (fdo#95344).
- Splash: Improve rendering of some dotted lines (fdo#84693).
- Refactor GooString::Set() (fdo#94201).
- Fix typo in GfxPatchMeshShading::parse.
- Fix memory leak in PSOutputDev::filterPSLabel.
- Fix memory leak in
SignatureHandler::getDefaultFirefoxCertDB_Linux.
- Fix potential crash in SplashOutputDev::doUpdateFont.
- Fix potential crash in TextPage::coalesce.
- Remove call that does nothing.
+ utils: pdftocairo: add -antialias option (fdo#94977).
- Bump soname following upstream changes.
- Add poppler-Fix-mem-leak-SplashgouraudTriangleShadedFill.patch:
Fix memory leak in Splash::gouraudTriangleShadedFill, patch from
upstream git.

==== poppler-qt5 ====
Version update (0.43.0 -> 0.44.0)
Subpackages: libpoppler-qt5-1 libpoppler-qt5-devel

- Update to version 0.44.0:
+ core:
- Fix Compile in 32bit linux (fdo#95492).
- Splash: type 3 chars. restore the current position also in
output device (fdo#95344).
- Splash: Improve rendering of some dotted lines (fdo#84693).
- Refactor GooString::Set() (fdo#94201).
- Fix typo in GfxPatchMeshShading::parse.
- Fix memory leak in PSOutputDev::filterPSLabel.
- Fix memory leak in
SignatureHandler::getDefaultFirefoxCertDB_Linux.
- Fix potential crash in SplashOutputDev::doUpdateFont.
- Fix potential crash in TextPage::coalesce.
- Remove call that does nothing.
+ utils: pdftocairo: add -antialias option (fdo#94977).
- Bump soname following upstream changes.
- Add poppler-Fix-mem-leak-SplashgouraudTriangleShadedFill.patch:
Fix memory leak in Splash::gouraudTriangleShadedFill, patch from
upstream git.

==== python-Pillow ====
Subpackages: python-Pillow-tk

- ignore make check errors on all bigendian archs
(adding ppc s390 s390x)

==== python3-pyxdg ====

- specfile:
* updated source url to files.pythonhosted.org

==== star ====
Subpackages: spax

- Create rules for aarch64

==== sudo ====

- add "BuildRequires: cyrus-sasl-devel" to enable SASL
authentication [bnc#979531]

==== vm-install ====
Version update (0.8.52 -> 0.8.53)

- fate#319328 - Add virsh console conf to KVM Guests
- Version 0.8.53

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups