Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
Re: [opensuse-factory] libpci.so.3 accidentally broke ABI
  • From: "C. Brouerius van Nidek" <constant@xxxxxxxxxxx>
  • Date: Thu, 26 May 2016 16:01:04 +0700
  • Message-id: <4725354.aQNnBXXMSQ@dhcppc2>
On Thursday, May 26, 2016 9:51:42 AM WIB Dominique Leuenberger / DimStar
wrote:
On Thu, 2016-05-26 at 01:44 +0200, Ludwig Nussel wrote:
pciutils (3.4.1 -> 3.5.0)

This package also delviers libpci.so.3, which by accident lost a
symbol, making the library ABI incompatible with the old one.

This shows with various applications not starting when this has been
updated (most notably probably chromium)

If you did not yet update libpci3, I recommend for now to lock it
(zypper al libpci3) - this will keep version 3.4.1 around. The next
snapshot should hopefully already solve this (chromium got a rebuild
against the new lib and will use the new provided symbol).

There is also an update of pciutils 3.5.1 pending, which restores that
missing symbol so that stuff that currently fails will not have to be
rebuilt in the future.


Dear Dominique,

And what are we going to do if we have already updated the libpci3 file?
My Chromium does not want to run and in konsole it reacts with:

/usr/lib64/chromium/chromium: relocation error: /usr/lib64/chromium/lib/
libgpu.so: symbol pci_init, version LIBPCI_3.0 not defined in file libpci.so.3
with link time reference

Where could I find the version 3.4.1? And would a downgrade give me a working
chromium?

Thanks

Constant

--
Linux User 183145 using Tumbleweed on a Pentium IV
System : Linux 4.5.4-1-default
Distro : openSUSE 20160524 (x86_64)
Desktop: KDE Frameworks: 5.22.0 and Plasma 5.6.4

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >