Mailinglist Archive: opensuse-factory (498 mails)

< Previous Next >
Re: [opensuse-factory] Broken /boot/initrd file after latest upgrade (Tumbleweed 20160519) (SOLVED)
Roger Whittaker wrote:
On Sat, May 21, 2016 at 04:44:10PM +0200, Stefan Bruens wrote:

[...]

*if* you really want to do it manually:

$> cpio -vt < /boot/initrd-4.5.2-1-default
drwxr-xr-x 1 root root 0 May 20 02:31 .
-rw-r--r-- 1 root root 2 May 20 02:31 early_cpio
drwxr-xr-x 1 root root 0 May 20 02:31 kernel
drwxr-xr-x 1 root root 0 May 20 02:31 kernel/x86
drwxr-xr-x 1 root root 0 May 20 02:31 kernel/x86/microcode
-rw-r--r-- 1 root root 20480 May 20 02:31 kernel/x86/microcode/
GenuineIntel.bin
42 blocks

tail -c +$((512*42 + 1)) /boot/initrd-4.5.2-1-default | xzcat | cpio -t
.
bin
bin/bash
bin/cat
bin/chown
...
There's also a tool for this:

/usr/lib/dracut/skipcpio

e.g.

/usr/lib/dracut/skipcpio initrd-4.5.4-1-default > initrd.xz

xz -d initrd.xz

cpio -idv < initrd
Ok, thanks for the "skipcpio" and "lsinitrd" commands.

The second problem (my own Kernel 4.5.5 stopped with an "uncompression
error") is now solved too.

My /boot filesystem is on an USB stick. I made a "fsck -f" filesystem
check there. After reinstalling the kernel-default-4.5.4-1.1.x86_64
kernel, this Kernel could boot again.

Now I reinstalled my own Kernel 4.5.5-mykernel from RPM. This Kernel now
also boots.

I compared the MD5 checksums before and after reinstalling my Kernel in
RPM format. The MD5 checksum of /boot/vmlinuz-4.5.5-mykernel changed.

So I am relatively sure, that all the problems came from an Ext4
filesystem corruption on my USB stick.

You may ask, why I do not use /boot on hard-disk and why I do not use
NVidia 364.19 driver with the Kernel 4.6 patch:

1. UEFI on my Intel DH55TC mainboard is incomplete. Partitioning the
hard disk and SSD with GPT and booting from USB solved my UEFI problems.
2. Last time I tested the NVidia 364 driver series I had the problem,
that VDPAU deinterlacing modules didn't worked in MythTV. So I like
to wait until the NVidia 364 drivers are production ready.

Greetings,
Björn

--
To unsubscribe, e-mail: opensuse-factory+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-factory+owner@xxxxxxxxxxxx

< Previous Next >